Αποστολέας Θέμα: Ασκήση στους διδιάστατους..  (Αναγνώστηκε 1046 φορές)

justelene23

  • Νέος
  • *
  • Μηνύματα: 6
Ασκήση στους διδιάστατους..
« στις: 25 Απρ 2014, 11:40:04 μμ »
Μπορει καποιος να με βοηθησει με αυτη την ασκηση??? Κατι κανω λαθος

Να γραφεί ο αλγόριθμος σε ψευδογλώσσα που θα διαβάζει τα στοιχεία ενός δισδιάστατου πίνακα Ν X M (μονοψήφιοι αριθμοί από το 0 μέχρι το 9), και θα τυπώνει τη συχνότητα εμφάνισης κάθε αριθμού για κάθε γραμμή του πίνακα.

justelene23

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Ασκήση στους διδιάστατους..
« Απάντηση #1 στις: 25 Απρ 2014, 11:42:37 μμ »
Για i από 1 μέχρι Κ
   Για j από 1 μέχρι Ν
   Διάβασε Α[ i, j ]
Τέλος_επανάληψης
Τέλος_επανάληψης
Για i από 1 μέχρι N
Για k από 0 μέχρι 9
      Γ[ k ] <- 0
      Για j από 1 μέχρι Μ
         Γ[Α[ i, j ]  ] <- Γ[Α[ i, j ]  ]  +1
         Τέλος_επανάληψης
      Tύπωσε Γ[ k ]
    Τέλος_επανάληψης
Τέλος_επανάληψης

Είναι σωστό? Κατι νομίζω κάνω λάθος

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Ασκήση στους διδιάστατους..
« Απάντηση #2 στις: 26 Απρ 2014, 12:12:36 πμ »
Το Κ τι είναι?

Κώδικας: Pascal
  1. Για k από 0 μέχρι 9
  2.       Γ[ k ] <- 0
  3. Τέλος_επανάληψης
  4. Για i από 1 μέχρι Ν
  5.         Για j από 1 μέχρι Μ
  6.               Διάβασε Α[ i, j ]
  7.               Γ[Α[ i, j ]  ] <- Γ[Α[ i, j ]  ]  +  1
  8.         Τέλος_επανάληψης
  9. Τέλος_επανάληψης
  10. Για k από 0 μέχρι 9
  11.      Τύπωσε  Γ[ k ]
  12. Τέλος_επανάληψης
  13.  

Το θέμα δεν είναι αν είναι σωστό ή λάθος, αλλά αν καταλαβαίνεις τη λύση ή έστω καταλαβαίνεις τι έχεις κάνει στον παραπάνω κώδικα που έδωσες.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr