Αποστολέας Θέμα: ΕΡΩΤΗΣΗ - ΔΙΕΥΚΡΙΝΗΣΗ - ΥΠΟΔΕΙΞΗ ΓΙΑ ΜΙΑ ΑΣΚΗΣΗ  (Αναγνώστηκε 567 φορές)

landreou

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 124
Γεια σας .
Είδα μία άσκηση και κάπου μπερδευτηκα στο τι ζητάει σε κάποια ερωτήματα της :

Η ΕΚΦΩΝΗΣΗ
Μια εταιρεία ορθοπεδικών ειδών προωθεί τα προϊόντα της με πωλητές. Οι πωλητές αμοίβονται ανάλογα με το μηνιαίο ύψος πωλήσεων, κλιμακωτά, ως εξής :
Ύψος μηνιαίων πωλήσεων    Ποσοστό αμοιβής
Ως 1000 €                                         5 %
Από 1001 ως 4000 €                         10 %
Πάνω από 4000 €                                 20 %

Να γράψετε αλγόριθμο ο οποίος :
α) διαβάζει τα ονόματα των 20 πωλητών,
β) με χρήση υποπρογράμματος διαβάζει τις μηνιαίες πωλήσεις τους για ένα έτος και εκχωρεί τα στοιχεία στον πίνακα Π[20,12], ελέγχοντας ώστε κάθε ένα να είναι αριθμός ≥ 0,
γ) με υποπρόγραμμα που δέχεται τον πίνακα Π, τον πωλητή και τον μήνα ( ΑΥΤΑ ΔΕΝ ΥΠΟΝΟΕΙ ΟΤΙ ΘΑ ΕΙΝΑΙ ΤΑ ΟΡΙΣΜΑΤΑ ΤΟΥ ΥΠΟΠΟΡΓΡΑΜΜΑΤΟΣ ) υπολογίζει την μηνιαία αμοιβή του και στη συνέχεια την ετήσια αμοιβή, την οποία (ΤΗΝ ΕΤΗΣΙΑ ΑΜΟΙΒΗ ΔΕΝ ΕΝΝΟΕΙ ΟΤΙ ΘΑ ΑΠΟΘΗΚΕΥΕΙ ; )αποθηκεύει σε μονοδιάστατο πίνακα,
δ) με τη βοήθεια του προηγούμενου υποπρογράμματος, εμφανίζει τον μήνα ή τους μήνες που η εταιρεία πλήρωσε τα λιγότερα χρήματα ως ποσοστά αμοιβής.

[======   1   ======]

ΤΟ ΥΠΟΠΡΟΓΡΑΜΜΑ ΠΟΥ ΣΚΕΦΤΗΚΑ

ΣΥΝΑΡΤΗΣΗ ΥΠΟΛΟΓΙΣΜΟΣ(i,j,Λ): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ

ΑΚΕΡΑΙΕΣ : i,j,Λ[20,12]


ΑΡΧΗ

ΑΝ Λ[i,j] <= 1000 TOTE

           ΥΠΟΛΟΓΙΣΜΟΣ <- Λ[i,j] * 5 / 100

ΑΛΛΙΩΣ_ΑΝ Λ[i,j] <= 4000 ΤΟΤΕ

          ΥΠΟΛΟΓΙΣΜΟΣ <- (1000 * 5 / 100) + ((Λ[i,j]-1000)*10/100))

ΑΛΛΙΩΣ

         ΥΠΟΛΟΓΙΣΜΟΣ <- ((1000*5/100) + (3000*10/100) + (Λ[i,j]-4000)*20/100))

ΤΕΛΟΣ_ΑΝ

     
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


ΑΥΤΗ Η ΣΥΝΑΡΤΗΣΗ ΘΑ ΕΙΝΑΙ ΜΕΣΑ ΣΕ ΔΥΟ ΒΡΟΧΟΥΣ ΓΙΑ .. ΜΕΧΡΙ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 20
      ΕΤΗΣΙΑ [ i ] <- 0
      ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 20

               μηνιαία <- ΥΠΟΛΟΓΙΣΜΟΣ(i,j,Λ)     
               ΕΤΗΣΙΑ [ i ] <- ΕΤΗΣΙΑ [ i ] + μηνιαία 


      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

[======   2   ======]

ΤΟ ΤΕΛΕΥΤΑΙΟ ΕΡΩΤΗΜΑ ΤΙ ΘΕΛΕΙ ΝΑ ΚΑΝΟΥΜΕ ; ΤΑΙΡΙΑΖΕΙ ΤΟ ΥΠΟΠΡΟΓΡΑΜΜΑ ΠΟΥ ΕΦΤΙΑΞΑ ;
« Τελευταία τροποποίηση: 30 Ιούλ 2013, 12:57:34 μμ από landreou »