Αποστολέας Θέμα: ΜΕΤΑΤΡΟΠΗ ΟΣΟ ---> ΓΙΑ και ΑΡΧΗ ---> ΓΙΑ  (Αναγνώστηκε 644 φορές)

landreou

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 124
ΜΕΤΑΤΡΟΠΗ ΟΣΟ ---> ΓΙΑ και ΑΡΧΗ ---> ΓΙΑ
« στις: 19 Ιούλ 2013, 11:18:05 πμ »
Να μετατραπεί η παρακάτω δομή όσο..επαναλαβε σε για..μεχρι

χ <- α

Οσο χ + α <= 3 + β επαναλαβε

χ <- χ + 5

εμφάνισε χ

Τέλος_επανάληψης

Πρόσθετες ερωτήσεις

[1] Ποιά η  διαφορά άν στην όσο έχουμε απλή ανίσωση ( αν υπαρχει )
[2] Ποιά η διαφορά αν η χ <- χ + 5 είναι μετά την εμφάνισε

Η λύση που δίνω εγώ για την μετατροπή

Για χ από α+5 μέχρι 3+β-α με_βήμα 5
           Εμφάνισε χ
Τέλος_απανάληψης

Θα μπορούσαμε να πούμε

Για χ από α μέχρι 3+β-α με_βήμα 5
          Εμφάνισε (χ+5)
Τέλος_επανάληψης

Σε περίπτωση των ερωτημάτων που λέω  τι αλλαγες έχουμε ;

Επίσης για μετατροπή από Αρχή_επανάληψης σε Για
Να μετατρέψουμε την παρακάτω δομή σε Για ...Μεχρι

Χ<-Α
Αρχή_επανάληψης

     Χ <- Χ+1   

     Εμφάνισε Χ

Μέχρις_ότου Χ>=Β


Εγώ λέω


Για χ από Α+1 μέχρι Β-1

          Εμφάνισε Χ

Τέλος_επανάληψης

Είναι σωστό ;

Ερωτήματα για αυτή τη περίπτωση :

[1] Αν το βήμα δεν ήταν 1 αλλα μεγαλύτερο τότε ποια η λύση ;

Ευχαριστώ
« Τελευταία τροποποίηση: 19 Ιούλ 2013, 12:36:45 μμ από landreou »