Αποστολέας Θέμα: Θέματα Επαναληπτικών Ημερησίων Λυκείων  (Αναγνώστηκε 5881 φορές)

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Θέματα Επαναληπτικών Ημερησίων Λυκείων
« στις: 15 Ιούν 2013, 09:56:11 πμ »
Θέματα Επαναληπτικών Ημερησίων Λυκείων

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #1 στις: 15 Ιούν 2013, 10:10:06 πμ »
Βάζω και τα εσπερινά στο ίδιο thread. Τα θέματα είναι ακριβώς ίδια, με μια πολύ μικρή διαφορά σε μια φράση (εδώ παίζουμε το παιχνίδι βρείτε τις διαφορές).
« Τελευταία τροποποίηση: 15 Ιούν 2013, 10:49:20 πμ από evry »
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2214
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #2 στις: 15 Ιούν 2013, 12:28:22 μμ »
Πολύς πίνακας και πολλά κενά για να συμπληωθούν από την φετινή επιτροπή
Αλήθεια, η εύρεση του μικρότερου είναι πρόβλημα βελτιστοποίησης;
Γιατί εγώ δεν βρίσκω σαφή δικαιολόγηση
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1015
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #3 στις: 15 Ιούν 2013, 08:22:06 μμ »
Η μόνη προφανής δικαιολόγηση (για το βελτιστοποίησης) είναι να βρει κάποιος τον μικρότερο με ταξινόμηση ενώ υπάρχει ο κλασικός (; βέλτιστος) τρόπος .
Πάντως εμένα μου φαίνεται για υπολογιστικό. (Κριτήριο : το είδος της επίλυσης).

Α

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1015
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #4 στις: 15 Ιούν 2013, 08:25:24 μμ »
Α1.α 4.

μέσος όρος ενός συνόλου ακεραίων μεταβλητών πρέπει να αποθηκευτεί σε μεταβλητή πραγματικού τύπου.

Τι θα πει  "μέσος όρος ακεραίων μεταβλητών" ;

Μήπως :

μέσος όρος ακεραίων τιμών ;

Α

Γιώργος Κατσαούνος

  • Καθηγητής Πληροφορικής
  • Νέος
  • *
  • Μηνύματα: 6
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #5 στις: 16 Ιούν 2013, 12:25:01 μμ »
Η μόνη προφανής δικαιολόγηση (για το βελτιστοποίησης) είναι να βρει κάποιος τον μικρότερο με ταξινόμηση ενώ υπάρχει ο κλασικός (; βέλτιστος) τρόπος .
Πάντως εμένα μου φαίνεται για υπολογιστικό. (Κριτήριο : το είδος της επίλυσης).

Α
Αν ψάχνεις (αφαιρετικά) να βρεις την φθηνότερη τιμή τότε είναι Βελτιστοποίηση...

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1015
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #6 στις: 16 Ιούν 2013, 02:06:12 μμ »
Είναι μια άποψη !  Πείθει όμως ;;

Α

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2214
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #7 στις: 16 Ιούν 2013, 03:33:04 μμ »
Αυτό λέω κι εγώ
Άστοχο ερώτημα
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Dinos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 86
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #8 στις: 16 Ιούν 2013, 09:12:08 μμ »
ιδιότητα=μικρό
βελτιστοποίηση = περισσότερο μικρό = μικρότερο
ΑΡΑ
η εύρεση του μικρότερου από 5 αριθμούς είναι πρόβλημα βελτιστοποίησης
όπως είναι το φθηνότερο, το χαμηλότερο αλλά και το ακριβότερο, το ψηλότερο.

όσον αφορά στα επαναληπτικά θέματα, το πνεύμα τους μοιάζει (πολύ) με αυτό των κανονικών

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #9 στις: 17 Ιούν 2013, 02:42:01 πμ »
Άμα ορίσεις την συνάρτηση f(x)=x με domain(f) = {x 1, ... , x 5},τότε το να βρεις το minimum της f είναι πρόβλημα optimization.

hobbit

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #10 στις: 06 Ιούλ 2013, 05:36:33 μμ »
Έχει δώσει κανείς λύση στο Α3 συμπληρώνοντας μόνο τα κενά; Προσπάθησα να το λύσω σήμερα αλλά δεν τα κατάφερα. Κάθε βοήθεια είναι ευπρόσδεκτη.

dimitris76

  • Καθηγητής Πληροφορικής
  • Νέος
  • *
  • Μηνύματα: 2
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #11 στις: 07 Ιούλ 2013, 10:36:42 πμ »
Έχει δώσει κανείς λύση στο Α3 συμπληρώνοντας μόνο τα κενά; Προσπάθησα να το λύσω σήμερα αλλά δεν τα κατάφερα. Κάθε βοήθεια είναι ευπρόσδεκτη.

F <- ΨΕΥΔΗΣ
 i <-1
ΟΣΟ i<=991 ΚΑΙ F=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
J<- 0
ΟΣΟ j<=9 ΚΑΙ S[ j+i ] = W [j+1 ] ΕΠΑΝΑΛΑΒΕ
j <- j + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ j=10 ΤΟΤΕ
F <-ΑΛΗΘΗΣ
 ΑΛΛΙΩΣ
i <- i + 1
ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ F = ΑΛΗΘΗΣ TOTE
ΓΡΑΨΕ i
ΑΛΛΙΩΣ
ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΕ'
ΤΕΛΟΣ_ΑΝ

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #12 στις: 07 Ιούλ 2013, 07:47:44 μμ »

Η παρακάτω λύση είναι λάθος

F <- ΨΕΥΔΗΣ
 i <-1
ΟΣΟ i<=991 ΚΑΙ F=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
J<- 0
ΟΣΟ j<=9 ΚΑΙ S[ j+i ] = W [j+1 ] ΕΠΑΝΑΛΑΒΕ
j <- j + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ j=10 ΤΟΤΕ
F <-ΑΛΗΘΗΣ
 ΑΛΛΙΩΣ
i <- i + 1
ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΑΝ F = ΑΛΗΘΗΣ TOTE
ΓΡΑΨΕ i
ΑΛΛΙΩΣ
ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΕ'
ΤΕΛΟΣ_ΑΝ

διότι στην εσωτερική επανάληψη για j=10 η συνθήκη γίνεται

Κώδικας: [Επιλογή]
ΟΣΟ 10<=9 ΚΑΙ S[ 10+i ] = W [10+1 ] ΕΠΑΝΑΛΑΒΕ
δηλαδή έχουμε προσπέλαση πέρα από τα όρια του πίνακα, που σημαίνει ότι παραβιάζεται το κριτήριο της καθοριστικότητας

ΥΓ. Στην γλώσσα/ψευδογλώσσα γίνεται πλήρης αποτίμηση των συνθηκών, δεν έχουμε short-circuit evaluation
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3177
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #13 στις: 07 Ιούλ 2013, 10:32:32 μμ »
έχεις πολύ δίκιο, άρα μια επανάληψης λιγότερη και η ερώτηση για το τελευταίο μετά:

F ← ΨΕΥΔΗΣ
i ← 1
ΟΣΟ F = ΨΕΥΔΗΣ ΚΑΙ i <= 991  ΕΠΑΝΑΛΑΒΕ   ! και όχι μέχρι 1000
j ← 0
ΟΣΟ j < 9  ΚΑΙ S[i + j] = W[j + 1] ΕΠΑΝΑΛΑΒΕ
j ← j + 1
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ j = 10 KAI S[i + 9] = W[10] ΤΟΤΕ
F ← ΑΛΗΘΗΣ
ΑΛΛΙΩΣ
i ← i + 1
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝ F = ΑΛΗΘΗΣ TOTE
ΓΡΑΨΕ i
ΑΛΛΙΩΣ
ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΕ'
ΤΕΛΟΣ_ΑΝ
« Τελευταία τροποποίηση: 08 Ιούλ 2013, 01:01:57 μμ από Παναγιώτης Τσιωτάκης »

Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 652
Απ: Θέματα Επαναληπτικών Ημερησίων Λυκείων
« Απάντηση #14 στις: 07 Ιούλ 2013, 10:55:04 μμ »
καλησπέρα...Παναγιώτη j=10 ή μήπως j=9?? δεν θα γίνει 10 έτσι που είναι το όσο αν δεν κάνω λάθος, το πολύ νά πάρει τιμή 9, και με την συνθήκη που βάζεις ελέγχουμε το δέκατο..