Αποστολέας Θέμα: ΜΙΑ ΔΙΑΦΟΡΕΤΙΚΗ ΛΥΣΗ ΓΙΑ ΤΟ Γ3  (Αναγνώστηκε 1047 φορές)

chris_bek

  • Νέος
  • *
  • Μηνύματα: 2
ΜΙΑ ΔΙΑΦΟΡΕΤΙΚΗ ΛΥΣΗ ΓΙΑ ΤΟ Γ3
« στις: 29 Μάι 2013, 08:47:13 μμ »
ΚΑΛΗΣΠΕΡΑ, ΣΗΜΕΡΑ ΕΔΩΣΑ ΠΑΝΕΛΛΗΝΙΕΣ ΚΑΙ ΘΑ ΗΘΕΛΑ ΤΙ ΓΝΩΜΗ ΣΑΣ ΓΙΑ ΑΥΤΟ ΠΟΥ ΕΓΡΑΨΑ ΣΤΟ Γ3

ΣΗΜΕΙΩΣΗ: αρχικα δημιουργω νεο πινακα SAP[30,2] και στην πρωτη στηλη για καθε εναν απο τους 30 μαθητες , αν ο ΜΟ_SAP του κεφαλιου ειναι <= 1,8 τοτε θα βαζω τον αριθμο 1 , αν ο ΜΟ_SAP του κεφαλιου ειναι <=2 τοτε θα βαλω τον αριθμο 2 (στο αντοιστιχο κελι του πινακα) αλλιως θα βαλω το 3.
αντιστοιχα και για την δευτερη στηλη
Στο συγκρινω τις δυο στειλες και δημιουργω εναν ακομα πινακα , τον ΤΕΛ[30] που καθε κελι εχει τον μεγαλυτερο αριθμο απο τους αριθμους που εχω αποθηκευσει στον πινακα SAP[30,2]
(πχ αν ο SAP[χ,1] = 1 και ο SAP[χ,2] = 2 τοτε ο ΤΕΛ[χ]=2)
Στο τελος αν ο αριθμος ειναι 1 , θα γνωριζω οτι ο ΜΟ ειναι χαμηλος , αν ειναι 2 θα γνωριζω οτι ειναι κοντα στα ορια , αλλιως θα τα ξεπερνα

παρακατω δινεται το τμημα αλγοριθμου



ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
ΑΝ ΜΟ[i,1] <= 1,8 ΤΟΤΕ
 SAP[i,1] <- 1
ΑΛΛΙΩΣ_ΑΝ ΜΟ[i,1] <= 2 ΤΟΤΕ
 SAP[i,1] <- 2
ΑΛΛΙΩΣ
 SAP[i,1] <- 3
ΤΕΛΟΣ_ΑΝ
ΑΝ ΜΟ[i,2] <= 1,8 ΤΟΤΕ
 SAP[i,2] <- 1
ΑΛΛΙΩΣ_ΑΝ ΜΟ[i,2] <= 2 ΤΟΤΕ
 SAP[i,2] <- 2
ΑΛΛΙΩΣ
 SAP[i,3] <- 3
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
ΑΝ SAP[i,1] < SAP[i,2] ΤΟΤΕ
 ΤΕΛ [ i ] <- SAP[i,2]
ΑΛΛΙΩΣ
 ΤΕΛ [ i ] <- SAP[i,1]
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
ΑΝ ΤΕΛ [ i ] = 1 ΤΟΤΕ
 ΕΜΦΑΝΙΣΕ 'ΧΑΜΗΛΟΣ ΣΑΡ'
ΑΛΛΙΩΣ_ΑΝ ΤΕΛ [ i ] = 2 ΤΟΤΕ
 ΕΜΦΑΝΙΣΕ 'ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ'
ΑΛΛΙΩΣ                         ! δηλαδη αν ΤΕΛ [ i ] = 3
 ΕΜΦΑΝΙΣΕ 'ΕΚΤΟΣ ΟΡΙΩΝ'
ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ



ευχαριστω για το χρονο σας



ΧΡΙΣΤΟΦΟΡΟΣ ΜΠΕΚΟΣ , 31ο ΓΕΛ ΘΕΣ/ΝΙΚΗΣ
« Τελευταία τροποποίηση: 01 Ιούν 2013, 11:42:00 πμ από chris_bek »

mokasa

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 27
Απ: ΜΙΑ ΔΙΑΦΟΡΕΤΙΚΗ ΛΥΣΗ ΓΙΑ ΤΟ Γ3
« Απάντηση #1 στις: 29 Μάι 2013, 09:17:46 μμ »
Νομίζω οτι είναι σωστό και πρέπει να βαθμολογηθεί με άριστα, αν δεν έχεις κάνει κάποιο λάθος στην υλοποίηση.

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Απ: ΜΙΑ ΔΙΑΦΟΡΕΤΙΚΗ ΛΥΣΗ ΓΙΑ ΤΟ Γ3
« Απάντηση #2 στις: 29 Μάι 2013, 09:50:56 μμ »
Καλό φαίνεται Χριστόφορε.
Καλή σου επιτυχία.
Φιλικά,
Γιώργος Θαλασσινός

J_Papajohn

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 4
Απ: ΜΙΑ ΔΙΑΦΟΡΕΤΙΚΗ ΛΥΣΗ ΓΙΑ ΤΟ Γ3
« Απάντηση #3 στις: 30 Μάι 2013, 11:24:15 μμ »
Συμφωνώ και εγώ μαζί σου Χριστόφορε,
αν και καθηγητής και εγώ εναλλακτικά έτσι το σκέφτηκα για να αποφύγω την μεγάλη πολλαπλή επιλογή.
Καλά αποτελέσματα.
Γ. Παπαϊωάννου