Αποστολέας Θέμα: προβληματισμός για το θέμα Α4 α  (Αναγνώστηκε 3067 φορές)

Κανάκη

  • Νέος
  • *
  • Μηνύματα: 7
  • μέλος εξωκοινο-βολευτικής δράσης
προβληματισμός για το θέμα Α4 α
« στις: 29 Μάι 2013, 06:41:49 μμ »
Καλησπέρα σας,

έχω μια αντίρρηση για τον τρόπο με τον οποίο αντιμετωπίζεται το θέμα Α4, α όχι μόνο εδώ αλλά και σε άλλα site  :D

Η άσκηση λέει ότι  ότι ο αλγόριθμος πρέπει να ξαναγραφεί ο ίδιος ακριβώς, χωρίς να μεταβάλουμε τίποτα παρά μόνο την δομή επιλογής την οποία πρέπει να εξαλείψουμε. Πιστεύω ότι είναι λάθος να αλλάξουμε τις τιμές στις Για :-\, αλλά πρέπει να  διατηρήσουμε αναλλοίωτο το τμήμα:

Για i από 1 μέχρι 100
Για j από 1 μέχρι 100
......
Διάβασε Π[i,j]
....
Τέλος_επανάληψης
Τέλος_επανάληψης


Μια λυση που θα πρότεινα είναι :

Για i από 1 μέχρι 100
Για j από 1 μέχρι 100

done <-  i< j
όσο done = ΑΛΗΘΗΣ επανάλαβε
Διάβασε Π[i,j]
done <- ΨΕΥΔΗΣ
τέλος_επανάληψης

Τέλος_επανάληψης
Τέλος_επανάληψης


Αυτό μας εξασφαλίζει 0 ή μια εκτέλεση του Διάβασε .. όπως άλλωστε γίνεται και στην Αν ::).
« Τελευταία τροποποίηση: 29 Μάι 2013, 07:09:08 μμ από Κανάκη »

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #1 στις: 29 Μάι 2013, 06:54:52 μμ »
Έλεγε επι λέξη
Παράθεση
χωρίς τη χρήση της δομής επιλογής

Οπότε δεν βλέπω το πρόβλημα να κάνεις κάτι στη Για(Στα όρια του επιτρεπτού επ'αυτής that is).

Κανάκη

  • Νέος
  • *
  • Μηνύματα: 7
  • μέλος εξωκοινο-βολευτικής δράσης
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #2 στις: 29 Μάι 2013, 06:59:59 μμ »
Έλεγε:

Παράθεση
Να ξαναγράψετε στο τετράδιό σας το παραπάνω τμήμα αλγορίθμου
χωρίς τη χρήση της δομής επιλογής, έτσι ώστε να επιτελεί την ίδια
λειτουργία

 ξαναγράφω δεν σημαίνει ότι γράφω ακριβώς το ίδιο;  :o

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #3 στις: 29 Μάι 2013, 07:16:17 μμ »
Δεν ξέρω,πιστεύω πως είναι πιο weak,με την έννοια ότι άμα θέλανε περισσότερους περιορισμούς,ας τους καταγράφανε explicitly.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3135
  • to Iterate is human to Recurse divine
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #4 στις: 29 Μάι 2013, 07:29:15 μμ »
Δεν υπάρχει πρόβλημα σε αυτό το θέμα.
Μέχρι στιγμής οι λύσεις είναι 3

αυτή με το i+1

αυτή που σαρώνει κατά στήλες οπότε πάει στην εσωτερική επανάληψη από 1 μέχρι j-1

και η λύση με την Όσο και τη λογική μεταβλητή

Για ι από 1 μέχρι 100
     Για j από 1 μέχρι 100
          done <-- i<j
          Όσο done Επανάλαβε
               Διάβασε Π[ι,j]
               done <-- Ψευδής
          Τέλος_Επανάληψης
     Τέλος_Επανάληψης
Τέλος_Επανάληψης


και οι 3 παραπάνω είναι δεκτές

What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #5 στις: 29 Μάι 2013, 09:24:36 μμ »
Πράγματι, αν με κάποιον τρόπο κάνεις μια Όσο να εκτελεστεί μία μόνο φορά, είναι ισοδύναμη με μια Αν
Αυτό είναι που δε μου αρέσει σ' αυτή τη λύση και μου φαίνεται "ζαβολιά".
Φυσικά ξεγλιστράει άριστα από τους περιορισμούς που θέτει η εκφώνηση, οπότε δε μπορεί να θεωρηθεί λάθος.

Από άλλη σκοπιά τώρα, από τη διδακτική, θα απέφευγα να τη συστήσω ως προτεινόμενη λύση, δεδομένου ότι μια σύγχυση που εμφανίζουν κάποια παιδιά για αρκετό διάστημα είναι ακριβώς αυτή: δε βλέπουν τη διαφορά της Οσο και της Αν και συχνά χρησιμοποιούν χωρίς λόγο την Οσο αντί της Αν
Φιλικά,
Γιώργος Θαλασσινός

Κανάκη

  • Νέος
  • *
  • Μηνύματα: 7
  • μέλος εξωκοινο-βολευτικής δράσης
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #6 στις: 29 Μάι 2013, 09:49:58 μμ »
Πράγματι, αν με κάποιον τρόπο κάνεις μια Όσο να εκτελεστεί μία μόνο φορά, είναι ισοδύναμη με μια Αν
Αυτό είναι που δε μου αρέσει σ' αυτή τη λύση και μου φαίνεται "ζαβολιά".
Φυσικά ξεγλιστράει άριστα από τους περιορισμούς που θέτει η εκφώνηση, οπότε δε μπορεί να θεωρηθεί λάθος.

Από άλλη σκοπιά τώρα, από τη διδακτική, θα απέφευγα να τη συστήσω ως προτεινόμενη λύση, δεδομένου ότι μια σύγχυση που εμφανίζουν κάποια παιδιά για αρκετό διάστημα είναι ακριβώς αυτή: δε βλέπουν τη διαφορά της Οσο και της Αν και συχνά χρησιμοποιούν χωρίς λόγο την Οσο αντί της Αν

Πιστεύω ότι δεν είναι "ζαβολιά"  :angel: διότι απάντάει ακριβώς στο ερώτημα. Είναι πολύ πιο εύκολο να σκεφτεί κάποιος ότι η συνθήκη i<j αναφέρεται στα στοιχεία πάνω από την κύρια διαγώνιο και να λύσει αναλόγως το θέμα. Εγώ θεώρησα ότι αυτό είναι η παγίδα (το να παρασυρθείς δηλαδή από την συνθήκη)  και ότι το ζητούμενο είναι να δείξει ο μαθητής ότι να μπορεί να "πάει"από την ΑΝ στην ΟΣΟ.

Ειλικρινά εξεπλάγην όταν διαπίστωσα ότι δεν προβλημάτησε το φόρουμ! ???

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #7 στις: 29 Μάι 2013, 10:13:00 μμ »
Εγώ θεώρησα ότι αυτό είναι η παγίδα (το να παρασυρθείς δηλαδή από την συνθήκη)  και ότι το ζητούμενο είναι να δείξει ο μαθητής ότι να μπορεί να πάει από την ΑΝ στην ΟΣΟ.
Εγώ πάλι είμαι σίγουρος το ζητούμενο δεν είναι να δείξει ο μαθητής ότι να μπορεί να πάει από την ΑΝ στην ΟΣΟ.  :angel:
Και δεν θα έπρεπε επ' ουδενί να είναι!
Αυτό επισημαίνω στο παραπάνω σχόλιό μου: η ΑΝ και η ΟΣΟ είναι δομές/εντολές διαφορετικών κατηγοριών. Είναι φτιαγμένες για να κάνουν η καθεμιά άλλο είδος δουλειάς. Η μία είναι για να κάνει επαναλήψεις, η άλλη για να επιλέγει, να παίρνει μια απόφαση.
Από διδακτικής πλευράς πρέπει να κατευθύνουμε τα παιδιά προς το να διακρίνουν την ειδοποιό διαφορά τους κι όχι να τις συγχέουν. Δεν πρέπει να τους βάζουμε να σκέφτονται πώς να ΜΗΝ χρησιμοποιήσουν μια ΑΝ αλλά στη θέση της να χρησιμοποιήσουν (χωρίς κάποιον επαρκή λόγο) μια (αχρείαστη) δομή επανάληψης.
Αντικαθιστώ μια δομή επιλογής με μια άλλη δομή επιλογής και αντικαθιστώ μια δομή επανάληψης μια άλλη δομή επανάληψης (εκτός βέβαια αν ο αρχικός κώδικας τις χρησιμοποιεί λάθος, οπότε θα έχω ακριβώς αυτή τη δουλειά, να χρησιμοποιήσω τη σωστή δομή)
Στην προγραμματιστική πραγματικότητα ποτέ δε θα αντικαταστήσω μια δομή επιλογής με μια δομή επανάληψης (μόνο αν το δω σαν σπαζοκεφαλιά για να διασκεδάσω το πώς θα κάνω τα αδύνατα δυνατά), ούτε και το αντίστροφο.
Αυτή είναι η δική μου ματιά  :)
Φιλικά,
Γιώργος Θαλασσινός

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2206
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #8 στις: 29 Μάι 2013, 10:16:54 μμ »
Γενικότερα, αυτό το θέμα νομίζω ότι θα έπρεπε να είναι πολύ εύκολο για τους μαθητές, παρόλο που τελικά τους δυσκόλεψε
Όποιος κατάλαβε ουσιαστικά ότι το j πρέπει να είναι μεγαλύτερο του i, θα έφτιαξε εύκολα την επανάληψη
Δεν έχει καμία σχέση π.χ. με το Β2 που χρειάζεται πλήρης φαντασία για την υλοποίηση
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Κανάκη

  • Νέος
  • *
  • Μηνύματα: 7
  • μέλος εξωκοινο-βολευτικής δράσης
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #9 στις: 29 Μάι 2013, 10:26:41 μμ »
a
« Τελευταία τροποποίηση: 30 Μάι 2013, 01:27:11 μμ από Κανάκη »

Κανάκη

  • Νέος
  • *
  • Μηνύματα: 7
  • μέλος εξωκοινο-βολευτικής δράσης
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #10 στις: 29 Μάι 2013, 10:27:09 μμ »
Εγώ πάλι είμαι σίγουρος το ζητούμενο δεν είναι να δείξει ο μαθητής ότι να μπορεί να πάει από την ΑΝ στην ΟΣΟ.  :angel:
Και δεν θα έπρεπε επ' ουδενί να είναι!
Αυτό επισημαίνω στο παραπάνω σχόλιό μου: η ΑΝ και η ΟΣΟ είναι δομές/εντολές διαφορετικών κατηγοριών. Είναι φτιαγμένες για να κάνουν η καθεμιά άλλο είδος δουλειάς. Η μία είναι για να κάνει επαναλήψεις, η άλλη για να επιλέγει, να παίρνει μια απόφαση.
Από διδακτικής πλευράς πρέπει να κατευθύνουμε τα παιδιά προς το να διακρίνουν την ειδοποιό διαφορά τους κι όχι να τις συγχέουν. Δεν πρέπει να τους βάζουμε να σκέφτονται πώς να ΜΗΝ χρησιμοποιήσουν μια ΑΝ αλλά στη θέση της να χρησιμοποιήσουν (χωρίς κάποιον επαρκή λόγο) μια (αχρείαστη) δομή επανάληψης.
Αντικαθιστώ μια δομή επιλογής με μια άλλη δομή επιλογής και αντικαθιστώ μια δομή επανάληψης μια άλλη δομή επανάληψης (εκτός βέβαια αν ο αρχικός κώδικας τις χρησιμοποιεί λάθος, οπότε θα έχω ακριβώς αυτή τη δουλειά, να χρησιμοποιήσω τη σωστή δομή)
Στην προγραμματιστική πραγματικότητα ποτέ δε θα αντικαταστήσω μια δομή επιλογής με μια δομή επανάληψης (μόνο αν το δω σαν σπαζοκεφαλιά για να διασκεδάσω το πώς θα κάνω τα αδύνατα δυνατά), ούτε και το αντίστροφο.
Αυτή είναι η δική μου ματιά  :)

Το να μπορεί κάποιο παιδί να μετατρέψει την αν σε οσο, δείχνει πλήρη καταννόηση, ευελιξία και άνεση στην χρήση των δύο δομών.

Εντέλει, δεν πρέπει να λύνουμε μια άσκηση με βάση τι νομίζουμε ότι θέλει να ¨πει ο ποιητής¨ή τι στόχους έχει, αλλά με βάση την ακριβή διατύπωση της εκφώνησης : τι εννοεί όταν λέει να ξαναγράψετε τον αλγόριθμο; Δεν πρέπει να αφήσουμε αναλλοίωτο τον κώδικα έκτός από την Αν;

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #11 στις: 29 Μάι 2013, 10:46:54 μμ »
Δεν πρέπει να αφήσουμε αναλλοίωτο τον κώδικα έκτός από την Αν;
Αν το σκεφτείς, και οι δυο μας αλλοιώνουμε τον κώδικα.
Κι εσύ, για να εξαφανίσεις την Αν, προσθέτεις εντολές μέσα στη Για οι οποίες δεν υπήρχαν. Προσθέτεις μάλιστα και μια καινούρια μεταβλητή!
Αν θέλεις όμως, η μεγαλύτερή μου ένσταση είναι ότι ξαναχρησιμοποιείς την ίδια συνθήκη που έχει και η Αν
Κατά βάθος, μια καλύτερη διατύπωση του θέματος ώστε να διατηρήσει το πνεύμα της (όπως το καταλαβαίνω εγώ) θα ήταν:
"Να το ξαναγράψετε χωρίς τη χρήση συνθήκης"  >:D
Φιλικά,
Γιώργος Θαλασσινός

Κανάκη

  • Νέος
  • *
  • Μηνύματα: 7
  • μέλος εξωκοινο-βολευτικής δράσης
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #12 στις: 29 Μάι 2013, 10:56:51 μμ »
Αν το σκεφτείς, και οι δυο μας αλλοιώνουμε τον κώδικα.
Κι εσύ, για να εξαφανίσεις την Αν, προσθέτεις εντολές μέσα στη Για οι οποίες δεν υπήρχαν. Προσθέτεις μάλιστα και μια καινούρια μεταβλητή!
Αν θέλεις όμως, η μεγαλύτερή μου ένσταση είναι ότι ξαναχρησιμοποιείς την ίδια συνθήκη που έχει και η Αν
Κατά βάθος, μια καλύτερη διατύπωση του θέματος ώστε να διατηρήσει το πνεύμα της (όπως το καταλαβαίνω εγώ) θα ήταν:
"Να το ξαναγράψετε χωρίς τη χρήση συνθήκης"  >:D

Σου λέει τι πρέπει να γράψεις και τι δεν πρέπεινα γράψεις. Το να αλλάζεις κάτι που σου λέει ότι πρέπει να το γράψεις είναι λάθος . Συμφωνώ εννοείται ότι προσθέτω κάτι καινούριο στον κώδικα αλλά δεν γίνεται αλλιώς  :P.

« Τελευταία τροποποίηση: 29 Μάι 2013, 11:34:57 μμ από Κανάκη »

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #13 στις: 29 Μάι 2013, 11:16:10 μμ »
Ναι, αλλά εν τέλει μέτρα τις αλλαγές  : πιο πολλές είναι οι δικές σου  :P
(τελος πάντων, εμένα δε με νοιάζει αυτό. επειδή εσύ λες ότι πιο πολύ αλλάζει τον αρχικό κώδικα η άλλη λύση παρά η δική σου)

εδώ δεν κατάλαβα τι λες
Το να αλλάζεις κάτι που σου λέει ότι πρέπει να το γράψεις (όπως την συνθήκη) είναι λάθος .
Φιλικά,
Γιώργος Θαλασσινός

ilias01

  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #14 στις: 29 Μάι 2013, 11:36:49 μμ »
Για ι απο 1 μεχρι 100
   Για ξ απο 1 μεχρι 100
       οσο ι<ξ επαναλαβε
           διαβασε π[ι,ξ]
           ι<-- ι+1
       τελος_επαναληψης
   τελος_επαναληψης
τελος_επαναληψης

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2206
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #15 στις: 29 Μάι 2013, 11:38:14 μμ »
Το ι απαγορεύεται να αλλάζει τιμή με εντολή
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

ilias01

  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #16 στις: 30 Μάι 2013, 11:12:38 πμ »
ΠΡΟΓΡΑΜΜΑ ασκ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, ξ, π[100, 100]
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 100
       ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ 100
           ΟΣΟ ι < ξ ΚΑΙ ξ <= 100 ΕΠΑΝΑΛΑΒΕ
                ΔΙΑΒΑΣΕ π[ι, ξ]
                ξ <- ξ + 1
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ilias01

  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #17 στις: 30 Μάι 2013, 11:41:50 πμ »
ΠΡΟΓΡΑΜΜΑ ασκ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, ξ, π[100, 100]
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 100
       ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ 100
           ΟΣΟ ι < ξ ΚΑΙ ξ <= 100 ΕΠΑΝΑΛΑΒΕ
ΠΡΟΓΡΑΜΜΑ ασκ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, ξ, π[100, 100]
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 100
       ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ 100
           ΟΣΟ ι < ξ ΚΑΙ ξ <= 100 ΕΠΑΝΑΛΑΒΕ
                ΔΙΑΒΑΣΕ π[ι, ξ]
                ξ <- ξ + 1
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Η ΕΣΩΤΕΡΙΚΗ ΕΠΑΝΑΛΗΨΗ ΜΕ ΟΣΟ ΑΦΟΥ ΔΕΣΜΕΥΟΜΑΣΤΕ ΝΑ ΜΗΝ ΤΡΟΠΟΠΟΙΗΣΟΥΜΕ ΤΟΝ ΜΕΤΡΗΤΗ. ΑΦΟΥ ΘΕΩΡΗΤΙΚΑ ΑΠΑΓΟΡΕΥΕΤΑΙ ΝΑ ΑΛΛΑΞΟΥΜΕ ΤΟ ΜΕΤΡΗΤΗ ΔΕΝ ΘΑ ΠΡΕΠΕΙ ΝΑ ΤΡΟΠΟΠΟΙΗΘΕΙ ΚΑΙ Ο ΔΙΕΡΜΗΝΕΥΤΗΣ ΤΗΣ ΓΛΩΣΣΑΣ ΝΑ ΜΗΝ ΔΕΧΕΤΑΙ ΤΗΝ ΕΝΤΟΛΗ ΑΥΤΗ;
                ΔΙΑΒΑΣΕ π[ι, ξ]
                ξ <- ξ + 1
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Το ι απαγορεύεται να αλλάζει τιμή με εντολή

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3135
  • to Iterate is human to Recurse divine
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #18 στις: 30 Μάι 2013, 12:34:53 μμ »

ΠΡΟΓΡΑΜΜΑ ασκ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, ξ, π[100, 100]
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 100
       ξ <-- 1
       Όσο ξ <= 100  Επανάλαβε
           ΟΣΟ ι < ξ ΚΑΙ ξ <= 100 ΕΠΑΝΑΛΑΒΕ
                ΔΙΑΒΑΣΕ π[ι, ξ]
                ξ <- ξ + 1
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ξ <-- ξ  + 1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Το παραπάνω νομίζω ότι είναι σωστό.
Ερώτηση (που έχω κάνει πολλές φορές) : Τι λάθος είναι η αλλαγή του μετρητή της Για μέσα στην επανάληψη? λογικό ή συντακτικό?
και τι θα πει απαγορεύεται? ή είναι σωστό ή όχι, δεν υπάρχει μέση λύση

Αν το παραπάνω που έχω γράψει είναι σωστό τότε γιατί να μην είναι σωστό με Για
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #19 στις: 30 Μάι 2013, 01:05:53 μμ »
Παράθεση
Στην προγραμματιστική πραγματικότητα ποτέ δε θα αντικαταστήσω μια δομή επιλογής με μια δομή επανάληψης (μόνο αν το δω σαν σπαζοκεφαλιά για να διασκεδάσω το πώς θα κάνω τα αδύνατα δυνατά), ούτε και το αντίστροφο.

To αντίστροφο μπορεί να γίνει σε κάποιες περιπτώσεις.


Παράθεση
Το να μπορεί κάποιο παιδί να μετατρέψει την αν σε οσο, δείχνει πλήρη καταννόηση, ευελιξία και άνεση στην χρήση των δύο δομών.

Χρειάζεται να έχει και ευλεξία κατανοήση και άνεση και σε άλλα πράγματα.Για παράδειγμα στο πόσο readable είναι αυτό που γράφει.Ενδιαφέρον το swap της Αν σε Όσο,αλλά ίσως υπερβολικό άμα υπάρχουν πιο ευανάγνωστες λύσεις.


Παράθεση
Εντέλει, δεν πρέπει να λύνουμε μια άσκηση με βάση τι νομίζουμε ότι θέλει να ¨πει ο ποιητής¨ή τι στόχους έχει, αλλά με βάση την ακριβή διατύπωση της εκφώνησης : τι εννοεί όταν λέει να ξαναγράψετε τον αλγόριθμο; Δεν πρέπει να αφήσουμε αναλλοίωτο τον κώδικα έκτός από την Αν;

Συμφωνώ ως ένα σημείο,οι ερωτήσεις πρέπει να είναι απόλυτα καθορισμένες.

Παράθεση
Ερώτηση (που έχω κάνει πολλές φορές) : Τι λάθος είναι η αλλαγή του μετρητή της Για μέσα στην επανάληψη? λογικό ή συντακτικό?
και τι θα πει απαγορεύεται? ή είναι σωστό ή όχι, δεν υπάρχει μέση λύση

Εμένα προσωπικά δεν μου φαίνεται λάθος,αλλά κάποιος θα μπορούσε εύλογα να υποστηρίξει πώς είναι κάπως μη-δομημένο.Δεδομένου και του ζηλωτισμού στο όλο θέμα της δόμησης,δεν μου φαίνεται και τόσο περίεργο.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3135
  • to Iterate is human to Recurse divine
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #20 στις: 30 Μάι 2013, 03:21:08 μμ »
Δεν ξέρω αν το έχει πει κάποιος αλλά τι λέτε για τον παρακάτω τρόπο?

Για i από 1 μέχρι 99
   Για j από 1 μέχρι 100-i
          Διάβασε Π[i, j+i]
   Τέλος_Επανάληψης
Τέλος_Επανάληψης

το σκέφτηκε μαθητής

ΥΓ. Ακόμα δεν έχω τελειώσει τις ενδεικτικές λύσεις για την πειραματική. Πρώτη φορά μου τυχαίνει να έχω σε ένα θέμα 5 διαφορετικούς τρόπους !!  (Β2)
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

accordionman

  • Οπαδός
  • **
  • Μηνύματα: 19
    • stergios@jabber.org
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #21 στις: 30 Μάι 2013, 03:27:47 μμ »
Γειά σας παιδιά, χθες δίναμε πανελλήνιες. και ήθελα να ρωτήσω κάτι για το Α4α. έπρεπε να 'εξαφανήσουμε την αν (Δομή έπιλογης)..Χρησιμοποίησα την όσο και εναν 'διακοπτη' flag δηλαδή ο οποιος αρχικά ειναι ψευδης και οταν το ι<j τοτε αλλαζει σε αληθής και σταματά να γίνεται η όσο οπότε πάει πάνω στο για..και πάλι απο την αρχή..Φανταζομαι είναι σωστό ετσι??

kkkerm

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 18
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #22 στις: 30 Μάι 2013, 06:44:09 μμ »
Αρκετά παιδία έχουν και δυνατότητες και φαντασία... Οι σωστές λύσεις είναι σίγουρα πολλές...

!Μαθητής 1
j ← 1
Για ι από 1 μέχρι 100
  j ← j + 1
  α ← j
  Όσο (ι < j) και (j ≤ 100) επανάλαβε
    Διαβασε Π[ι, j]
    j ← j + 1
  Τέλος_επανάληψης
  j ← α
Τέλος_επανάληψης


!Μαθητής2
κ ← 2
Για ι από 1 μέχρι 100
  Για j από κ μέχρι 100
    Διαβασε Π[ι, j]
  Τέλος_επανάληψης
  κ ← κ + 1
Τέλος_επανάληψης
« Τελευταία τροποποίηση: 30 Μάι 2013, 07:50:03 μμ από kkkerm »

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #23 στις: 30 Μάι 2013, 06:59:58 μμ »
Γειά σας παιδιά, χθες δίναμε πανελλήνιες. και ήθελα να ρωτήσω κάτι για το Α4α. έπρεπε να 'εξαφανήσουμε την αν (Δομή έπιλογης)..Χρησιμοποίησα την όσο και εναν 'διακοπτη' flag δηλαδή ο οποιος αρχικά ειναι ψευδης και οταν το ι<j τοτε αλλαζει σε αληθής και σταματά να γίνεται η όσο οπότε πάει πάνω στο για..και πάλι απο την αρχή..Φανταζομαι είναι σωστό ετσι??
έκανες κάτι σαν αυτό ;
http://alkisg.mysch.gr/steki/index.php?topic=5236.msg54634#msg54634

αν ναι, ήδη είπαμε ότι είναι σωστό
Φιλικά,
Γιώργος Θαλασσινός

Κανάκη

  • Νέος
  • *
  • Μηνύματα: 7
  • μέλος εξωκοινο-βολευτικής δράσης
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #24 στις: 31 Μάι 2013, 12:42:56 πμ »
Γειά σας παιδιά, χθες δίναμε πανελλήνιες. και ήθελα να ρωτήσω κάτι για το Α4α. έπρεπε να 'εξαφανήσουμε την αν (Δομή έπιλογης)..Χρησιμοποίησα την όσο και εναν 'διακοπτη' flag δηλαδή ο οποιος αρχικά ειναι ψευδης και οταν το ι<j τοτε αλλαζει σε αληθής και σταματά να γίνεται η όσο οπότε πάει πάνω στο για..και πάλι απο την αρχή..Φανταζομαι είναι σωστό ετσι??

Καλό μου παιδι η λύση σου είναι μια χαρά...
Πραγματικά έχω εκπλαγεί με το πόσο ιδιαίτερες και πρωτότυπες είναι οι λύσεις των παιδιών (πριν λίγες ώρες γύρισα από το Βαθμολογικό).... σε αντίθεση με τις συμβατικές κόπιες που κυκλοφόρησαν στο ίντερνετ πολλά φροντιστήρια, οι οποίες σημειωτέον τις πρώτες ώρες μετά τις Πανελλαδικές ήταν γεμάτες λάθη!!!!

Φοβάμαι επίσης ότι κάποιοι βαθμολογητές ίσως να μην δώσουν την πρέπουσα σημασία σε κάποιες αξιόλογες λύσεις  και  τις θεωρήσουν λανθασμένες... ΠΡΕΠΕΙ ΝΑ ΠΡΟΣΕΞΟΥΜΕ ΠΟΛΥ ΣΤΗΝ ΒΑΘΜΟΛΟΓΗΣΗ!