Αποστολέας Θέμα: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ  (Αναγνώστηκε 1822 φορές)

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • manosteach.com
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
« στις: 29 Μάι 2013, 12:52:31 μμ »
Άραγε θα μπορούσα να ανεβάσω τώρα ενδεικτικές λύσεις;
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

Σούλας Βασίλης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 305
    • Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
« Απάντηση #1 στις: 29 Μάι 2013, 01:42:04 μμ »
Πάνω από το μέσο όρο το επίπεδο των φετινών θεμάτων κατά την γνώμη μου. Ανεβάζω λύσεις. Στείλτε μου διορθώσεις γιατί τα έχω κάνει λίγο βιαστικά και σίγουρα θα έχω λαθάκια.
« Τελευταία τροποποίηση: 29 Μάι 2013, 02:15:39 μμ από Σούλας Βασίλης »
Σούλας Βασίλης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Δ.Π.Θ.
Καθηγητής Πληροφορικής ΠΕ19
http://users.sch.gr/vasisoulas
http://eclass.sch.gr/modules/auth/opencourses.php?fc=%D4-52

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
« Απάντηση #2 στις: 29 Μάι 2013, 01:47:19 μμ »
Προτεινόμενες Λύσεις

Διόρθωση σε ένα λαθάκι...

αλλιώς_αν (ΜΟ[i, 1] > 1.8 και ΜΟ[i, 2] ≤ 2) ή (ΜΟ[i, 2] > 3.6 και ΜΟ[i, 2] ≤ 4) τότε

                                     και ΜΟ[i, 1] 

και έκδοση v1 με καλύτερη προέγγιση στην συνθήκη αυτή!

Ευχαριστώ τον συνάδελφο που εντόπισε το λαθάκι!
« Τελευταία τροποποίηση: 29 Μάι 2013, 03:03:52 μμ από sdoukakis »

lsourtzo

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
« Απάντηση #3 στις: 29 Μάι 2013, 02:10:22 μμ »
Παραθέτω και εγώ τις λύσεις ... αν κάποιος έχει καμία διαφωνία ... ας ενημερώσει ...

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
« Απάντηση #4 στις: 29 Μάι 2013, 02:12:46 μμ »
@Σούλας Βασίλης
Ευχαριστώ για τον κόπο που έκανες και τα ανέβασες.
Στο Δ2 αναφέρει πως δεν απαιτείται έλεγχος εγκυρότητας δεδομένων.
Επίσης, αν έχουμε 1 εντολή μετά την αν... χρειάζεται το τέλος_αν;
Σωκράτης

Σούλας Βασίλης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 305
    • Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
« Απάντηση #5 στις: 29 Μάι 2013, 02:16:25 μμ »
Το άλλαξα, έχεις δίκιο. Επίσης είχα και άλλα λαθάκια τα οποία διόρθωσα.
Σούλας Βασίλης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Δ.Π.Θ.
Καθηγητής Πληροφορικής ΠΕ19
http://users.sch.gr/vasisoulas
http://eclass.sch.gr/modules/auth/opencourses.php?fc=%D4-52

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
« Απάντηση #6 στις: 29 Μάι 2013, 02:21:53 μμ »
Στο Β2 μπορείς να βάλεις το ακόλουθο (πιο απλό)

Κώδικας: [Επιλογή]
ΝΑ<--0
Για i από 1 μέχρι 100
Αν Π[i]=ΑΛΗΘΗΣ τότε ΝΑ<--ΝΑ+1
Τέλος_επανάληψης
Για i από 1 μέχρι ΝΑ
Π[i]<--ΑΛΗΘΗΣ
Τέλος_επανάληψης
Για i από ΝΑ+1 μέχρι 100
Π[i]<--ΨΕΥΔΗΣ
Τέλος_επανάληψης
Σωκράτης

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
« Απάντηση #7 στις: 29 Μάι 2013, 02:47:47 μμ »
Τη λύση του Βασίλη έκαναν οι περισσότεροι μαθητές μου.
Δίνω και μια παραλλαγή της για πιο ... άρρωστους   ;)

Κώδικας: [Επιλογή]
ΝΑ<-0
Για i από 1 μέχρι 100
  Αν Π[i]=ΑΛΗΘΗΣ τότε
  ΝΑ<-ΝΑ+1
Τέλος_αν
Τέλος_επανάληψης
Για i από 1 μέχρι 100
  Π[i]<- i<=ΝΑ
Τέλος_επανάληψης
Φιλικά,
Γιώργος Θαλασσινός

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: ΕΝΔΕΙΚΤΙΚΕΣ ΛΥΣΕΙΣ
« Απάντηση #8 στις: 29 Μάι 2013, 02:50:38 μμ »
Το καλό με το Β2 ήταν η ελευθερία που αφήνει.
Άλλη μια λύση έξω από τα συνηθισμένα:

Κώδικας: [Επιλογή]
  κ ← 1
  Για ι από 1 μέχρι 100
    Αν Π[ι] τότε
      Για λ από ι μέχρι κ+1 με_βήμα -1
        Π[λ] ← Π[λ-1]
      Τέλος_επανάληψης
      Π[κ] ← Αληθής
      κ ← κ+1
    Τέλος_αν
  Τέλος_επανάληψης
Φιλικά,
Γιώργος Θαλασσινός