Αποστολέας Θέμα: προβληματισμός για το θέμα Α4 α  (Αναγνώστηκε 3273 φορές)

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2220
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #15 στις: 29 Μάι 2013, 11:38:14 μμ »
Το ι απαγορεύεται να αλλάζει τιμή με εντολή
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

ilias01

  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #16 στις: 30 Μάι 2013, 11:12:38 πμ »
ΠΡΟΓΡΑΜΜΑ ασκ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, ξ, π[100, 100]
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 100
       ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ 100
           ΟΣΟ ι < ξ ΚΑΙ ξ <= 100 ΕΠΑΝΑΛΑΒΕ
                ΔΙΑΒΑΣΕ π[ι, ξ]
                ξ <- ξ + 1
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ilias01

  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #17 στις: 30 Μάι 2013, 11:41:50 πμ »
ΠΡΟΓΡΑΜΜΑ ασκ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, ξ, π[100, 100]
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 100
       ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ 100
           ΟΣΟ ι < ξ ΚΑΙ ξ <= 100 ΕΠΑΝΑΛΑΒΕ
ΠΡΟΓΡΑΜΜΑ ασκ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, ξ, π[100, 100]
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 100
       ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ 100
           ΟΣΟ ι < ξ ΚΑΙ ξ <= 100 ΕΠΑΝΑΛΑΒΕ
                ΔΙΑΒΑΣΕ π[ι, ξ]
                ξ <- ξ + 1
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Η ΕΣΩΤΕΡΙΚΗ ΕΠΑΝΑΛΗΨΗ ΜΕ ΟΣΟ ΑΦΟΥ ΔΕΣΜΕΥΟΜΑΣΤΕ ΝΑ ΜΗΝ ΤΡΟΠΟΠΟΙΗΣΟΥΜΕ ΤΟΝ ΜΕΤΡΗΤΗ. ΑΦΟΥ ΘΕΩΡΗΤΙΚΑ ΑΠΑΓΟΡΕΥΕΤΑΙ ΝΑ ΑΛΛΑΞΟΥΜΕ ΤΟ ΜΕΤΡΗΤΗ ΔΕΝ ΘΑ ΠΡΕΠΕΙ ΝΑ ΤΡΟΠΟΠΟΙΗΘΕΙ ΚΑΙ Ο ΔΙΕΡΜΗΝΕΥΤΗΣ ΤΗΣ ΓΛΩΣΣΑΣ ΝΑ ΜΗΝ ΔΕΧΕΤΑΙ ΤΗΝ ΕΝΤΟΛΗ ΑΥΤΗ;
                ΔΙΑΒΑΣΕ π[ι, ξ]
                ξ <- ξ + 1
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Το ι απαγορεύεται να αλλάζει τιμή με εντολή

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3153
  • to Iterate is human to Recurse divine
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #18 στις: 30 Μάι 2013, 12:34:53 μμ »

ΠΡΟΓΡΑΜΜΑ ασκ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, ξ, π[100, 100]
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 100
       ξ <-- 1
       Όσο ξ <= 100  Επανάλαβε
           ΟΣΟ ι < ξ ΚΑΙ ξ <= 100 ΕΠΑΝΑΛΑΒΕ
                ΔΙΑΒΑΣΕ π[ι, ξ]
                ξ <- ξ + 1
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ξ <-- ξ  + 1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


Το παραπάνω νομίζω ότι είναι σωστό.
Ερώτηση (που έχω κάνει πολλές φορές) : Τι λάθος είναι η αλλαγή του μετρητή της Για μέσα στην επανάληψη? λογικό ή συντακτικό?
και τι θα πει απαγορεύεται? ή είναι σωστό ή όχι, δεν υπάρχει μέση λύση

Αν το παραπάνω που έχω γράψει είναι σωστό τότε γιατί να μην είναι σωστό με Για
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #19 στις: 30 Μάι 2013, 01:05:53 μμ »
Παράθεση
Στην προγραμματιστική πραγματικότητα ποτέ δε θα αντικαταστήσω μια δομή επιλογής με μια δομή επανάληψης (μόνο αν το δω σαν σπαζοκεφαλιά για να διασκεδάσω το πώς θα κάνω τα αδύνατα δυνατά), ούτε και το αντίστροφο.

To αντίστροφο μπορεί να γίνει σε κάποιες περιπτώσεις.


Παράθεση
Το να μπορεί κάποιο παιδί να μετατρέψει την αν σε οσο, δείχνει πλήρη καταννόηση, ευελιξία και άνεση στην χρήση των δύο δομών.

Χρειάζεται να έχει και ευλεξία κατανοήση και άνεση και σε άλλα πράγματα.Για παράδειγμα στο πόσο readable είναι αυτό που γράφει.Ενδιαφέρον το swap της Αν σε Όσο,αλλά ίσως υπερβολικό άμα υπάρχουν πιο ευανάγνωστες λύσεις.


Παράθεση
Εντέλει, δεν πρέπει να λύνουμε μια άσκηση με βάση τι νομίζουμε ότι θέλει να ¨πει ο ποιητής¨ή τι στόχους έχει, αλλά με βάση την ακριβή διατύπωση της εκφώνησης : τι εννοεί όταν λέει να ξαναγράψετε τον αλγόριθμο; Δεν πρέπει να αφήσουμε αναλλοίωτο τον κώδικα έκτός από την Αν;

Συμφωνώ ως ένα σημείο,οι ερωτήσεις πρέπει να είναι απόλυτα καθορισμένες.

Παράθεση
Ερώτηση (που έχω κάνει πολλές φορές) : Τι λάθος είναι η αλλαγή του μετρητή της Για μέσα στην επανάληψη? λογικό ή συντακτικό?
και τι θα πει απαγορεύεται? ή είναι σωστό ή όχι, δεν υπάρχει μέση λύση

Εμένα προσωπικά δεν μου φαίνεται λάθος,αλλά κάποιος θα μπορούσε εύλογα να υποστηρίξει πώς είναι κάπως μη-δομημένο.Δεδομένου και του ζηλωτισμού στο όλο θέμα της δόμησης,δεν μου φαίνεται και τόσο περίεργο.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3153
  • to Iterate is human to Recurse divine
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #20 στις: 30 Μάι 2013, 03:21:08 μμ »
Δεν ξέρω αν το έχει πει κάποιος αλλά τι λέτε για τον παρακάτω τρόπο?

Για i από 1 μέχρι 99
   Για j από 1 μέχρι 100-i
          Διάβασε Π[i, j+i]
   Τέλος_Επανάληψης
Τέλος_Επανάληψης

το σκέφτηκε μαθητής

ΥΓ. Ακόμα δεν έχω τελειώσει τις ενδεικτικές λύσεις για την πειραματική. Πρώτη φορά μου τυχαίνει να έχω σε ένα θέμα 5 διαφορετικούς τρόπους !!  (Β2)
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

accordionman

  • Οπαδός
  • **
  • Μηνύματα: 19
    • stergios@jabber.org
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #21 στις: 30 Μάι 2013, 03:27:47 μμ »
Γειά σας παιδιά, χθες δίναμε πανελλήνιες. και ήθελα να ρωτήσω κάτι για το Α4α. έπρεπε να 'εξαφανήσουμε την αν (Δομή έπιλογης)..Χρησιμοποίησα την όσο και εναν 'διακοπτη' flag δηλαδή ο οποιος αρχικά ειναι ψευδης και οταν το ι<j τοτε αλλαζει σε αληθής και σταματά να γίνεται η όσο οπότε πάει πάνω στο για..και πάλι απο την αρχή..Φανταζομαι είναι σωστό ετσι??

kkkerm

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 18
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #22 στις: 30 Μάι 2013, 06:44:09 μμ »
Αρκετά παιδία έχουν και δυνατότητες και φαντασία... Οι σωστές λύσεις είναι σίγουρα πολλές...

!Μαθητής 1
j ← 1
Για ι από 1 μέχρι 100
  j ← j + 1
  α ← j
  Όσο (ι < j) και (j ≤ 100) επανάλαβε
    Διαβασε Π[ι, j]
    j ← j + 1
  Τέλος_επανάληψης
  j ← α
Τέλος_επανάληψης


!Μαθητής2
κ ← 2
Για ι από 1 μέχρι 100
  Για j από κ μέχρι 100
    Διαβασε Π[ι, j]
  Τέλος_επανάληψης
  κ ← κ + 1
Τέλος_επανάληψης
« Τελευταία τροποποίηση: 30 Μάι 2013, 07:50:03 μμ από kkkerm »

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #23 στις: 30 Μάι 2013, 06:59:58 μμ »
Γειά σας παιδιά, χθες δίναμε πανελλήνιες. και ήθελα να ρωτήσω κάτι για το Α4α. έπρεπε να 'εξαφανήσουμε την αν (Δομή έπιλογης)..Χρησιμοποίησα την όσο και εναν 'διακοπτη' flag δηλαδή ο οποιος αρχικά ειναι ψευδης και οταν το ι<j τοτε αλλαζει σε αληθής και σταματά να γίνεται η όσο οπότε πάει πάνω στο για..και πάλι απο την αρχή..Φανταζομαι είναι σωστό ετσι??
έκανες κάτι σαν αυτό ;
http://alkisg.mysch.gr/steki/index.php?topic=5236.msg54634#msg54634

αν ναι, ήδη είπαμε ότι είναι σωστό
Φιλικά,
Γιώργος Θαλασσινός

Κανάκη

  • Νέος
  • *
  • Μηνύματα: 7
  • μέλος εξωκοινο-βολευτικής δράσης
Απ: προβληματισμός για το θέμα Α4 α
« Απάντηση #24 στις: 31 Μάι 2013, 12:42:56 πμ »
Γειά σας παιδιά, χθες δίναμε πανελλήνιες. και ήθελα να ρωτήσω κάτι για το Α4α. έπρεπε να 'εξαφανήσουμε την αν (Δομή έπιλογης)..Χρησιμοποίησα την όσο και εναν 'διακοπτη' flag δηλαδή ο οποιος αρχικά ειναι ψευδης και οταν το ι<j τοτε αλλαζει σε αληθής και σταματά να γίνεται η όσο οπότε πάει πάνω στο για..και πάλι απο την αρχή..Φανταζομαι είναι σωστό ετσι??

Καλό μου παιδι η λύση σου είναι μια χαρά...
Πραγματικά έχω εκπλαγεί με το πόσο ιδιαίτερες και πρωτότυπες είναι οι λύσεις των παιδιών (πριν λίγες ώρες γύρισα από το Βαθμολογικό).... σε αντίθεση με τις συμβατικές κόπιες που κυκλοφόρησαν στο ίντερνετ πολλά φροντιστήρια, οι οποίες σημειωτέον τις πρώτες ώρες μετά τις Πανελλαδικές ήταν γεμάτες λάθη!!!!

Φοβάμαι επίσης ότι κάποιοι βαθμολογητές ίσως να μην δώσουν την πρέπουσα σημασία σε κάποιες αξιόλογες λύσεις  και  τις θεωρήσουν λανθασμένες... ΠΡΕΠΕΙ ΝΑ ΠΡΟΣΕΞΟΥΜΕ ΠΟΛΥ ΣΤΗΝ ΒΑΘΜΟΛΟΓΗΣΗ!