Αποστολέας Θέμα: Θέμα Γ  (Αναγνώστηκε 8811 φορές)

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #15 στις: 29 Μάι 2013, 02:49:56 μμ »
Για 1.6 και 3.8 δεν πρέπει να εμφανίσει "Κοντά στα όρια";;;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: Θέμα Γ
« Απάντηση #16 στις: 29 Μάι 2013, 02:51:25 μμ »
Για 1.6 και 3.8 δεν πρέπει να εμφανίσει "Κοντά στα όρια";;;
Πράγματι!

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #17 στις: 29 Μάι 2013, 02:52:18 μμ »
Και τι εμφανίζει;;;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: Θέμα Γ
« Απάντηση #18 στις: 29 Μάι 2013, 02:53:27 μμ »
Και τι εμφανίζει;;;
Κοντά στα όρια!!!

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Απ: Θέμα Γ
« Απάντηση #19 στις: 29 Μάι 2013, 02:58:19 μμ »
Νομίζω η ποιο σύντομη και σωστή λύση ...
αλλά υπάρχουν πάρα πολλές δυνατές λύσεις σε αυτό το ερώτημα ... νομίζω ότι θα τα χρειαστούν οι διορθωτές ...
Συμφωνώ κι εγώ με τη λύση του Πέτρου (αν και ακόμα, μόνο διαισθητικά καταλαβαίνω τη "μεγαλύτερη περιοχή" - μπορεί κανείς να δώσει μια σαφή περιγραφή; )
Πράγματι θα τα χρειαστούν οι διορθωτές!
Φιλικά,
Γιώργος Θαλασσινός

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Γ
« Απάντηση #20 στις: 29 Μάι 2013, 03:00:15 μμ »
Συμφωνώ κι εγώ με τη λύση του Πέτρου (αν και ακόμα, μόνο διαισθητικά καταλαβαίνω τη "μεγαλύτερη περιοχή" - μπορεί κανείς να δώσει μια σαφή περιγραφή; )

Δες πιο πάνω τι έχω γράψει
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #21 στις: 29 Μάι 2013, 03:00:29 μμ »
Κοντά στα όρια!!!

Έλεγξα και τις 9 περιπτώσεις και δουλεύει

 ;)
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Γ
« Απάντηση #22 στις: 29 Μάι 2013, 03:01:06 μμ »
Συμφωνώ κι εγώ με τη λύση του Πέτρου (αν και ακόμα, μόνο διαισθητικά καταλαβαίνω τη "μεγαλύτερη περιοχή" - μπορεί κανείς να δώσει μια σαφή περιγραφή; )

Δες παραπάνω τι έχω γράψει
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: Θέμα Γ
« Απάντηση #23 στις: 29 Μάι 2013, 03:02:55 μμ »
Έλεγξα και τις 9 περιπτώσεις και δουλεύει

 ;)
Να 'σαι καλά :)

vanalex

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: Θέμα Γ
« Απάντηση #24 στις: 29 Μάι 2013, 03:20:32 μμ »
Μπαίνοντας πάντα στη θέση του μαθητή έγραψα (όπως πόσταρα και αλλού τη λύση) την παρακάτω λύση βρίσκοντας ποιο είναι πρώτα το πεδίο που υπερισχύει χωρίς να "μπλεχτώ" με πολύπλοκες συνθήκες...Αν και έχει περισσότερο γράψιμο νομίζω δουλεύει...

Κώδικας: [Επιλογή]
  !ΕΡΩΤΗΜΑ Γ3
!ΕΥΡΕΣΗ ΠΕΔΙΟΥ ΣΤΟ ΟΠΟΙΟ ΑΝΗΚΕΙ ΤΟ ΚΕΦΑΛΙ
Για Ι από 1 μέχρι 30
  Αν ΜΟ[Ι, 1] ≤ 1.8 τότε
    ΠΕΔΙΟ_ΚΕΦ ← 1
  αλλιώς_αν ΜΟ[Ι, 1] ≤ 2 τότε
    ΠΕΔΙΟ_ΚΕΦ ← 2
  αλλιώς
    ΠΕΔΙΟ_ΚΕΦ ← 3
  Τέλος_αν

!ΕΥΡΕΣΗ ΠΕΔΙΟΥ ΣΤΟ ΟΠΟΙΟ ΑΝΗΚΕΙ ΤΟ ΑΚΡΟ
  Αν ΜΟ[Ι, 2] ≤ 3.6 τότε
    ΠΕΔΙΟ_ΑΚΡ ← 1
  αλλιώς_αν ΜΟ[Ι, 1] ≤ 4 τότε
    ΠΕΔΙΟ_ΑΚΡ ← 2
  αλλιώς
    ΠΕΔΙΟ_ΑΚΡ ← 3
  Τέλος_αν

!ΕΥΡΕΣΗ ΓΕΝΙΚΟΥ ΠΕΔΙΟΥ
  Αν ΠΕΔΙΟ_ΚΕΦ ≥ ΠΕΔΙΟ_ΑΚΡ τότε
    ΠΕΔΙΟ ← ΠΕΔΙΟ_ΚΕΦ
  αλλιώς
    ΠΕΔΙΟ ← ΠΕΔΙΟ_ΑΚΡ
  Τέλος_αν

  Αν ΠΕΔΙΟ = 1 τότε
    Εμφάνισε ΚΩΔ[Ι], "ΧΑΜΗΛΟΣ SAR"
  αλλιώς_αν ΠΕΔΙΟ = 2 τότε
    Εμφάνισε ΚΩΔ[Ι], "ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ"
  αλλιώς
    Εμφάνισε ΚΩΔ[Ι], "ΕΚΤΟΣ ΟΡΙΩΝ"
  Τέλος_αν
Τέλος_επανάληψης



Γενικά νομίζω ότι ήταν το δυσκολότερο από τα θέματα...
Αλέξης Μιχαλακίδης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ

anyiota

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 4
Απ: Θέμα Γ
« Απάντηση #25 στις: 29 Μάι 2013, 03:25:46 μμ »
Γεια σας κι από μένα, δεν έχω ξαναγράψει κάτι και δεν ξέρω πού θα πρέπει να απευθυνθώ, αλλά πρέπει οπωσδήποτε να γίνει μια κίνηση για το υποερώτημα Γ3 εγκαίρως. Η διατύπωση δεν είναι απλά "ατυχής", αλλά λάθος. "Μεγαλύτερη περιοχή τιμών" σημαίνει αυτή με μεγαλύτερο εύρος. Αυτό που ζητάει όμως τελικά είναι στην "Περιοχή μεγαλύτερων τιμών" δλδ ισχύον για τον κάθε μαθητή είναι το μήνυμα με τη μεγαλύτερη επικινδυνότητα.
Προφανώς είναι κάτι που δεν μπορούν να διαπιστώσουν οι μαθητές στην (1) ώρα δυνατής αποχώρησης έτσι ώστε να προλάβουν για διευκρινιστική. όμως κάτι πρέπει να γίνει τουλάχιστον για την εν λόγω βαθμολόγηση!
« Τελευταία τροποποίηση: 29 Μάι 2013, 04:47:14 μμ από anyiota »

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #26 στις: 29 Μάι 2013, 03:27:24 μμ »
Βλέποντας τα θέματα, νόμιζα ότι η καθυστέρηση δημοσιοποίησης τους έγινε λόγω διευκρίνισης σε αυτό το σημείο, λόγω ατυχούς διατύπωσης
Μάλλον δεν υπήρξε όμως
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

olga_2703

  • Οπαδός
  • **
  • Μηνύματα: 13
Απ: Θέμα Γ
« Απάντηση #27 στις: 29 Μάι 2013, 03:33:14 μμ »
Αυτό δουλευει?

Για i από 1 μέχρι 30
   Αν ΜΟ[i, 1] <= 1,8 τότε
      Αν ΜΟ[i, 2]<= 3,6 τότε
         εμφάνισε “Χαμηλός SAR”
      αλλιώς_αν ΜΟ[i, 2]<= 4 τότε
         εμφάνισε “Κοντά στα όρια”
      αλλιώς
         εμφάνισε “Εκτός ορίων”
      Τέλος_αν
   αλλιώς_αν ΜΟ[i, 1] <= 2 τότε
      Αν ΜΟ[i, 2]<= 4 τότε
         εμφάνισε “Κοντά στα όρια”
      αλλιώς
         εμφάνισε “Εκτός ορίων”
      Τέλος_αν
   αλλιώς
      Εμφάνισε “Εκτός ορίων”
   Τέλος_αν
Τέλος_επανάληψης

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Απ: Θέμα Γ
« Απάντηση #28 στις: 29 Μάι 2013, 03:44:49 μμ »
νομίζω δουλεύει όλγα
Φιλικά,
Γιώργος Θαλασσινός

anyiota

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 4
Απ: Θέμα Γ
« Απάντηση #29 στις: 29 Μάι 2013, 04:07:52 μμ »
Εδώ είναι η δική μου (λιτή) εκδοχή.

Για i από 1 μέχρι 30
Αν ΜΟ[i,1]>2 ή ΜΟ[ι,2]>4 τότε
   Εμφάνισε "Εκτός Ορίων"
Αλλιώς_αν (ΜΟ[i,1]>1.8 και ΜΟ[i,1]<=2) ή (ΜΟ[i,2]>3.6 και ΜΟ[i,2]<=4) τότε
   Εμφάνισε "Κοντά στα όρια"
Αλλιώς
   Εμφάνισε "Χαμηλός SAR"
Τέλος_Επανάληψης
« Τελευταία τροποποίηση: 29 Μάι 2013, 04:47:38 μμ από anyiota »