Αποστολέας Θέμα: Θέμα Γ  (Αναγνώστηκε 8787 φορές)

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2452
  • I 'm not young enough to know everything
Θέμα Γ
« στις: 29 Μάι 2013, 10:20:08 πμ »
Εδώ μιλάμε για θέμα Γ

katif

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Θέμα Γ
« Απάντηση #1 στις: 29 Μάι 2013, 01:18:08 μμ »
Μια πρόταση για το Γ3
ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 30
      ΑΝ 2*ΜΟ[ι,1]>ΜΟ[ι,2] ΤΟΤΕ
          ΜΑΧ<-- 2*ΜΟ[ι,1]
     ΑΛΛΙΩΣ
         ΜΑΧ<--ΜΟ[ι,2]
    ΤΕΛΟΣ_ΑΝ

   ΑΝ ΜΑΧ<=3,6 ΤΟΤΕ
       ΓΡΑΨΕ 'Χαμηλός SAR'
   AΛΛΙΩΣ_ΑΝ ΜΑΧ<=4 ΤΟΤΕ
       ΓΡΑΨΕ 'Κοντά στα όρια'
   ΑΛΛΙΩΣ
       ΓΡΑΨΕ 'Έκτος ορίων'
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
« Τελευταία τροποποίηση: 29 Μάι 2013, 01:34:57 μμ από katif »
Κατηφόρης Παναγιώτης
Καθηγητής Πληροφορικής - Μαθηματικός

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • manosteach.com
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Θέμα Γ
« Απάντηση #2 στις: 29 Μάι 2013, 01:26:13 μμ »
Κατά την γνώμη μου το παράδειγμα που δίνει είναι άστοχο και θα μπερδέψει πολύ τους μαθητές.
Θα έπρεπε να το θέσει ανάποδα.
ΜΟ SAR  άκρων 1.9 και ΜΟ SAR  κεφαλής 3.4 τότε κοντά στα όρια.
Εκτός και αν εγώ δεν κατάλαβα κάτι σωστά
« Τελευταία τροποποίηση: 29 Μάι 2013, 01:45:08 μμ από manosteach »
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: Θέμα Γ
« Απάντηση #3 στις: 29 Μάι 2013, 01:30:42 μμ »
Μία άλλη προσέγγιση για το Γ3 είναι η εξής:

Για i από 1 μέχρι 30
  Εμφάνισε ΚΩΔ[ i ]
  Αν ΜΟ[i,1] <= 1.8 και ΜΟ[i,2] <= 3.6 τότε
    Εμφάνισε "Χαμηλός SAR"
  Αλλιώς_αν ΜΟ[i,1] <= 2 και ΜΟ[i,2] <= 4 τότε
    Εμφάνισε "Κοντά στα όρια"
  Αλλιώς
    Εμφάνισε "Εκτός ορίων"
  Τέλος_αν
Τέλος_επανάληψης
« Τελευταία τροποποίηση: 29 Μάι 2013, 01:41:04 μμ από Βασίλης Παπαχρήστος »

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #4 στις: 29 Μάι 2013, 01:49:54 μμ »
Δεν νομίζω ότι δουλεύει το παραπάνω..
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Απ: Θέμα Γ
« Απάντηση #5 στις: 29 Μάι 2013, 02:01:50 μμ »
Το Γ3 είναι πολύ ασαφές.
Τι σημαίνει "μεγαλύτερη περιοχή τιμών" ;
Εγώ προσωπικά το καταλαβαίνω ως την περιοχή με το μεγαλύτερο εύρος.
Το παράδειγμα που δίνεται βέβαια δεν με επιβεβαιώνει.
Πολύ ατυχής διατύπωση  :(
Φιλικά,
Γιώργος Θαλασσινός

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Θέμα Γ
« Απάντηση #6 στις: 29 Μάι 2013, 02:04:34 μμ »
Το Γ3 νομίζω πως "βγαίνει" απλά:

Κώδικας: [Επιλογή]
!ΕΡΩΤΗΜΑ Γ3

Για Ι από 1 μέχρι 30
  Αν ΜΟ[Ι,1]>(ΜΟ[Ι,2]/2) τότε     ! ΕΛΕΓΧΟΣ ΑΝ ΤΟ ΚΕΦΑΛΙ ΒΓΑΖΕΙ ΠΕΡΙΣΣΟΤΕΡΟ SAR
    Αν ΜΟ[Ι, 1] ≤ 1.8 τότε
      εμφάνισε "ΧΑΜΗΛΟΣ SAR"
    αλλιώς_αν ΜΟ[Ι,1] ≤ 2 τότε
      εμφάνισε "ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ"
    αλλιώς
      εμφάνισε "ΕΚΤΟΣ ΟΡΙΩΝ"
    Τέλος_αν
  αλλιώς
    Αν ΜΟ[Ι,2] ≤ 3.6 τότε
      εμφάνισε "ΧΑΜΗΛΟΣ SAR"
    αλλιώς_αν ΜΟ[Ι,2] <= 4 τότε
      εμφάνισε "ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ"
    αλλιώς
      εμφάνισε "ΕΚΤΟΣ ΟΡΙΩΝ"
  Τέλος_αν
Τέλος_επανάληψης

Συμφωνείτε;
Σωκράτης

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #7 στις: 29 Μάι 2013, 02:10:37 μμ »
Αν ΜΟ[ι,1] > 2 ή ΜΟ[ι,2] > 4 τότε
   Εμφάνισε ...
Αλλιώς_Αν (ΜΟ[ι,1] > 1.8) ή (ΜΟ[ι,2] > 3.6) τότε
  Εμφάνισε ...
Αλλιώς
  Εμφάνισε ...
Τέλος_Αν
 
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

lsourtzo

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 131
Απ: Θέμα Γ
« Απάντηση #8 στις: 29 Μάι 2013, 02:14:34 μμ »
Αν ΜΟ[ι,1] > 2 ή ΜΟ[ι,2] > 4 τότε
   Εμφάνισε ...
Αλλιώς_Αν (ΜΟ[ι,1] > 1.8) ή (ΜΟ[ι,2] > 3.6) τότε
  Εμφάνισε ...
Αλλιώς
  Εμφάνισε ...
Τέλος_Αν
 

Νομίζω η ποιο σύντομη και σωστή λύση ...
αλλά υπάρχουν πάρα πολλές δυνατές λύσεις σε αυτό το ερώτημα ... νομίζω ότι θα τα χρειαστούν οι διορθωτές ...

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Θέμα Γ
« Απάντηση #9 στις: 29 Μάι 2013, 02:29:04 μμ »
@petrosp13
ωραίος...
Σωκράτης

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: Θέμα Γ
« Απάντηση #10 στις: 29 Μάι 2013, 02:30:13 μμ »
Δεν νομίζω ότι δουλεύει το παραπάνω..
Μπορείς να γίνεις πιο σαφής;

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #11 στις: 29 Μάι 2013, 02:30:27 μμ »
Το σκεπτικό είναι ότι αφού τα μεγαλύτερα υπερισχύουν, ξεκινάμε από τα μεγαλύτερα και βρίσκουμε αν υπάρχει τουλάχιστον ένας από τους 2 αριθμούς εκεί και μετά κατεβαίνουμε αποκλείοντας τα μεγαλύτερα...

(Αυτό πάει στον δικό μου τρόπο)

Μπορείς να γίνεις πιο σαφής;

Ο κώδικας αυτός παίρνει τις τομές μόνο των συνόλων, δηλαδή αν ΚΑΙ οι δυο τιμές είναι στο ίδιο διάστημα
Δεν λαμβάνει υπόψιν αν είναι σε διαφορετικά διαστήματα..
Π.χ. δοκίμασε τις τιμές 1.6 και 3.8
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Γ
« Απάντηση #12 στις: 29 Μάι 2013, 02:33:07 μμ »
Μια γρήγορη απάντηση και από εμένα όσο αφορά το Γ3:

Για i από 1 μέχρι 30
  Εμφάνισε ΚΩΔ[ i ]
  Αν ΜΟ[i,1] > 2 ή ΜΟ[i,2] > 4 τότε
    Εμφάνισε "Εμφάνισε εκτός ορίων"
  Αλλιώς_αν ΜΟ[i,1] <= 1.8 και ΜΟ[i,2] <= 3.6 τότε
    Εμφάνισε "Χαμηλός SAR"
  Αλλιώς
    Εμφάνισε "Κοντά στα όρια"
  Τέλος_αν
Τέλος_επανάληψης


Θεωρώντας βέβαια ότι λέγοντας μεγαλύτερη περιοχή τιμών εννοούμε την πιο επιβλαβή για το άτομο περιοχή, κάτι που έπρεπε να διατυπωθεί καλύτερα

Όσο αφορά το Γ4 χωρίς να χρειαστεί να χρησιμοποιηθέι νέος πίνακας :

Για i από 2 μέχρι 30
  Για j από 30 μέχρι i με_βήμα -1
     Αν ΜΟ[j-1,1]<ΜΟ[j,1] τότε
           Αντιμετάθεσε ΜΟ[j-1,1]<ΜΟ[j,1]
           Αντιμετάθεσε ΜΟ[j-1,2]<ΜΟ[j,2]
           Αντιμετάθεσε ΚΩΔ[j-1]< ΚΩΔ[j] 
    τέλος_αν
  τέλος_επανάληψης
τέλος_επανάληψης
Για i από 1 μέχρι 3
  εμφάνισε ΚΩΔ [ i ],  ΜΟ[i,1]
τέλος_επανάληψης

Για i από 2 μέχρι 30
  Για j από 30 μέχρι i με_βήμα -1
     Αν ΜΟ[j-1,2]<ΜΟ[j,2] τότε
           Αντιμετάθεσε ΜΟ[j-1,1]<ΜΟ[j,1]
           Αντιμετάθεσε ΜΟ[j-1,2]<ΜΟ[j,2]
           Αντιμετάθεσε ΚΩΔ[j-1]< ΚΩΔ[j] 
    τέλος_αν
  τέλος_επανάληψης
τέλος_επανάληψης
Για i από 1 μέχρι 3
  εμφάνισε ΚΩΔ[ i ],  ΜΟ[i,2]
τέλος_επανάληψης


« Τελευταία τροποποίηση: 29 Μάι 2013, 04:36:56 μμ από amanou »
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: Θέμα Γ
« Απάντηση #13 στις: 29 Μάι 2013, 02:46:53 μμ »
Το σκεπτικό είναι ότι αφού τα μεγαλύτερα υπερισχύουν, ξεκινάμε από τα μεγαλύτερα και βρίσκουμε αν υπάρχει τουλάχιστον ένας από τους 2 αριθμούς εκεί και μετά κατεβαίνουμε αποκλείοντας τα μεγαλύτερα...

(Αυτό πάει στον δικό μου τρόπο)

Ο κώδικας αυτός παίρνει τις τομές μόνο των συνόλων, δηλαδή αν ΚΑΙ οι δυο τιμές είναι στο ίδιο διάστημα
Δεν λαμβάνει υπόψιν αν είναι σε διαφορετικά διαστήματα..
Π.χ. δοκίμασε τις τιμές 1.6 και 3.8
Εξακολουθώ να μην καταλαβαίνω τι εννοείς. Δοκίμασα τις τιμές που προτείνεις και μια χαρά δουλεύει ο κώδικας.
Αν ΜΟ[i,1] <= 1.8 και ΜΟ[i,2] <= 3.6 τότε
    Εμφάνισε "Χαμηλός SAR"
  Αλλιώς_αν ΜΟ[i,1] <= 2 και ΜΟ[i,2] <= 4 τότε
    Εμφάνισε "Κοντά στα όρια"
  Αλλιώς
    Εμφάνισε "Εκτός ορίων"
  Τέλος_αν

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Θέμα Γ
« Απάντηση #14 στις: 29 Μάι 2013, 02:48:34 μμ »
Θέλει έλεγχο...
Σωκράτης

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #15 στις: 29 Μάι 2013, 02:49:56 μμ »
Για 1.6 και 3.8 δεν πρέπει να εμφανίσει "Κοντά στα όρια";;;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: Θέμα Γ
« Απάντηση #16 στις: 29 Μάι 2013, 02:51:25 μμ »
Για 1.6 και 3.8 δεν πρέπει να εμφανίσει "Κοντά στα όρια";;;
Πράγματι!

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #17 στις: 29 Μάι 2013, 02:52:18 μμ »
Και τι εμφανίζει;;;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: Θέμα Γ
« Απάντηση #18 στις: 29 Μάι 2013, 02:53:27 μμ »
Και τι εμφανίζει;;;
Κοντά στα όρια!!!

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Απ: Θέμα Γ
« Απάντηση #19 στις: 29 Μάι 2013, 02:58:19 μμ »
Νομίζω η ποιο σύντομη και σωστή λύση ...
αλλά υπάρχουν πάρα πολλές δυνατές λύσεις σε αυτό το ερώτημα ... νομίζω ότι θα τα χρειαστούν οι διορθωτές ...
Συμφωνώ κι εγώ με τη λύση του Πέτρου (αν και ακόμα, μόνο διαισθητικά καταλαβαίνω τη "μεγαλύτερη περιοχή" - μπορεί κανείς να δώσει μια σαφή περιγραφή; )
Πράγματι θα τα χρειαστούν οι διορθωτές!
Φιλικά,
Γιώργος Θαλασσινός

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Γ
« Απάντηση #20 στις: 29 Μάι 2013, 03:00:15 μμ »
Συμφωνώ κι εγώ με τη λύση του Πέτρου (αν και ακόμα, μόνο διαισθητικά καταλαβαίνω τη "μεγαλύτερη περιοχή" - μπορεί κανείς να δώσει μια σαφή περιγραφή; )

Δες πιο πάνω τι έχω γράψει
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #21 στις: 29 Μάι 2013, 03:00:29 μμ »
Κοντά στα όρια!!!

Έλεγξα και τις 9 περιπτώσεις και δουλεύει

 ;)
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Γ
« Απάντηση #22 στις: 29 Μάι 2013, 03:01:06 μμ »
Συμφωνώ κι εγώ με τη λύση του Πέτρου (αν και ακόμα, μόνο διαισθητικά καταλαβαίνω τη "μεγαλύτερη περιοχή" - μπορεί κανείς να δώσει μια σαφή περιγραφή; )

Δες παραπάνω τι έχω γράψει
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: Θέμα Γ
« Απάντηση #23 στις: 29 Μάι 2013, 03:02:55 μμ »
Έλεγξα και τις 9 περιπτώσεις και δουλεύει

 ;)
Να 'σαι καλά :)

vanalex

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: Θέμα Γ
« Απάντηση #24 στις: 29 Μάι 2013, 03:20:32 μμ »
Μπαίνοντας πάντα στη θέση του μαθητή έγραψα (όπως πόσταρα και αλλού τη λύση) την παρακάτω λύση βρίσκοντας ποιο είναι πρώτα το πεδίο που υπερισχύει χωρίς να "μπλεχτώ" με πολύπλοκες συνθήκες...Αν και έχει περισσότερο γράψιμο νομίζω δουλεύει...

Κώδικας: [Επιλογή]
  !ΕΡΩΤΗΜΑ Γ3
!ΕΥΡΕΣΗ ΠΕΔΙΟΥ ΣΤΟ ΟΠΟΙΟ ΑΝΗΚΕΙ ΤΟ ΚΕΦΑΛΙ
Για Ι από 1 μέχρι 30
  Αν ΜΟ[Ι, 1] ≤ 1.8 τότε
    ΠΕΔΙΟ_ΚΕΦ ← 1
  αλλιώς_αν ΜΟ[Ι, 1] ≤ 2 τότε
    ΠΕΔΙΟ_ΚΕΦ ← 2
  αλλιώς
    ΠΕΔΙΟ_ΚΕΦ ← 3
  Τέλος_αν

!ΕΥΡΕΣΗ ΠΕΔΙΟΥ ΣΤΟ ΟΠΟΙΟ ΑΝΗΚΕΙ ΤΟ ΑΚΡΟ
  Αν ΜΟ[Ι, 2] ≤ 3.6 τότε
    ΠΕΔΙΟ_ΑΚΡ ← 1
  αλλιώς_αν ΜΟ[Ι, 1] ≤ 4 τότε
    ΠΕΔΙΟ_ΑΚΡ ← 2
  αλλιώς
    ΠΕΔΙΟ_ΑΚΡ ← 3
  Τέλος_αν

!ΕΥΡΕΣΗ ΓΕΝΙΚΟΥ ΠΕΔΙΟΥ
  Αν ΠΕΔΙΟ_ΚΕΦ ≥ ΠΕΔΙΟ_ΑΚΡ τότε
    ΠΕΔΙΟ ← ΠΕΔΙΟ_ΚΕΦ
  αλλιώς
    ΠΕΔΙΟ ← ΠΕΔΙΟ_ΑΚΡ
  Τέλος_αν

  Αν ΠΕΔΙΟ = 1 τότε
    Εμφάνισε ΚΩΔ[Ι], "ΧΑΜΗΛΟΣ SAR"
  αλλιώς_αν ΠΕΔΙΟ = 2 τότε
    Εμφάνισε ΚΩΔ[Ι], "ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ"
  αλλιώς
    Εμφάνισε ΚΩΔ[Ι], "ΕΚΤΟΣ ΟΡΙΩΝ"
  Τέλος_αν
Τέλος_επανάληψης



Γενικά νομίζω ότι ήταν το δυσκολότερο από τα θέματα...
Αλέξης Μιχαλακίδης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ

anyiota

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 4
Απ: Θέμα Γ
« Απάντηση #25 στις: 29 Μάι 2013, 03:25:46 μμ »
Γεια σας κι από μένα, δεν έχω ξαναγράψει κάτι και δεν ξέρω πού θα πρέπει να απευθυνθώ, αλλά πρέπει οπωσδήποτε να γίνει μια κίνηση για το υποερώτημα Γ3 εγκαίρως. Η διατύπωση δεν είναι απλά "ατυχής", αλλά λάθος. "Μεγαλύτερη περιοχή τιμών" σημαίνει αυτή με μεγαλύτερο εύρος. Αυτό που ζητάει όμως τελικά είναι στην "Περιοχή μεγαλύτερων τιμών" δλδ ισχύον για τον κάθε μαθητή είναι το μήνυμα με τη μεγαλύτερη επικινδυνότητα.
Προφανώς είναι κάτι που δεν μπορούν να διαπιστώσουν οι μαθητές στην (1) ώρα δυνατής αποχώρησης έτσι ώστε να προλάβουν για διευκρινιστική. όμως κάτι πρέπει να γίνει τουλάχιστον για την εν λόγω βαθμολόγηση!
« Τελευταία τροποποίηση: 29 Μάι 2013, 04:47:14 μμ από anyiota »

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #26 στις: 29 Μάι 2013, 03:27:24 μμ »
Βλέποντας τα θέματα, νόμιζα ότι η καθυστέρηση δημοσιοποίησης τους έγινε λόγω διευκρίνισης σε αυτό το σημείο, λόγω ατυχούς διατύπωσης
Μάλλον δεν υπήρξε όμως
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

olga_2703

  • Οπαδός
  • **
  • Μηνύματα: 13
Απ: Θέμα Γ
« Απάντηση #27 στις: 29 Μάι 2013, 03:33:14 μμ »
Αυτό δουλευει?

Για i από 1 μέχρι 30
   Αν ΜΟ[i, 1] <= 1,8 τότε
      Αν ΜΟ[i, 2]<= 3,6 τότε
         εμφάνισε “Χαμηλός SAR”
      αλλιώς_αν ΜΟ[i, 2]<= 4 τότε
         εμφάνισε “Κοντά στα όρια”
      αλλιώς
         εμφάνισε “Εκτός ορίων”
      Τέλος_αν
   αλλιώς_αν ΜΟ[i, 1] <= 2 τότε
      Αν ΜΟ[i, 2]<= 4 τότε
         εμφάνισε “Κοντά στα όρια”
      αλλιώς
         εμφάνισε “Εκτός ορίων”
      Τέλος_αν
   αλλιώς
      Εμφάνισε “Εκτός ορίων”
   Τέλος_αν
Τέλος_επανάληψης

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Απ: Θέμα Γ
« Απάντηση #28 στις: 29 Μάι 2013, 03:44:49 μμ »
νομίζω δουλεύει όλγα
Φιλικά,
Γιώργος Θαλασσινός

anyiota

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 4
Απ: Θέμα Γ
« Απάντηση #29 στις: 29 Μάι 2013, 04:07:52 μμ »
Εδώ είναι η δική μου (λιτή) εκδοχή.

Για i από 1 μέχρι 30
Αν ΜΟ[i,1]>2 ή ΜΟ[ι,2]>4 τότε
   Εμφάνισε "Εκτός Ορίων"
Αλλιώς_αν (ΜΟ[i,1]>1.8 και ΜΟ[i,1]<=2) ή (ΜΟ[i,2]>3.6 και ΜΟ[i,2]<=4) τότε
   Εμφάνισε "Κοντά στα όρια"
Αλλιώς
   Εμφάνισε "Χαμηλός SAR"
Τέλος_Επανάληψης
« Τελευταία τροποποίηση: 29 Μάι 2013, 04:47:38 μμ από anyiota »

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Απ: Θέμα Γ
« Απάντηση #30 στις: 29 Μάι 2013, 04:12:00 μμ »
θα γίνει ακόμα πιο λιτή αν δεις ότι δε χρειάζονται οι ΚΑΙ στη συνθήκη της αλλιώς_αν  :)
Φιλικά,
Γιώργος Θαλασσινός

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: Θέμα Γ
« Απάντηση #31 στις: 29 Μάι 2013, 04:12:14 μμ »
Γιώτα μπορεί να αφαιρεθεί ένα κομμάτι από την δεύτερη συνθήκη...

Εδώ είναι η δική μου (λιτή) εκδοχή.

Για i από 1 μέχρι 30
Αν ΜΟ[i,1} >2 ή ΜΟ[ι,2]>4 τότε
   Εμφάνισε "Εκτός Ορίων"
Αλλιώς_αν (ΜΟ[i,1]>1.8 και ΜΟ[i,1]<=2) ή (ΜΟ[i,2]>3.6 και ΜΟ[i,2]<=4) τότε
   Εμφάνισε "Κοντά στα όρια"
Αλλιώς
   Εμφάνισε "Χαμηλός SAR"
Τέλος_Επανάληψης

summer

  • Θαμώνας
  • ***
  • Μηνύματα: 31
Θέμα Γ
« Απάντηση #32 στις: 29 Μάι 2013, 04:20:03 μμ »
Στο τελευταίο ερώτημα Γ4 με την ταξινόμηση μια μαθήτριά μου τοποθέτησε τα στοιχεία των 2 στηλών του ΜΟ σε δύο μονοδιάστατους πίνακες ΜΟ1 και ΜΟ2 και στη συνέχεια έκανε φθίνουσα ταξινόμηση μια φορά για τον ΜΟ1 και ΚΩΔ,εμφάνισε τα 3 πρώτα στοιχεία των ΜΟ1 και ΚΩΔ και μετά έκανε ταξινόμηση στον ΜΟ2 και ΚΩΔ εμφανίζοντας ομοίως τα 3 πρώτα στοιχεία των ΜΟ2 και ΚΩΔ.

Το λάθος προφανώς είναι ότι έπρεπε να κρατήσει σε έναν πίνακα ΚΩΔ2 τα στοιχεία του πίνακα ΚΩΔ στην αρχή και αυτόν να χρησιμοποιήσει στη δεύτερη ταξινόμηση.Νομίζω θα την έχουν πατήσει πολλοί εδώ.... Από τα 7 μόρια πόσο λέτε θα χάσει?
« Τελευταία τροποποίηση: 29 Μάι 2013, 04:53:54 μμ από summer »

anyiota

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 4
Απ: Θέμα Γ
« Απάντηση #33 στις: 29 Μάι 2013, 04:33:32 μμ »
σωστά, thanks

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: Θέμα Γ
« Απάντηση #34 στις: 29 Μάι 2013, 04:35:42 μμ »
Δεν ξέρω αν το παρατηρήσατε... αλλά στο θέμα Γ ήθελε αλγόριθμο με ψευδογλώσσα.
"Να αναπτύξετε αλγόριθμο σε ψευδογλώσσα, ο οποίος:"
Δηλαδή υποχρεωτικά με έναν από τους 4 τρόπους αναπαράστασης αλγορίθμου...

Να υπενθυμίσω ότι στο ΦΕΚ 2156/2012 που αναφέρει την εξεταστέα ύλη υπάρχει το εξής:

Οι μαθητές θα μπορούν να διατυπώνουν τις λύσεις των ασκήσεων των εξετάσεων είτε σε οποιαδήποτε μορφή παράστασης αλγορίθμου είτε σε «ΓΛΩΣΣΑ», όπως αυτή ορίζεται και χρησιμοποιείται στο διδακτικό εγχειρίδιο.

anyiota

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 4
Απ: Θέμα Γ
« Απάντηση #35 στις: 29 Μάι 2013, 04:52:28 μμ »
Γιώτα μπορεί να αφαιρεθεί ένα κομμάτι από την δεύτερη συνθήκη...


σωστά, thanks

dski

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 185
Απ: Θέμα Γ
« Απάντηση #36 στις: 29 Μάι 2013, 05:10:55 μμ »
To Γ4 νομίζω ότι λύνεται και χωρίς ταξινόμηση αλλά με απλή σειριακή ανάγνωση των δύο πινάκων και χρήση τριών μεταβλητών max1, max2, max3 για τις 3 μεγαλύτερες τιμές της κάθε στήλης πίνακα ΜΟ καθώς και code_max1, code_max1, code_max1 για τους αντίστοιχους κωδικούς του πίνακα ΚΩΔ (ή αν προτιμάτε τους δείκτες προς τις αντίστοιχες θέσεις του πίνακα ΚΩΔ).

Σκέφτομαι κάτι σαν (ας πούμε μόνο για την 1η στήλη του πίνακα ΚΩΔ (για το κεφάλι). Μέσα στην ίδια επανάληψη μπορεί να γίνει και για τη 2η στήλη):

max1  <- MO[1,1]
max2 <- 0
max3 <- 0
code_max1 <- ΚΩΔ[1]

ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 30
  ΑΝ ΜΟ[ι,1] > max1 ΤΟΤΕ
     max3 <- max2
     max2 <- max1
     max1 <- MO[ι,1]
     code_max3 <- code_max2
     code_max2 <- code_max1
     code_max1 <- ΚΩΔ[ι]
  ΑΛΛΙΩΣ_ΑΝ ΜΟ[ι,1] > max2 ΤΟΤΕ
     max3 <- max2
     max2 <- MO[ι,1]
     code_max3 <- code_max2
     code_max2 <- ΚΩΔ[ι]
 ΑΛΛΙΩΣ_ΑΝ ΜΟ[ι,1] > max3 ΤΟΤΕ
     max3 <- MO[ι,1]
     code_max3 <- ΚΩΔ[ι]

ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΕΜΦΑΝΙΣΕ code_max1, max1
ΕΜΦΑΝΙΣΕ code_max2, max2
ΕΜΦΑΝΙΣΕ code_max3, max3
         

Dinos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 86
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Γ
« Απάντηση #37 στις: 29 Μάι 2013, 05:20:11 μμ »
Στο Γ3 μπορούμε:
να δημιουργήσουμε παράλληλο πίνακα Β[30,2] με τον ΜΟ[30,2] , ο οποίος θα περιέχει τα στοιχεία "Α", "Β", "Γ" που θα αντιστοιχούν με τη σειρά στο "χαμηλός SAR", "κοντά στα όρια" , "εκτός ορίων".
Μετά σε κάθε γραμμή βρίσκουμε το μεγαλύτερο από τα 2 στοιχεία και επιστρέφουμε το μήνυμα που αντιστοιχεί σε αυτό.

Στο Γ4 μπορούμε:
χωρίς ταξινόμηση, να βρούμε το max1 με σάρωση των 30 στοιχείων, μετά να βρούμε το max2 με σάρωση πάλι των 30 στοιχείων μη λαμβάνοντας υπ' όψη το max1 και τέλος με ξανασάρωση των 30 στοιχείων βρίσκουμε max3 μη λαμβάνοντας υπ' όψη max1 kai max2

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 117
Απ: Θέμα Γ
« Απάντηση #38 στις: 29 Μάι 2013, 08:30:19 μμ »
Μπορείς να γίνεις πιο σαφής;

όχι μωρέ, μια χαρά δουλεύει

klitos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 133
Απ: Θέμα Γ
« Απάντηση #39 στις: 30 Μάι 2013, 08:58:35 πμ »
Εξακολουθώ να μην καταλαβαίνω τι εννοείς. Δοκίμασα τις τιμές που προτείνεις και μια χαρά δουλεύει ο κώδικας.
Αν ΜΟ[i,1] <= 1.8 και ΜΟ[i,2] <= 3.6 τότε
    Εμφάνισε "Χαμηλός SAR"
  Αλλιώς_αν ΜΟ[i,1] <= 2 και ΜΟ[i,2] <= 4 τότε
    Εμφάνισε "Κοντά στα όρια"
  Αλλιώς
    Εμφάνισε "Εκτός ορίων"
  Τέλος_αν
για δοκίμασε τις τιμές
 Κεφαλή=1,9 και Ακρα=2
Κεφαλή = 1 και Ακρα=3.8
ο κωδικας που προτείνεις θα εμφανίσει "εκτος οριων" ενω πρεπει να εμφανίσει "κοντα στα ορια"

το ιδιο πρόβλημα θα παρουσιαστεί και με τις τιμές που προτείνει το παράδειγμα του θέματος πχ άκρα=3,8 και κεφαλή=1,5


κλητος χατζηγεωργιου

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #40 στις: 30 Μάι 2013, 10:56:02 πμ »
Ξαναδες το
Κι εγώ έτσι νόμιζα, αλλά για κάποιο σατανικό λόγο, δουλεύει  >:D
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

makryd

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Θέμα Γ
« Απάντηση #41 στις: 30 Μάι 2013, 12:07:21 μμ »
Καλημέρα,
Μια μαθήτρια μου έγραψε το εξής για το Γ3:
Αν ΜΟ[i,1]<=1.8 τότε
     μνμ1 ← “ Χαμηλός SAR”
Αλλιώς_Αν ΜΟ[i,1]<=2 τότε
     μνμ1 ←  “ Κοντά στα όρια”
Αλλιώς
     μνμ1 ← “ Εκτός ορίων”
Τέλος_Αν
Αν ΜΟ[i,2]<=3.6 τότε
     μνμ2 ← “ Χαμηλός SAR”
Αλλιώς_Αν ΜΟ[i,2]<=4 τότε
     μνμ2 ← “ Κοντά στα όρια”
Αλλιώς
     μνμ2 ← “ Εκτός ορίων”
Τέλος_Αν
Αν μνμ1 < μνμ2 τότε
     Εμφάνισε ΚΩΔ, μνμ1
Αλλιώς
     Εμφάνισε ΚΩΔ, μνμ2
Τέλος_Αν

Παρατηρώντας ότι στην μεγαλύτερη περιοχή τιμών το μήνυμα ξεκινάει από αλφαβητικά μικρότερο γράμμα! 
Ελπίζω να βαθμολογηθεί ως σωστό.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #42 στις: 30 Μάι 2013, 12:18:46 μμ »
Τέλειο είναι!!!
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Γιάννης Αναγνωστάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 817
Απ: Θέμα Γ
« Απάντηση #43 στις: 30 Μάι 2013, 12:43:46 μμ »
για δοκίμασε τις τιμές
 Κεφαλή=1,9 και Ακρα=2
Κεφαλή = 1 και Ακρα=3.8
ο κωδικας που προτείνεις θα εμφανίσει "εκτος οριων" ενω πρεπει να εμφανίσει "κοντα στα ορια"

το ιδιο πρόβλημα θα παρουσιαστεί και με τις τιμές που προτείνει το παράδειγμα του θέματος πχ άκρα=3,8 και κεφαλή=1,5




Μία χαρά δουλεύει

για κεφαλή 1.9 και άκρα=2, θα μπει στο πρώτο αλλιως_αν και θα εμφανίσει  κοντά στα όρια
ομοίως και για τις άλλες τιμές

Η φιλοσοφία εδώ είναι ότι είτε ξεκινάς από τις μεγαλύτερες τιμές και ελέγχεις με διάζευξη αν έχει ξεπεραστεί κάποιο απο τα 2 όρια, ή ξεκινάς από τα κάτω όρια και ελέγχεις με σύζευξη να μην έχει ξεπεραστεί κάποιο από τα 2 όρια..






mokasa

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 27
Απ: Θέμα Γ
« Απάντηση #44 στις: 30 Μάι 2013, 01:39:00 μμ »
Εγραψα μια άσκηση που διδάσκει - εξετάζει την πολλαπλή επιλογή του θέματος Γ3, με σκοπό να χρησιμοποιηθεί
σαν εύκολη άσκηση στην διάρκεια της διδακτικής χρονιάς ή ίσως σε ένα από τα τελευταία επαναληπτικά μαθήματα.

Στην πορεία μπήκα στον πειρασμό να γράψω και μια πιο δύσκολη παραλλαγή της. Παρακαλώ αν βρείτε λάθη ή παραλείψεις
σε οποιαδήποτε από τις δύο εκδοχές να με διορθώσετε.

Να επισημάνω οτι την ιδέα της εκφώνησης την πήρα απο μια άλλη άσκηση που είχε στείλει ο χρήστης landreou.

gpitsa01

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Θέμα Γ
« Απάντηση #45 στις: 30 Μάι 2013, 08:16:48 μμ »
Υπάρχει στην ύλη του σχολικού βιβλίου ταξινόμηση δισδιάστατου πίνακα? Και αν ναι σε ποιό σημείο?

gpitsa01

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Θέμα Γ
« Απάντηση #46 στις: 30 Μάι 2013, 08:17:28 μμ »
Αναφέρομαι για το Γ4 Θέμα

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1015
Απ: Θέμα Γ
« Απάντηση #47 στις: 30 Μάι 2013, 08:28:20 μμ »
Το σκεπτικό του Γ4 :

Μία στήλη σε έναν δισδιάστατο, είναι ένας μονοδιάστατος !

Υ.Γ.  Η 1η στήλη του ΜΟ[30,2] είναι σε παραλληλία  με τη 2η αλλά και με τον ΚΩΔ[30].

Α

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Θέμα Γ
« Απάντηση #48 στις: 31 Μάι 2013, 10:44:54 πμ »
Θεωρώντας βέβαια ότι λέγοντας μεγαλύτερη περιοχή τιμών εννοούμε την πιο επιβλαβή για το άτομο περιοχή, κάτι που έπρεπε να διατυπωθεί καλύτερα
Συμφωνώ απόλυτα.
Διδάσκω το μάθημα πάνω από 10 χρόνια. Θεωρώ την εκφώνιση "μεγαλύτερη περιοχή τιμών" απαράδεκτη. Με την πρώτη ματιά κατάλαβα ότι εννοούσαν την περιοχή με το μεγαλύτερο εύρος.Προσωπικά κατάλαβα τι ήθελαν να πουν οι θεματοδότες μετά από αρκετή ώρα. Το παράδειγμα που δόθηκε μάλλον μπέρδευε παρά διαφώτιζε τους μαθητές. Δυο από τους καλύτερους μαθητές του σχολείου μου (από τα πιο λαμπρά μυαλά που έχω συναντήσει) κατάλαβαν ότι υπερίσχυε ο μεγαλύτερος μέσος όρος.
Η ΚΕΕ όταν έδωσε το θέμα δεν κατάλαβε το ατόπημά της. Δεν μπόρεσε να το καταλάβει ούτε όταν ζητήθηκε διευκρίνιση; Γιατί θα πρέπει να χαθούν μονάδες εξαιτίας μιας λανθασμένης διατύπωσης; Μήπως θα έπρεπε να απολογηθούν γι΄αυτό οι κύριοι της ΚΕΕ;

ολγα

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Θέμα Γ
« Απάντηση #49 στις: 31 Μάι 2013, 11:14:20 πμ »
... σε συνέχεια του προηγούμενου
Η ΠΕΚΑΠ τι κάνει; Ανακοινώνει ότι τα θέματα είναι "ορθά διατυπωμένα";
Μήπως εκθέτουν τους εαυτούς τους;

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3164
  • to Iterate is human to Recurse divine
Απ: Θέμα Γ
« Απάντηση #50 στις: 31 Μάι 2013, 11:27:54 πμ »
Η εκφώνηση πράγματι είναι πολυ κακή. Ωστόσο δεν διαμαρτύθηκαν και τόσοι πολλοί μαθητές. Δεν είναι περίεργο?
Επειδή το θέμα με προβλημάτισε πολύ χθες στην ενημέρωση των βαθμολογητών κατέληξα στο εξής συμπέρασμα:

Όσοι διάβασαν βιαστικά το θέμα και είδαν τον πίνακα και ήταν προπονημένοι σε τέτοιες άσκησεις ήξεραν τι να κάνουν. Δηλαδή αυτοί που διάβασαν περίπου την εκφώνηση και κατάλαβαν περίπου τι ζητείται απάντησαν σωστά και γρήγορα.

Όσοι όμως ήταν πιο προσεκτικοί μπερδεύτηκαν γιατί διάβασαν προσεκτικά την εκφώνηση και δεν μπορούσαν να καταλάβουν τι εννοεί. Εμείς καταλαβαίνουμε τι θέλει να πει επειδή έχουμε στο μυαλό μας την άσκηση με τους ρύπους από το Τετράδιο μαθητή. Αν όμως δεν είχαμε δει τέτοια άσκηση πως θα το αντιμετωπίζαμε?

Πιστεύω ότι το αποτέλεσμα αυτής της κακής εκφώνησης ήταν ότι πολλοί καλοί μαθητές που την διάβασαν προσεκτικά έχασαν πολύτιμο χρόνο προσπαθώντας να την ερμηνεύσουν. Νομίζω όμως ότι στο τέλος το έκαναν σωστά.

Από εκεί και πέρα αυτή τη στιγμή δεν μπορεί να γίνει κάτι. Το καλύτερο που μπορεί να γίνει είναι οι βαθμολογητές έχοντας υπόψην τους αυτή την ασάφεια να είναι πιο επιεικείς σε περίεργες λάθος λύσεις που όμως έχουν μια σωστή λογική. Κάτι τέτοιο δεν έγινε και πέρυσι με το θέμα Δ?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

klitos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 133
Απ: Θέμα Γ
« Απάντηση #51 στις: 05 Ιούν 2013, 09:14:19 πμ »
Μία χαρά δουλεύει

για κεφαλή 1.9 και άκρα=2, θα μπει στο πρώτο αλλιως_αν και θα εμφανίσει  κοντά στα όρια
ομοίως και για τις άλλες τιμές

Η φιλοσοφία εδώ είναι ότι είτε ξεκινάς από τις μεγαλύτερες τιμές και ελέγχεις με διάζευξη αν έχει ξεπεραστεί κάποιο απο τα 2 όρια, ή ξεκινάς από τα κάτω όρια και ελέγχεις με σύζευξη να μην έχει ξεπεραστεί κάποιο από τα 2 όρια..
OK εχεις δίκιο , δουλεύει ...
κλητος χατζηγεωργιου

igeorgi

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Θέμα Γ
« Απάντηση #52 στις: 05 Ιούν 2013, 02:00:48 μμ »
Λύση που έδωσε μαθητής μου στο Γ3 και την είδα και σε γραπτό που διόρθωνα προχθες. Εκμεταλλεύεται το γεγονός ότι τα μηνύματα βρίσκονται σε αντίστροφη αλφαβητική σειρά:

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30
   ΑΝ ΜΟ[Ι,1] <= 1,8 ΤΟΤΕ
      ΜΗΝΥΜΑ1 <- 'ΧΑΜΗΛΟΣ SAR'
   ΑΛΛΙΩΣ_ΑΝ ΜΟ[Ι,1] <=2 ΤΟΤΕ
      ΜΗΝΥΜΑ1 <- 'ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ'
   ΑΛΛΙΩΣ
      ΜΗΝΥΜΑ1 <- 'ΕΚΤΟΣ ΟΡΙΩΝ'
   ΤΕΛΟΣ_ΑΝ
   ΑΝ ΜΟ[Ι,2] <= 3,6 ΤΟΤΕ
      ΜΗΝΥΜΑ2 <- 'ΧΑΜΗΛΟΣ SAR'
   ΑΛΛΙΩΣ_ΑΝ ΜΟ[Ι,2] <=4 ΤΟΤΕ
      ΜΗΝΥΜΑ2 <- 'ΚΟΝΤΑ ΣΤΑ ΟΡΙΑ'
   ΑΛΛΙΩΣ
      ΜΗΝΥΜΑ2 <- 'ΕΚΤΟΣ ΟΡΙΩΝ'
   ΤΕΛΟΣ_ΑΝ
   ΑΝ ΜΗΝΥΜΑ1 > ΜΗΝΥΜΑ2 ΤΟΤΕ
      ΕΜΦΑΝΙΣΕ ΚΩΔ[Ι], ΜΗΝΥΜΑ2
   ΑΛΛΙΩΣ
      ΕΜΦΑΝΙΣΕ ΚΩΔ[Ι], ΜΗΝΥΜΑ1
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3164
  • to Iterate is human to Recurse divine
Απ: Θέμα Γ
« Απάντηση #53 στις: 05 Ιούν 2013, 02:05:45 μμ »
Αυτή τη λύση την πρότεινε συνάδελφος στο βαθμολογικό που είμαι και όλοι είπαν ότι αποκλείεται μαθητής να τη σκεφτεί, ωστόσο να που κάποιος το είδε. Φοβερό

Πάντως το Γ3 είναι το πιο δύσκολο ερώτημα στη βαθμολόγηση μαζί με το Β2. Όλες οι διαφορές μεταξύ των βαθμολογητών από εκεί βγαίνουν
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

igeorgi

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Θέμα Γ
« Απάντηση #54 στις: 05 Ιούν 2013, 02:09:28 μμ »
Εξακολουθώ να μην καταλαβαίνω τι εννοείς. Δοκίμασα τις τιμές που προτείνεις και μια χαρά δουλεύει ο κώδικας.
Αν ΜΟ[i,1] <= 1.8 και ΜΟ[i,2] <= 3.6 τότε
    Εμφάνισε "Χαμηλός SAR"
  Αλλιώς_αν ΜΟ[i,1] <= 2 και ΜΟ[i,2] <= 4 τότε
    Εμφάνισε "Κοντά στα όρια"
  Αλλιώς
    Εμφάνισε "Εκτός ορίων"
  Τέλος_αν

Αυτό θα έβγαζε λάθος αν (πράγμα που έχουν κάνει αρκετοί μαθητές στα γραπτά που βλέπω) περιορίζαμε την δεύτερη συνθήκη ως εξής:

Αλλιώς_αν (ΜΟ[i,1] > 1,8] ΚΑΙ ΜΟ[i,1] <= 2) και (ΜΟ[i,2] > 3,6 ΚΑΙ ΜΟ[i,2] <= 4) τότε

Στην περίπτωση αυτή ο αλγόριθμος θα ήθελε και τις 2 τιμές "Κοντά στα όρια" για να εμφανίσει το αντίστοιχο αποτέλεσμα, ενώ με μία τιμή "Κοντά στα όρια" και μια τιμή "Χαμηλός SAR" θα εμφάνιζε "Εκτός ορίων" (θα ενέπιπτε στην περίπτωση ΑΛΛΙΩΣ).

igeorgi

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Θέμα Γ
« Απάντηση #55 στις: 05 Ιούν 2013, 02:12:15 μμ »
Αυτή τη λύση την πρότεινε συνάδελφος στο βαθμολογικό που είμαι και όλοι είπαν ότι αποκλείεται μαθητής να τη σκεφτεί, ωστόσο να που κάποιος το είδε. Φοβερό

Πάντως το Γ3 είναι το πιο δύσκολο ερώτημα στη βαθμολόγηση μαζί με το Β2. Όλες οι διαφορές μεταξύ των βαθμολογητών από εκεί βγαίνουν

Ομολογώ ότι κι εμένα όταν μου την είπε ο μαθητής μου με εξέπληξε πολύ θετικά. Δεν το είχα σκεφτεί μέχρι εκείνη την στιγμή και ούτε περίμενα να την δω σε γραπτό. Εκείνος μου είπε ότι ήταν το πρώτο που του ήρθε στο μυαλό. Κάποιοι το έχουν υλοποιήσει και με αριθμητικές τιμές (Μήνυμα_Κεφ <- 1 κ.ο.κ.)
Διαφορές προκύπτουν και από το Δ2 γιατί κάποιοι έχουν πάρει 10 διαφορετικές περιπτώσεις για να προσθέσουν στην κατάλληλη θέση του πίνακα +1 και κάποιοι συνάδελφοι κόβουν όλες τις μονάδες του ερωτήματος. Είμαι εκτός θέματος, αλλά επειδή αναφέρθηκαν οι διαφορές στην βαθμολόγηση το επεσήμανα..

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3164
  • to Iterate is human to Recurse divine
Απ: Θέμα Γ
« Απάντηση #56 στις: 05 Ιούν 2013, 02:32:19 μμ »
Ας παραμείνουμε εκτός θέματος  :police:

και να πω ότι στο Δ2 υπάρχουν ακόμα 2 λύσεις
1 μια που λες με τα 10 (5 + 5) Αν τότε
και μια 2η που μαζεύει τα 5 Αν σε μια επανάληψη

και τις 2 τις παίρνουμε σωστές, τις έχουμε και στις ενδεικτικές λύσεις των συνονιστών, και δεν υπήρχε αντίδραση από κανέναν.

Φαντάζομαι ότι αν η ΚΕΕ δεν ήθελε πολλά Αν θα έβαζε όχι 5 αλλά 100 οπότε εκεί δεν θα έβγαινε έτσι. Στην περίπτωση αυτή θα δούλευε φυσικά η λύση που λέω με επανάληψη όπως φαίνεται παρακάτω (την έχουμε δει σε γραπτά)

Διάβασε απ
Για ι από 1 μέχρι 5
  Αν ι = απ Τότε     EL[ι] <- EL[ι] + 1
TE

Διαφορές προκύπτουν και από το Δ2 γιατί κάποιοι έχουν πάρει 10 διαφορετικές περιπτώσεις για να προσθέσουν στην κατάλληλη θέση του πίνακα +1 και κάποιοι συνάδελφοι κόβουν όλες τις μονάδες του ερωτήματος. Είμαι εκτός θέματος, αλλά επειδή αναφέρθηκαν οι διαφορές στην βαθμολόγηση το επεσήμανα..

Συνάδελφε igeorgi σε ποιο βαθμολογικό συμβαίνει αυτό? Διότι ειλικρινά δυσκολεύομαι να το πιστέψω.
« Τελευταία τροποποίηση: 05 Ιούν 2013, 05:53:15 μμ από evry »
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #57 στις: 05 Ιούν 2013, 03:24:27 μμ »
Διαφορές προκύπτουν και από το Δ2 γιατί κάποιοι έχουν πάρει 10 διαφορετικές περιπτώσεις για να προσθέσουν στην κατάλληλη θέση του πίνακα +1 και κάποιοι συνάδελφοι κόβουν όλες τις μονάδες του ερωτήματος.

Αυτό ισχύει πραγματικά;;;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Απ: Θέμα Γ
« Απάντηση #58 στις: 06 Ιούν 2013, 09:23:49 πμ »
Διαφορές προκύπτουν και από το Δ2 γιατί κάποιοι έχουν πάρει 10 διαφορετικές περιπτώσεις για να προσθέσουν στην κατάλληλη θέση του πίνακα +1 και κάποιοι συνάδελφοι κόβουν όλες τις μονάδες του ερωτήματος.
Αυτό είναι απαράδεκτο! Καμία δε θα έπρεπε να κόβεται.
Αλλά πραγματικά δεν καταλαβαίνω πώς χωράει τόση υποκειμενικότητα στη βαθμολόγηση. Σε τέτοια λεπτά σημεία νομίζω ότι θα έπρεπε να δίνονται σαφείς οδηγίες προς τους βαθμολογητές.
Φιλικά,
Γιώργος Θαλασσινός

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2452
  • I 'm not young enough to know everything
Απ: Θέμα Γ
« Απάντηση #59 στις: 06 Ιούν 2013, 09:59:00 πμ »
Διαφορές προκύπτουν και από το Δ2 γιατί κάποιοι έχουν πάρει 10 διαφορετικές περιπτώσεις για να προσθέσουν στην κατάλληλη θέση του πίνακα +1 και κάποιοι συνάδελφοι κόβουν όλες τις μονάδες του ερωτήματος. Είμαι εκτός θέματος, αλλά επειδή αναφέρθηκαν οι διαφορές στην βαθμολόγηση το επεσήμανα..

Αν καταλαβαίνω καλά μέσα λες ότι μέσα στο ίδιο εξεταστικό κέντρο κάποιοι βαθμολογούν την ίδια λύση με 0 και κάποιοι άλλοι με άριστα. Το γεγονός αυτό το εντόπισες εσύ, άρα το ξέρει και ο συντονιστής και παρόλα αυτά δεν γίνεται κάτι... αλλά συνεχίσουν εν γνώση τους να βαθμολογούν διαφορετικά. Κατάλαβα καλά τι λες;

igeorgi

  • Θαμώνας
  • ***
  • Μηνύματα: 23
Απ: Θέμα Γ
« Απάντηση #60 στις: 08 Ιούν 2013, 01:54:13 πμ »
Μίλησα με τον συντονιστή, αλλά τώρα μάλλον είναι αργά διότι η διόρθωση τελειώνει, έχω στην φύλαξη τον τελευταίο φάκελο του βαθμολογικού. Εγώ σαν δεύτερος βαθμολογητής διόρθωσα γραπτό με την μάσκα του πρώτου να έχει ξεκολλήσει και είδα ότι στο συγκεκριμένο θέμα ο συνάδελφος είχε βαθμολογήσει με το απόλυτο μηδέν. Κι επειδή είχε κόψει και κάποιες μονάδες ακόμα από άλλα ερωτήματα, στην τελική βαθμολογία προέκυψε διαφορά 10 μονάδων. Μετά σκέφτηκα ότι ίσως θα έπρεπε να βάλω +13 για να πάει σε αναβαθμολογητή το γραπτό, αλλά φαντάζομαι ότι αυτό δεν θα έσωζε την κατάσταση διότι την συγκεκριμένη λύση την έχουν δώσει το 40% των παιδιών των οποίων τα γραπτά διόρθωσα. Κι έχω διορθώσει 7 φακέλους, αρκετά αντιπροσωπευτικό το δείγμα.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Θέμα Γ
« Απάντηση #61 στις: 08 Ιούν 2013, 09:56:44 πμ »
Ωραία πράγματα...
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Peandbal

  • Θαμώνας
  • ***
  • Μηνύματα: 48
  • Αρθρο 16
Απ: Θέμα Γ
« Απάντηση #62 στις: 08 Ιούν 2013, 06:45:22 μμ »
Δεν νομίζω ότι δουλεύει το παραπάνω..
Το Γ3 είναι πολύ ασαφές.
Τι σημαίνει "μεγαλύτερη περιοχή τιμών" ;
Εγώ προσωπικά το καταλαβαίνω ως την περιοχή με το μεγαλύτερο εύρος.
Το παράδειγμα που δίνεται βέβαια δεν με επιβεβαιώνει.
Πολύ ατυχής διατύπωση  :(
Δεν νομίζω ότι δουλεύει το παραπάνω..

Συνάδελφε νομίζω ότι δουλεύει μια χαρά και αυτή η λύση.

elenitaaaaa

  • Βετεράνος
  • ****
  • Μηνύματα: 90
Απ: Θέμα Γ
« Απάντηση #63 στις: 11 Ιούν 2013, 01:59:22 πμ »
Για i από 2 μέχρι 30
  Για j από 30 μέχρι i με_βήμα -1
     Αν ΜΟ[j-1,2]<ΜΟ[j,2] τότε
           Αντιμετάθεσε ΜΟ[j-1,1]<ΜΟ[j,1]
           Αντιμετάθεσε ΜΟ[j-1,2]<ΜΟ[j,2]
           Αντιμετάθεσε ΚΩΔ[j-1]< ΚΩΔ[j] 
    τέλος_αν
  τέλος_επανάληψης
τέλος_επανάληψης
Για i από 1 μέχρι 3
  εμφάνισε ΚΩΔ[ i ],  ΜΟ[i,2]
τέλος_επανάληψης

το " Αντιμετάθεσε ΜΟ[j-1,1]<ΜΟ[j,1] " μπορει να παραλειφθει. δεν χρειαζεται να διατηρηθει συσχέτιση απ τη στιγμη που η ασκηση τελειωνει.

CyberMove

  • Νέος
  • *
  • Μηνύματα: 8
  • 404 Error!
Απ: Θέμα Γ
« Απάντηση #64 στις: 17 Ιούν 2013, 03:41:55 μμ »
Καλησπέρα σε όλους!

Ορίστε η λύση μου για το Γ.4


Για κ από 1 μέχρι 3
          MAX_ΚΕΦΑΛΙ<--ΜΟ[1,1]               !Εύρεση μεγίστου για το SAR κεφάλι.
          ΘΕΣΗ<--1
          Για i από 2 μέχρι 30
                  Αν ΜΟ[i,1]>MAX_ΚΕΦΑΛΙ τότε
                       MAX_ΚΕΦΑΛΙ<--ΜΟ[i,1]
                       ΘΕΣΗ<--i
                  Τέλος_Αν
          Τέλος_Επανάληψης
                  Εμφάνισε MAX_ΚΕΦΑΛΙ,ΚΩΔ[ΘΕΣΗ]
                  ΜΑΧ_ΚΕΦΑΛΙ<--0                         !Τέλος εύρεσης μεγίστου για το SAR κεφάλι.
                  MAX_ΑΚΡΟ<--ΜΟ[1,2]                  !Εύρεση μεγίστου για το SAR άκρο.       
          ΘΕΣΗ2<--1
          Για j από 2 μέχρι 30
                  Αν ΜΟ[j,2]>MAX_ΑΚΡΟ τότε
                      MAX_ΑΚΡΟ<--ΜΟ[j,2]
                      ΘΕΣΗ2<--j
                 Τέλος_Αν
          Τέλος_Επανάληψης
          Εμφάνισε MAX_ΑΚΡΟ,ΚΩΔ[ΘΕΣΗ2]
          ΜΑΧ_ΑΚΡΟ<--0                                    !Τέλος εύρεσης μεγίστου για το SAR άκρο.
Τέλος_Επανάληψης                                   

Απλά το έχω βάλει να βρίσκει κάθε φορά τα μέγιστα και από τα 2 SAR (δηλαδή όταν κ=1,το πρώτο MAX_SAR_ΚΕΦΑΛΙ και MAX_SAR_ΑΚΡΟ,όταν κ=2 τότε το δεύτερο MAX_SAR_ΚΕΦΑΛΙ και MAX_SAR_ΑΚΡΟ και όταν κ=3 τότε το τρίτο MAX_SAR_ΚΕΦΑΛΙ και MAX_SAR_ΑΚΡΟ)

Ελπίζω να μου το πάρουν σωστό στην βαθμολόγηση... :P
« Τελευταία τροποποίηση: 19 Ιούν 2013, 08:21:12 μμ από CyberMove »
If Grandma_Had_Rolls = TRUE Then
        MsgBox.Style ("Grandma = TROLLEY")
End_If

Dinos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 86
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Γ
« Απάντηση #65 στις: 18 Ιούν 2013, 06:08:14 μμ »
Αγαπητέ CyberMove, σου εύχομαι ολόψυχα καλά αποτελέσματα και καλό καλοκαίρι.
Όσον αφορά στο Γ4, σου παραθέτω μια ενδεικτική λύση, βασισμένη στη δική σου πρωτότυπη αλλά λίγο "μπελαλίδικη" προσέγγιση.
ΠΡΟΣΟΧΗ: Κάθε φορά αναζητάς το μέγιστο από όλα εκτός από το ένα ή  τα δύο προηγούμενα μέγιστα[/color
Κώδικας: [Επιλογή]
Θ1 <-- 0, Θ2 <-- 0
Θ3 <-- 0, Θ4 <-- 0
Για κ από 1 μέχρι 3
MAX_ΚΕΦΑΛΙ <-- 0               !Εύρεση μεγίστου για το SAR κεφάλι.
Για i από 1 μέχρι 30
Αν ΜΟ[i,1] > MAX_ΚΕΦΑΛΙ  ΚΑΙ i<>Θ1 ΚΑΙ i<>Θ2 τότε
MAX_ΚΕΦΑΛΙ<--ΜΟ[i,1]
ΘΕΣΗ<--i
Τέλος_Αν         
Τέλος_Επανάληψης
Εμφάνισε ΜΑΧ_ΚΕΦΑΛΙ, ΚΩΔ[ΘΕΣΗ]                     
MAX_ΑΚΡΟ<--0                  !Εύρεση μεγίστου για το SAR άκρο.       
Για j από 1 μέχρι 30
Αν ΜΟ[j,2]>MAX_ΑΚΡΟ ΚΑΙ i <>Θ3 ΚΑΙ i <>Θ4 τότε
MAX_ΑΚΡΟ<--ΜΟ[j,2]
ΘΕΣΗ2<--j
Τέλος_Αν
Τέλος_Επανάληψης                        !
Εμφάνισε MAX_ΑΚΡΟ,ΚΩΔ[ΘΕΣΗ2]
Αν κ = 1 τότε
Θ1 <-- ΘΕΣΗ
Θ3 <-- ΘΕΣΗ2
Αλλιώς_αν κ = 2 τότε
Θ2 <-- ΘΕΣΗ
Θ4 <-- ΘΕΣΗ2
Τέλος_αν
Τέλος_Επανάληψης

CyberMove

  • Νέος
  • *
  • Μηνύματα: 8
  • 404 Error!
Απ: Θέμα Γ
« Απάντηση #66 στις: 19 Ιούν 2013, 08:29:19 μμ »
Αγαπητέ CyberMove, σου εύχομαι ολόψυχα καλά αποτελέσματα και καλό καλοκαίρι.
Όσον αφορά στο Γ4, σου παραθέτω μια ενδεικτική λύση, βασισμένη στη δική σου πρωτότυπη αλλά λίγο "μπελαλίδικη" προσέγγιση.
ΠΡΟΣΟΧΗ: Κάθε φορά αναζητάς το μέγιστο από όλα εκτός από το ένα ή  τα δύο προηγούμενα μέγιστα[/color
Κώδικας: [Επιλογή]
Θ1 <-- 0, Θ2 <-- 0
Θ3 <-- 0, Θ4 <-- 0
Για κ από 1 μέχρι 3
MAX_ΚΕΦΑΛΙ <-- 0               !Εύρεση μεγίστου για το SAR κεφάλι.
Για i από 1 μέχρι 30
Αν ΜΟ[i,1] > MAX_ΚΕΦΑΛΙ  ΚΑΙ i<>Θ1 ΚΑΙ i<>Θ2 τότε
MAX_ΚΕΦΑΛΙ<--ΜΟ[i,1]
ΘΕΣΗ<--i
Τέλος_Αν         
Τέλος_Επανάληψης
Εμφάνισε ΜΑΧ_ΚΕΦΑΛΙ, ΚΩΔ[ΘΕΣΗ]                     
MAX_ΑΚΡΟ<--0                  !Εύρεση μεγίστου για το SAR άκρο.       
Για j από 1 μέχρι 30
Αν ΜΟ[j,2]>MAX_ΑΚΡΟ ΚΑΙ i <>Θ3 ΚΑΙ i <>Θ4 τότε
MAX_ΑΚΡΟ<--ΜΟ[j,2]
ΘΕΣΗ2<--j
Τέλος_Αν
Τέλος_Επανάληψης                        !
Εμφάνισε MAX_ΑΚΡΟ,ΚΩΔ[ΘΕΣΗ2]
Αν κ = 1 τότε
Θ1 <-- ΘΕΣΗ
Θ3 <-- ΘΕΣΗ2
Αλλιώς_αν κ = 2 τότε
Θ2 <-- ΘΕΣΗ
Θ4 <-- ΘΕΣΗ2
Τέλος_αν
Τέλος_Επανάληψης

Κατ'αρχάς σε ευχαριστώ πολύ! Σου εύχομαι και εσένα (και όλους εδώ) ένα υπέροχο καλοκαίρι και καλή ξεκούραση (για όσους έδιναν,καλά αποτελέσματα).

Όντως η παραλλαγή αυτή είναι λίγο μπελαλίδικη.Μου πήρε πάνω-κάτω 10 λεπτά να κατανοήσω αυτό το κομμάτι:

Αν κ = 1 τότε
      Θ1 <-- ΘΕΣΗ
      Θ3 <-- ΘΕΣΗ2
   Αλλιώς_αν κ = 2 τότε
      Θ2 <-- ΘΕΣΗ
      Θ4 <-- ΘΕΣΗ2
   Τέλος_αν


Αν κατάλαβα σωστά,επειδή στις δομές επιλογής έχεις i<>Θ1 ΚΑΙ i<>Θ2,i <>Θ3 ΚΑΙ i <>Θ4 απλά όταν θα φτάσει στην θέση του πρώτου MAX δεν θα μπει γιατί δεν θα ικανοποιήτε η συνθήκη και πάει στο επόμενο στοιχείο (αν υπάρχει).
Το κ=3 δεν το έβαλες γιατί είναι τα τελικά MAX που θα εμφανίζει και εκεί μετά τελειώνει η άσκηση.

:)
If Grandma_Had_Rolls = TRUE Then
        MsgBox.Style ("Grandma = TROLLEY")
End_If