Αποστολέας Θέμα: Θέμα Β  (Αναγνώστηκε 27227 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #90 στις: 01 Ιούν 2013, 06:53:08 μμ »
Ερώτηση προς όλους όσους ασχολούνται με το θέμα:

Αν ο μαθητής δώσει την "ταξινόμηση"  ;) της φυσαλίδας αλλά σωστά, δηλαδή με

   Αν Π[j-1]=Ψευδής και Π[j]=Αληθής Τότε

πόσες μονάδες παίρνει , κατά τη γνώμη σας? Πρέπει να πάρει κάτι από τις 10 μονάδες?

Νομίζω είναι ενδιαφέρον προβληματισμός

What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3174
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Β
« Απάντηση #91 στις: 01 Ιούν 2013, 08:45:26 μμ »
Μετα απο διόρθωση 25 γραπτών σε 8:30 ώρες:
1. Ειμαι σα να έχω πιει τσίπουρα
2. Δε θυμωνω και ειδικά με φίλους.

Απλα σας είπα οτι αν δεν υπήρχε το μπλοκ που μπήκε στο β2 θα έπεφτε πολυ φυσαλιδα...
Και διαφωνω με το θεματακι αυτο (την επιλογη του)

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #92 στις: 02 Ιούν 2013, 12:41:53 πμ »
Χεχε, το είχα σκεφτεί ένα λεπτό αφότου είχα γράψει το μήνυμα, αλλά είπα να μην το χοντρύνω! Σύμφωνοι, η O(n (+k για το πλήθος του πεδίου τιμών)) πολυπλοκότητα θα ήταν η καλύτερη εκφώνηση!
...αλλά από την άλλη, αν κάποιος κατάφερνε ταξινόμηση φυσαλίδας με μονό loop, εγώ θα του έβαζα 100 χωρίς να κοιτάξω καν τις άλλες απαντήσεις του!  >:D


Ή θα αναρωτιόσουν γιατί να αναλώσει χρόνο σε κάτι που δεν έχει καμμια ουσία.Υπάρχουν αρκετοί λόγοι για να μην κάνεις την bubblesort με ένα loop.Αλλά από την άλλη θα μου πεις,γιατί να περιορίζεις την φαντασία του ανθρώπου.

Ερώτηση προς όλους όσους ασχολούνται με το θέμα:

Αν ο μαθητής δώσει την "ταξινόμηση"  ;) της φυσαλίδας αλλά σωστά, δηλαδή με

   Αν Π[j-1]=Ψευδής και Π[j]=Αληθής Τότε

πόσες μονάδες παίρνει , κατά τη γνώμη σας? Πρέπει να πάρει κάτι από τις 10 μονάδες?

Νομίζω είναι ενδιαφέρον προβληματισμός


Το θέμα είναι πώς μπορεί ό,τι και να δώσει ο μαθητής να μην είναι "ταξινόμηση";Επίσης δεν αντιλαμβάνομαι γιατί το θέσανε ως
Παράθεση
...χωρίς  τη  χρήση«αλγορίθμων  ταξινόμησης»...
Έχουν διδαχθεί πολλούς αλγορίθμους ταξινόμησης;Γενικά,η εκφώνηση του θέματος είναι τουλάχιστον άστοχη.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #93 στις: 02 Ιούν 2013, 10:49:06 πμ »
Μαθητής έδωσε την παρακάτω απάντηση στο Β2

Για κ από 99 μέχρι 1
    Για λ από 1 μέχρι κ
        Αν Π[λ]=Ψευδής και Π[λ+1]=Αληθής Τότε
            Αντιμετάθεσε Π[λ], Π[λ+1]
        Τέλος_αν
    Τέλος_Επανάληψης
Τέλος_Επανάληψης

What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #94 στις: 02 Ιούν 2013, 11:11:16 πμ »
Μαθητής έδωσε την παρακάτω απάντηση στο Β2

Για κ από 99 μέχρι 1
    Για λ από 1 μέχρι κ
        Αν Π[λ]=Ψευδής και Π[λ+1]=Αληθής Τότε
            Αντιμετάθεσε Π[λ], Π[λ+1]
        Τέλος_αν
    Τέλος_Επανάληψης
Τέλος_Επανάληψης

Έχω αρχίσει να λυπάμαι αυτούς που βαθμολογούν...

nassos

  • Νέος
  • *
  • Μηνύματα: 1
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Β
« Απάντηση #95 στις: 02 Ιούν 2013, 04:52:42 μμ »
Μαθητής το έγραψε όπως είπαν και άλλοι συνάδελφοι...

μ <-- 1
Για κ από 1 μέχρι 100
  Αν Π[κ] = Αληθής τότε
    Αντιμετάθεσε Π[κ], Π[μ]
    μ <-- μ + 1
  Τέλος_αν
Τέλος_επανάληψης


και αντί να του βάλουμε 10 που βρήκε τρόπο που δεν τον διδάχτηκε, (γιατί διδάχτηκε μόνο φυσσαλίδα και έστω καποιες βελτιώσεις της), εμείς θέλουμε να του μηδενίσουμε την απάντηση. Καθόλου σωστό και πρέπει να γίνει κάτι γρήγορα γιατί τα γραπτά διορθώθηκαν κατά το 1/4.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #96 στις: 02 Ιούν 2013, 06:28:01 μμ »
Για ποιο λόγο? Αφού το κάνει σε ένα πέρασμα. Ομολογώ ότι μου πήρε λίγη ώρα για να μπορέσω να αποδείξω την ορθότητα αυτού του αλγορίθμου. Νομίζω είναι ο πιο έξυπνος που έχει προταθεί
Μου φαίνεται περίεργο πάντως που λες κάτι τέτοιο, γιατί εμείς το έχουμε στις ενδεικτικές λύσεις και δεν υπήρξε ούτε ένας που να διαφωνήσει

Μαθητής το έγραψε όπως είπαν και άλλοι συνάδελφοι...

μ <-- 1
Για κ από 1 μέχρι 100
  Αν Π[κ] = Αληθής τότε
    Αντιμετάθεσε Π[κ], Π[μ]
    μ <-- μ + 1
  Τέλος_αν
Τέλος_επανάληψης


και αντί να του βάλουμε 10 που βρήκε τρόπο που δεν τον διδάχτηκε, (γιατί διδάχτηκε μόνο φυσσαλίδα και έστω καποιες βελτιώσεις της), εμείς θέλουμε να του μηδενίσουμε την απάντηση. Καθόλου σωστό και πρέπει να γίνει κάτι γρήγορα γιατί τα γραπτά διορθώθηκαν κατά το 1/4.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3174
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Β
« Απάντηση #97 στις: 02 Ιούν 2013, 07:18:23 μμ »
εμείς αποφασίσαμε: πως κάθε αλγόριθμος, που δεν θα διέτασσε τα στοιχεία ενός οποιουδήποτε πίνακα (αριθμητικού ή άλλου δηλαδή) είναι αποδεκτός

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #98 στις: 02 Ιούν 2013, 07:46:42 μμ »
Παναγιώτη εννοείς να μην χρησιμοποιεί τους τελεστές < και > ;

εμείς αποφασίσαμε: πως κάθε αλγόριθμος, που δεν θα διέτασσε τα στοιχεία ενός οποιουδήποτε πίνακα (αριθμητικού ή άλλου δηλαδή) είναι αποδεκτός
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Θέμα Β
« Απάντηση #99 στις: 02 Ιούν 2013, 07:55:43 μμ »
Καταρχήν θεωρώ την εκφώνηση του θέματος ατυχέστατη. Τα θέματα πρέπει να είναι μονοσήμαντα. Μία λύση για να θεωρείται σωστή πρέπει να είναι αποδεκτή από όλους και όχι να μαζεύονται 5-10 συνάδερφοι υπό την πίεση της διόρθωσης και να αποφασίζουν τι είναι σωστό και τι όχι. Και αλήθεια με ποια κριτήρια.

εμείς αποφασίσαμε: πως κάθε αλγόριθμος, που δεν θα διέτασσε τα στοιχεία ενός οποιουδήποτε πίνακα (αριθμητικού ή άλλου δηλαδή) είναι αποδεκτός

Παναγιώτη ο πίνακας [1 , -5, 3, -7 , 2, -4] που είναι αριθμητικός πίνακας διατάσσεται με βάση τον παραπάνω αλγόριθμο αν ορίσω συνάρτηση f(x<0)=0 και f(x>=0) =1. Άρα αν μεταφράζω σωστά, αποφασίσατε ότι οποιοσδήποτε αλγόριθμος που δεν διατάσσει οποιαδήποτε στοιχεία με βάση την ταυτοτική συνάρτηση είναι αποδεκτός. Από την άλλη όμως όσο και αν έψαξα στη βιβλιογραφία δεν βρήκα πουθενά την παραδοχή ότι ένας αλγόριθμος χαρακτηρίζεται ως ταξινόμησης μόνο αν ικανοποιεί και την ταυτοτική συνάρτηση.

Θεωρώ ότι οποιαδήποτε λύση πρέπει να θεωρηθεί σωστή εφόσον πετυχαίνει το ζητούμενο. Διαφορετικά παίρνουμε ευθύνη ότι δεν είμαστε δίκαιοι απέναντι σε όλους τους μαθητές.
« Τελευταία τροποποίηση: 02 Ιούν 2013, 08:10:47 μμ από aperdos »

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #100 στις: 02 Ιούν 2013, 08:16:06 μμ »
Μαθητής το έγραψε όπως είπαν και άλλοι συνάδελφοι...

μ <-- 1
Για κ από 1 μέχρι 100
  Αν Π[κ] = Αληθής τότε
    Αντιμετάθεσε Π[κ], Π[μ]
    μ <-- μ + 1
  Τέλος_αν
Τέλος_επανάληψης


και αντί να του βάλουμε 10 που βρήκε τρόπο που δεν τον διδάχτηκε, (γιατί διδάχτηκε μόνο φυσσαλίδα και έστω καποιες βελτιώσεις της), εμείς θέλουμε να του μηδενίσουμε την απάντηση. Καθόλου σωστό και πρέπει να γίνει κάτι γρήγορα γιατί τα γραπτά διορθώθηκαν κατά το 1/4.

Γιατί να την μηδενίσετε την απάντηση;

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3174
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Β
« Απάντηση #101 στις: 02 Ιούν 2013, 08:42:33 μμ »
Χωρίς παρεξήγηση, κείμενα που αρχίζουν με το κείμενο "αν ορίσουμε μια συνάρτηση διάταξης f. ..." δεν τα διαβάζω μέχρι το τέλος.
Πρόσφατα έμαθα οτι τα πλεονεκτήματα των γλωσσών υψηλού επιπέδου είναι 6 (+κόστος +υποδομές) και έκανε λάθος η επιτροπή που έδωσε 4 μονάδες στο θέμα.

Από την πρώτη μέρα που ασχολήθηκα με την ΑΕΠΠ βλέπω το μάθημα πρακτικά.
Όσοι διορθώνουν γραπτά βλέπουν την εξουθένωση των παιδιών προς το θέμα Δ, όπου ακόμη και πολύ καλά γραπτά έχουν βιαστικά και επιπόλαια συντακτικά/λογικά λάθη.

Ευρυπίδη, λύση με <, > στα 25 γραπτά που είδα συνάντησα μόνο 1, οι μαθητές πορεύτηκαν μόνο με ισότητες. Αν ο αλγόριθμος που έδωσαν ταξινομεί πίνακα αριθμών, πίνακα με περισσότερα από 2 διακριτά/διαφορετικά στοιχεία δεν θεωρήθηκε σωστή από εμάς. Το οτι ομαδοποιεί τα στοιχεία πίνακα με ΜΟΝΟ ΔΥΟ διαφορετικές τιμές μέσα του δε σημαίνει οτι πάντα μπορεί να ταξινομήσει οποιονδήποτε πίνακα.

Θεωρήσαμε ότι αυτό είναι το ύφος της επιτροπής σχετικά με τους "αλγορίθμους ταξινόμησης" με μια παρατήρηση που απέκλεισε τη φυσαλίδα και τα <,> αλλά γέννησε άλλα προβλήματα. ένα ερώτημα που δεν έπρεπε να μπει.
Αν δεν κάνω λάθος με αυτό το σκεπτικό, οι περισσότερες κωδικοποιήσεις που είδα παραπάνω θεωρούνται σωστές

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #102 στις: 02 Ιούν 2013, 11:23:05 μμ »
Κάτι άλλο που είδαμε. Δίνει κάποιος τη λύση

Για ι από 1 μέχρι Ν
  Α[ι] <- Αληθής
ΤΕ

Για ι από Ν+1 μέχρι 100
  Α[ι] <- Ψευδής
ΤΕ

Δηλαδή δεν μετράει τα Αληθής / Ψευδής αλλά θεωρεί ότι είναι Ν.
Εδώ θα πρέπει να πάρει τουλάχιστον τις μισές μονάδες αφού έχει κάνει τη μισή δουλειά  ;)
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1014
Απ: Θέμα Β
« Απάντηση #103 στις: 03 Ιούν 2013, 12:18:59 πμ »
"εμείς θέλουμε να του μηδενίσουμε την απάντηση" ...

Παιδιά, είναι μια μαγική λύση με φαντασία !!!

Σε ένα τέτοιο "φαινόμενο", του δίνεις 10++ !!!

Τρέξτε το  !!!

Α

pgrontas

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 1315
  • There are always possibilities...
Απ: Θέμα Β
« Απάντηση #104 στις: 03 Ιούν 2013, 06:25:19 μμ »
Κάτι άλλο που είδαμε. Δίνει κάποιος τη λύση

Για ι από 1 μέχρι Ν
  Α[ι] <- Αληθής
ΤΕ

Για ι από Ν+1 μέχρι 100
  Α[ι] <- Ψευδής
ΤΕ

Δηλαδή δεν μετράει τα Αληθής / Ψευδής αλλά θεωρεί ότι είναι Ν.
Εδώ θα πρέπει να πάρει τουλάχιστον τις μισές μονάδες αφού έχει κάνει τη μισή δουλειά  ;)

Και εγώ είδα μια τέτοια σήμερα με Ν1, Ν2 δεδομένα για πλήθος Α,Ψ!

Επανερχόμενος στο προηγούμενο θέμα, πάντως νομίζω ότι οποιοσδήποτε αλγόριθμος βάζει τα αληθής πριν τα ψευδής πρέπει να πάρει όλες τις μονάδες.
A man provided with paper, pencil, and rubber, and subject to strict discipline is in effect a universal machine - Alan Turing