Αποστολέας Θέμα: Θέμα Β  (Αναγνώστηκε 27967 φορές)

ege

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Θέμα Β
« Απάντηση #30 στις: 29 Μάι 2013, 08:23:00 μμ »
Γεια σας και από μένα.
Είναι η πρώτη φορά που συμμετέχω σε συζήτηση στο φόρουμ αλλά θα ήθελα να κάνω μια "ηλίθια" ερώτηση :angel:.
Εφόσον το τελικό αποτελέσμα είναι ένας ταξινομημένος πίνακας οποιαδήποτε λύση που δίνουμε
δεν είναι ένας "αλγόριθμος ταξινόμησης?".
Καταλαβαίνω το σκεπτικό της επισήμανσης στο ερώτημα αλλά θεωρώ το ερώτημα κατ΄ουσίαν λανθασμένο.
(εγώ το θεωρώ άλυτο)
« Τελευταία τροποποίηση: 29 Μάι 2013, 08:51:06 μμ από ege »

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 115
Απ: Θέμα Β
« Απάντηση #31 στις: 29 Μάι 2013, 08:25:33 μμ »

μ<-- 0
Για κ από 1 μέχρι 100
      Αν Π[κ] = Αληθής τότε
           μ <-- μ + 1
           Αντιμετάθεσε Π[κ], Π[μ]
      τέλος_αν
τελος_επανάληψης


Απίστευτο!
Αυτή είναι θαυμάσια λύση !!!

ω ναι! η καλύτερη που έχω δει!!

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #32 στις: 29 Μάι 2013, 09:01:07 μμ »
Καταλαβαίνω το σκεπτικό της επισήμανσης στο ερώτημα αλλά θεωρώ το ερώτημα κατ΄ουσίαν λανθασμένο.
Συμφωνώ μαζί σου.
Και αυτό το ερώτημα έχει κάτι το θολό και ενοχλητικό.
Χωρίς τη χρήση "αλγορίθμων ταξινόμησης" (το έχουν και σε εισαγωγικά!!)
Μπορεί ο μαθητής να αναγνωρίσει αν ο αλγόριθμος που μόλις έγραψε εμπίπτει σε αυτή την κατηγορία;;;; Όχι, μόνο τη φυσαλίδα μπορεί να αποφύγει.
Κι αν ο αλγόριθμός του μοιάζει με έναν αλγόριθμο ταξινόμησης;
Κι αν μοιάζει με τη φυσαλίδα αλλά δεν είναι η φυσαλίδα όπως τη διδάχτηκε αλλά της έχει κάνει κατάλληλες προσαρμογές;
Τεράστια ασάφεια ...
Φιλικά,
Γιώργος Θαλασσινός

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #33 στις: 29 Μάι 2013, 09:04:36 μμ »
Και η ειρωνεία είναι ότι αν δεν έβαζαν τον περιορισμό θα έμενε στο μαθητή να καταλάβει πως δεν μπορεί να χρησιμοποιήσει τη φυσαλίδα όπως την ξέρει  (πολλοί θα την πάταγαν) άρα ή να την παραλλάξει ή να το λύσει με άλλο τρόπο.
Φιλικά,
Γιώργος Θαλασσινός

Vagnes

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Απ: Θέμα Β
« Απάντηση #34 στις: 29 Μάι 2013, 09:51:34 μμ »
Έχω διαβάσει ορισμένες λυσεις , παραθέτω μια λίγο πιο γρήγορη, με χρήση δυο βοηθητικών δεικτών.

Για i απο 1 μεχρι 100
   k<--1
   λ<--100
   Αν Π = Αληθής τότε  ! Π με δείκτη i ,δεν ξέρω γιατι δε το εμφανίζει
      Π[k] <--Αληθής
          κ  <-- κ + 1
   Αλλιώς
      Π[λ] <-- Ψευδής
          λ  <-- λ - 1
   Τέλος_αν
Τέλος_επανάληψης
Καλησπέρα και απο μένα.. Ενας μαθητης μου εκανε αυτή τη λαθος λύση.. θα πάρει έστω κάποιες μονάδες απ την απάντησή του???

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #35 στις: 29 Μάι 2013, 10:01:33 μμ »
Το μεγάλο πρόβλημα του Β2 είναι ότι του έχουν δώσει 10 μόρια. Αυτό κατά τη γνώμη μου είναι από τα πιο τραγικά σημεία του διαγωνίσματος.
Πόσα από τα 10 θα πάρουν τα παιδιά που έχουν μια λύση η οποία ναι μεν είναι λάθος αλλά φαίνεται ότι έχουν καταλάβει τι κάνουν? Δηλαδή έχουν πλησιάσει?
Δυστυχώς αυτές οι λύσεις δεν νομίζω ότι μπαίνουν σε καλούπια οπότε η βαθμολόγηση εδώ θα είναι κατά την κρίση του βαθμολογητή, αφού δεν μπορούμε να προβλέψουμε όλες τις δυνατές περιπτώσεις
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #36 στις: 29 Μάι 2013, 10:36:48 μμ »
Δεν είμαι βαθμολογητής, οπότε θα πω την καθαρά προσωπική μου γνώμη, όπως θα το διόρθωνα αν ήταν δικό μου διαγώνισμα.
Μόνο που θα σχολιάσω αυτό τον κώδικα (έβγαλα τις αρχικοποιήσεις έξω γιατί μου φαίνεται πολύ "φτηνό" λάθος να έχει γίνει από κάποιον που σκέφτηκε όλη την υπόλοιπη λύση. Αν το έκανε, σίγουρα θα του κοστίσει και αυτό)
Κώδικας: [Επιλογή]
k<--1
λ<--100
Για i απο 1 μεχρι 100
   Αν Π = Αληθής τότε  ! Π με δείκτη i ,δεν ξέρω γιατι δε το εμφανίζει
      Π[k] <--Αληθής
          κ  <-- κ + 1
   Αλλιώς
      Π[λ] <-- Ψευδής
          λ  <-- λ - 1
   Τέλος_αν
Τέλος_επανάληψης
Αυτή η λύση δείχνει ότι ο μαθητής έχει σκεφτεί πολλά σημεία προς τη σωστή κατεύθυνση αλλά έχει χάσει μια λεπτομέρεια.
Μάλιστα αν είχε χρησιμοποιήσει έναν έξτρα πίνακα, η λύση θα ήταν σωστή.
Για μένα παίρνει τα μισά και ίσως παραπάνω μόρια (έτσι κι αλλιώς τη "μισή" δουλειά την κάνει σωστά)
Θα του έδινα 5-6 μόρια
αν έχει και λάθος τις αρχικοποιήσεις θα του κόψω άλλα 2
Είναι εντελώς διαισθητική η βαθμολόγησή μου αλλά όπως λέει κι ο Ευριπίδης, δε γίνεται αλλιώς.
Φιλικά,
Γιώργος Θαλασσινός

Vagnes

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Απ: Θέμα Β
« Απάντηση #37 στις: 29 Μάι 2013, 10:40:28 μμ »
Ναι οι αρχικοποιήσεις γίνανε κανονικά απ' έξω.. απλά επειδή ήταν ίδιο περίπου το παρέθεσα απο τον φίλο...

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Θέμα Β
« Απάντηση #38 στις: 29 Μάι 2013, 11:06:57 μμ »
Μαθητής μου στην διάρκεια της χρονιάς είχε δώσει αυτή την λύση. Η άσκηση ζητούσε να μεταφερθούν όλες οι τιμές 2 στο τέλος του πίνακα χωρίς να αλλάξει η σειρά των υπόλοιπων στοιχείων. Προσαρμόζω τη λύση στο σημερινό ζητούμενο. Θα πρέπει να δωθούν οι μονάδες ή όχι;

Για ι από 1 μέχρι 100
  κ ← ι + 1
  Όσο κ ≤ 100 επανάλαβε
    Αν Π[ι] = Ψευδής και Π[κ] = Αληθής τότε
      Αντιμετάθεσε Π[ι], Π[κ]
    αλλιώς
      κ ← κ + 1
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης

grdereken

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 30
Απ: Θέμα Β
« Απάντηση #39 στις: 29 Μάι 2013, 11:27:15 μμ »
@grdereken
 
 /quote

Αλ <-- 1
Ψ <-- 100
ΟΣΟ Αλ < Ψ επανάλαβε
    ΟΣΟ Π[ΑΛ] = "ΑΛΗΘΗΣ" ΕΠΑΝΑΛΑΒΕ
      ΑΛ <-- ΑΛ + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

...

Τέλος_επανάληψης

quote/

Για τον αλγόριθμο που προτείνεις:
Στην περίπτωση που όλες οι τιμές του πίνακα Π είναι "ΑΛΗΘΗΣ" μενεις στην εσωτερική επανάληψη μέχρι να βρεθείς εκτός πίνακα στη θέση 101 με τη συνθήκη Π[101] = 'ΑΛΗΘΗΣ':
   
 
Δίκιο έχεις Ευαγγελία. Έκανα τις παρακάτω τροποποιήσεις, ελπίζω να είναι σωστό τώρα.
ΑΛ <- 1
  Ψ <- 100
  ΟΣΟ ΑΛ < Ψ ΕΠΑΝΑΛΑΒΕ

!ΑΝ ΣΥΝΑΝΤΑΣ ΑΛΗΘΕΙΕΣ ΠΡΟΧΩΡΑ ΜΠΡΟΣΤΑ ΚΑΙ ΑΝ ΒΡΕΙΣ ΨΕΜΑΤΑ ΣΤΑΜΑΤΑ
    ΕΞΟΔΟΣ <- ΨΕΥΔΗΣ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ Π[ΑΛ] = "ΑΛΗΘΗΣ" ΤΟΤΕ
        ΑΛ <- ΑΛ + 1
      ΑΛΛΙΩΣ
        ΕΞΟΔΟΣ <- ΑΛΗΘΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΕΞΟΔΟΣ = ΑΛΗΘΗΣ Η ΑΛ > Ψ

!ΑΝ ΣΥΝΑΝΤΑΣ ΨΕΜΑΤΑ ΠΗΓΑΙΝΕ ΠΡΟΣ ΤΑ ΠΙΣΩ ΚΑΙ ΣΤΑΜΑΤΑ ΣΤΗΝ ΑΛΗΘΕΙΑ
    ΕΞΟΔΟΣ <- ΨΕΥΔΗΣ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ Π[Ψ] = "ΨΕΥΔΗΣ" ΤΟΤΕ
        Ψ <- Ψ - 1
      ΑΛΛΙΩΣ
        ΕΞΟΔΟΣ <- ΑΛΗΘΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΕΞΟΔΟΣ = ΑΛΗΘΗΣ Η ΑΛ > Ψ

!ΕΚΕΙ ΠΟΥ ΣΤΑΜΑΤΑΣ ΚΑΝΕ ΑΝΤΙΜΕΤΑΘΕΣΗ ΤΑ ΨΕΜΑΤΑ ΜΕ ΤΗΝ ΑΛΗΘΕΙΑ
    ΑΝ ΑΛ < Ψ ΤΟΤΕ
      ΤΕΜΠ <- Π[ΑΛ]
      Π[ΑΛ] <- Π[Ψ]
      Π[Ψ] <- ΤΕΜΠ
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Για αυτόν που πρότεινες δες λίγο το παρακάτω σύνολο τιμών.
ΑΛΗΘΗΣ
ΑΛΗΘΗΣ
ΑΛΗΘΗΣ
ΑΛΗΘΗΣ
ΑΛΗΘΗΣ
ΨΕΥΔΗΣ
ΨΕΥΔΗΣ
ΨΕΥΔΗΣ
ΨΕΥΔΗΣ
ΨΕΥΔΗΣ

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #40 στις: 29 Μάι 2013, 11:30:26 μμ »
@aperdos
Έχει κάποιο λάθος που δε βλέπω;
Νομίζω ότι δουλεύει άρα το ερώτημα μάλλον θα πρέπει να αντιστραφεί:
Θα πρέπει να κοπούν μονάδες για την περιττή δουλειά που κάνει;
Νομίζω όμως από προηγούμενες συζητήσεις εδώ ότι οι περισσότεροι συμφωνούν στο να μην κοπούν.
Φιλικά,
Γιώργος Θαλασσινός

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #41 στις: 29 Μάι 2013, 11:41:17 μμ »
και εγώ τόσο θα έδινα γιώργο 5-6 ίσως και παραπάνω, ανάλογα με την εικόνα του γραπτού.

Πάντως αυτό το θέμα είναι αφορμή να καταλάβουμε ότι πρέπει να βαθμολογούμε τη σκέψη του μαθητή και όχι να ασχολούμαστε με το αν ο αλγόριθμος "τρέχει" σωστά.
Νομίζω ότι εδώ θα έχουμε πολλές διαφορές στη βαθμολόγηση όπως και στο θέμα Γ

Θα του έδινα 5-6 μόρια
αν έχει και λάθος τις αρχικοποιήσεις θα του κόψω άλλα 2
Είναι εντελώς διαισθητική η βαθμολόγησή μου αλλά όπως λέει κι ο Ευριπίδης, δε γίνεται αλλιώς.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #42 στις: 29 Μάι 2013, 11:43:50 μμ »
Δεν ξέρω γιατί αλλά μου θυμίζει την ταξινόμηση με επιλογή, άρα το θεωρώ ταξινόμηση  :D

Μαθητής μου στην διάρκεια της χρονιάς είχε δώσει αυτή την λύση. Η άσκηση ζητούσε να μεταφερθούν όλες οι τιμές 2 στο τέλος του πίνακα χωρίς να αλλάξει η σειρά των υπόλοιπων στοιχείων. Προσαρμόζω τη λύση στο σημερινό ζητούμενο. Θα πρέπει να δωθούν οι μονάδες ή όχι;

Για ι από 1 μέχρι 100
  κ ← ι + 1
  Όσο κ ≤ 100 επανάλαβε
    Αν Π[ι] = Ψευδής και Π[κ] = Αληθής τότε
      Αντιμετάθεσε Π[ι], Π[κ]
    αλλιώς
      κ ← κ + 1
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Θέμα Β
« Απάντηση #43 στις: 29 Μάι 2013, 11:45:42 μμ »
@aperdos
Έχει κάποιο λάθος που δε βλέπω;
Νομίζω ότι δουλεύει άρα το ερώτημα μάλλον θα πρέπει να αντιστραφεί:
Θα πρέπει να κοπούν μονάδες για την περιττή δουλειά που κάνει;
Νομίζω όμως από προηγούμενες συζητήσεις εδώ ότι οι περισσότεροι συμφωνούν στο να μην κοπούν.

Είναι αλγόριθμος ταξινόμησης. Ούτε εγώ το είχα συνειδητοποιήσει μέχρι σήμερα που ξεκίνησε αυτή η συζήτηση. Σαν παραλλαγή της ταξινόμησης με επιλογή μου φαίνεται.

@evry με πρόλαβες

Για ι από 1 μέχρι 10
  κ ← ι + 1
  Όσο κ ≤ 10 επανάλαβε
    Αν Π[ι] < Π[κ] τότε
      Αντιμετάθεσε Π[ι], Π[κ]
    αλλιώς
      κ ← κ + 1
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης

Το μόνο που αλλάζει είναι η συνάρτηση διάταξης. Οφείλει να το ξέρει ο μαθητής αυτό ή όχι.
Και αν συμφωνούμε να μην κοπούν μονάδες σε αυτή τη λύση γιατί τότε να κοπούν μονάδες αν στη φυσαλίδα τροποποίησω τη συνθήκη;

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: Θέμα Β
« Απάντηση #44 στις: 30 Μάι 2013, 12:00:26 πμ »
@grdereken

Έχεις δίκιο, το σύνολο με πρώτες τιμές όλες Αληθής κάνει μία επιπλέον αντιμετάθεση, το πρόβλημα λύνεται και αν η τελευταία δομή επιλογής μπει πρώτη στη σειρά ώστε να ελέγχει πρώτα τη ανίσωση των δύο τρεχόντων στοιχείων και έπειτα με τις επόμενες Αν τη θέση του καθενός:

  κ <-- 1
  λ <-- 10                                                                                   
  Οσο κ < λ επανάλαβε
    Αν  Π[λ] <> Π[κ] και Π[κ] = ΨΕΥΔΗΣ τότε
      τεμπ <-- Π[κ]
      Π[κ] <-- Π[λ]
      Π[λ] <-- τεμπ     
      κ <-- κ + 1
      λ <-- λ - 1
    Τέλος_αν   

    Αν Π[κ] = ΑΛΗΘΗΣ τότε
      κ <-- κ + 1
    τελος_αν

    Αν Π[λ] = ΨΕΥΔΗΣ τότε
      λ <-- λ - 1
    τελος_αν
  Τέλος_επανάληψης

Επίσης,  με μια ματιά που έριξα νομίζω ότι και ο δικός σου αλγόριθμος με τις εμφωλευμένες επαναλήψεις είναι σωστός :-)
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"