Αποστολέας Θέμα: Θέμα Β  (Αναγνώστηκε 27879 φορές)

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Θέμα Β
« στις: 29 Μάι 2013, 10:19:38 πμ »
Εδώ μιλάμε για θέμα Β

katif

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Θέμα Β
« Απάντηση #1 στις: 29 Μάι 2013, 01:30:41 μμ »
Για το Β2.
Ένας μαθητής απάντησε:
ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 100
    ΓΙΑ κ ΑΠΟ 100 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
        ΑΝ Π[Κ-1]=ΨΕΥΔΗΣ ΚΑΙ Π[κ]=ΑΛΗΘΗΣ ΤΟΤΕ
                ΑΝΤΙΜΕΤΑΘΕΣΕ Π[κ-1], Π[κ]
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠ
ΤΕΛΟΣ_ΕΠ
Θα το πάρουν σωστό;
Κατηφόρης Παναγιώτης
Καθηγητής Πληροφορικής - Μαθηματικός

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Θέμα Β
« Απάντηση #2 στις: 29 Μάι 2013, 01:43:52 μμ »
Κάνει χρήση του αλγορίθμου ταξινόμησης. Η εκφώνηση λέει χωρίς χρήση αλγορίθμων ταξινόμησης.

eftsousis

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Θέμα Β
« Απάντηση #3 στις: 29 Μάι 2013, 01:55:58 μμ »
Έχω διαβάσει ορισμένες λυσεις , παραθέτω μια λίγο πιο γρήγορη, με χρήση δυο βοηθητικών δεικτών.

Για i απο 1 μεχρι 100
   k<--1
   λ<--100
   Αν Π = Αληθής τότε  ! Π με δείκτη i ,δεν ξέρω γιατι δε το εμφανίζει
      Π[k] <--Αληθής
          κ  <-- κ + 1
   Αλλιώς
      Π[λ] <-- Ψευδής
          λ  <-- λ - 1
   Τέλος_αν
Τέλος_επανάληψης

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Θέμα Β
« Απάντηση #4 στις: 29 Μάι 2013, 02:01:45 μμ »
Κάνεις εγγραφή σε θέσεις του πίνακα Π που δεν έχεις διαβάσει ακόμα (και άρα χάνεις πληροφορίες σε θέσεις που θα χρειαστεί να διαβάσεις αργότερα).
Δεν είναι σωστό.
Σωκράτης

eftsousis

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Θέμα Β
« Απάντηση #5 στις: 29 Μάι 2013, 02:05:25 μμ »
Το ξέρω και έχεις δίκιο λάθος copy paste..  δεν πήρε το τελευταιό
είναι αλλος πίνακας δε ξέρω τι παίζει με την αντιγραφή πραγματικα, είδα οτι το έχει γράψει και άλλη συνάδελφος στην κύρια σελίδα. οπότε διπλός κόπος..

Για i απο 1 μεχρι 100
   k<--1
   λ<--100
   Αν Π = Αληθής τότε  ! Π με δείκτη i ,δεν ξέρω γιατι δε το εμφανίζει
      Τ[k] <--Αληθής
          κ  <-- κ + 1
   Αλλιώς
      Τ[λ] <-- Ψευδής
          λ  <-- λ - 1
   Τέλος_αν
Τέλος_επανάληψης
Για i απο 1 μεχρι 100
      Π(i) <-- T(i)
Τέλος_επανάληψης

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Θέμα Β
« Απάντηση #6 στις: 29 Μάι 2013, 02:07:03 μμ »
Ναι, αυτό δουλεύει.
Σωκράτης

Νίκη

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Θέμα Β
« Απάντηση #7 στις: 29 Μάι 2013, 02:15:02 μμ »
ΕΝΔΕΙΚΤΙΚΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΤΑ ΕΙΔΙΚΑ ΕΞΕΤΑΣΤΙΚΑ ΚΕΝΤΡΑ
Β2.
κ <- 0
Για i από 1 μέχρι 100
   Αν Π[ι] = ΑΛΗΘΗΣ τότε κ<- κ+1
Τέλος_Επανάληψης
Για i από 1 μέχρι κ
   Π[ι] <- ΑΛΗΘΗΣ
Τέλος_Επανάληψης
Για i από κ+1 μέχρι 100
   Π[ι] <- ΨΕΥΔΗΣ
Τέλος_Επανάληψης


eftsousis

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Θέμα Β
« Απάντηση #8 στις: 29 Μάι 2013, 02:22:01 μμ »
Θα έχει την τελευταία τιμή κ που πήρε. Τώρα στο worst case scenario που είναι όλα ΑΛΗΘΗ, η τιμή αυτή θα είναι 100. Η 3η επανάληψη δε θα εκτελεστεί ποτέ γιατι θα ξεκινάει απο το 101.

Άρα είναι σωστό.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2213
Απ: Θέμα Β
« Απάντηση #9 στις: 29 Μάι 2013, 02:22:14 μμ »
Τι σημασία έχει;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: Θέμα Β
« Απάντηση #10 στις: 29 Μάι 2013, 03:27:15 μμ »
Β2. Προσπαθώντας να λύσω την ταξινόμηση χωρίς 2ο πίνακα και χωρίς μετρητή count  σκέφτηκα το παρακάτω:

κ <-- 1
λ <-- 100
Οσο κ < λ επανάλαβε
    Αν Π[κ] = Αληθης τότε
            κ <-- κ + 1
   τελος_αν

   Αν Π[λ] = Ψευδης τότε
            λ <-- λ - 1
   τελος_αν

   Αν Π[κ] <> Π[λ] και Π[κ] = Ψευδης τότε
           Αντιμετάθεσε Π[κ], Π[λ]
           κ <-- κ + 1
           λ <-- λ - 1
   Τέλος_αν
Τέλος_επανάληψης

Βλέπει κανείς κανένα λογικό λάθος;
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #11 στις: 29 Μάι 2013, 03:43:30 μμ »
φαίνεται να δουλεύει !
Φιλικά,
Γιώργος Θαλασσινός

summer

  • Θαμώνας
  • ***
  • Μηνύματα: 31
Θέμα Β
« Απάντηση #12 στις: 29 Μάι 2013, 04:34:17 μμ »
Για δείτε αυτό
πλ<-0
Για ι από 1 μέχρι 100
  Αν Π[ι]=ΑΛΗΘΗΣ τότε πλ<--πλ+1
Τέλος Επανάληψης

Για ι από 1 μέχρι πλ
Αν Π[ι]=ΨΕΥΔΗΣ τότε Π[ι]<--ΑΛΗΘΗΣ
Τέλος Επανάληψης

Για ι από πλ+1 μέχρι 100
Αν Π[ι]=ΑΛΗΘΗΣ τότε  Π[ι]<--ΨΕΥΔΗΣ
Τέλος Επανάληψης

ωραίο δεν είναι?
« Τελευταία τροποποίηση: 29 Μάι 2013, 04:46:29 μμ από summer »

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Θέμα Β
« Απάντηση #13 στις: 29 Μάι 2013, 04:47:49 μμ »
Για το Β2.
Ένας μαθητής απάντησε:
ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 100
    ΓΙΑ κ ΑΠΟ 100 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
        ΑΝ Π[Κ-1]=ΨΕΥΔΗΣ ΚΑΙ Π[κ]=ΑΛΗΘΗΣ ΤΟΤΕ
                ΑΝΤΙΜΕΤΑΘΕΣΕ Π[κ-1], Π[κ]
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠ
ΤΕΛΟΣ_ΕΠ
Θα το πάρουν σωστό;


Κάνει χρήση του αλγορίθμου ταξινόμησης. Η εκφώνηση λέει χωρίς χρήση αλγορίθμων ταξινόμησης.


Δοθέντων των στοιχείων α1, α2,...αn η ταξινόμηση συνίσταται στη μετάθεση της θέσης των στοιχείων, ώστε να τοποθετηθούν σε μία σειρά ακ1, ακ2,..., ακν έτσι ώστε, δοθείσης μιας συνάρτησης διάταξης f να ισχύει:
f(ak1) <= f(ak2) <= ...<=f(akn)
σχολικό βιβλίο σελ 66

Η σύγκριση λογικών έχει έννοια μόνο στην περίπτωση του ίσου (=) και του διάφορου (<>).
σχολικό βιβλίο σελ 166

Επίσης στον πίνακα υπάρχουν δύο διαφορετικές τιμές.

Που ακριβώς υπάρχει η ταξινόμηση στον παραπάνω κώδικα;

Νομίζω ότι η επιτροπή θέλοντας να προστατέψει τους μαθητές να χρησιμοποιήσουν την φυσαλίδα αφού δεν υφίσταται η σύγκριση  (<) ή  (>) σε λογικές τιμές έδωσε τη φράση "χωρίς τη χρήση αλγορίθμων ταξινόμησης".

Εγώ θεωρώ τη λύση ολόσωστη και θα δώσω όλες τις μονάδες αν μου τύχει τέτοιο γραπτό.

spantoulis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 109
Απ: Θέμα Β
« Απάντηση #14 στις: 29 Μάι 2013, 05:07:38 μμ »

Που ακριβώς υπάρχει η ταξινόμηση στον παραπάνω κώδικα;


υπάρχουν δύο είδη φυσαλίδων, οι ΑΛΗΘΕΙΣ και οι ΨΕΥΔΕΙΣ. Αν το φανταστείς  σαν εικόνα καθώς εκτελείται ο αλγόριθμος θα δεις μονο ταξινόμηση.

Ο αλγόριθμος είναι καρμπόν η ταξινόμηση φυσαλίδας με αλλαγμένη τη συνθήκη

Η χρήση υπολογιστών ΔΕΝ είναι πληροφορική

Dinos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 86
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Β
« Απάντηση #15 στις: 29 Μάι 2013, 05:12:40 μμ »
Θέμα Β2

Κώδικας: [Επιλογή]
κ <-- 0
λ <-- 101
Για ι από 1 μέχρι 100
   Αν Π[ι] = αληθής τότε
        κ <-- κ + 1
        Β[κ] <-- αληθής
   Αλλιώς
        λ <-- λ - 1
        Β[λ] <-- ψευδής
   Τέλος_αν
Τέλος_επανάληψης

Για ι από 1 μέχρι 100
  Π[ι] <-- Β[ι]
Τέλος_επανάληψης

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4926
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Θέμα Β
« Απάντηση #16 στις: 29 Μάι 2013, 05:20:21 μμ »
Δοθέντων των στοιχείων α1, α2,...αn η ταξινόμηση συνίσταται στη μετάθεση της θέσης των στοιχείων, ώστε να τοποθετηθούν σε μία σειρά ακ1, ακ2,..., ακν έτσι ώστε, δοθείσης μιας συνάρτησης διάταξης f να ισχύει:
f(ak1) <= f(ak2) <= ...<=f(akn)
σχολικό βιβλίο σελ 66

Που ακριβώς υπάρχει η ταξινόμηση στον παραπάνω κώδικα;

Ορίζω f(Ψευδής)=0 και f(Αληθής)=1, και έτσι ο ζητούμενος πίνακας τελικά θα είναι ταξινομημένος ως προς αυτήν την f().
Το θέμα δηλαδή ουσιαστικά ζητάει να ταξινομηθεί ένας πίνακας λογικών μεταβλητών. Δεν έχει καμία σημασία που δεν ορίζονται οι σχέσεις > και < μεταξύ λογικών μεταβλητών, στον ορισμό της ταξινόμησης δεν συγκρίνουμε τα a1 ... an αλλά τα f(a1)...f(an).

Η διαφορά είναι ότι ήθελε να τους υποχρεώσει να το κάνουν με πολυπλοκότητα O(n) και όχι (n^2), χωρίς να αναφέρει τη λέξη πολυπλοκότητα. Ίσως είναι αμφιλεγόμενο το κατά πόσο η εκφώνηση καταφέρνει καλά αυτόν το στόχο.

Μια παρόμοια άσκηση θα ήταν "σε έναν πίνακα ακεραίων, βάλτε τους αρνητικούς στις πρώτες θέσεις ώστε να είναι πριν από τους θετικούς, αλλά χωρίς να «ταξινομήσετε» εντελώς τον πίνακα, δηλαδή να υπάρχουν και περιπτώσεις εισόδου κατά τις οποίες στην έξοδο να ΜΗΝ ισχύει an <= an+1 για κάθε n".

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #17 στις: 29 Μάι 2013, 05:31:45 μμ »
Για δείτε αυτό
πλ<-0
Για ι από 1 μέχρι 100
  Αν Π[ι]=ΑΛΗΘΗΣ τότε πλ<--πλ+1
Τέλος Επανάληψης

Για ι από 1 μέχρι πλ
Αν Π[ι]=ΨΕΥΔΗΣ τότε Π[ι]<--ΑΛΗΘΗΣ
Τέλος Επανάληψης

Για ι από πλ+1 μέχρι 100
Αν Π[ι]=ΑΛΗΘΗΣ τότε  Π[ι]<--ΨΕΥΔΗΣ
Τέλος Επανάληψης

ωραίο δεν είναι?

Υποθέτω πώς αυτό θα θεωρείται απολύτως σωστό σαν λύση;

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2213
Απ: Θέμα Β
« Απάντηση #18 στις: 29 Μάι 2013, 05:39:11 μμ »
Σωστό είναι
Ουσιαστικά μετράει πόσα "ΑΛΗΘΗΣ" πρέπει να υπάρχουν, έτσι χωρίζει τον πίνακα στα 2 και αντικαθιστά όλα τα "ΨΕΥΔΗΣ" στο πρώτο κομμάτι με "ΑΛΗΘΗΣ" και το ανάποδο στο δεύτερο
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

michaeljohn

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 129
  • "Είναι παιδιά πολλών ανθρώπων τα λόγια μας"
Απ: Θέμα Β
« Απάντηση #19 στις: 29 Μάι 2013, 05:51:30 μμ »
Δείτε λίγο και αυτό :

μ<-- 0
Για κ από 1 μέχρι 100
      Αν Π[κ] = Αληθής τότε
           μ <-- μ + 1
           Αντιμετάθεσε Π[κ], Π[μ]
      τέλος_αν
τελος_επανάληψης

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: Θέμα Β
« Απάντηση #20 στις: 29 Μάι 2013, 06:00:38 μμ »
Δείτε λίγο και αυτό :

μ<-- 0
Για κ από 1 μέχρι 100
      Αν Π[κ] = Αληθής τότε
           μ <-- μ + 1
           Αντιμετάθεσε Π[κ], Π[μ]
      τέλος_αν
τελος_επανάληψης



Πολύ ωραία λύση!
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"

Γιάννης Αναγνωστάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 815
Απ: Θέμα Β
« Απάντηση #21 στις: 29 Μάι 2013, 06:08:37 μμ »
Δεδομένα //Π//
Κ<-0
Για ι από 1 μέχρι 100
Αν Π[ι]= ΑΛΗΘΗΣ τότε
      Κ<- Κ +1
Τέλος_αν
Τέλος_επανάληψης
Για ι από 1 μέχρι 100
Αν ι <=  Κ τότε
      Π[ι]<- ΑΛΗΘΗΣ
Αλλιώς
      Π[ι]<- ΨΕΥΔΗΣ
Τέλος_αν
Τέλος_επανάληψης
Αποτελέσματα //Π//

grdereken

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 30
Απ: Θέμα Β
« Απάντηση #22 στις: 29 Μάι 2013, 06:13:47 μμ »
Β2. Προσπαθώντας να λύσω την ταξινόμηση χωρίς 2ο πίνακα και χωρίς μετρητή count  σκέφτηκα το παρακάτω:

κ <-- 1
λ <-- 100
Οσο κ < λ επανάλαβε
    Αν Π[κ] = Αληθης τότε
            κ <-- κ + 1
   τελος_αν

   Αν Π[λ] = Ψευδης τότε
            λ <-- λ - 1
   τελος_αν

   Αν Π[κ] <> Π[λ] και Π[κ] = Ψευδης τότε
           Αντιμετάθεσε Π[κ], Π[λ]
           κ <-- κ + 1
           λ <-- λ - 1
   Τέλος_αν
Τέλος_επανάληψης

Βλέπει κανείς κανένα λογικό λάθος;


Δες λίγο τα τελευταία στοιχεία, δεν τα βάζει στη σωστή σειρά, λίγο που το έτρεξα. Τρέχει σωστά με τον επιπλέον έλεγχο κ < λ στην τρίτη ΑΝ. Παραμφερής λύση που μοιάζει όμως με τους αλγορίθμους ταξινόμησης  είναι η
 ΑΛ <-- 1
  Ψ <-- 100
  ΟΣΟ ΑΛ < Ψ  ΕΠΑΝΑΛΑΒΕ
   
    ΟΣΟ Π[ΑΛ] = "ΑΛΗΘΗΣ" ΕΠΑΝΑΛΑΒΕ
      ΑΛ <-- ΑΛ + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   
   ΟΣΟ Π[Ψ] = "ΨΕΥΔΗΣ" ΚΑΙ Ψ > ΑΛ ΕΠΑΝΑΛΑΒΕ
      Ψ <-- Ψ - 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΤΕΜΠ <-- Π[ΑΛ] !Αντιμετάθεση
    Π[ΑΛ] <-- Π[Ψ]
    Π[Ψ] <-- ΤΕΜΠ


  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
« Τελευταία τροποποίηση: 29 Μάι 2013, 06:51:28 μμ από grdereken »

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Θέμα Β
« Απάντηση #23 στις: 29 Μάι 2013, 06:24:29 μμ »
Ορίζω f(Ψευδής)=0 και f(Αληθής)=1, και έτσι ο ζητούμενος πίνακας τελικά θα είναι ταξινομημένος ως προς αυτήν την f().
Το θέμα δηλαδή ουσιαστικά ζητάει να ταξινομηθεί ένας πίνακας λογικών μεταβλητών. Δεν έχει καμία σημασία που δεν ορίζονται οι σχέσεις > και < μεταξύ λογικών μεταβλητών, στον ορισμό της ταξινόμησης δεν συγκρίνουμε τα a1 ... an αλλά τα f(a1)...f(an).

Η διαφορά είναι ότι ήθελε να τους υποχρεώσει να το κάνουν με πολυπλοκότητα O(n) και όχι (n^2), χωρίς να αναφέρει τη λέξη πολυπλοκότητα. Ίσως είναι αμφιλεγόμενο το κατά πόσο η εκφώνηση καταφέρνει καλά αυτόν το στόχο.

Μια παρόμοια άσκηση θα ήταν "σε έναν πίνακα ακεραίων, βάλτε τους αρνητικούς στις πρώτες θέσεις ώστε να είναι πριν από τους θετικούς, αλλά χωρίς να «ταξινομήσετε» εντελώς τον πίνακα, δηλαδή να υπάρχουν και περιπτώσεις εισόδου κατά τις οποίες στην έξοδο να ΜΗΝ ισχύει an <= an+1 για κάθε n".

Είσαι πολύ σωστός. Ομολογώ ότι δεν το είχα σκεφτεί έτσι.
Έτσι όμως και ο πίνακας με τιμές -3, -5, -1, 2, 0, 4 είναι "εντελώς" ταξινομημένος αφού f(α) = 0 αν α <0 και και f(α) = 1 αν α >= 0. (Θεωρώ το 0 θετικό)
Πάντως με βάση την περιγραφή που υπάρχει στην παράγραφο 3.7 δεν νομίζω ότι οι μαθητές έχουν αυτή τη θεώρηση για την ταξινόμηση. Βέβαια για να λέμε την αλήθεια δεν φταίνε αυτοί αλλά ο καθηγητής τους που μάλλον βιάστηκα να μιλήσω. Σίγουρα πρέπει να αναθεωρήσω. Αφού λοιπόν υπάρχουν προσπελάσεις και συγκρίσεις ανά δύο γειτονικά, είναι ο αλγόριθμος της φυσαλίδας.

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: Θέμα Β
« Απάντηση #24 στις: 29 Μάι 2013, 06:43:40 μμ »


Δες λίγο τα τελευταία στοιχεία, δεν τα βάζει στη σωστή σειρά, λίγο που το έτρεξα.


Το δοκίμασα στο χαρτί σε πίνακα 6 θέσεων τυχαίων περιεχομένων και δούλεψε κανονικά.
Έπειτα το έτρεξα και στη Γλωσσομάθεια 3 φόρες με διαφορετικές παραλλαγές περιεχομένων (συνδυασμούς Α - Ψ) πίνακα 10 θέσεων και δούλεψε επίσης κανονικά.
ποια συνθήκη δε σου βγήκε όταν το έτρεξες?
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"

grdereken

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 30
Απ: Θέμα Β
« Απάντηση #25 στις: 29 Μάι 2013, 06:59:30 μμ »
Το δοκίμασα στο χαρτί σε πίνακα 6 θέσεων τυχαίων περιεχομένων και δούλεψε κανονικά.
Έπειτα το έτρεξα και στη Γλωσσομάθεια 3 φόρες με διαφορετικές παραλλαγές περιεχομένων (συνδυασμούς Α - Ψ) πίνακα 10 θέσεων και δούλεψε επίσης κανονικά.
ποια συνθήκη δε σου βγήκε όταν το έτρεξες?
Στο δείγμα που χρησιμοποίησα δεν έβαζε σωστά τα τελευταία στοιχειά, πρέπει να έκανε μία περιττή αντιμετάθεση στο τέλος, που διορθώνεται με τον επιπλέον έλεγχο κ<λ στην τρίτη ΑΝ.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4926
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Θέμα Β
« Απάντηση #26 στις: 29 Μάι 2013, 07:08:16 μμ »
Έτσι όμως και ο πίνακας με τιμές -3, -5, -1, 2, 0, 4 είναι "εντελώς" ταξινομημένος αφού f(α) = 0 αν α <0 και και f(α) = 1 αν α >= 0. (Θεωρώ το 0 θετικό)

Γι' αυτό έβαλα σε εισαγωγικά το «ταξινομημένος», γιατί παρακάτω ζητάω «an <= an+1» και δεν ζητάω να οριστεί κάποια f(), δηλαδή δεν θέλουμε "τυπική" ταξινόμηση.

Δηλαδή αν ήταν να το πούμε με πιο επίσημους όρους, ο πίνακας που έδωσες ως παράδειγμα, είναι όντως ταξινομημένος με βάση την
f(x) = sign(x),
...που είναι και το ζητούμενο,
αλλά δεν είναι ταξινομημένος με βάση την ταυτοτική συνάρτηση,
f(x) = x,
και αυτό μπαίνει σαν προϋπόθεση στην εκφώνηση ότι δεν θέλουμε να ισχύει, για να αποφευχθούν γενικές λύσεις full sorting.

...αν και μάλλον βγήκαμε λίγο εκτός θέματος πια, ας το αφήσουμε να μην μπλέκουμε τον κόσμο! :)

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: Θέμα Β
« Απάντηση #27 στις: 29 Μάι 2013, 07:20:21 μμ »
Στο δείγμα που χρησιμοποίησα δεν έβαζε σωστά τα τελευταία στοιχειά, πρέπει να έκανε μία περιττή αντιμετάθεση στο τέλος, που διορθώνεται με τον επιπλέον έλεγχο κ<λ στην τρίτη ΑΝ.


Αντιμετάθεση γίνεται μόνο όταν:
οι δύο τρέχουσες εξεταζόμενες τιμές του πίνακα είναι διαφορετικές μεταξύ τους  και η πρώτη από αυτές (που είναι και πρώτη στη σειρά θέσεων του πίνακα) είναι Ψευδής οπότε η θέση της στον πίνακα δεν είναι σωστή,  άρα είναι αδύνατο να γίνει περιττή αντιμετάθεση και δε χρειάζεται ο έλεγχος κ <λ
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: Θέμα Β
« Απάντηση #28 στις: 29 Μάι 2013, 07:28:02 μμ »
@grdereken
 
 /quote

Αλ <-- 1
Ψ <-- 100
ΟΣΟ Αλ < Ψ επανάλαβε
    ΟΣΟ Π[ΑΛ] = "ΑΛΗΘΗΣ" ΕΠΑΝΑΛΑΒΕ
      ΑΛ <-- ΑΛ + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

...

Τέλος_επανάληψης

quote/

Για τον αλγόριθμο που προτείνεις:
Στην περίπτωση που όλες οι τιμές του πίνακα Π είναι "ΑΛΗΘΗΣ" μενεις στην εσωτερική επανάληψη μέχρι να βρεθείς εκτός πίνακα στη θέση 101 με τη συνθήκη Π[101] = 'ΑΛΗΘΗΣ':
   
 
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #29 στις: 29 Μάι 2013, 07:59:26 μμ »
Δείτε λίγο και αυτό :

μ<-- 0
Για κ από 1 μέχρι 100
      Αν Π[κ] = Αληθής τότε
           μ <-- μ + 1
           Αντιμετάθεσε Π[κ], Π[μ]
      τέλος_αν
τελος_επανάληψης
Απίστευτο!
Αυτή είναι θαυμάσια λύση !!!
Φιλικά,
Γιώργος Θαλασσινός

ege

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Θέμα Β
« Απάντηση #30 στις: 29 Μάι 2013, 08:23:00 μμ »
Γεια σας και από μένα.
Είναι η πρώτη φορά που συμμετέχω σε συζήτηση στο φόρουμ αλλά θα ήθελα να κάνω μια "ηλίθια" ερώτηση :angel:.
Εφόσον το τελικό αποτελέσμα είναι ένας ταξινομημένος πίνακας οποιαδήποτε λύση που δίνουμε
δεν είναι ένας "αλγόριθμος ταξινόμησης?".
Καταλαβαίνω το σκεπτικό της επισήμανσης στο ερώτημα αλλά θεωρώ το ερώτημα κατ΄ουσίαν λανθασμένο.
(εγώ το θεωρώ άλυτο)
« Τελευταία τροποποίηση: 29 Μάι 2013, 08:51:06 μμ από ege »

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 115
Απ: Θέμα Β
« Απάντηση #31 στις: 29 Μάι 2013, 08:25:33 μμ »

μ<-- 0
Για κ από 1 μέχρι 100
      Αν Π[κ] = Αληθής τότε
           μ <-- μ + 1
           Αντιμετάθεσε Π[κ], Π[μ]
      τέλος_αν
τελος_επανάληψης


Απίστευτο!
Αυτή είναι θαυμάσια λύση !!!

ω ναι! η καλύτερη που έχω δει!!

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #32 στις: 29 Μάι 2013, 09:01:07 μμ »
Καταλαβαίνω το σκεπτικό της επισήμανσης στο ερώτημα αλλά θεωρώ το ερώτημα κατ΄ουσίαν λανθασμένο.
Συμφωνώ μαζί σου.
Και αυτό το ερώτημα έχει κάτι το θολό και ενοχλητικό.
Χωρίς τη χρήση "αλγορίθμων ταξινόμησης" (το έχουν και σε εισαγωγικά!!)
Μπορεί ο μαθητής να αναγνωρίσει αν ο αλγόριθμος που μόλις έγραψε εμπίπτει σε αυτή την κατηγορία;;;; Όχι, μόνο τη φυσαλίδα μπορεί να αποφύγει.
Κι αν ο αλγόριθμός του μοιάζει με έναν αλγόριθμο ταξινόμησης;
Κι αν μοιάζει με τη φυσαλίδα αλλά δεν είναι η φυσαλίδα όπως τη διδάχτηκε αλλά της έχει κάνει κατάλληλες προσαρμογές;
Τεράστια ασάφεια ...
Φιλικά,
Γιώργος Θαλασσινός

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #33 στις: 29 Μάι 2013, 09:04:36 μμ »
Και η ειρωνεία είναι ότι αν δεν έβαζαν τον περιορισμό θα έμενε στο μαθητή να καταλάβει πως δεν μπορεί να χρησιμοποιήσει τη φυσαλίδα όπως την ξέρει  (πολλοί θα την πάταγαν) άρα ή να την παραλλάξει ή να το λύσει με άλλο τρόπο.
Φιλικά,
Γιώργος Θαλασσινός

Vagnes

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Απ: Θέμα Β
« Απάντηση #34 στις: 29 Μάι 2013, 09:51:34 μμ »
Έχω διαβάσει ορισμένες λυσεις , παραθέτω μια λίγο πιο γρήγορη, με χρήση δυο βοηθητικών δεικτών.

Για i απο 1 μεχρι 100
   k<--1
   λ<--100
   Αν Π = Αληθής τότε  ! Π με δείκτη i ,δεν ξέρω γιατι δε το εμφανίζει
      Π[k] <--Αληθής
          κ  <-- κ + 1
   Αλλιώς
      Π[λ] <-- Ψευδής
          λ  <-- λ - 1
   Τέλος_αν
Τέλος_επανάληψης
Καλησπέρα και απο μένα.. Ενας μαθητης μου εκανε αυτή τη λαθος λύση.. θα πάρει έστω κάποιες μονάδες απ την απάντησή του???

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #35 στις: 29 Μάι 2013, 10:01:33 μμ »
Το μεγάλο πρόβλημα του Β2 είναι ότι του έχουν δώσει 10 μόρια. Αυτό κατά τη γνώμη μου είναι από τα πιο τραγικά σημεία του διαγωνίσματος.
Πόσα από τα 10 θα πάρουν τα παιδιά που έχουν μια λύση η οποία ναι μεν είναι λάθος αλλά φαίνεται ότι έχουν καταλάβει τι κάνουν? Δηλαδή έχουν πλησιάσει?
Δυστυχώς αυτές οι λύσεις δεν νομίζω ότι μπαίνουν σε καλούπια οπότε η βαθμολόγηση εδώ θα είναι κατά την κρίση του βαθμολογητή, αφού δεν μπορούμε να προβλέψουμε όλες τις δυνατές περιπτώσεις
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #36 στις: 29 Μάι 2013, 10:36:48 μμ »
Δεν είμαι βαθμολογητής, οπότε θα πω την καθαρά προσωπική μου γνώμη, όπως θα το διόρθωνα αν ήταν δικό μου διαγώνισμα.
Μόνο που θα σχολιάσω αυτό τον κώδικα (έβγαλα τις αρχικοποιήσεις έξω γιατί μου φαίνεται πολύ "φτηνό" λάθος να έχει γίνει από κάποιον που σκέφτηκε όλη την υπόλοιπη λύση. Αν το έκανε, σίγουρα θα του κοστίσει και αυτό)
Κώδικας: [Επιλογή]
k<--1
λ<--100
Για i απο 1 μεχρι 100
   Αν Π = Αληθής τότε  ! Π με δείκτη i ,δεν ξέρω γιατι δε το εμφανίζει
      Π[k] <--Αληθής
          κ  <-- κ + 1
   Αλλιώς
      Π[λ] <-- Ψευδής
          λ  <-- λ - 1
   Τέλος_αν
Τέλος_επανάληψης
Αυτή η λύση δείχνει ότι ο μαθητής έχει σκεφτεί πολλά σημεία προς τη σωστή κατεύθυνση αλλά έχει χάσει μια λεπτομέρεια.
Μάλιστα αν είχε χρησιμοποιήσει έναν έξτρα πίνακα, η λύση θα ήταν σωστή.
Για μένα παίρνει τα μισά και ίσως παραπάνω μόρια (έτσι κι αλλιώς τη "μισή" δουλειά την κάνει σωστά)
Θα του έδινα 5-6 μόρια
αν έχει και λάθος τις αρχικοποιήσεις θα του κόψω άλλα 2
Είναι εντελώς διαισθητική η βαθμολόγησή μου αλλά όπως λέει κι ο Ευριπίδης, δε γίνεται αλλιώς.
Φιλικά,
Γιώργος Θαλασσινός

Vagnes

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Απ: Θέμα Β
« Απάντηση #37 στις: 29 Μάι 2013, 10:40:28 μμ »
Ναι οι αρχικοποιήσεις γίνανε κανονικά απ' έξω.. απλά επειδή ήταν ίδιο περίπου το παρέθεσα απο τον φίλο...

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Θέμα Β
« Απάντηση #38 στις: 29 Μάι 2013, 11:06:57 μμ »
Μαθητής μου στην διάρκεια της χρονιάς είχε δώσει αυτή την λύση. Η άσκηση ζητούσε να μεταφερθούν όλες οι τιμές 2 στο τέλος του πίνακα χωρίς να αλλάξει η σειρά των υπόλοιπων στοιχείων. Προσαρμόζω τη λύση στο σημερινό ζητούμενο. Θα πρέπει να δωθούν οι μονάδες ή όχι;

Για ι από 1 μέχρι 100
  κ ← ι + 1
  Όσο κ ≤ 100 επανάλαβε
    Αν Π[ι] = Ψευδής και Π[κ] = Αληθής τότε
      Αντιμετάθεσε Π[ι], Π[κ]
    αλλιώς
      κ ← κ + 1
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης

grdereken

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 30
Απ: Θέμα Β
« Απάντηση #39 στις: 29 Μάι 2013, 11:27:15 μμ »
@grdereken
 
 /quote

Αλ <-- 1
Ψ <-- 100
ΟΣΟ Αλ < Ψ επανάλαβε
    ΟΣΟ Π[ΑΛ] = "ΑΛΗΘΗΣ" ΕΠΑΝΑΛΑΒΕ
      ΑΛ <-- ΑΛ + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

...

Τέλος_επανάληψης

quote/

Για τον αλγόριθμο που προτείνεις:
Στην περίπτωση που όλες οι τιμές του πίνακα Π είναι "ΑΛΗΘΗΣ" μενεις στην εσωτερική επανάληψη μέχρι να βρεθείς εκτός πίνακα στη θέση 101 με τη συνθήκη Π[101] = 'ΑΛΗΘΗΣ':
   
 
Δίκιο έχεις Ευαγγελία. Έκανα τις παρακάτω τροποποιήσεις, ελπίζω να είναι σωστό τώρα.
ΑΛ <- 1
  Ψ <- 100
  ΟΣΟ ΑΛ < Ψ ΕΠΑΝΑΛΑΒΕ

!ΑΝ ΣΥΝΑΝΤΑΣ ΑΛΗΘΕΙΕΣ ΠΡΟΧΩΡΑ ΜΠΡΟΣΤΑ ΚΑΙ ΑΝ ΒΡΕΙΣ ΨΕΜΑΤΑ ΣΤΑΜΑΤΑ
    ΕΞΟΔΟΣ <- ΨΕΥΔΗΣ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ Π[ΑΛ] = "ΑΛΗΘΗΣ" ΤΟΤΕ
        ΑΛ <- ΑΛ + 1
      ΑΛΛΙΩΣ
        ΕΞΟΔΟΣ <- ΑΛΗΘΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΕΞΟΔΟΣ = ΑΛΗΘΗΣ Η ΑΛ > Ψ

!ΑΝ ΣΥΝΑΝΤΑΣ ΨΕΜΑΤΑ ΠΗΓΑΙΝΕ ΠΡΟΣ ΤΑ ΠΙΣΩ ΚΑΙ ΣΤΑΜΑΤΑ ΣΤΗΝ ΑΛΗΘΕΙΑ
    ΕΞΟΔΟΣ <- ΨΕΥΔΗΣ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΑΝ Π[Ψ] = "ΨΕΥΔΗΣ" ΤΟΤΕ
        Ψ <- Ψ - 1
      ΑΛΛΙΩΣ
        ΕΞΟΔΟΣ <- ΑΛΗΘΗΣ
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΕΞΟΔΟΣ = ΑΛΗΘΗΣ Η ΑΛ > Ψ

!ΕΚΕΙ ΠΟΥ ΣΤΑΜΑΤΑΣ ΚΑΝΕ ΑΝΤΙΜΕΤΑΘΕΣΗ ΤΑ ΨΕΜΑΤΑ ΜΕ ΤΗΝ ΑΛΗΘΕΙΑ
    ΑΝ ΑΛ < Ψ ΤΟΤΕ
      ΤΕΜΠ <- Π[ΑΛ]
      Π[ΑΛ] <- Π[Ψ]
      Π[Ψ] <- ΤΕΜΠ
    ΤΕΛΟΣ_ΑΝ

  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Για αυτόν που πρότεινες δες λίγο το παρακάτω σύνολο τιμών.
ΑΛΗΘΗΣ
ΑΛΗΘΗΣ
ΑΛΗΘΗΣ
ΑΛΗΘΗΣ
ΑΛΗΘΗΣ
ΨΕΥΔΗΣ
ΨΕΥΔΗΣ
ΨΕΥΔΗΣ
ΨΕΥΔΗΣ
ΨΕΥΔΗΣ

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #40 στις: 29 Μάι 2013, 11:30:26 μμ »
@aperdos
Έχει κάποιο λάθος που δε βλέπω;
Νομίζω ότι δουλεύει άρα το ερώτημα μάλλον θα πρέπει να αντιστραφεί:
Θα πρέπει να κοπούν μονάδες για την περιττή δουλειά που κάνει;
Νομίζω όμως από προηγούμενες συζητήσεις εδώ ότι οι περισσότεροι συμφωνούν στο να μην κοπούν.
Φιλικά,
Γιώργος Θαλασσινός

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #41 στις: 29 Μάι 2013, 11:41:17 μμ »
και εγώ τόσο θα έδινα γιώργο 5-6 ίσως και παραπάνω, ανάλογα με την εικόνα του γραπτού.

Πάντως αυτό το θέμα είναι αφορμή να καταλάβουμε ότι πρέπει να βαθμολογούμε τη σκέψη του μαθητή και όχι να ασχολούμαστε με το αν ο αλγόριθμος "τρέχει" σωστά.
Νομίζω ότι εδώ θα έχουμε πολλές διαφορές στη βαθμολόγηση όπως και στο θέμα Γ

Θα του έδινα 5-6 μόρια
αν έχει και λάθος τις αρχικοποιήσεις θα του κόψω άλλα 2
Είναι εντελώς διαισθητική η βαθμολόγησή μου αλλά όπως λέει κι ο Ευριπίδης, δε γίνεται αλλιώς.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #42 στις: 29 Μάι 2013, 11:43:50 μμ »
Δεν ξέρω γιατί αλλά μου θυμίζει την ταξινόμηση με επιλογή, άρα το θεωρώ ταξινόμηση  :D

Μαθητής μου στην διάρκεια της χρονιάς είχε δώσει αυτή την λύση. Η άσκηση ζητούσε να μεταφερθούν όλες οι τιμές 2 στο τέλος του πίνακα χωρίς να αλλάξει η σειρά των υπόλοιπων στοιχείων. Προσαρμόζω τη λύση στο σημερινό ζητούμενο. Θα πρέπει να δωθούν οι μονάδες ή όχι;

Για ι από 1 μέχρι 100
  κ ← ι + 1
  Όσο κ ≤ 100 επανάλαβε
    Αν Π[ι] = Ψευδής και Π[κ] = Αληθής τότε
      Αντιμετάθεσε Π[ι], Π[κ]
    αλλιώς
      κ ← κ + 1
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Θέμα Β
« Απάντηση #43 στις: 29 Μάι 2013, 11:45:42 μμ »
@aperdos
Έχει κάποιο λάθος που δε βλέπω;
Νομίζω ότι δουλεύει άρα το ερώτημα μάλλον θα πρέπει να αντιστραφεί:
Θα πρέπει να κοπούν μονάδες για την περιττή δουλειά που κάνει;
Νομίζω όμως από προηγούμενες συζητήσεις εδώ ότι οι περισσότεροι συμφωνούν στο να μην κοπούν.

Είναι αλγόριθμος ταξινόμησης. Ούτε εγώ το είχα συνειδητοποιήσει μέχρι σήμερα που ξεκίνησε αυτή η συζήτηση. Σαν παραλλαγή της ταξινόμησης με επιλογή μου φαίνεται.

@evry με πρόλαβες

Για ι από 1 μέχρι 10
  κ ← ι + 1
  Όσο κ ≤ 10 επανάλαβε
    Αν Π[ι] < Π[κ] τότε
      Αντιμετάθεσε Π[ι], Π[κ]
    αλλιώς
      κ ← κ + 1
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης

Το μόνο που αλλάζει είναι η συνάρτηση διάταξης. Οφείλει να το ξέρει ο μαθητής αυτό ή όχι.
Και αν συμφωνούμε να μην κοπούν μονάδες σε αυτή τη λύση γιατί τότε να κοπούν μονάδες αν στη φυσαλίδα τροποποίησω τη συνθήκη;

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: Θέμα Β
« Απάντηση #44 στις: 30 Μάι 2013, 12:00:26 πμ »
@grdereken

Έχεις δίκιο, το σύνολο με πρώτες τιμές όλες Αληθής κάνει μία επιπλέον αντιμετάθεση, το πρόβλημα λύνεται και αν η τελευταία δομή επιλογής μπει πρώτη στη σειρά ώστε να ελέγχει πρώτα τη ανίσωση των δύο τρεχόντων στοιχείων και έπειτα με τις επόμενες Αν τη θέση του καθενός:

  κ <-- 1
  λ <-- 10                                                                                   
  Οσο κ < λ επανάλαβε
    Αν  Π[λ] <> Π[κ] και Π[κ] = ΨΕΥΔΗΣ τότε
      τεμπ <-- Π[κ]
      Π[κ] <-- Π[λ]
      Π[λ] <-- τεμπ     
      κ <-- κ + 1
      λ <-- λ - 1
    Τέλος_αν   

    Αν Π[κ] = ΑΛΗΘΗΣ τότε
      κ <-- κ + 1
    τελος_αν

    Αν Π[λ] = ΨΕΥΔΗΣ τότε
      λ <-- λ - 1
    τελος_αν
  Τέλος_επανάληψης

Επίσης,  με μια ματιά που έριξα νομίζω ότι και ο δικός σου αλγόριθμος με τις εμφωλευμένες επαναλήψεις είναι σωστός :-)
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #45 στις: 30 Μάι 2013, 12:06:55 πμ »
Είναι αλγόριθμος ταξινόμησης.
Α! είναι η επιλογή ;
Έλεος!
ε, ακριβώς αυτό σχολίαζα νωρίτερα εδώ
http://alkisg.mysch.gr/steki/index.php?topic=5230.msg54656#msg54656
Φιλικά,
Γιώργος Θαλασσινός

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Θέμα Β
« Απάντηση #46 στις: 30 Μάι 2013, 10:53:34 πμ »
Το Β2 είναι ένα περίεργο θέμα. Αρχικά το είδα σαν κάτι εύκολο και βατό, αλλά στη συνέχεια τόσο η κουβέντα με τον Ευριπίδη όσο και το γεγονός ότι το έχασαν κυρίως καλοί μαθητές, ενώ το έγραψαν οι αδύναμοι, με έβαλε σε σκέψεις.

Τυπικά θα μπορούσε κάποιος να διαμαρτυρηθεί λέγοντας ότι "ο μαθητής δεν μπορεί να ξέρεις πότε κάτι είναι ταξινόμηση και πότε δεν είναι". Τι θα γίνει πχ αν από μόνος του "φτιάξει" την insert sort και σφηνώνει από κάτω τα ψευδής; Είναι ταξινόμηση, αλλά το ξέρει ο μαθητής; Και τι θα του πεις... ότι όφειλε να το ξέρει; Επίσης θα μπορούσε κανείς να διαμαρτυρηθεί για την έλλειψη κλιμάκωσης των 10 βαθμών. Αν κάποιος κάνει λάθος πόσο θα του κόψεις;

Νομίζω όμως ότι το ουσιαστικό πρόβλημα είναι άλλο. Οι καλοί που την πάτησαν το έπαθαν για ένα λόγο.
Η εύκολη λύση που μετράς τα αληθής και στη συνέχεια τα βάζεις στον πίνακα, δεν μεταφέρει στον πίνακα το ίδιο το στοιχείο που είναι αρχικά στον πίνακα. Βάζει εξαρχής ένα άλλο αληθής, δηλαδή μια τιμή ίση με αυτή που είναι στον πίνακα (αλλά όχι την ίδια). Έτσι αποτέλεσμα είναι το ίδιο. Κάποιοι καλοί μαθητές ενστικτωδώς προσπάθησαν να μεταφέρουν την ίδια την τιμή που είναι αρχικά στον πίνακα σε άλλη θέση... και εκεί έγινε το μπλέξιμο. Συνήθως την έβαλαν σε σημείο που ήταν κάποια άλλη και έχαναν πληροφορία.
Η λύση που θα ήθελαν να κάνουν είναι αυτή που εμφανίζεται στην  πρώτη σάρωση της qsort. Δηλαδή βάζουν ένα δείκτη πάνω και ένα κάτω. Ο πάνω δείκτης σταματάει όταν βρει τιμή ψευδής και ο κάτω όταν βρει αληθής. Στη συνέχεια αντιμετατίθενται τα περιεχόμενα των 2 θέσεων και συνεχίζουμε το ίδιο μέχρι να συμπέσουν οι δείκτες. Δυστυχώς δεν το έφτασαν σωστά μέχρι το τέλος και έχουμε σαν αποτέλεσμα το Β2 να γίνεται λάθος κυρίως από καλούς μαθητές και λιγότερο από αδύναμους.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2213
Απ: Θέμα Β
« Απάντηση #47 στις: 30 Μάι 2013, 11:25:40 πμ »
Ομολογώ ότι το θέμα με δυσκόλεψε αρκετά για έναν προφανή λόγο και μάλιστα το άφησα για το τέλος
Το ίδιο φαντάζομαι συνέβη και στους καλούς μαθητές που προσπάθησαν να το λύσουν και δεν τα κατάφεραν
Η εκφώνηση σε κατευθύνει να ψάξεις λύση εντός του πίνακα με μετακινήσεις στοιχείων όποτε και αν πρέπει, κάτι που θέλει πολύ προσοχή στην υλοποίηση, αν και προκύπτουν πολλές διαφορετικές λύσεις
Ωστόσο, το άγχος και η βιασύνη των μαθητών τους οδήγησε στις λεγόμενες "μπακάλικες" λύσεις:
-Μέτρηση πλήθους και τοποθέτηση νέων τιμών στον πίνακα από την αρχή
-Αντιγραφή των τιμών σε νέο πίνακα και κατόπιν αντιγραφή τους πίσω

Οι λύσεις σαφώς και είναι και πρέπει να γίνουν αποδεκτές, αλλά δεν νομίζω ότι αυτό ήθελαν να εξετάσουν οι θεματοδότες

Επίσης, ένα άλλο θέμα είναι οι 10 μονάδες σε άσκηση παραγωγής κώδικα σε θέμα που δεν είναι ούτε το 3ο, ούτε το 4ο

Γενικότερα, νομίζω ότι τα θέματα Α2, Α4 και Β2 ήταν περισσότερο σπαζοκεφαλιές, παρά εξέταση αφομοίωσης ύλης
Κι αν κάποιο ταλαντούχο παιδί δεν κατέληξε σε κάποια ιδέα, ή αγχώθηκε και θόλωσε επειδή έφτασε στα όρια του στο τέλος μιας τόσο κουραστικής χρονιάς, μετά από εξέταση στα μαθηματικά κατεύθυνσης (όπου ουσιαστικά κατάλαβε ότι πήγε τζάμπα ο χρόνος που αφιέρωσε όλη την χρονιά), δεν είναι άδικο να έχασε τόσες πολλές μονάδες σε αυτά τα ερωτήματα, ειδικά όταν δόθηκαν άλλες 11 μονάδες σε ερωτήματα αποστήθισης;

Προβλέπεται μείωση των αριστούχων φέτος
Ένα χαμένο θέμα από όλα αυτά σε ρίχνει στα όρια του 90+
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Θέμα Β
« Απάντηση #48 στις: 30 Μάι 2013, 11:48:58 πμ »
Γενικότερα, νομίζω ότι τα θέματα Α2, Α4 και Β2 ήταν περισσότερο σπαζοκεφαλιές, παρά εξέταση αφομοίωσης ύλης

Για το Α4 δεν μπορώ να μην επαναλάβω ότι έχει την πηγή του στο τετράδιο μαθητή κεφάλαιο 9 ΔΣ6 (ευρομπάσκετ). Η τριγωνική σάρωση είναι μέρος της ύλης.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2213
Απ: Θέμα Β
« Απάντηση #49 στις: 30 Μάι 2013, 12:04:56 μμ »
Ειλικρινά, πόσοι ασχολούνται (καθηγητές και μαθητές) και πόσοι μπορούν να ασχοληθούν με ασκήσεις 3 αστέρων του τετραδίου μαθητή;
Το γνωρίζω ότι είναι εντός ύλης, αλλά η συγκεκριμένη άσκηση ξεφεύγει αρκετά σε δυσκολία (αυτό φυσικά δεν σημαίνει ότι το Α4 ζητούσε τα περισσότερα από αυτή την άσκηση)
Με την ίδια λογική, μπορεί να ζητηθεί στις κανονικές (μη επαναληπτικές) εξετάσεις το λυμένο παράδειγμα της συγχώνευσης ταξινομημένων πινάκων που έχει το τετράδιο μαθητή και να θρηνήσουμε θύματα...
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Θέμα Β
« Απάντηση #50 στις: 30 Μάι 2013, 01:05:01 μμ »
Οι μαθητές και οι καθηγητές οφείλουν να κάνουν την ύλη τους και όχι να μένουν στα ΣΟΣ. Αυτό το έλεγα πάντα. Τι πάει να πει που είναι δύσκολα κάποια θέματα; Αυτή είναι η ύλη του μαθήματος. Δεν είναι ανάγκη να είναι εύκολο το μάθημα. Είναι υποχρεωτικό τα μαθηματικά και η φυσική να είναι εύκολα;
Αυτό ήταν η μεγάλη επιτυχία των φετινών θεμάτων. Ότι τιμώρησαν όποιον έμενε στα ΣΟΣ και δεν έβγαζε όλη την ύλη. Κάποτε θα γινόταν. Ξέρεις πόσες φορές πόσοι καθηγητές μέσα από το στέκι έλεγαν ότι ένιωσαν βλάκες που δίδασκαν όλη την ύλη και πάλι έπεσαν τα ΣΟΣ στις εξετάσεις;

Και φυσικά η συγχώνευση των ταξινομημένων μπορεί να πέσει εφόσον είναι στο τετράδιο. Η μόνη επιφύλαξη είναι κατά πόσο μπορείς να απαγορέψεις το μαθητή να «ξεγλιστρίσει» κολλώντας απλώς τους πίνακες και ταξινομώντας στη συνέχεια, μια που από τη μια δε βαθμολογείται η πολυπλοκότητα και από την άλλη είναι άκομψο να πεις στο μαθητή να το λύσει έτσι και όχι αλλιώς.

Κατά τα άλλα είναι μέσα στην ύλη και φυσικά μπορεί να πέσει.

Γιάννης Αναγνωστάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 815
Απ: Θέμα Β
« Απάντηση #51 στις: 30 Μάι 2013, 01:14:27 μμ »
Οι μαθητές και οι καθηγητές οφείλουν να κάνουν την ύλη τους και όχι να μένουν στα ΣΟΣ. Αυτό το έλεγα πάντα. Τι πάει να πει που είναι δύσκολα κάποια θέματα; Αυτή είναι η ύλη του μαθήματος. Δεν είναι ανάγκη να είναι εύκολο το μάθημα. Είναι υποχρεωτικό τα μαθηματικά και η φυσική να είναι εύκολα;
Αυτό ήταν η μεγάλη επιτυχία των φετινών θεμάτων. Ότι τιμώρησαν όποιον έμενε στα ΣΟΣ και δεν έβγαζε όλη την ύλη. Κάποτε θα γινόταν. Ξέρεις πόσες φορές πόσοι καθηγητές μέσα από το στέκι έλεγαν ότι ένιωσαν βλάκες που δίδασκαν όλη την ύλη και πάλι έπεσαν τα ΣΟΣ στις εξετάσεις;

Και φυσικά η συγχώνευση των ταξινομημένων μπορεί να πέσει εφόσον είναι στο τετράδιο. Η μόνη επιφύλαξη είναι κατά πόσο μπορείς να απαγορέψεις το μαθητή να «ξεγλιστρίσει» κολλώντας απλώς τους πίνακες και ταξινομώντας στη συνέχεια, μια που από τη μια δε βαθμολογείται η πολυπλοκότητα και από την άλλη είναι άκομψο να πεις στο μαθητή να το λύσει έτσι και όχι αλλιώς.

Κατά τα άλλα είναι μέσα στην ύλη και φυσικά μπορεί να πέσει.

++++++

Με κάλυψες απόλυτα

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Θέμα Β
« Απάντηση #52 στις: 30 Μάι 2013, 02:03:30 μμ »
Οι μαθητές και οι καθηγητές οφείλουν να κάνουν την ύλη τους και όχι να μένουν στα ΣΟΣ. Αυτό το έλεγα πάντα. Τι πάει να πει που είναι δύσκολα κάποια θέματα; Αυτή είναι η ύλη του μαθήματος. Δεν είναι ανάγκη να είναι εύκολο το μάθημα. Είναι υποχρεωτικό τα μαθηματικά και η φυσική να είναι εύκολα;
Αυτό ήταν η μεγάλη επιτυχία των φετινών θεμάτων. Ότι τιμώρησαν όποιον έμενε στα ΣΟΣ και δεν έβγαζε όλη την ύλη. Κάποτε θα γινόταν. Ξέρεις πόσες φορές πόσοι καθηγητές μέσα από το στέκι έλεγαν ότι ένιωσαν βλάκες που δίδασκαν όλη την ύλη και πάλι έπεσαν τα ΣΟΣ στις εξετάσεις;

Και φυσικά η συγχώνευση των ταξινομημένων μπορεί να πέσει εφόσον είναι στο τετράδιο. Η μόνη επιφύλαξη είναι κατά πόσο μπορείς να απαγορέψεις το μαθητή να «ξεγλιστρίσει» κολλώντας απλώς τους πίνακες και ταξινομώντας στη συνέχεια, μια που από τη μια δε βαθμολογείται η πολυπλοκότητα και από την άλλη είναι άκομψο να πεις στο μαθητή να το λύσει έτσι και όχι αλλιώς.

Κατά τα άλλα είναι μέσα στην ύλη και φυσικά μπορεί να πέσει.


Συμφωνώ απόλυτα με όσα λες. Νομίζω ότι δεν υπάρχει θέμα πια στο να απαγορέψεις σε ένα μαθητή να δουλέψει όπως κρίνει αυτός. Στο επαναληπτικό του 2008 στο 4ο θέμα αν απαγορεύονταν η χρήση άλλου βοηθητικού πίνακα ο ενδεδειγμένος τρόπος για να λυθεί με βάση το διδακτικό πακέτο ήταν με προσαρμογή του αλγορίθμου της συγχώνευσης. Εξάλλου η φράση χωρίς χρήση "αλγορίθμων ταξινόμησης" στο Β2, αυτό δεν κάνει; Απαγορεύει στο μαθητή να χρησιμοποιήσει τους αλγόριθμους ταξινόμησης που ξέρει όπως φυσαλίδα (σχολικό βιβλίο) και τον αλγόριθμο στη σελίδα 34 της άσκησης ΔΣ3 τον οποίο δεν ονομάζει αλλά απλά περιγράφει. Η πρωτοτυπία όμως του Β2 είναι ότι απαγορεύει και οποιοδήποτε άλλον αλγόριθμο ταξινόμησης μπορεί να φανταστεί ο μαθητής χωρίς βέβαια να γνωρίζει ότι πρόκειται για ταξινόμηση. Η μήπως όλοι μας γνωρίζουμε όλους τους αλγόριθμους της ταξινόμησης και μπορούμε αμέσως να αναγνωρίσουμε και μια οποιαδήποτε παραλλαγή τους.
Είχα την αίσθηση ότι η συγκεκριμένη φράση μπήκε για να προστατεύσει τους μαθητές από την σύγκριση Π[ι] < Π[ι-1] αλλά μάλλον όπως αποδεικνύεται έκανα λάθος. Νομίζω ότι ο Άλκης έθεσε το ζήτημα στη σωστή του βάση.   


Η διαφορά είναι ότι ήθελε να τους υποχρεώσει να το κάνουν με πολυπλοκότητα O(n) και όχι (n^2), χωρίς να αναφέρει τη λέξη πολυπλοκότητα. Ίσως είναι αμφιλεγόμενο το κατά πόσο η εκφώνηση καταφέρνει καλά αυτόν το στόχο.


Το θέμα λοιπόν για μένα είναι αν θα ισχύσουν για όλους τα ίδια κριτήρια στη βαθμολογία.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2213
Απ: Θέμα Β
« Απάντηση #53 στις: 30 Μάι 2013, 02:35:32 μμ »
Οι μαθητές και οι καθηγητές οφείλουν να κάνουν την ύλη τους και όχι να μένουν στα ΣΟΣ. Αυτό το έλεγα πάντα. Τι πάει να πει που είναι δύσκολα κάποια θέματα; Αυτή είναι η ύλη του μαθήματος. Δεν είναι ανάγκη να είναι εύκολο το μάθημα. Είναι υποχρεωτικό τα μαθηματικά και η φυσική να είναι εύκολα;
Αυτό ήταν η μεγάλη επιτυχία των φετινών θεμάτων. Ότι τιμώρησαν όποιον έμενε στα ΣΟΣ και δεν έβγαζε όλη την ύλη. Κάποτε θα γινόταν. Ξέρεις πόσες φορές πόσοι καθηγητές μέσα από το στέκι έλεγαν ότι ένιωσαν βλάκες που δίδασκαν όλη την ύλη και πάλι έπεσαν τα ΣΟΣ στις εξετάσεις;

Και φυσικά η συγχώνευση των ταξινομημένων μπορεί να πέσει εφόσον είναι στο τετράδιο. Η μόνη επιφύλαξη είναι κατά πόσο μπορείς να απαγορέψεις το μαθητή να «ξεγλιστρίσει» κολλώντας απλώς τους πίνακες και ταξινομώντας στη συνέχεια, μια που από τη μια δε βαθμολογείται η πολυπλοκότητα και από την άλλη είναι άκομψο να πεις στο μαθητή να το λύσει έτσι και όχι αλλιώς.

Κατά τα άλλα είναι μέσα στην ύλη και φυσικά μπορεί να πέσει.


Νομίζω ότι κρίνουμε πάλι με τα δικά μας κριτήρια
Εμείς ασχολούμαστε πολλά χρόνια με το μάθημα και ψάχνουμε να βρούμε περίεργα και μη τυποποιημένα θέματα
Μήπως ξεχνάμε ότι τα παιδιά που διαγωνίζονται κάθε χρόνο είναι διαφορετικά και έχουν εμπειρία μόλις 9 μηνών στον προγραμματισμό και άρα καλό θα είναι τα θέματα να παραμένουν σε ένα ικανοποιητικό επίπεδο, με σωστή διαβάθμιση που να ξεχωρίζει κάποιους;
Δεν νομίζω ότι πάνω από 10% των μαθητών μπορεί να ανταποκριθεί σε τέτοια θέματα και φέτος τα ζήτησαν στο πρώτο και στο δεύτερο θέμα, όχι σαν δύσκολα ερωτήματα στο τέταρτο
Η επιτροπή των εξετάσεων στην φυσική και τα μαθηματικά έχει χάσει την επαφή με τα σχολεία και την κοινωνία εδώ και χρόνια
Θέλουμε κι εμείς κάτι τέτοιο;


Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

vasiko

  • Βετεράνος
  • ****
  • Μηνύματα: 82
  • !!!!...!!!
Απ: Θέμα Β
« Απάντηση #54 στις: 30 Μάι 2013, 03:04:15 μμ »
Για το Α4 δεν μπορώ να μην επαναλάβω ότι έχει την πηγή του στο τετράδιο μαθητή κεφάλαιο 9 ΔΣ6 (ευρομπάσκετ). Η τριγωνική σάρωση είναι μέρος της ύλης.
Η δραστηριότητα που αναφέρεις ζητάει απλά τριγωνική σάρωση και δεν αναφέρει πουθενά ότι αυτή πρέπει να γίνει χωρίς τη χρήση της δομής επιλογής. Οι περισσότεροι συνάδελφοι -μεταξύ των οποίων κι εγώ- τη διδάσκουν με τη χρήση της δομής επιλογής. Αυτό που ζητήθηκε στο Α4 δεν έυπάρχει στα διδακτικά εγχειρίδια. Η άποψη μου είναι ότι πρόκειται για φθηνό εντυπωσιασμό και καταστρατηγεί τη λογική της κλιμάκωσης των θεμάτων . Οι συζητήσεις άλλωστε με έναν πολύ μεγάλο αριθμό υποψηφίων που απάντησαν λάθος αυτό δείχνουν.

ilias01

  • Οπαδός
  • **
  • Μηνύματα: 11
Απ: Θέμα Β
« Απάντηση #55 στις: 30 Μάι 2013, 03:14:12 μμ »
  ι <- 1
  κ <- 100
  ΟΣΟ ι < κ ΕΠΑΝΑΛΑΒΕ
        ΟΣΟ π[ι] = ΑΛΗΘΗΣ ΕΠΑΝΑΛΑΒΕ
               ι <- ι + 1
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         π[ι] <- ΑΛΗΘΗΣ
         ΟΣΟ π[κ] = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
               κ <- κ - 1
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          π[κ] <- ΨΕΥΔΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

euron

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Θέμα Β
« Απάντηση #56 στις: 30 Μάι 2013, 03:17:30 μμ »
Η δραστηριότητα που αναφέρεις ζητάει απλά τριγωνική σάρωση και δεν αναφέρει πουθενά ότι αυτή πρέπει να γίνει χωρίς τη χρήση της δομής επιλογής. Οι περισσότεροι συνάδελφοι -μεταξύ των οποίων κι εγώ- τη διδάσκουν με τη χρήση της δομής επιλογής. Αυτό που ζητήθηκε στο Α4 δεν έυπάρχει στα διδακτικά εγχειρίδια. Η άποψη μου είναι ότι πρόκειται για φθηνό εντυπωσιασμό και καταστρατηγεί τη λογική της κλιμάκωσης των θεμάτων . Οι συζητήσεις άλλωστε με έναν πολύ μεγάλο αριθμό υποψηφίων που απάντησαν λάθος αυτό δείχνουν.
Συμφωνώ απόλυτα. Το θέμα με το eurobasket το δίδαξα ξανά την τελευταία μέρα! Υπήρξαν μαθητές μου που το θέμα των εξετάσεων δεν το έγραψαν, ενώ το θέμα του τετραδίου του μαθητή θα το έγραφαν.

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Θέμα Β
« Απάντηση #57 στις: 30 Μάι 2013, 05:23:46 μμ »
Τώρα κατάλαβα τι λέτε! Εγώ την τριγωνική την κάνω χωρίς Αν (δηλαδή κανονικά τριγωνικά όχι τετραγωνικά με συνθήκη) γι αυτό έλεγα τα παραπάνω. Απλά δηλαδή έβλεπες που σαρώνει και το έκανες αλλιώς.

Αλλά ρε παιδιά... με πάσα ειλικρίνεια... δε συμφωνώ με τη λύση με Αν στην άσκηση με το ευρομπάσκετ. Αν σάρωνες τη διαγώνιο θα το έκανες με διπλή Για και μια Αν μέσα; Αν σάρωνες μόνο πχ την 3η στήλη θα το έκανες με διπλή Για και μέσα μια Αν j=3;
Μπορεί να μη βαθμολογείται η ποιότητα (κακώς για μένα) αλλά θεωρώ ότι εμείς πρέπει να ενθαρρύνουμε τον αποτελεσματικό κώδικα. 

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1015
Απ: Θέμα Β
« Απάντηση #58 στις: 30 Μάι 2013, 07:43:47 μμ »
Παιδιά θα συμφωνήσω με τον Γιώργο.
Επειδή δούλεψα μέσα στην τάξη (27 παρακαλώ !!!) την ΔΣ6 Κεφ. 9 Τετράδιο,
εννοείται ότι η σάρωση
είτε γραμμής , είτε στήλης, είτε διαγωνίου κύριας, διαγωνίου δευτερεύουσας, είτε άνω τριγωνικού τμήματος, είτε κάτω τριγωνικού  τμήματος
θα βασίζεται καθαρά στη σχέση των δεικτών (γραμμής, στήλης) και ΟΧΙ στην τυποποιημένη - τυφλή σάρωση !!!

Άλλωστε η "ομορφιά" των τετραγωνικών πινάκων είναι τα παραπάνω ...

Τι να πω στον μαθητή ;;;;

Σε ένα πίνακα  Π[1000,1000] , για να σαρώσω την κύρια διαγώνιο , θα ελέγχω 10^6 στοιχεία ;;;;  Γιατί ;;;

Θα μου πείτε είναι πολυπλοκότητα αλγορίθμου ;;;

Ε, και αν τον αφήσεις (το μαθητή) να σκεφθεί λίγο ... "λοξοδρομώντας" πέρα απ' τα συνήθη,  θα τον βλάψει  ;;;

Α

vasiko

  • Βετεράνος
  • ****
  • Μηνύματα: 82
  • !!!!...!!!
Απ: Θέμα Β
« Απάντηση #59 στις: 30 Μάι 2013, 09:56:51 μμ »
Τώρα κατάλαβα τι λέτε! Εγώ την τριγωνική την κάνω χωρίς Αν (δηλαδή κανονικά τριγωνικά όχι τετραγωνικά με συνθήκη) γι αυτό έλεγα τα παραπάνω. Απλά δηλαδή έβλεπες που σαρώνει και το έκανες αλλιώς.

Αλλά ρε παιδιά... με πάσα ειλικρίνεια... δε συμφωνώ με τη λύση με Αν στην άσκηση με το ευρομπάσκετ. Αν σάρωνες τη διαγώνιο θα το έκανες με διπλή Για και μια Αν μέσα; Αν σάρωνες μόνο πχ την 3η στήλη θα το έκανες με διπλή Για και μέσα μια Αν j=3;
Μπορεί να μη βαθμολογείται η ποιότητα (κακώς για μένα) αλλά θεωρώ ότι εμείς πρέπει να ενθαρρύνουμε τον αποτελεσματικό κώδικα. 
Έχουμε εντελώς διαφορετική προσέγγιση στο θέμα. Ας συμφωνήσουμε ότι διαφωνούμε. Ήθελα απλά να καταγραφεί και η αντίθετη άποψη.

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1089
Απ: Θέμα Β
« Απάντηση #60 στις: 30 Μάι 2013, 11:21:57 μμ »
Η απαγόρευση των αλγορίθμων ταξινόμησης, πρακτικά σημαίνει απαγόρευσης χρήσης της ταξινόμησης ευθείας ανταλλαγής καθώς μόνο αυτή διδάσκεται ο μαθητής.

Σχετικά με τη βαθμολόγηση, μια λύση όχι και τόση σωστή θα βαθμολογηθεί αναλογικά και όχι αρνητικά εντελώς

Παράθεση
Το θέμα λοιπόν για μένα είναι αν θα ισχύσουν για όλους τα ίδια κριτήρια στη βαθμολογία.

Δυστυχώς αυτό δύσκολο να εφαρμοστεί.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #61 στις: 30 Μάι 2013, 11:49:43 μμ »
Ένα λεπτάκι. Η εκφώνηση λέει ξεκάθαρα ότι δεν επιτρέπεται να κάνουν χρήση "αλγορίθμων ταξινόμησης".
Φαντάζομαι πως όλοι καταλαβαίνουμε ότι εννοεί όλους τους αλγορίθμους ταξινόμησης. Να μην σχολιάσω το γεγονός ότι χρησιμοποιεί πληθυντικό, άρα δεν εννοεί μόνον την φυσαλίδα.

Αν ήθελαν μόνο τη φυσαλίδα να έλεγαν συγκεκριμένα μόνο τη φυσαλίδα.

Η άποψή μου είναι ότι ήθελαν να απαγορέψουν στους μαθητές τη διπλή επανάληψη και τους βγήκε αυτή η εκφώνηση. Ήθελαν δηλαδή αλγόριθμο O(n) όπως είπε και ο Άλκης παραπάνω.

Η απαγόρευση των αλγορίθμων ταξινόμησης, πρακτικά σημαίνει απαγόρευσης χρήσης της ταξινόμησης ευθείας ανταλλαγής καθώς μόνο αυτή διδάσκεται ο μαθητής.

Σχετικά με τη βαθμολόγηση, μια λύση όχι και τόση σωστή θα βαθμολογηθεί αναλογικά και όχι αρνητικά εντελώς

Δυστυχώς αυτό δύσκολο να εφαρμοστεί.

Είναι τόσες οι διαφορετικές εκδοχές του αλγορίθμου που μπορούν να σκεφτούν τα παιδιά και τα πιθανά λάθη που μπορούν να κάνουν που καθιστούν τον συντονισμό της βαθμολόγησης πρακτικά αδύνατο. (Το ανακάλυψα σήμερα στην πειραματική βαθμολόγηση)
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Θέμα Β
« Απάντηση #62 στις: 31 Μάι 2013, 08:39:04 πμ »
Νομίζω ότι κρίνουμε πάλι με τα δικά μας κριτήρια
Εμείς ασχολούμαστε πολλά χρόνια με το μάθημα και ψάχνουμε να βρούμε περίεργα και μη τυποποιημένα θέματα
Μήπως ξεχνάμε ότι τα παιδιά που διαγωνίζονται κάθε χρόνο είναι διαφορετικά και έχουν εμπειρία μόλις 9 μηνών στον προγραμματισμό και άρα καλό θα είναι τα θέματα να παραμένουν σε ένα ικανοποιητικό επίπεδο, με σωστή διαβάθμιση που να ξεχωρίζει κάποιους;
Δεν νομίζω ότι πάνω από 10% των μαθητών μπορεί να ανταποκριθεί σε τέτοια θέματα και φέτος τα ζήτησαν στο πρώτο και στο δεύτερο θέμα, όχι σαν δύσκολα ερωτήματα στο τέταρτο
Η επιτροπή των εξετάσεων στην φυσική και τα μαθηματικά έχει χάσει την επαφή με τα σχολεία και την κοινωνία εδώ και χρόνια
Θέλουμε κι εμείς κάτι τέτοιο;




Εγώ θα συμφωνήσω ότι δεν είναι σωστό ο καθένας να βάζει προσωπικά κριτήρια. Τα κριτήρια για μένα πρέπει να τα θέτει το διδακτικό πακέτο… ούτε ο μαθητής ούτε ο καθηγητής. Γι αυτό κι εγώ αναφέρομαι σε αυτό και όχι στις προσωπικές μου απόψεις (πχ χωρίς υπερβολή οι απόψεις μου είναι να ωθήσουμε το μάθημα προς τις μαθηματικές εφαρμογές και θεωρία αριθμών γιατί έτσι αντιλαμβάνομαι εγώ τους αλγορίθμους).

Οι μαθηματικοί είναι φάουλ γιατί αγνοούν συστηματικά το σχολικό βιβλίο και έβαλαν τρυκ που δεν υπάρχει κάπου μέσα.

Στα φετινά θέματα της ΑΕΠΠ δε μιλάμε για περίεργα μη τυποποιημένα θέματα. Μιλάμε για θέματα εντός του διδακτικού πακέτου.
Θέλουμε να ξεχωρίσουν κάποιοι. Η λογική λέει ότι οι βαθμοί πάνω από 18 πρέπει να είναι κάτω από το 10% (10% έχεις στην ομοιόμορφη κατανομή)... κάτι που δεν ισχύει στο μάθημά μας να δούμε τα στατιστικά. Πιο πολλοί γράφουν 18-20 από ότι 16-18.
Με δεδομένο ότι πρέπει να πέσει και κάτι δύσκολο και οι βαθμοί στο 18-20 να είναι κάτω από 10%, ο πιο έντιμος τρόπος να το πετύχεις αυτό είναι να βάλεις δύσκολα θέματα από το διδακτικό πακέτο. Διαφορετικά, αν έπεφταν τρυκ που δεν είναι πουθενά στην ύλη (όπως έκαναν οι μαθηματικοί) τότε θα ωθούσαμε τα παιδιά στο να ψάξουν κάπου να τα βρουν… και αυτό είναι παρεξηγήσιμο έτσι δεν είναι; Από την άλλη, αν βάζουμε τα κλασσικά ΣΟΣ, έχουμε ένα μάθημα σούπα που το διδάσκει ο καθένας εντελώς τυποποιημένα, κάνει 5-6 στάνταρ θεματάκια και γράφει ο μαθητής 18+. Ούτε αυτό είναι αποδεκτό.

Ξαναλέω… ο πιο ασφαλής και κυρίως ο πιο έντιμος τρόπος να έχεις κλιμάκωση σε ένα μάθημα είναι να χρησιμοποιείς ιδέες που είναι σαφώς εντός ύλης και περιέχονται στα σχολικά βιβλία. Όχι ατόφιες ασκήσεις, αλλά ιδέες που υπάρχουν. Και ο μαθητής να ελέγχεται στο αν τις έχει κάνει κτήμα του και όχι αν ξέρει απέξω τη συγκεκριμένη άσκηση.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2213
Απ: Θέμα Β
« Απάντηση #63 στις: 31 Μάι 2013, 10:56:10 πμ »
Δεν διαφωνώ φίλε μου, απλά δεν νομίζεις κι εσύ  ότι η ποσότητα των θεμάτων που θα κάνουν τους άριστους να ξεχωρίσουν ήταν αρκετά μεγάλη;
Δεν θεωρείς ότι φέτος θα φτάσουμε πάλι στο θλιβερό 50+% κάτω από την βάση; (είχε φτάσει πέρσι περίπου το 41% αν θυμάμαι καλά, μειούμενο κάθε χρόνο από το 2007 και μετά (πλην 2010))
Γιατί η κανονική κατανομή δεν αφορά μόνο τους αριστούχους, αλλά και τους χαμηλόβαθμους και αυτοί την πλήρωσαν μάλλον φέτος, αφού υπήρχαν το πολύ 30-35 μονάδες που θα μπορούσαν να αντιμετωπίσουν σχετικά εύκολα
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #64 στις: 31 Μάι 2013, 11:20:00 πμ »
Κατά τη γνώμη μου σε αυτό το διαγώνισμα δεν υπήρχε θέμα το οποίο ξεχώριζε τον άριστο από τον πολύ καλό.
Νομίζω ότι στις βαθμολογίες θα έχουμε συμπίεση προς τα κάτω και προς τα πάνω, γιατί οι "διαβασμένοι" έχουν γράψει και έχουν χάσει μικροπράγματα από εδώ και από εκεί, και οι μέτριοι έχασαν πολλά και από το θέμα Α και Β από τα οποία περίμεναν να πάρουν. Στο Γ θα μπερδεύτηκαν και όταν έφτασαν στο εύκολο Δ ήταν πια αργά.

Όσον αφορά τον χρόνο που χρειάστηκαν οι μαθητές ενώ στην αρχή φαινόταν ότι δεν είναι τόσα πολλά σε όγκο τελικά για πρώτη φορά είδα μαθητές να τελειώνουν οριακά, ίσως λόγω των εκφωνήσεων που ήθελαν προσεκτική ανάγνωση.

Επίσης για το Β2 νομίζω ότι υπάρχει και ένα ακόμα πρόβλημα. Η εκφώνηση λέει "στις πρώτες θέσεις οι Αληθείς και στις τελευταίες οι Ψευδείς"
Αυτό κατά τη γνώμη μου είναι λάθος, διότι αν είχαμε 99 Αληθείς και μια Ψευδή τι θα λέγαμε ? ότι η 99η θέση είναι από τις πρώτες θέσεις του πίνακα?
Μερικοί μπορείτε να πείτε ότι το παραπάνω επιχείρημα είναι εξυπναδίστικο και ότι παίζω με τις λέξεις.
Δεν το λέω έτσι. Στην εξέταση των ΦΑ είχαμε το εξής πρόβλημα: Πολλοί θεώρησαν ότι  ο πίνακας έχει 50 αληθείς και 50 ψευδείς. Πιστεύω ότι η συγκεκριμένη διατύπωση τους δημιούργησε την παρανόηση μιας ιδιότυπης συμμετρίας, δηλαδή έχω δύο άκρα, ισοβαρή κλπ. Επίσης μπορεί κάποιοι να αναρωτήθηκαν οκ στις πρώτες έχει αυτά και στις τελευταίες αυτά, στις μεσαίες τι έχει?

Νομίζω ( απλά για την ιστορία ) ότι η διατύπωση θα έπρεπε να ήταν "Να τοποθετεί τα στοιχεία του πίνακα έτσι ώστε όλες οι Αληθείς να είναι πριν από τις Ψευδείς"


« Τελευταία τροποποίηση: 31 Μάι 2013, 11:34:23 πμ από evry »
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3176
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Β
« Απάντηση #65 στις: 31 Μάι 2013, 03:21:28 μμ »
ένας φίλος του κου Αρβίλογλου αναρωτήθηκε, αν η -μπακάλικη- λύση για το Β2 είναι απλοποίηση του αλγορίθμου counting sort. Ακόμη, δεν ξέρει αν εντάσσεται στους "αλγορίθμους ταξινόμησης".
Μπακάλικη χαρακτηρίζεται, από εμένα, γιατί -κάνοντας το ζητούμενο- αλλοιώνει τον πίνακα και δεν γενικεύεται. Για παράδειγμα αν θέλαμε να διαχωρίσουμε άρτια και περιττά στοιχεία (πανω-κάτω).
Άρα δεν είναι αυτή που θέλουμε να προτείνουμε στα επόμενα παιδιά μας.

Μια άλλη λύση, εκτός από την χρήση αντιγραφής σε νέο πίνακα και πέρασμά του στον Π θα μπορούσε να είναι:

Για i από 1 μέχρι 100
κρατάω το Π[ i]
κατεβαίνω από τη θέση i+1 προς τα κάτω και αναζητώ κάποια τιμή ψευδής
όταν τη βρώ πχ στη θέση pos
ΑΝΤΙΜΕΤΑΘΕΤΩ τα στοιχεία Π[ ι] και Π[pos]
Τέλος_επανάληψης


ΔΕΝ θεωρώ οτι ο αποκλεισμός των "αλγορίθμων ταξινόμησης" είναι για την πολυπλοκότητα. Η επιτροπή προσπάθησε πιθανόν να αποτρέψει όλους μας να λύσουμε ΛΑΝΘΑΣΜΕΝΑ με φυσαλίδα την άσκηση, μιας και ΔΕΝ ΜΠΟΡΟΥΜΕ ΝΑ ΤΑΞΙΝΟΜΗΣΟΥΜΕ λογικές τιμές edit: με ερωτήσεις > και < σε αυτές.
Διαφορετικά, θα συζητούσαμε ακόμη σήμερα (edit:) τη σχετική αναφορά στη σελίδα 166 του σχολικού βιβλίου μαθητή  και θα διυλίζαμε τον κώνωπα όπως το 2010.
Ευτυχώς, ο καλός Θεούλης μας προστάτεψε από αυτήν την εξέλιξη.
« Τελευταία τροποποίηση: 31 Μάι 2013, 05:25:51 μμ από Παναγιώτης Τσιωτάκης »

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Θέμα Β
« Απάντηση #66 στις: 31 Μάι 2013, 03:48:16 μμ »
Δεν διαφωνώ φίλε μου, απλά δεν νομίζεις κι εσύ  ότι η ποσότητα των θεμάτων που θα κάνουν τους άριστους να ξεχωρίσουν ήταν αρκετά μεγάλη;
Δεν θεωρείς ότι φέτος θα φτάσουμε πάλι στο θλιβερό 50+% κάτω από την βάση; (είχε φτάσει πέρσι περίπου το 41% αν θυμάμαι καλά, μειούμενο κάθε χρόνο από το 2007 και μετά (πλην 2010))
Γιατί η κανονική κατανομή δεν αφορά μόνο τους αριστούχους, αλλά και τους χαμηλόβαθμους και αυτοί την πλήρωσαν μάλλον φέτος, αφού υπήρχαν το πολύ 30-35 μονάδες που θα μπορούσαν να αντιμετωπίσουν σχετικά εύκολα

Θα σου πω τη γνώμη μου. Θα ήθελα καταρχήν να ξεκαθαρίσω ότι σε καμία περίπτωση δε θα ήθελα αυτοί που είναι κάτω από τη βάση να καθορίσουν το επίπεδο του μαθήματος. Το επίπεδο του μαθήματος πρέπει να το καθορίζουν αυτοί που είναι άνω του 18. Εκεί θέλω να έχω ποσοστά της τάξης του 5% ή τουλάχιστο κάτω από 10% και εμείς είμαστε στο 16%. Αν έχω εκεί τα ποσοστά που θέλω μετά γιατί όχι… να δούμε και τα άλλα.

Τώρα στα νούμερα.
Ένα ποσοστό της τάξης του 30% πέφτει και στη ΑΟΔΕ που σημαίνει ότι υπάρχει μια κατηγορία μαθητών που είναι εντελώς αδιάφοροι. Αυτοί ότι και να τους βάλεις θα κοπούν. Καλώς ή κακώς οι εντελώς αδιάφοροι μαθητές Άρα βασικά μιλάμε για το υπόλοιπο 10-20%. Αν δεις τα ποσοστά των μαθηματικών και της φυσικής μιλάμε για ποσοστό κομμένων της τάξης του 70%. Στα μαθηματικά γενικής (που θεωρείται βατό μάθημα) μιλάμε για ποσοστά περίπου 35-40%. Δε βλέπω δηλαδή σοβαρό πρόβλημα συγκριτικά με τα άλλα μαθήματα.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4926
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Θέμα Β
« Απάντηση #67 στις: 31 Μάι 2013, 03:55:13 μμ »
Η επιτροπή προσπάθησε πιθανόν να αποτρέψει όλους μας να λύσουμε ΛΑΝΘΑΣΜΕΝΑ με φυσαλίδα την άσκηση, μιας και ΔΕΝ ΜΠΟΡΟΥΜΕ ΝΑ ΤΑΞΙΝΟΜΗΣΟΥΜΕ λογικές τιμές αφού δεν μπορούμε να κάνουμε ερωτήσεις > και < σε αυτές.

Ο ορισμός της ταξινόμησης στη σελίδα 66 του σχολικού βιβλίου (αλλά και γενικότερα) αναφέρει ότι δεν συγκρίνουμε τις τιμές "ak" του πίνακα,
αλλά τις τιμές μια συνάρτησης "f(ak)",
η οποία για την περίπτωση των λογικών μεταβλητών θα μπορούσε να οριστεί ως f(Ψευδής)=0 και f(Αληθής)=1.

Δηλαδή φυσικά και μπορεί να οριστεί ταξινόμηση πινάκων λογικών μεταβλητών.

Στην υλοποίηση της φυσαλίδας στη σελίδα 68, εάν θέλαμε να βάλουμε τη συνάρτηση f(), ώστε να "πιάσουμε" και τους πίνακες λογικών μεταβλητών, θα αλλάζαμε μόνο την εντολή Αν:
Αν f(table[j-1]) > f(table[j]) τότε
...

Αν δεν ίσχυε ο παραπάνω ορισμός, τότε δεν θα μπορούσαμε να μιλάμε ούτε καν για ταξινομημένους τηλεφωνικούς καταλόγους, αφού δεν ορίζεται η σύγκριση μεταξύ εγγραφών (structs). Αλλά και σ' εκείνη την περίπτωση ορίζουμε έμμεσα μια συνάρτηση f(struct) η οποία μας επιστρέφει μόνο το ονοματεπώνυμο και όχι το τηλέφωνο, οπότε και χρησιμοποιούμε αυτό για τη σύγκριση των εγγραφών.

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3176
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Β
« Απάντηση #68 στις: 31 Μάι 2013, 04:15:34 μμ »
Σελίδα 166 βιβλίου μαθητή (και όχι οδηγία ΠΙ όπως εκ παραδρομή έγραψα):
Η σύγκριση λογικών έχει έννοια μόνο στην περίπτωση του ίσου (=) και του διάφορου (<>), αφού οι τιμές που μπορούν να έχουν είναι ΑΛΗΘΗΣ και ΨΕΥΔΗΣ.

αλλιώς απλά δεν έχει έννοια, όπως η αλλαγή του μετρητή του Για εντός του βρόχου δεν έχει έννοια, όπως το Διάβασε/Γράψε σε συνάρτηση δεν έχει έννοια

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Θέμα Β
« Απάντηση #69 στις: 31 Μάι 2013, 04:21:58 μμ »
Ο ορισμός της ταξινόμησης στη σελίδα 66 του σχολικού βιβλίου (αλλά και γενικότερα) αναφέρει ότι δεν συγκρίνουμε τις τιμές "ak" του πίνακα,
αλλά τις τιμές μια συνάρτησης "f(ak)",
η οποία για την περίπτωση των λογικών μεταβλητών θα μπορούσε να οριστεί ως f(Ψευδής)=0 και f(Αληθής)=1.

Δηλαδή φυσικά και μπορεί να οριστεί ταξινόμηση πινάκων λογικών μεταβλητών.

Στην υλοποίηση της φυσαλίδας στη σελίδα 68, εάν θέλαμε να βάλουμε τη συνάρτηση f(), ώστε να "πιάσουμε" και τους πίνακες λογικών μεταβλητών, θα αλλάζαμε μόνο την εντολή Αν:
Αν f(table[j-1]) > f(table[j]) τότε
...

Αν δεν ίσχυε ο παραπάνω ορισμός, τότε δεν θα μπορούσαμε να μιλάμε ούτε καν για ταξινομημένους τηλεφωνικούς καταλόγους, αφού δεν ορίζεται η σύγκριση μεταξύ εγγραφών (structs). Αλλά και σ' εκείνη την περίπτωση ορίζουμε έμμεσα μια συνάρτηση f(struct) η οποία μας επιστρέφει μόνο το ονοματεπώνυμο και όχι το τηλέφωνο, οπότε και χρησιμοποιούμε αυτό για τη σύγκριση των εγγραφών.

Έτσι είναι. Για να υπάρχει ταξινόμηση πρέπει να υπάρχει διάταξη. Διάταξη όχι στο σύνολο των στοιχείων που ταξινομούμε, αλλά στο σύνολο των εικόνων των στοιχείων που ταξινομούμε μέσω της ordering function.
Στην κλασσική αύξουσα ταξινόμηση ordering function έχεις την ταυτοτική f(x)=x, στην αύξουσα την f(x)=-x. Προφανώς το σύνολο των 2 τιμών {Αληθής, Ψευδής} δεν είναι διατεταγμένο, αλλά μπορείς να ορίσεις μια ordering function πχ f(Αληθής)=0 και f(Ψευδής)=1 και να συνεχίσεις. Αν ορίσεις f(x)=x στις λογικές τότε προφανώς δε γίνεται ταξινόμηση γιατί δεν υπάρχει διάταξη στις λογικές τιμές. Αυτά όμως παρακάμπτονται εύκολα.
Κι εγώ αν ήθελα formal διατύπωση του θέματος χωρίς περιορισμό από τη σχολική ύλη θα μίλαγα για Ο(ν) αντί για Ο(ν^2).

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3176
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Β
« Απάντηση #70 στις: 31 Μάι 2013, 04:27:40 μμ »
Μάλλον παρανόησα, μου φάνηκε ότι διάβασα στο σχολικό βιβλίο μαθητή ότι δεν έχει έννοια το

ΑΛΗΘΗΣ < ΨΕΥΔΗΣ
ούτε το
ΑΛΗΘΗΣ > ΨΕΥΔΗΣ

ένας φίλος του κου Αρβίλογλου αναρωτήθηκε, αν η -μπακάλικη- λύση για το Β2 είναι απλοποίηση του αλγορίθμου counting sort. Ακόμη, δεν ξέρει αν εντάσσεται στους "αλγορίθμους ταξινόμησης".
Μπακάλικη χαρακτηρίζεται, από εμένα, γιατί -κάνοντας το ζητούμενο- αλλοιώνει τον πίνακα και δεν γενικεύεται. Για παράδειγμα αν θέλαμε να διαχωρίσουμε άρτια και περιττά στοιχεία (πανω-κάτω).
Άρα δεν είναι αυτή που θέλουμε να προτείνουμε στα επόμενα παιδιά μας.

Μια άλλη λύση, εκτός από την χρήση αντιγραφής σε νέο πίνακα και πέρασμά του στον Π θα μπορούσε να είναι:

Για i από 1 μέχρι 100
κρατάω το Π[ i]
κατεβαίνω από τη θέση i+1 προς τα κάτω και αναζητώ κάποια τιμή ψευδής
όταν τη βρώ πχ στη θέση pos
ΑΝΤΙΜΕΤΑΘΕΤΩ τα στοιχεία Π[ ι] και Π[pos]
Τέλος_επανάληψης


ΔΕΝ θεωρώ οτι ο αποκλεισμός των "αλγορίθμων ταξινόμησης" είναι για την πολυπλοκότητα. Η επιτροπή προσπάθησε πιθανόν να αποτρέψει όλους μας να λύσουμε ΛΑΝΘΑΣΜΕΝΑ με φυσαλίδα την άσκηση, μιας και ΔΕΝ ΜΠΟΡΟΥΜΕ ΝΑ ΤΑΞΙΝΟΜΗΣΟΥΜΕ λογικές τιμές αφού δεν μπορούμε να κάνουμε ερωτήσεις > και < σε αυτές.
Διαφορετικά, θα συζητούσαμε ακόμη σήμερα (edit:) τη σχετική αναφορά στη σελίδα 166 του σχολικού βιβλίου μαθητή  και θα διυλίζαμε τον κώνωπα όπως το 2010.
Ευτυχώς, ο καλός Θεούλης μας προστάτεψε από αυτήν την εξέλιξη.

« Τελευταία τροποποίηση: 31 Μάι 2013, 04:39:16 μμ από Παναγιώτης Τσιωτάκης »

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #71 στις: 31 Μάι 2013, 04:44:00 μμ »
Μάλλον παρανόησα, μου φάνηκε ότι διάβασα στο σχολικό βιβλίο μαθητή ότι δεν έχει έννοια το

ΑΛΗΘΗΣ < ΨΕΥΔΗΣ
ούτε το
ΑΛΗΘΗΣ > ΨΕΥΔΗΣ

Aκόμα και αν στα πλαίσια του βιβλίου υποθέσουμε πώς δεν έχει,που διαφωνείς με αυτό που ήδη σου είπαν;Αν αντί  να συγκρίνεις τα ΑΛΗΘΗΣ/ΨΕΥΔΗΣ συγκρίνεις τα f(AΛΗΘΗΣ)/f(ΨΕΥΔΗΣ) που είναι το πρόβλημα;

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3176
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Β
« Απάντηση #72 στις: 31 Μάι 2013, 04:48:10 μμ »
Συζητώ μόνο για το θέμα Β
ειλικρινά, οι 2 βδομάδες που πέρασαν ήταν πολύ κουραστικές για μένα, δεν καταλαβαίνω τι ειναι το f;;

Η εντολή Π[j] > Π[j-1] όπου Π λογικός πίνακας, στην ΑΕΠΠ δεν έχει έννοια

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #73 στις: 31 Μάι 2013, 04:54:53 μμ »
Συζητώ μόνο για το θέμα Β
ειλικρινά, οι 2 βδομάδες που πέρασαν ήταν πολύ κουραστικές για μένα, δεν καταλαβαίνω τι ειναι το f;;


Το f είναι μια συνάρτηση που παίρνει μια λογική μεταβλητή και την κάνει map/απεικονίζει σε έναν ακέραιο.Στην περίπτωση μάς :

f(AΛΗΘΗΣ) = 1
f(ΨΕΥΔΗΣ)  = 0

Παράθεση

Η εντολή Π[j] > Π[j-1] όπου Π λογικός πίνακας, στην ΑΕΠΠ δεν έχει έννοια

Συμφωνώ δεν έχει,αλλά με βάση τη συνάρτηση που σου έγραψα,το f(Π[j]) > f(Π[j-1]) έχει.Με βάση αυτού δεν μπορείς να ταξινομήσεις τώρα;Με τον κλασικό αλγόριθμο;Απλά αντικαθιστάς με αυτό που σου έγραψα.

Όχι δεν θα είναι ταξινομημένος ο πίνακας αλλά με τον αλγόριθμο της ταξινόμησης που τους διδάσκεις,σου παράγουν το αποτέλεσμα που θες.Νομίζω,αυτό ήθελαν να το αποφύγουν οι της ΚΕΕ,ή ίσως δεν ήθελαν να βάλουν τους εξεταζόμενους να μπουν στην διαδικασία να σκεφτούν την f(Ή πες την και bool2Int άμα θες να έχει πιο εύγλωττο όνομα) ;


Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3176
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Β
« Απάντηση #74 στις: 31 Μάι 2013, 04:58:25 μμ »
OK, άρα η ταξινόμηση του Π στην ψευδογλώσσα -αν ο μαθητής δεν ορίσει και παρουσιάσει συνάρτηση f με τις παραπάνω ιδιότητες- δεν έχει έννοια (δε γίνεται θα προσέθετα εγώ).

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #75 στις: 31 Μάι 2013, 05:02:16 μμ »
Ναι συμφώνω μαζί σου,δεν ορίζεται διάταξη μεταξύ των λογικών μεταβλητών,τουλάχιστον στο ΑΕΠΠ.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #76 στις: 31 Μάι 2013, 05:16:38 μμ »
Ωστόσο μπορείς να χρησιμοποιήσεις τον αλγόριθμο ταξινόμησης της φυσαλίδας για να διατάξεις τις λογικές τιμές έτσι ώστε να είναι οι Αληθείς πριν από τις Ψευδείς.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3176
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Β
« Απάντηση #77 στις: 31 Μάι 2013, 05:21:12 μμ »
πιθανώς εννοείς μόνο με τη χρήση = και <>, δεκτό
κάτι που δεν αναιρεί το νόημα του παρακάτω (το οποίο άλλαξα ελαφρά στο πρωτότυπο)

ΔΕΝ θεωρώ οτι ο αποκλεισμός των "αλγορίθμων ταξινόμησης" είναι για την πολυπλοκότητα. Η επιτροπή προσπάθησε πιθανόν να αποτρέψει όλους μας να λύσουμε ΛΑΝΘΑΣΜΕΝΑ με φυσαλίδα την άσκηση, μιας και ΔΕΝ ΜΠΟΡΟΥΜΕ ΝΑ ΤΑΞΙΝΟΜΗΣΟΥΜΕ λογικές τιμές αφού δεν μπορούμε να κάνουμε ερωτήσεις > και < σε αυτές.
Διαφορετικά, θα συζητούσαμε ακόμη σήμερα (edit:) τη σχετική αναφορά στη σελίδα 166 του σχολικού βιβλίου μαθητή  και θα διυλίζαμε τον κώνωπα όπως το 2010.
Ευτυχώς, ο καλός Θεούλης μας προστάτεψε από αυτήν την εξέλιξη.


itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #78 στις: 31 Μάι 2013, 06:13:44 μμ »
Παράθεση
Μερικοί μπορείτε να πείτε ότι το παραπάνω επιχείρημα είναι εξυπναδίστικο και ότι παίζω με τις λέξεις.
Δεν το λέω έτσι. Στην εξέταση των ΦΑ είχαμε το εξής πρόβλημα: Πολλοί θεώρησαν ότι  ο πίνακας έχει 50 αληθείς και 50 ψευδείς. Πιστεύω ότι η συγκεκριμένη διατύπωση τους δημιούργησε την παρανόηση μιας ιδιότυπης συμμετρίας, δηλαδή έχω δύο άκρα, ισοβαρή κλπ. Επίσης μπορεί κάποιοι να αναρωτήθηκαν οκ στις πρώτες έχει αυτά και στις τελευταίες αυτά, στις μεσαίες τι έχει?

Νομίζω ( απλά για την ιστορία ) ότι η διατύπωση θα έπρεπε να ήταν "Να τοποθετεί τα στοιχεία του πίνακα έτσι ώστε όλες οι Αληθείς να είναι πριν από τις Ψευδείς"

Έχεις απόλυτο δίκιο,η εκφώνηση είναι απαράδεκτη.Και εγώ όταν το είδα χωρίς να το διαβάσω καλά αυτό ακριβώς σκέφτηκα αρχικά.Επίσης έτσι όπως είναι διατυπωμένο,παρόλο που προφανώς δεν βγάζει νόημα να βάζεις τα 50 πρώτα αληθή και τα άλλα ψευδή,εγώ δεν θα μπορούσα να πω σε κάποιον ότι έχει κάνει λάθος.

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Θέμα Β
« Απάντηση #79 στις: 31 Μάι 2013, 08:07:53 μμ »
Δεν το λέω έτσι. Στην εξέταση των ΦΑ είχαμε το εξής πρόβλημα: Πολλοί θεώρησαν ότι  ο πίνακας έχει 50 αληθείς και 50 ψευδείς.

Αυτό το υπέθεσε και ένας γνωστός μου (μέτριος προς κακός) μαθητής και το υλοποίησε με 2 εντολές Για. Άραγε τι πιάνει;

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #80 στις: 31 Μάι 2013, 10:07:31 μμ »
Αυτό το υπέθεσε και ένας γνωστός μου (μέτριος προς κακός) μαθητής και το υλοποίησε με 2 εντολές Για. Άραγε τι πιάνει;

Καλή ερώτηση.Προφανώς δεν μπορείς να δεχτείς ότι είναι σωστό,παρόλο που δεν προκύπτει κάτι τέτοιο από την εκφώνηση.Οπότε δεν παίρνει τίποτα υποθέτω.

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Θέμα Β
« Απάντηση #81 στις: 31 Μάι 2013, 10:26:33 μμ »
Ο ορισμός της ταξινόμησης στη σελίδα 66 του σχολικού βιβλίου (αλλά και γενικότερα) αναφέρει ότι δεν συγκρίνουμε τις τιμές "ak" του πίνακα,
αλλά τις τιμές μια συνάρτησης "f(ak)",
η οποία για την περίπτωση των λογικών μεταβλητών θα μπορούσε να οριστεί ως f(Ψευδής)=0 και f(Αληθής)=1.

Δηλαδή φυσικά και μπορεί να οριστεί ταξινόμηση πινάκων λογικών μεταβλητών.

Στην υλοποίηση της φυσαλίδας στη σελίδα 68, εάν θέλαμε να βάλουμε τη συνάρτηση f(), ώστε να "πιάσουμε" και τους πίνακες λογικών μεταβλητών, θα αλλάζαμε μόνο την εντολή Αν:
Αν f(table[j-1]) > f(table[j]) τότε
...

Αν δεν ίσχυε ο παραπάνω ορισμός, τότε δεν θα μπορούσαμε να μιλάμε ούτε καν για ταξινομημένους τηλεφωνικούς καταλόγους, αφού δεν ορίζεται η σύγκριση μεταξύ εγγραφών (structs). Αλλά και σ' εκείνη την περίπτωση ορίζουμε έμμεσα μια συνάρτηση f(struct) η οποία μας επιστρέφει μόνο το ονοματεπώνυμο και όχι το τηλέφωνο, οπότε και χρησιμοποιούμε αυτό για τη σύγκριση των εγγραφών.

Έτσι είναι. Για να υπάρχει ταξινόμηση πρέπει να υπάρχει διάταξη. Διάταξη όχι στο σύνολο των στοιχείων που ταξινομούμε, αλλά στο σύνολο των εικόνων των στοιχείων που ταξινομούμε μέσω της ordering function.
Στην κλασσική αύξουσα ταξινόμηση ordering function έχεις την ταυτοτική f(x)=x, στην αύξουσα την f(x)=-x. Προφανώς το σύνολο των 2 τιμών {Αληθής, Ψευδής} δεν είναι διατεταγμένο, αλλά μπορείς να ορίσεις μια ordering function πχ f(Αληθής)=0 και f(Ψευδής)=1 και να συνεχίσεις. Αν ορίσεις f(x)=x στις λογικές τότε προφανώς δε γίνεται ταξινόμηση γιατί δεν υπάρχει διάταξη στις λογικές τιμές. Αυτά όμως παρακάμπτονται εύκολα.
Κι εγώ αν ήθελα formal διατύπωση του θέματος χωρίς περιορισμό από τη σχολική ύλη θα μίλαγα για Ο(ν) αντί για Ο(ν^2).


Αυτή ήταν ακριβώς και η άποψη ενός πανεπιστημιακού με τον οποίο συζήτησα το θέμα. Αν ένα σύνολο είναι διατεταγμένο μπορεί να γίνει ταξινόμηση όπως περιγράφεται παραπάνω.
Το θέμα είναι το εξής. Αν οριστεί συνάρτηση διάταξης για σύνολο τιμών όπως άνδρες - γυναίκες, αρνητικοί - θετικοί, ζυγοί - περιττοί κ.α τότε ο αλγόριθμος που δόθηκε παραπάνω

μ<-- 0
Για κ από 1 μέχρι 100
      Αν Π[κ] = Αληθής τότε (ή Π[κ] < 0 ή Π[κ]mod2 = 0 για παράδειγμα)
           μ <-- μ + 1
           Αντιμετάθεσε Π[κ], Π[μ]
      τέλος_αν
τελος_επανάληψης

με βάση τα παραπάνω καταφέρνει να ταξινομήσει διατεταγμένο σύνολο.

Είναι αλγόριθμος ταξινόμησης ή όχι; Και αν όχι γιατί; Εγώ πάντως δεν μπορώ να απαντήσω.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4926
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Θέμα Β
« Απάντηση #82 στις: 01 Ιούν 2013, 07:17:05 πμ »
Είναι αλγόριθμος ταξινόμησης ή όχι; Και αν όχι γιατί; Εγώ πάντως δεν μπορώ να απαντήσω.

Εφόσον ικανοποιεί τον ορισμό της ταξινόμησης, δηλαδή κάνει τον πίνακα να είναι τελικά διατεταγμένος με βάση κάποια συνάρτηση (ή τελεστή) σύγκρισης, ναι, είναι ταξινόμηση.

Βυθίζεται ο Τιτανικός! Να σωθούν πρώτα τα γυναικόπαιδα!
=> έχουμε έναν πίνακα (σειρά ανθρώπων) ο οποίος περιέχει λογικές μεταβλητές (γυναικόπαιδο ή όχι)
=> η επεξεργασία που θέλουμε να του κάνουμε είναι ταξινόμηση πίνακα λογικών μεταβλητών, το ίδιο με το θέμα Β´

Τώρα αν θα το κάνουμε με τελεστή σύγκρισης, Αν γυναικόπαιδο = Αληθής,
ή με συνάρτηση σύγκρισης, f(γυναικόπαιδο) = 1 ή 0,
αυτό είναι λεπτομέρεια, ο τελεστής είναι απλά μια υποπερίπτωση της συνάρτησης.


Οπότε συνοψίζοντας,
  • αυτό που ζητούσε το ερώτημα είναι ταξινόμηση,
  • δεν ορίζονται οι τελεστές > και < μεταξύ λογικών μεταβλητών στην ΑΕΠΠ,
  • μπορεί να οριστεί διάταξη μεταξύ των δύο λογικών τιμών στην ΑΕΠΠ, είτε με συγκριτικό τελεστή (= Ψευδής, <> Αληθής...) είτε με συνάρτηση,
  • άρα ορίζεται ταξινόμηση πίνακα λογικών μεταβλητών στα πλαίσια της ΑΕΠΠ,
  • και αν δεν υπήρχαν οι περιορισμοί της εκφώνησης, το ερώτημα θα μπορούσε να λυθεί (μπακαλίστικα) με ταξινόμηση φυσαλίδας και συγκριτικούς τελεστές.

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Θέμα Β
« Απάντηση #83 στις: 01 Ιούν 2013, 09:55:04 πμ »
Για να μην τσαντίσουμε τον Παναγιώτη, διατυπώνω κάπως διαφορετικά. Το σύνολο {Αληθής, Ψευδής} δεν είναι διατεταγμένο και άρα δεν μπορεί να γίνει σύγκριση μεταξύ του Αληθής και του ψευδής Με τελεστές < και >. Για αυτό μεταφερόμαστε σε άλλο συνολο που υπάρχει η διάταξη. Στέλνεις το Αληθής στο 0 και το Ψευδής στο 1 και συγκρίνεις όχι πια τα 0 Αληθής και Ψευδής αλλά τα 0 και 1 δηλαδή τις εικόνες τους μέσω της συνάρτησης f η οποία υλοποιεί απλώς αυτή την αντιστοιχία. Η f δηλαδή ορίζεται με πεδίο ορισμού το {Αληθής, Ψευδής} και απεικονίζει αυτό το σύνολο στο {0,1} όπου υπάρχει η διάταξη και άρα οι τελεστές < και > παίζουν κανονικά.

Τώρα στο θέμα του αν ένας συγκεκριμένος αλγόριθμος είναι αλγόριθμος ταξινόμησης, εγώ θα έλεγα ότι πρέπει να μπορεί να ταξινομεί (έστω και με χρήση κάποιας f) οποιεςσδήποτε τιμές και όχι μόνο βολικές. Δηλαδή αλγόριθμος που τελικά βάζει σε σειρά όχι οποιοδήποτε σύνολο αλλά μόνο βολικό σύνολο 2 τιμών δεν είναι γενικός αλγόριθμος ταξινόμησης. "Ταξινομεί" μόνο βολικά δεδομένα.
Δηλαδή έχω ένα αλγόριθμο ο οποίος είναι ένα σύνολο εντολών που περιέχει μια συνάρτηση f. Για να είναι αλγόριθμος ταξινόμησης θα πρέπει να τα βάζει σε σειρά ανεξάρτητα από το σύνολο των τιμών που δίνει η f. Τότε είναι γενικός αλγόριθμος ταξινόμησης. Διαφορετικά ταξινομεί ειδικές τιμές μόνο και δεν είναι αλγόριθμος ταξινόμησης με τη συνήθη έννοια αλλά με μια πιο "χαλαρή" έννοια.
 
Αυτό δεν το έχω σκεφτεί καλά ακόμα, απλά θέτω αυτό το θέμα προς συζήτηση για να σκεφτούν και οι άλλοι και τα ξαναλέμε.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4926
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Θέμα Β
« Απάντηση #84 στις: 01 Ιούν 2013, 11:10:17 πμ »
Γιώργο νομίζω έχεις στο νου σου τους "comparison sort" αλγορίθμους, που δουλεύουν με οποιοδήποτε σύνολο εισόδου, έχουν αποδεδειγμένο κάτω όριο Ω(n*logn) κλπ.
Οι περισσότεροι "non comparison sorts" έχουν συγκεκριμένες απαιτήσεις από το σύνολο εισόδου, δεν δεσμεύονται από το Ω(n*logn), και παρόλα αυτά στην βιβλιογραφία αναφέρονται ως sorting algorithms...

http://en.wikipedia.org/wiki/Sorting_algorithm#Comparison_of_algorithms
...εκεί έχει έναν πίνακα με τους "comparison sorts", και αμέσως μετά έναν με τους "non comparison sorts" στους οποίους αναφέρομαι.

edit:
Για να μην τσαντίσουμε τον Παναγιώτη, διατυπώνω κάπως διαφορετικά.
...εντάξει μωρέ στο επόμενο συνέδριο τον κερνάμε 2-3 τσίπουρα παραπάνω και θα μας συγχωρήσει!  :D

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #85 στις: 01 Ιούν 2013, 11:28:56 πμ »
Εφόσον ικανοποιεί τον ορισμό της ταξινόμησης, δηλαδή κάνει τον πίνακα να είναι τελικά διατεταγμένος με βάση κάποια συνάρτηση (ή τελεστή) σύγκρισης, ναι, είναι ταξινόμηση.

Βυθίζεται ο Τιτανικός! Να σωθούν πρώτα τα γυναικόπαιδα!
=> έχουμε έναν πίνακα (σειρά ανθρώπων) ο οποίος περιέχει λογικές μεταβλητές (γυναικόπαιδο ή όχι)
=> η επεξεργασία που θέλουμε να του κάνουμε είναι ταξινόμηση πίνακα λογικών μεταβλητών, το ίδιο με το θέμα Β´

Τώρα αν θα το κάνουμε με τελεστή σύγκρισης, Αν γυναικόπαιδο = Αληθής,
ή με συνάρτηση σύγκρισης, f(γυναικόπαιδο) = 1 ή 0,
αυτό είναι λεπτομέρεια, ο τελεστής είναι απλά μια υποπερίπτωση της συνάρτησης.


Οπότε συνοψίζοντας,
  • αυτό που ζητούσε το ερώτημα είναι ταξινόμηση,
  • δεν ορίζονται οι τελεστές > και < μεταξύ λογικών μεταβλητών στην ΑΕΠΠ,
  • μπορεί να οριστεί διάταξη μεταξύ των δύο λογικών τιμών στην ΑΕΠΠ, είτε με συγκριτικό τελεστή (= Ψευδής, <> Αληθής...) είτε με συνάρτηση,
  • άρα ορίζεται ταξινόμηση πίνακα λογικών μεταβλητών στα πλαίσια της ΑΕΠΠ,
  • και αν δεν υπήρχαν οι περιορισμοί της εκφώνησης, το ερώτημα θα μπορούσε να λυθεί (μπακαλίστικα) με ταξινόμηση φυσαλίδας και συγκριτικούς τελεστές.

Άμα αυτό που ζητούσε η ερώτηση εἰναι ταξινόμηση τότε δεν έχει νόημα.Αφού με τη λογική αυτή όποιον αλγόριθμο και να χρησιμοποιούσες θα έπρεπε να θεωρηθεί αλγόριθμος ταξινόμησης καθώς θα ταξινομούσε τα στοιχεία με βάση κάποια total order.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4926
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Θέμα Β
« Απάντηση #86 στις: 01 Ιούν 2013, 11:49:06 πμ »
Άμα αυτό που ζητούσε η ερώτηση εἰναι ταξινόμηση τότε δεν έχει νόημα.Αφού με τη λογική αυτή όποιον αλγόριθμο και να χρησιμοποιούσες θα έπρεπε να θεωρηθεί αλγόριθμος ταξινόμησης καθώς θα ταξινομούσε τα στοιχεία με βάση κάποια total order.

Yup, πιστεύω πώς οι περισσότεροι συμφωνούμε ότι αν και το θέμα ήταν ωραίο, η εκφώνησή του ήταν λίγο αμφιλεγόμενη.
Π.χ. νομίζω ότι οι πιο αποδεκτές υλοποιήσεις που προτάθηκαν, εφαρμόζουν την εκφυλισμένη περίπτωση του counting sort για k=2 (όπου δεν χρειάζεται πίνακας k μετρητών, αλλά μόνο ένας ή δύο μετρητές), και παίρνουν όλα τα μόρια...
...ενώ πιο αμφιλεγόμενο στη βαθμολόγηση θα είναι αν κάποιος έχει υλοποιήσει σωστά το bubble sort, με τους τελεστές = ή <>.

Από την άλλη, αν η εκφώνηση μπορούσε να πει "απαγορεύετε να χρησιμοποιήσετε εμφωλευμένη επανάληψη", δεν θα υπήρχε τίποτα αμφιλεγόμενο.

cets89

  • Βαθμολογικά 2016
  • *
  • Μηνύματα: 42
  • Μηδέν άγαν!
Απ: Θέμα Β
« Απάντηση #87 στις: 01 Ιούν 2013, 04:24:16 μμ »
Παραθέτω μια "κομψή" λύση που δώσαμε για το Β2 ως εξεταστές Φ.Α.
j <- 0
Για i από 1 μέχρι 100
     Αν Π[ i ] = ΑΛΗΘΗΣ τότε
          j <- j+1
          Αντιμετάθεσε Π[ i ], Π[ j ]
     Τέλος_αν
Τέλος_επανάληψης
Κωνσταντίνος Τσουκάρας
Διπλωματούχος Μηχανικός Η/Υ και Πληροφορικής Πανεπιστημίου Πατρών

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Θέμα Β
« Απάντηση #88 στις: 01 Ιούν 2013, 04:37:57 μμ »
Από την άλλη, αν η εκφώνηση μπορούσε να πει "απαγορεύετε να χρησιμοποιήσετε εμφωλευμένη επανάληψη", δεν θα υπήρχε τίποτα αμφιλεγόμενο.
Σκέψου όμως ότι θα μπορούσε να υλοποιήσει φυσσαλίδα με μονό βρόχο   :D

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4926
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Θέμα Β
« Απάντηση #89 στις: 01 Ιούν 2013, 06:27:27 μμ »
Χεχε, το είχα σκεφτεί ένα λεπτό αφότου είχα γράψει το μήνυμα, αλλά είπα να μην το χοντρύνω! Σύμφωνοι, η O(n (+k για το πλήθος του πεδίου τιμών)) πολυπλοκότητα θα ήταν η καλύτερη εκφώνηση!
...αλλά από την άλλη, αν κάποιος κατάφερνε ταξινόμηση φυσαλίδας με μονό loop, εγώ θα του έβαζα 100 χωρίς να κοιτάξω καν τις άλλες απαντήσεις του!  >:D

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #90 στις: 01 Ιούν 2013, 06:53:08 μμ »
Ερώτηση προς όλους όσους ασχολούνται με το θέμα:

Αν ο μαθητής δώσει την "ταξινόμηση"  ;) της φυσαλίδας αλλά σωστά, δηλαδή με

   Αν Π[j-1]=Ψευδής και Π[j]=Αληθής Τότε

πόσες μονάδες παίρνει , κατά τη γνώμη σας? Πρέπει να πάρει κάτι από τις 10 μονάδες?

Νομίζω είναι ενδιαφέρον προβληματισμός

What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3176
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Β
« Απάντηση #91 στις: 01 Ιούν 2013, 08:45:26 μμ »
Μετα απο διόρθωση 25 γραπτών σε 8:30 ώρες:
1. Ειμαι σα να έχω πιει τσίπουρα
2. Δε θυμωνω και ειδικά με φίλους.

Απλα σας είπα οτι αν δεν υπήρχε το μπλοκ που μπήκε στο β2 θα έπεφτε πολυ φυσαλιδα...
Και διαφωνω με το θεματακι αυτο (την επιλογη του)

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #92 στις: 02 Ιούν 2013, 12:41:53 πμ »
Χεχε, το είχα σκεφτεί ένα λεπτό αφότου είχα γράψει το μήνυμα, αλλά είπα να μην το χοντρύνω! Σύμφωνοι, η O(n (+k για το πλήθος του πεδίου τιμών)) πολυπλοκότητα θα ήταν η καλύτερη εκφώνηση!
...αλλά από την άλλη, αν κάποιος κατάφερνε ταξινόμηση φυσαλίδας με μονό loop, εγώ θα του έβαζα 100 χωρίς να κοιτάξω καν τις άλλες απαντήσεις του!  >:D


Ή θα αναρωτιόσουν γιατί να αναλώσει χρόνο σε κάτι που δεν έχει καμμια ουσία.Υπάρχουν αρκετοί λόγοι για να μην κάνεις την bubblesort με ένα loop.Αλλά από την άλλη θα μου πεις,γιατί να περιορίζεις την φαντασία του ανθρώπου.

Ερώτηση προς όλους όσους ασχολούνται με το θέμα:

Αν ο μαθητής δώσει την "ταξινόμηση"  ;) της φυσαλίδας αλλά σωστά, δηλαδή με

   Αν Π[j-1]=Ψευδής και Π[j]=Αληθής Τότε

πόσες μονάδες παίρνει , κατά τη γνώμη σας? Πρέπει να πάρει κάτι από τις 10 μονάδες?

Νομίζω είναι ενδιαφέρον προβληματισμός


Το θέμα είναι πώς μπορεί ό,τι και να δώσει ο μαθητής να μην είναι "ταξινόμηση";Επίσης δεν αντιλαμβάνομαι γιατί το θέσανε ως
Παράθεση
...χωρίς  τη  χρήση«αλγορίθμων  ταξινόμησης»...
Έχουν διδαχθεί πολλούς αλγορίθμους ταξινόμησης;Γενικά,η εκφώνηση του θέματος είναι τουλάχιστον άστοχη.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #93 στις: 02 Ιούν 2013, 10:49:06 πμ »
Μαθητής έδωσε την παρακάτω απάντηση στο Β2

Για κ από 99 μέχρι 1
    Για λ από 1 μέχρι κ
        Αν Π[λ]=Ψευδής και Π[λ+1]=Αληθής Τότε
            Αντιμετάθεσε Π[λ], Π[λ+1]
        Τέλος_αν
    Τέλος_Επανάληψης
Τέλος_Επανάληψης

What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #94 στις: 02 Ιούν 2013, 11:11:16 πμ »
Μαθητής έδωσε την παρακάτω απάντηση στο Β2

Για κ από 99 μέχρι 1
    Για λ από 1 μέχρι κ
        Αν Π[λ]=Ψευδής και Π[λ+1]=Αληθής Τότε
            Αντιμετάθεσε Π[λ], Π[λ+1]
        Τέλος_αν
    Τέλος_Επανάληψης
Τέλος_Επανάληψης

Έχω αρχίσει να λυπάμαι αυτούς που βαθμολογούν...

nassos

  • Νέος
  • *
  • Μηνύματα: 1
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα Β
« Απάντηση #95 στις: 02 Ιούν 2013, 04:52:42 μμ »
Μαθητής το έγραψε όπως είπαν και άλλοι συνάδελφοι...

μ <-- 1
Για κ από 1 μέχρι 100
  Αν Π[κ] = Αληθής τότε
    Αντιμετάθεσε Π[κ], Π[μ]
    μ <-- μ + 1
  Τέλος_αν
Τέλος_επανάληψης


και αντί να του βάλουμε 10 που βρήκε τρόπο που δεν τον διδάχτηκε, (γιατί διδάχτηκε μόνο φυσσαλίδα και έστω καποιες βελτιώσεις της), εμείς θέλουμε να του μηδενίσουμε την απάντηση. Καθόλου σωστό και πρέπει να γίνει κάτι γρήγορα γιατί τα γραπτά διορθώθηκαν κατά το 1/4.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #96 στις: 02 Ιούν 2013, 06:28:01 μμ »
Για ποιο λόγο? Αφού το κάνει σε ένα πέρασμα. Ομολογώ ότι μου πήρε λίγη ώρα για να μπορέσω να αποδείξω την ορθότητα αυτού του αλγορίθμου. Νομίζω είναι ο πιο έξυπνος που έχει προταθεί
Μου φαίνεται περίεργο πάντως που λες κάτι τέτοιο, γιατί εμείς το έχουμε στις ενδεικτικές λύσεις και δεν υπήρξε ούτε ένας που να διαφωνήσει

Μαθητής το έγραψε όπως είπαν και άλλοι συνάδελφοι...

μ <-- 1
Για κ από 1 μέχρι 100
  Αν Π[κ] = Αληθής τότε
    Αντιμετάθεσε Π[κ], Π[μ]
    μ <-- μ + 1
  Τέλος_αν
Τέλος_επανάληψης


και αντί να του βάλουμε 10 που βρήκε τρόπο που δεν τον διδάχτηκε, (γιατί διδάχτηκε μόνο φυσσαλίδα και έστω καποιες βελτιώσεις της), εμείς θέλουμε να του μηδενίσουμε την απάντηση. Καθόλου σωστό και πρέπει να γίνει κάτι γρήγορα γιατί τα γραπτά διορθώθηκαν κατά το 1/4.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3176
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Β
« Απάντηση #97 στις: 02 Ιούν 2013, 07:18:23 μμ »
εμείς αποφασίσαμε: πως κάθε αλγόριθμος, που δεν θα διέτασσε τα στοιχεία ενός οποιουδήποτε πίνακα (αριθμητικού ή άλλου δηλαδή) είναι αποδεκτός

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #98 στις: 02 Ιούν 2013, 07:46:42 μμ »
Παναγιώτη εννοείς να μην χρησιμοποιεί τους τελεστές < και > ;

εμείς αποφασίσαμε: πως κάθε αλγόριθμος, που δεν θα διέτασσε τα στοιχεία ενός οποιουδήποτε πίνακα (αριθμητικού ή άλλου δηλαδή) είναι αποδεκτός
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Θέμα Β
« Απάντηση #99 στις: 02 Ιούν 2013, 07:55:43 μμ »
Καταρχήν θεωρώ την εκφώνηση του θέματος ατυχέστατη. Τα θέματα πρέπει να είναι μονοσήμαντα. Μία λύση για να θεωρείται σωστή πρέπει να είναι αποδεκτή από όλους και όχι να μαζεύονται 5-10 συνάδερφοι υπό την πίεση της διόρθωσης και να αποφασίζουν τι είναι σωστό και τι όχι. Και αλήθεια με ποια κριτήρια.

εμείς αποφασίσαμε: πως κάθε αλγόριθμος, που δεν θα διέτασσε τα στοιχεία ενός οποιουδήποτε πίνακα (αριθμητικού ή άλλου δηλαδή) είναι αποδεκτός

Παναγιώτη ο πίνακας [1 , -5, 3, -7 , 2, -4] που είναι αριθμητικός πίνακας διατάσσεται με βάση τον παραπάνω αλγόριθμο αν ορίσω συνάρτηση f(x<0)=0 και f(x>=0) =1. Άρα αν μεταφράζω σωστά, αποφασίσατε ότι οποιοσδήποτε αλγόριθμος που δεν διατάσσει οποιαδήποτε στοιχεία με βάση την ταυτοτική συνάρτηση είναι αποδεκτός. Από την άλλη όμως όσο και αν έψαξα στη βιβλιογραφία δεν βρήκα πουθενά την παραδοχή ότι ένας αλγόριθμος χαρακτηρίζεται ως ταξινόμησης μόνο αν ικανοποιεί και την ταυτοτική συνάρτηση.

Θεωρώ ότι οποιαδήποτε λύση πρέπει να θεωρηθεί σωστή εφόσον πετυχαίνει το ζητούμενο. Διαφορετικά παίρνουμε ευθύνη ότι δεν είμαστε δίκαιοι απέναντι σε όλους τους μαθητές.
« Τελευταία τροποποίηση: 02 Ιούν 2013, 08:10:47 μμ από aperdos »

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Θέμα Β
« Απάντηση #100 στις: 02 Ιούν 2013, 08:16:06 μμ »
Μαθητής το έγραψε όπως είπαν και άλλοι συνάδελφοι...

μ <-- 1
Για κ από 1 μέχρι 100
  Αν Π[κ] = Αληθής τότε
    Αντιμετάθεσε Π[κ], Π[μ]
    μ <-- μ + 1
  Τέλος_αν
Τέλος_επανάληψης


και αντί να του βάλουμε 10 που βρήκε τρόπο που δεν τον διδάχτηκε, (γιατί διδάχτηκε μόνο φυσσαλίδα και έστω καποιες βελτιώσεις της), εμείς θέλουμε να του μηδενίσουμε την απάντηση. Καθόλου σωστό και πρέπει να γίνει κάτι γρήγορα γιατί τα γραπτά διορθώθηκαν κατά το 1/4.

Γιατί να την μηδενίσετε την απάντηση;

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3176
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα Β
« Απάντηση #101 στις: 02 Ιούν 2013, 08:42:33 μμ »
Χωρίς παρεξήγηση, κείμενα που αρχίζουν με το κείμενο "αν ορίσουμε μια συνάρτηση διάταξης f. ..." δεν τα διαβάζω μέχρι το τέλος.
Πρόσφατα έμαθα οτι τα πλεονεκτήματα των γλωσσών υψηλού επιπέδου είναι 6 (+κόστος +υποδομές) και έκανε λάθος η επιτροπή που έδωσε 4 μονάδες στο θέμα.

Από την πρώτη μέρα που ασχολήθηκα με την ΑΕΠΠ βλέπω το μάθημα πρακτικά.
Όσοι διορθώνουν γραπτά βλέπουν την εξουθένωση των παιδιών προς το θέμα Δ, όπου ακόμη και πολύ καλά γραπτά έχουν βιαστικά και επιπόλαια συντακτικά/λογικά λάθη.

Ευρυπίδη, λύση με <, > στα 25 γραπτά που είδα συνάντησα μόνο 1, οι μαθητές πορεύτηκαν μόνο με ισότητες. Αν ο αλγόριθμος που έδωσαν ταξινομεί πίνακα αριθμών, πίνακα με περισσότερα από 2 διακριτά/διαφορετικά στοιχεία δεν θεωρήθηκε σωστή από εμάς. Το οτι ομαδοποιεί τα στοιχεία πίνακα με ΜΟΝΟ ΔΥΟ διαφορετικές τιμές μέσα του δε σημαίνει οτι πάντα μπορεί να ταξινομήσει οποιονδήποτε πίνακα.

Θεωρήσαμε ότι αυτό είναι το ύφος της επιτροπής σχετικά με τους "αλγορίθμους ταξινόμησης" με μια παρατήρηση που απέκλεισε τη φυσαλίδα και τα <,> αλλά γέννησε άλλα προβλήματα. ένα ερώτημα που δεν έπρεπε να μπει.
Αν δεν κάνω λάθος με αυτό το σκεπτικό, οι περισσότερες κωδικοποιήσεις που είδα παραπάνω θεωρούνται σωστές

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #102 στις: 02 Ιούν 2013, 11:23:05 μμ »
Κάτι άλλο που είδαμε. Δίνει κάποιος τη λύση

Για ι από 1 μέχρι Ν
  Α[ι] <- Αληθής
ΤΕ

Για ι από Ν+1 μέχρι 100
  Α[ι] <- Ψευδής
ΤΕ

Δηλαδή δεν μετράει τα Αληθής / Ψευδής αλλά θεωρεί ότι είναι Ν.
Εδώ θα πρέπει να πάρει τουλάχιστον τις μισές μονάδες αφού έχει κάνει τη μισή δουλειά  ;)
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1015
Απ: Θέμα Β
« Απάντηση #103 στις: 03 Ιούν 2013, 12:18:59 πμ »
"εμείς θέλουμε να του μηδενίσουμε την απάντηση" ...

Παιδιά, είναι μια μαγική λύση με φαντασία !!!

Σε ένα τέτοιο "φαινόμενο", του δίνεις 10++ !!!

Τρέξτε το  !!!

Α

pgrontas

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 1316
  • There are always possibilities...
Απ: Θέμα Β
« Απάντηση #104 στις: 03 Ιούν 2013, 06:25:19 μμ »
Κάτι άλλο που είδαμε. Δίνει κάποιος τη λύση

Για ι από 1 μέχρι Ν
  Α[ι] <- Αληθής
ΤΕ

Για ι από Ν+1 μέχρι 100
  Α[ι] <- Ψευδής
ΤΕ

Δηλαδή δεν μετράει τα Αληθής / Ψευδής αλλά θεωρεί ότι είναι Ν.
Εδώ θα πρέπει να πάρει τουλάχιστον τις μισές μονάδες αφού έχει κάνει τη μισή δουλειά  ;)

Και εγώ είδα μια τέτοια σήμερα με Ν1, Ν2 δεδομένα για πλήθος Α,Ψ!

Επανερχόμενος στο προηγούμενο θέμα, πάντως νομίζω ότι οποιοσδήποτε αλγόριθμος βάζει τα αληθής πριν τα ψευδής πρέπει να πάρει όλες τις μονάδες.
A man provided with paper, pencil, and rubber, and subject to strict discipline is in effect a universal machine - Alan Turing

cets89

  • Βαθμολογικά 2016
  • *
  • Μηνύματα: 42
  • Μηδέν άγαν!
Απ: Θέμα Β
« Απάντηση #105 στις: 04 Ιούν 2013, 11:19:15 μμ »
Καλησπέρα σας
Είμαι συντονιστής βαθμολόγησης του μαθήματος της ΑΕΠΠ και δεδομένης της αδρανοποίησης του επίσημου forum των συντονιστών που λειτούργησε παλιότερα (αν θυμάμαι καλά στις εξετάσεις του 2009), απευθύνομαι στους συντονιστές των διαφόρων ΒΚ αναφορικά με τον τρόπο βαθμολόγησης που έχουν επιλέξει για την επίλυση του Β2 με χρήση του αλγορίθμου ταξινόμησης φυσαλίδας.
Συγκεκριμένα η λύση που έχει ήδη παρουσιαστεί:
Για i από 2 μέχρι 100
     Για j από 100 μέχρι 2 με_βήμα -1
          Αν Π[j-1] = ΨΕΥΔΗΣ και Π[j] = ΑΛΗΘΗΣ τότε
               Αντιμετάθεσε Π[j-1], Π[j]
          Τέλος_αν
     Τέλος_επανάληψης
Τέλος_επανάληψης
πώς βαθμολογείται;
Επίσης αν έχει χρησιμοποιηθεί μια λανθασμένη συνθήκη της μορφής:
Αν Π[j-1] > Π[j] τότε
η λύση αυτή απορρίπτεται (μηδενίζεται) ή βαθμολογείται με κάποιες μονάδες;
Περιμένω τις απόψεις σας.
Κωνσταντίνος Τσουκάρας
Διπλωματούχος Μηχανικός Η/Υ και Πληροφορικής Πανεπιστημίου Πατρών

vtsakan

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 273
  • printf("Smile");
Απ: Θέμα Β
« Απάντηση #106 στις: 05 Ιούν 2013, 09:31:44 πμ »
Καλησπέρα σας
Είμαι συντονιστής βαθμολόγησης του μαθήματος της ΑΕΠΠ και δεδομένης της αδρανοποίησης του επίσημου forum των συντονιστών που λειτούργησε παλιότερα (αν θυμάμαι καλά στις εξετάσεις του 2009), απευθύνομαι στους συντονιστές των διαφόρων ΒΚ αναφορικά με τον τρόπο βαθμολόγησης που έχουν επιλέξει για την επίλυση του Β2 με χρήση του αλγορίθμου ταξινόμησης φυσαλίδας.
Συγκεκριμένα η λύση που έχει ήδη παρουσιαστεί:
Για i από 2 μέχρι 100
     Για j από 100 μέχρι 2 με_βήμα -1
          Αν Π[j-1] = ΨΕΥΔΗΣ και Π[j] = ΑΛΗΘΗΣ τότε
               Αντιμετάθεσε Π[j-1], Π[j]
          Τέλος_αν
     Τέλος_επανάληψης
Τέλος_επανάληψης
πώς βαθμολογείται;
Επίσης αν έχει χρησιμοποιηθεί μια λανθασμένη συνθήκη της μορφής:
Αν Π[j-1] > Π[j] τότε
η λύση αυτή απορρίπτεται (μηδενίζεται) ή βαθμολογείται με κάποιες μονάδες;
Περιμένω τις απόψεις σας.

Ανεξάρτητα απο την χρήση του = ή του >, η λύση αυτή δεν λαμβάνει κανένα μόριο, μιας και ο μαθητής προφανώς χρησιμοποιεί την φυσαλίδα. Η εκφώνηση ορίζει ρητά την απαγόρευση χρήσης αλγορίθμων ταξινόμησης.

Δεν συμφωνώ βέβαια με την παραπάνω λογική, αλλά για να έχουν οι εξετάσεις έναν ενιαίο χαρακτήρα, πιστεύω πως το θέμα θα πρέπει να μηδενιστεί.
Βασίλης Τσακανίκας
Ηλεκτρολόγος Μηχανικός και Μηχανικός Υπολογιστών Ε.Μ.Π.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #107 στις: 05 Ιούν 2013, 01:21:40 μμ »
Το πόσα λαμβάνει μια λάθος απάντηση σε ένα ερώτημα και πως γίνεται η μοριοδότηση σε αυτό είναι αποτέλεσμα του τι έχουν συμφωνήσει όλοι οι καθηγητές και οι  συντονιστές.
Εμείς δίνουμε μόρια για τη λύση αυτή και δεν την κόβουμε ως τελείως λάθος. Μην ξεχνάς ότι δίνει 10 μονάδες. Πως θα γίνει η διαβάθμιση των 10? Δεν είναι τόσο απλό να πούμε ή 0 ή 10.

Παραθέτω το σκεπτικό μου  αν και αυτά που θα πω έχουν ειπωθεί και παραπάνω, από πολλούς συναδέλφους και δεν αποτελούν δικές μου ιδέες :

Πως ορίζονται "οι αλγόριθμοι ταξινόμησης". Φαντάζομαι πως όλοι θα συμφωνήσουμε ότι πρέπει να ακολουθήσουμε αυτά που λέει το βιβλίο. Το βιβλίο λοιπόν ορίζει ταξινόμηση μόνο όταν ορίζουμε συνάρτηση διάταξης.
Παρακάτω στο κεφάλαιο 8 λέει ότι όταν έχουμε λογικές τιμές δεν ορίζεται διάταξη παρά μόνο οι τελεστές = και <>.

Αν ένας μαθητής τα σκεφτεί όλα αυτά και πει: Αφού δεν έχουμε διάταξη δεν είναι αλγόριθμος ταξινόμησης, άρα μπορώ να το χρησιμοποιήσω, εμείς τι θα του πούμε ? ότι αυτοί που το έβαλαν είχαν κάτι άλλο στο μυαλό τους? (ελπίζω να μην περίμεναν από τον μαθητή να ορίσει ο ίδιος συνάρτηση διάταξης των λογικών τιμών)
Για μένα ο μαθητής που θα το σκεφτεί αυτό πρέπει να πάρει μόρια και μάλιστα αρκετά διότι δείχνει ότι έχει υψηλού επιπέδου κατανόηση. Σίγουρα καλύτερη από αυτόν που απλά μέτρησε πόσα είναι τα Αληθείς όπως έκανε η  ΚΕΕ.


και κάτι άλλο

όπως έγραψα και σε προηγούμενο μήνυμα πέσαμε πάνω στην παρακάτω λύση

Για κ από 99 μέχρι 1
    Για λ από 1 μέχρι κ
        Αν Π[λ]=Ψευδής και Π[λ+1]=Αληθής Τότε
            Αντιμετάθεσε Π[λ], Π[λ+1]
        Τέλος_αν
    Τέλος_Επανάληψης
Τέλος_Επανάληψης

Αν ο/η μαθητής/τρια που σκέφτηκε αυτό έκανε το συλλογισμό "η φυσαλίδα πάει προς τα πάνω, οπότε εγώ θα τα μετακινώ προς τα κάτω άρα δεν είναι φυσαλίδα" , ερωτώ:
Τι θα πρέπει να πάρει το παιδάκι που το σκέφτηκε αυτό? μηδέν?

Όλα τα παραπάνω τα  συζητήσαμε στο βαθμολογικό όπου είμαι συντονιστής

ΥΓ. Αν ακόμα θεωρεί κάποιος ότι πρέπει να βάλουμε 0 για αυτή τη λύση τότε θα πρέπει να βάλει 0 και στην λύση που έδωσε η ΚΕΕ διότι η λύση της ΚΕΕ αποτελεί ειδική περίπτωση του αλγορίθμου ταξινόμησης  Counting Sort  όπως και η παραπάνω αποτελεί ειδική περίπτωση τoυ αλγορίθμου ευθείας ανταλλαγής. Άρα ανήκει στους "αλγόριθμους ταξινόμησης" και πρέπει να βαθμολογηθεί με 0.

« Τελευταία τροποποίηση: 05 Ιούν 2013, 03:12:53 μμ από evry »
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #108 στις: 06 Ιούν 2013, 09:40:51 πμ »
Συμφωνώ με το σκεπτικό σου Ευριπίδη.

Αυτή η συζήτηση όμως με κάνει να σκέπτομαι ότι εν τέλει το να υπάρχει κοινή γραμμή στη βαθμολόγηση σε πανελλαδικό επίπεδο είναι το πιο σημαντικό. Πιο σημαντικό ακόμα κι από το αν είναι δίκαιη αυτή η γραμμή - αρκεί να είναι κοινή (αν είναι και δίκαιη βέβαια, τόσο το καλύτερο).
Αυτό που γίνεται τώρα, και κάθε βαθμολογικό αφήνεται να αποφασίσει τη δική του γραμμή μου φαίνεται αδιανόητο.
Πιστεύω ότι θα έπρεπε η ΚΕΕ, αφού παρακολουθήσει την πειραματική βαθμολόγηση, να δώσει ρητές οδηγίες για τη βαθμολόγηση/διαβάθμηση του κάθε ζητήματος σε πανελλαδικό επίπεδο.
Φιλικά,
Γιώργος Θαλασσινός

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1015
Απ: Θέμα Β
« Απάντηση #109 στις: 06 Ιούν 2013, 06:09:13 μμ »
Άραγε, πόσο δύσκολο είναι , σε έναν κλειστό πίνακα να συμμετέχουν πιστοποιημένοι συντονιστές και βαθμολογητές ;;

Α

cets89

  • Βαθμολογικά 2016
  • *
  • Μηνύματα: 42
  • Μηδέν άγαν!
Απ: Θέμα Β
« Απάντηση #110 στις: 06 Ιούν 2013, 11:19:08 μμ »
Τελικά η φαντασία των υποψηφίων δεν έχει όρια. Ιδού μια άλλη λύση για το Β2.
k <- 1
Για i από 1 μέχρι 100
     Αν Π[ i ] = Αληθής τότε
          Π[ k ] <- Π[ i ]
          Αν i <> k τότε
               Π[ i ] <- Ψευδής
          Τέλος_αν
          k <- k+1
     Τέλος_αν
Τέλος_επανάληψης
Κωνσταντίνος Τσουκάρας
Διπλωματούχος Μηχανικός Η/Υ και Πληροφορικής Πανεπιστημίου Πατρών

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #111 στις: 09 Ιούν 2013, 09:03:31 πμ »
Εκτός από φαντασία μερικές λύσεις έχουν και θράσος.  :police:

Κώδικας: [Επιλογή]
κ <-- 1
λ <-- 100
Για ι από 1 μέχρι 100
   Αν Π[ι] = ΟΧΙ(Ψευδής) Τότε
         Α[κ] <-- 7>5
         κ <-- κ + 1
   Αλλιώς
         Α[λ] <-- 2<1
         λ <-- λ - 1
   Τέλος_Αν
ΤΕ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

michaeljohn

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 129
  • "Είναι παιδιά πολλών ανθρώπων τα λόγια μας"
Απ: Θέμα Β
« Απάντηση #112 στις: 09 Ιούν 2013, 03:20:50 μμ »
Θράσους, . .  συνέχεια

L<-- 1
R<--100
Όσο  L< R επανάλαβε
   Αν ΟΧΙ Π[L] και Π[R]  τότε
      αντιμετάθεσε Π[L], Π[R]
      L++
      R--
   Αλλιώς
      Αν  Π[L] τότε   L++
      Αν  ΟΧΙ Π[R] τότε  R--
   Τέλος_αν
 Τέλος_επανάληψης


Και ο παραπάνω μαθητής έγραψε 89/100 ( από που άραγε να έχασε 11 μονάδες?.....)

CyberMove

  • Νέος
  • *
  • Μηνύματα: 8
  • 404 Error!
Απ: Θέμα Β
« Απάντηση #113 στις: 17 Ιούν 2013, 02:52:09 μμ »
Δείτε λίγο και αυτό :

μ<-- 0
Για κ από 1 μέχρι 100
      Αν Π[κ] = Αληθής τότε
           μ <-- μ + 1
           Αντιμετάθεσε Π[κ], Π[μ]
      τέλος_αν
τελος_επανάληψης

Σε καμία περίπτωση βέβαια η λύση δεν είναι λάθος!

Σε περίπτωση όμως που ο πίνακας έστω ότι είναι έτσι?

|Α|Α|Α|Ψ|Ψ|Α|

Τότε αν το κ είναι 1,δηλαδή Π[1]=ΑΛΗΘΗΣ όπως είναι στον υποθετικό πίνακα μου, θα κάνει αντιμετάθεση το ίδιο στοιχείο?
Γιατί η μεταβλητή μ αρχικά είναι 0 και μετά αυξάνεται κατά 1 οπότε θα είναι μ=1 και κ=1 και θα αναφέρονται στο ίδιο στοιχείο.

Και πάλι,πολύ ωραία λύση!
« Τελευταία τροποποίηση: 17 Ιούν 2013, 03:12:05 μμ από CyberMove »
If Grandma_Had_Rolls = TRUE Then
        MsgBox.Style ("Grandma = TROLLEY")
End_If

michaeljohn

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 129
  • "Είναι παιδιά πολλών ανθρώπων τα λόγια μας"
Απ: Θέμα Β
« Απάντηση #114 στις: 28 Ιούν 2013, 10:53:47 μμ »
Σε καμία περίπτωση βέβαια η λύση δεν είναι λάθος!

Σε περίπτωση όμως που ο πίνακας έστω ότι είναι έτσι?

|Α|Α|Α|Ψ|Ψ|Α|

Τότε αν το κ είναι 1,δηλαδή Π[1]=ΑΛΗΘΗΣ όπως είναι στον υποθετικό πίνακα μου, θα κάνει αντιμετάθεση το ίδιο στοιχείο?
Γιατί η μεταβλητή μ αρχικά είναι 0 και μετά αυξάνεται κατά 1 οπότε θα είναι μ=1 και κ=1 και θα αναφέρονται στο ίδιο στοιχείο.

Και πάλι,πολύ ωραία λύση!

Κατ' αρχήν μπράβο σου CyberMove
Πράγματι, ο αλγόριθμος κάνει περιττές αντιμεταθέσεις (αντιμεταθέτει ένα στοιχείο με το εαυτό του!!) στα ενδεχόμενα συνεχόμενα Α στην αρχή του πίνακα(Όσο θα ισχύει μ=κ) και μέχρι τη θέση πριν του πρώτου Ψ. Στην ακραία δε περίπτωση που ο πίνακας περιέχει μόνο Α τότε κάνει 100 περιττές αντιμεταθέσεις.
Για να αποφευχθούν οι περιττές αντιμεταθέσεις μπορούμε να εισάγουμε μία εντολή Αν ως εξής
μ<-- 0
Για κ από 1 μέχρι 100
      Αν Π[κ] = Αληθής τότε
           μ <-- μ + 1
           Αν μ < > κ   τότε    Αντιμετάθεσε Π[κ], Π[μ]
      Τέλος_αν
Τέλος_επανάληψης
επιβαρύνοντας τον κώδικα και πιθανότατα την  ταχύτητα εκτέλεσης του αλγορίθμου.
Αν θεωρήσουμε την πιθανότητα ένα στοιχείο του πίνακα να είναι Α ίση με την πιθανότητα να είναι Β τότε είναι πολύ πιο πιθανότερο να βρεθεί ένα Ψ στις πρώτες θέσεις (π.χ. 5η) και οι περιττές αντιμεταθέσεις να είναι λίγες (μόνο τέσσερεις από την 1η μέχρι την 4η θέση)  από το να υπάρχει ένα ψ σε μεγάλες θέσεις. (η απόδειξη παραλείπετε για ευνόητους λόγους)
 Επομένως είναι "καλύτερο" η εντολή Αν να μην εισαχθεί γιατί θα εκτελεσθεί σίγουρα μ φορές ενώ οι περιττές αντιμεταθέσεις λ φορές με 0 <= λ <= μ και ισχυρή πιθανότητα το λ να είναι μικρός αριθμός. 
Επιπλέον η εντολή Αντιμετάθεσε Π[κ], Π[μ]
η οποία είναι ισοδύναμη με τρεις εντολές εκχώρησης :
Temp <--  Π[κ]
Π[κ] <-- Π[μ]
Π[μ] <-- Temp
μπορεί να αντικατασταθεί με τις εξής δύο εντολές :
Π[κ] <-- Π[μ]
Π[μ] <-- Αληθής
και να βελτιωθεί η ταχύτητα του αλγορίθμου.
Αλλά, ας δούμε ξανά τη λύση χωρίς να σκεφτούμε συγκεκριμένα στιγμιότυπα (συνδυασμοί Α ,Ψ)  του πίνακα Π.
μ<-- 0
Για κ από 1 μέχρι 100
      Αν Π[κ] = Αληθής τότε
           μ <-- μ + 1
           Αντιμετάθεσε Π[κ], Π[μ]
      Τέλος_αν
Τέλος_επανάληψης
Τι κάνει ; Απλά :
Βρίσκει το πλήθος(μ) των Αληθής και
τα (αντι) μεταθέτει στις πρώτες μ θέσεις του Π.
οπότε τα Ψευδής είναι στις τελευταίες θέσεις…


Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέμα Β
« Απάντηση #115 στις: 16 Μάι 2017, 12:28:09 μμ »
Τελικά, ΚΑΠΟΙΟΙ μαθητές της ΟΠ Σπουδών Οικονομίας και Πληροφορικής ΕΙΝΑΙ γεννημένοι Πληροφορικοί!!

ΛΥΣΗ φετινού μαθητή:
Κώδικας: [Επιλογή]
  εψ <- 1
  εα <- Ν
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    βρ <- ΨΕΥΔΗΣ
    ΟΣΟ εα >= 1 ΚΑΙ βρ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΑΝ Π[εα] = ΑΛΗΘΗΣ ΤΟΤΕ
        βρ <- ΑΛΗΘΗΣ
      ΑΛΛΙΩΣ
        εα <- εα - 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    βρ <- ΨΕΥΔΗΣ
    ΟΣΟ εψ <= Ν ΚΑΙ βρ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΑΝ Π[εψ] = ΨΕΥΔΗΣ ΤΟΤΕ
        βρ <- ΑΛΗΘΗΣ
      ΑΛΛΙΩΣ
        εψ <- εψ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝ εψ < εα ΤΟΤΕ
      Χ <- Π[εα]
      Π[εα] <- Π[εψ]
      Π[εψ] <- Χ
      εα <- εα - 1
      εψ <- εψ + 1
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ εψ > εα
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 540
  • There can be only one...may it be AEPP.
Απ: Θέμα Β
« Απάντηση #116 στις: 16 Μάι 2017, 05:24:27 μμ »
Τελικά, ΚΑΠΟΙΟΙ μαθητές της ΟΠ Σπουδών Οικονομίας και Πληροφορικής ΕΙΝΑΙ γεννημένοι Πληροφορικοί!!

ΛΥΣΗ φετινού μαθητή:
Κώδικας: [Επιλογή]
  εψ <- 1
  εα <- Ν
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ

    βρ <- ΨΕΥΔΗΣ
    ΟΣΟ εα >= 1 ΚΑΙ βρ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΑΝ Π[εα] = ΑΛΗΘΗΣ ΤΟΤΕ
        βρ <- ΑΛΗΘΗΣ
      ΑΛΛΙΩΣ
        εα <- εα - 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    βρ <- ΨΕΥΔΗΣ
    ΟΣΟ εψ <= Ν ΚΑΙ βρ = ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
      ΑΝ Π[εψ] = ΨΕΥΔΗΣ ΤΟΤΕ
        βρ <- ΑΛΗΘΗΣ
      ΑΛΛΙΩΣ
        εψ <- εψ + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΝ εψ < εα ΤΟΤΕ
      Χ <- Π[εα]
      Π[εα] <- Π[εψ]
      Π[εψ] <- Χ
      εα <- εα - 1
      εψ <- εψ + 1
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ εψ > εα
Επειδή έχεις τέτοιους μαθητές Στέργιο έτσι εξηγείται γιατί σε γειτονικό νήμα κάνεις και τρισδιάστατες πινελιές . Ορισμένοι από μας εξηγούν ακόμα τη χρήση και ύπαρξη της εξωτερικής ΓΙΑ στη φυσσαλίδα. 10 μέρες πριν τις εξετάσεις.
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέμα Β
« Απάντηση #117 στις: 16 Μάι 2017, 07:15:11 μμ »
Επειδή έχεις τέτοιους μαθητές Στέργιο έτσι εξηγείται γιατί σε γειτονικό νήμα κάνεις και τρισδιάστατες πινελιές . Ορισμένοι από μας εξηγούν ακόμα τη χρήση και ύπαρξη της εξωτερικής ΓΙΑ στη φυσσαλίδα. 10 μέρες πριν τις εξετάσεις.

Φωτεινές εξαιρέσεις Νίκο :( 

Όσο για τις "πολυδιάστατες" ανησυχίες  στο άλλο νήμα, δεν το βρίσκω υπερβολικό, εφόσον ήδη υπάρχει στο βιβλίο σχετική συζήτηση (Θερμοκρασία[30], Θερμοκρασία[30, 20], θερμοκρασία [30,20,4] ).  Γι αυτό και ανεφερα τις σχετικές ερωτήσεις αφού πλέον, νομίζω πως, σε επίπεδο θεωρίας, ειδικά μετά τη μείωση που έχει υποστεί, δεν είναι απίθανο ούτε εξωπραγματικό να εξεταστεί.

 Σε επίπεδο ασκήσεων βέβαια, η απουσία τέτοιων στο διδακτικό πακέτο νομίζω τις καθιστά ιδιαίτερα απίθανες και για τις εξετάσεις.
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)