Αποστολέας Θέμα: Θέμα Β  (Αναγνώστηκε 26278 φορές)

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2448
  • I 'm not young enough to know everything
Θέμα Β
« στις: 29 Μάι 2013, 10:19:38 πμ »
Εδώ μιλάμε για θέμα Β

katif

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Θέμα Β
« Απάντηση #1 στις: 29 Μάι 2013, 01:30:41 μμ »
Για το Β2.
Ένας μαθητής απάντησε:
ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 100
    ΓΙΑ κ ΑΠΟ 100 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
        ΑΝ Π[Κ-1]=ΨΕΥΔΗΣ ΚΑΙ Π[κ]=ΑΛΗΘΗΣ ΤΟΤΕ
                ΑΝΤΙΜΕΤΑΘΕΣΕ Π[κ-1], Π[κ]
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠ
ΤΕΛΟΣ_ΕΠ
Θα το πάρουν σωστό;
Κατηφόρης Παναγιώτης
Καθηγητής Πληροφορικής - Μαθηματικός

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2448
  • I 'm not young enough to know everything
Απ: Θέμα Β
« Απάντηση #2 στις: 29 Μάι 2013, 01:43:52 μμ »
Κάνει χρήση του αλγορίθμου ταξινόμησης. Η εκφώνηση λέει χωρίς χρήση αλγορίθμων ταξινόμησης.

eftsousis

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Θέμα Β
« Απάντηση #3 στις: 29 Μάι 2013, 01:55:58 μμ »
Έχω διαβάσει ορισμένες λυσεις , παραθέτω μια λίγο πιο γρήγορη, με χρήση δυο βοηθητικών δεικτών.

Για i απο 1 μεχρι 100
   k<--1
   λ<--100
   Αν Π = Αληθής τότε  ! Π με δείκτη i ,δεν ξέρω γιατι δε το εμφανίζει
      Π[k] <--Αληθής
          κ  <-- κ + 1
   Αλλιώς
      Π[λ] <-- Ψευδής
          λ  <-- λ - 1
   Τέλος_αν
Τέλος_επανάληψης

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 66
Απ: Θέμα Β
« Απάντηση #4 στις: 29 Μάι 2013, 02:01:45 μμ »
Κάνεις εγγραφή σε θέσεις του πίνακα Π που δεν έχεις διαβάσει ακόμα (και άρα χάνεις πληροφορίες σε θέσεις που θα χρειαστεί να διαβάσεις αργότερα).
Δεν είναι σωστό.
Σωκράτης

eftsousis

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Θέμα Β
« Απάντηση #5 στις: 29 Μάι 2013, 02:05:25 μμ »
Το ξέρω και έχεις δίκιο λάθος copy paste..  δεν πήρε το τελευταιό
είναι αλλος πίνακας δε ξέρω τι παίζει με την αντιγραφή πραγματικα, είδα οτι το έχει γράψει και άλλη συνάδελφος στην κύρια σελίδα. οπότε διπλός κόπος..

Για i απο 1 μεχρι 100
   k<--1
   λ<--100
   Αν Π = Αληθής τότε  ! Π με δείκτη i ,δεν ξέρω γιατι δε το εμφανίζει
      Τ[k] <--Αληθής
          κ  <-- κ + 1
   Αλλιώς
      Τ[λ] <-- Ψευδής
          λ  <-- λ - 1
   Τέλος_αν
Τέλος_επανάληψης
Για i απο 1 μεχρι 100
      Π(i) <-- T(i)
Τέλος_επανάληψης

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 66
Απ: Θέμα Β
« Απάντηση #6 στις: 29 Μάι 2013, 02:07:03 μμ »
Ναι, αυτό δουλεύει.
Σωκράτης

Νίκη

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Θέμα Β
« Απάντηση #7 στις: 29 Μάι 2013, 02:15:02 μμ »
ΕΝΔΕΙΚΤΙΚΕΣ ΑΠΑΝΤΗΣΕΙΣ ΣΤΑ ΕΙΔΙΚΑ ΕΞΕΤΑΣΤΙΚΑ ΚΕΝΤΡΑ
Β2.
κ <- 0
Για i από 1 μέχρι 100
   Αν Π[ι] = ΑΛΗΘΗΣ τότε κ<- κ+1
Τέλος_Επανάληψης
Για i από 1 μέχρι κ
   Π[ι] <- ΑΛΗΘΗΣ
Τέλος_Επανάληψης
Για i από κ+1 μέχρι 100
   Π[ι] <- ΨΕΥΔΗΣ
Τέλος_Επανάληψης


eftsousis

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Θέμα Β
« Απάντηση #8 στις: 29 Μάι 2013, 02:22:01 μμ »
Θα έχει την τελευταία τιμή κ που πήρε. Τώρα στο worst case scenario που είναι όλα ΑΛΗΘΗ, η τιμή αυτή θα είναι 100. Η 3η επανάληψη δε θα εκτελεστεί ποτέ γιατι θα ξεκινάει απο το 101.

Άρα είναι σωστό.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2206
Απ: Θέμα Β
« Απάντηση #9 στις: 29 Μάι 2013, 02:22:14 μμ »
Τι σημασία έχει;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: Θέμα Β
« Απάντηση #10 στις: 29 Μάι 2013, 03:27:15 μμ »
Β2. Προσπαθώντας να λύσω την ταξινόμηση χωρίς 2ο πίνακα και χωρίς μετρητή count  σκέφτηκα το παρακάτω:

κ <-- 1
λ <-- 100
Οσο κ < λ επανάλαβε
    Αν Π[κ] = Αληθης τότε
            κ <-- κ + 1
   τελος_αν

   Αν Π[λ] = Ψευδης τότε
            λ <-- λ - 1
   τελος_αν

   Αν Π[κ] <> Π[λ] και Π[κ] = Ψευδης τότε
           Αντιμετάθεσε Π[κ], Π[λ]
           κ <-- κ + 1
           λ <-- λ - 1
   Τέλος_αν
Τέλος_επανάληψης

Βλέπει κανείς κανένα λογικό λάθος;
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Θέμα Β
« Απάντηση #11 στις: 29 Μάι 2013, 03:43:30 μμ »
φαίνεται να δουλεύει !
Φιλικά,
Γιώργος Θαλασσινός

summer

  • Θαμώνας
  • ***
  • Μηνύματα: 31
Θέμα Β
« Απάντηση #12 στις: 29 Μάι 2013, 04:34:17 μμ »
Για δείτε αυτό
πλ<-0
Για ι από 1 μέχρι 100
  Αν Π[ι]=ΑΛΗΘΗΣ τότε πλ<--πλ+1
Τέλος Επανάληψης

Για ι από 1 μέχρι πλ
Αν Π[ι]=ΨΕΥΔΗΣ τότε Π[ι]<--ΑΛΗΘΗΣ
Τέλος Επανάληψης

Για ι από πλ+1 μέχρι 100
Αν Π[ι]=ΑΛΗΘΗΣ τότε  Π[ι]<--ΨΕΥΔΗΣ
Τέλος Επανάληψης

ωραίο δεν είναι?
« Τελευταία τροποποίηση: 29 Μάι 2013, 04:46:29 μμ από summer »

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Θέμα Β
« Απάντηση #13 στις: 29 Μάι 2013, 04:47:49 μμ »
Για το Β2.
Ένας μαθητής απάντησε:
ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 100
    ΓΙΑ κ ΑΠΟ 100 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
        ΑΝ Π[Κ-1]=ΨΕΥΔΗΣ ΚΑΙ Π[κ]=ΑΛΗΘΗΣ ΤΟΤΕ
                ΑΝΤΙΜΕΤΑΘΕΣΕ Π[κ-1], Π[κ]
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠ
ΤΕΛΟΣ_ΕΠ
Θα το πάρουν σωστό;


Κάνει χρήση του αλγορίθμου ταξινόμησης. Η εκφώνηση λέει χωρίς χρήση αλγορίθμων ταξινόμησης.


Δοθέντων των στοιχείων α1, α2,...αn η ταξινόμηση συνίσταται στη μετάθεση της θέσης των στοιχείων, ώστε να τοποθετηθούν σε μία σειρά ακ1, ακ2,..., ακν έτσι ώστε, δοθείσης μιας συνάρτησης διάταξης f να ισχύει:
f(ak1) <= f(ak2) <= ...<=f(akn)
σχολικό βιβλίο σελ 66

Η σύγκριση λογικών έχει έννοια μόνο στην περίπτωση του ίσου (=) και του διάφορου (<>).
σχολικό βιβλίο σελ 166

Επίσης στον πίνακα υπάρχουν δύο διαφορετικές τιμές.

Που ακριβώς υπάρχει η ταξινόμηση στον παραπάνω κώδικα;

Νομίζω ότι η επιτροπή θέλοντας να προστατέψει τους μαθητές να χρησιμοποιήσουν την φυσαλίδα αφού δεν υφίσταται η σύγκριση  (<) ή  (>) σε λογικές τιμές έδωσε τη φράση "χωρίς τη χρήση αλγορίθμων ταξινόμησης".

Εγώ θεωρώ τη λύση ολόσωστη και θα δώσω όλες τις μονάδες αν μου τύχει τέτοιο γραπτό.

spantoulis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 109
Απ: Θέμα Β
« Απάντηση #14 στις: 29 Μάι 2013, 05:07:38 μμ »

Που ακριβώς υπάρχει η ταξινόμηση στον παραπάνω κώδικα;


υπάρχουν δύο είδη φυσαλίδων, οι ΑΛΗΘΕΙΣ και οι ΨΕΥΔΕΙΣ. Αν το φανταστείς  σαν εικόνα καθώς εκτελείται ο αλγόριθμος θα δεις μονο ταξινόμηση.

Ο αλγόριθμος είναι καρμπόν η ταξινόμηση φυσαλίδας με αλλαγμένη τη συνθήκη

Η χρήση υπολογιστών ΔΕΝ είναι πληροφορική