Αποστολέας Θέμα: Πανελλαδικές εξετάσεις 2013  (Αναγνώστηκε 8928 φορές)

katif

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #45 στις: 29 Μάι 2013, 01:42:03 μμ »
Μια πρόταση για το Γ3
ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 30
      ΑΝ 2*ΜΟ[ι,1]>ΜΟ[ι,2] ΤΟΤΕ
          ΜΑΧ<-- 2*ΜΟ[ι,1]
     ΑΛΛΙΩΣ
         ΜΑΧ<--ΜΟ[ι,2]
    ΤΕΛΟΣ_ΑΝ

   ΑΝ ΜΑΧ<=3,6 ΤΟΤΕ
       ΓΡΑΨΕ 'Χαμηλός SAR'
   AΛΛΙΩΣ_ΑΝ ΜΑΧ<=4 ΤΟΤΕ
       ΓΡΑΨΕ 'Κοντά στα όρια'
   ΑΛΛΙΩΣ
       ΓΡΑΨΕ 'Έκτος ορίων'
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Κατηφόρης Παναγιώτης
Καθηγητής Πληροφορικής - Μαθηματικός

katif

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #46 στις: 29 Μάι 2013, 01:43:01 μμ »
Για το Β2.
Ένας μαθητής απάντησε:
ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 100
    ΓΙΑ κ ΑΠΟ 100 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
        ΑΝ Π[Κ-1]=ΨΕΥΔΗΣ ΚΑΙ Π[κ]=ΑΛΗΘΗΣ ΤΟΤΕ
                ΑΝΤΙΜΕΤΑΘΕΣΕ Π[κ-1], Π[κ]
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠ
ΤΕΛΟΣ_ΕΠ
Θα το πάρουν σωστό;
Κατηφόρης Παναγιώτης
Καθηγητής Πληροφορικής - Μαθηματικός

vanalex

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #47 στις: 29 Μάι 2013, 01:43:15 μμ »
Να ρωτήσω κάτι με τη σειρά μου: το Δ4 βγαίνει σωστά και με όσο και με μέχρις_ότου;
Με άλλα λόγια, αν χρησιμοποιηθεί μέχρις_ότου και η ερώτηση για διακοπή της εισαγωγής μπει στο τέλος του loop, υπάρχει θέμα ως προς την 1η απάντηση του χρήστη;
Επίσης, σε ποια μεταβλητή καταχωρείται η απάντηση δ ή Δ; στη μεταβλητή χώρα ή σε 3η; Το Δ3 είναι σχετικά ασαφές...

Σωκράτη νομίζω ότι το Δ3 μας λέει απλώς πότε να σταματήσει αυτός ο βρόχος, μας δίνει δηλαδή απλώς τη συνθήκη. Αφού θα πραγματοποιηθεί αυτή η διαδικασία σίγουρα μια φορά και δε χρειάζεται να ελέγξουμε κάτι από την αρχή τότε κατά την άποψή μου αρκεί να χρησιμοποιηθεί η ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ. Εγώ το υλοποίησα κάπως έτσι:

Κώδικας: [Επιλογή]
  ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Δ_2013

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, EL[5], ES[5], ΑΠΑΝΤΗΣΗ, Θ
  ΧΑΡΑΚΤΗΡΕΣ: ΧΩΡΑ, ΕΠΙΛΟΓΗ
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ


ΑΡΧΗ
! ΕΡΩΤΗΜΑ Δ1
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
    EL[Ι] <- 0
    ES[Ι] <- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ΕΡΩΤΗΜΑ Δ2
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ΧΩΡΑ, ΑΠΑΝΤΗΣΗ
    ΑΝ ΧΩΡΑ = "ES" ΤΟΤΕ
      ΑΝ ΑΠΑΝΤΗΣΗ = 1 ΤΟΤΕ
        ES[1] <- ES[1] + 1
      ΑΛΛΙΩΣ_ΑΝ ΑΠΑΝΤΗΣΗ = 2 ΤΟΤΕ
        ES[2] <- ES[2] + 1
      ΑΛΛΙΩΣ_ΑΝ ΑΠΑΝΤΗΣΗ = 3 ΤΟΤΕ
        ES[3] <- ES[3] + 1
      ΑΛΛΙΩΣ_ΑΝ ΑΠΑΝΤΗΣΗ = 4 ΤΟΤΕ
        ES[4] <- ES[4] + 1
      ΑΛΛΙΩΣ
        ES[5] <- ES[5] + 1
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      ΑΝ ΑΠΑΝΤΗΣΗ = 1 ΤΟΤΕ
        EL[1] <- EL[1] + 1
      ΑΛΛΙΩΣ_ΑΝ ΑΠΑΝΤΗΣΗ = 2 ΤΟΤΕ
        EL[2] <- EL[2] + 1
      ΑΛΛΙΩΣ_ΑΝ ΑΠΑΝΤΗΣΗ = 3 ΤΟΤΕ
        EL[3] <- EL[3] + 1
      ΑΛΛΙΩΣ_ΑΝ ΑΠΑΝΤΗΣΗ = 4 ΤΟΤΕ
        EL[4] <- EL[4] + 1
      ΑΛΛΙΩΣ
        EL[5] <- EL[5] + 1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
                                                    ! ΕΡΩΤΗΜΑ Δ3
    ΓΡΑΨΕ "ΓΙΑ ΔΙΑΚΟΠΗ ΤΗΣ ΕΙΣΑΓΩΓΗΣ ΠΑΤΗΣΤΕ Δ Η δ"
    ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙΛΟΓΗ = 'Δ' Η ΕΠΙΛΟΓΗ = 'δ'

!ΕΡΩΤΗΜΑ Δ4
  ΚΑΛΕΣΕ ΜΕΓ_ΠΟΣ(EL, ΠΟΣ, Θ)
  ΓΡΑΨΕ "ΓΙΑ ΤΗΝ ΕΛΛΑΔΑ Η ΑΠΑΝΤΗΣΗ ΜΕ ΤΟ ΜΕΓΑΛΥΤΕΡΟ ΠΟΣΟΣΤΟ ΗΤΑΝ Η ", Θ, " ΜΕ ΠΟΣΟΣΤΟ ", ΠΟΣ
  ΚΑΛΕΣΕ ΜΕΓ_ΠΟΣ(ES, ΠΟΣ, Θ)
  ΓΡΑΨΕ "ΓΙΑ ΤΗΝ ΙΣΠΑΝΙΑ Η ΑΠΑΝΤΗΣΗ ΜΕ ΤΟ ΜΕΓΑΛΥΤΕΡΟ ΠΟΣΟΣΤΟ ΗΤΑΝ Η ", Θ, " ΜΕ ΠΟΣΟΣΤΟ ", ΠΟΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΘΕΜΑ_Δ_2013

!ΕΡΩΤΗΜΑ Δ5
ΔΙΑΔΙΚΑΣΙΑ ΜΕΓ_ΠΟΣ(Π, ΠΟΣΟΣΤΟ, ΘΕΣΗ)

ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Π[5], ΘΕΣΗ, ΜΑΧ, ΑΘΡΟΙΣΜΑ, Ι
  ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟΣΤΟ

ΑΡΧΗ
  ΜΑΧ <- Π[1]
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 5
    ΑΝ Π[Ι] < ΜΑΧ ΤΟΤΕ
      ΜΑΧ <- Π[Ι]
      ΘΕΣΗ <- Ι
    ΤΕΛΟΣ_ΑΝ
    ΑΘΡΟΙΣΜΑ <- ΑΘΡΟΙΣΜΑ + Π[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 
  ΠΟΣΟΣΤΟ <- (ΜΑΧ/ ΑΘΡΟΙΣΜΑ)* 100
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
Αλέξης Μιχαλακίδης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ

vanalex

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #48 στις: 29 Μάι 2013, 01:47:29 μμ »
Για το Β2.
Ένας μαθητής απάντησε:
ΓΙΑ ι ΑΠΟ 2 ΜΕΧΡΙ 100
    ΓΙΑ κ ΑΠΟ 100 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
        ΑΝ Π[Κ-1]=ΨΕΥΔΗΣ ΚΑΙ Π[κ]=ΑΛΗΘΗΣ ΤΟΤΕ
                ΑΝΤΙΜΕΤΑΘΕΣΕ Π[κ-1], Π[κ]
        ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠ
ΤΕΛΟΣ_ΕΠ
Θα το πάρουν σωστό;

Αναφέρουν να μην χρησιμοποιηθεί στην ουσία η τεχνική του αλγορίθμου της ταξινόμησης...οπότε νομίζω ότι θα χάσει μονάδες..
Αλέξης Μιχαλακίδης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2219
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #49 στις: 29 Μάι 2013, 01:47:49 μμ »


Κώδικας: [Επιλογή]
 

! ΕΡΩΤΗΜΑ Δ2
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ΧΩΡΑ, ΑΠΑΝΤΗΣΗ
    [b]ΑΝ ΧΩΡΑ = "ES" ΤΟΤΕ
        ES[ΑΠΑΝΤΗΣΗ] <- ES[ΑΠΑΝΤΗΣΗ] + 1
    ΑΛΛΙΩΣ
        EL[ΑΠΑΝΤΗΣΗ] <- EL[ΑΠΑΝΤΗΣΗ] + 1
     
    ΤΕΛΟΣ_ΑΝ[/b]
                                                    ! ΕΡΩΤΗΜΑ Δ3
    ΓΡΑΨΕ "ΓΙΑ ΔΙΑΚΟΠΗ ΤΗΣ ΕΙΣΑΓΩΓΗΣ ΠΑΤΗΣΤΕ Δ Η δ"
    ΔΙΑΒΑΣΕ ΕΠΙΛΟΓΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΕΠΙΛΟΓΗ = 'Δ' Η ΕΠΙΛΟΓΗ = 'δ'


 :) :)
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

vanalex

  • Οπαδός
  • **
  • Μηνύματα: 18
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #50 στις: 29 Μάι 2013, 01:50:02 μμ »
:) :)

Πολύ σωστά! Τζάμπα παιδεύομαι πιο πάνω... :)
Αλέξης Μιχαλακίδης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ

soc_h

  • Βετεράνος
  • ****
  • Μηνύματα: 70
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #51 στις: 29 Μάι 2013, 02:09:44 μμ »
...Αφού θα πραγματοποιηθεί αυτή η διαδικασία σίγουρα μια φορά και δε χρειάζεται να ελέγξουμε κάτι από την αρχή ...
Σε ευχαριστώ για την απάντηση.
Το πιο πάνω πως το ξέρουμε σίγουρα;
Σωκράτης

eftsousis

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #52 στις: 29 Μάι 2013, 02:15:29 μμ »
Γνώμη μου και το Α4α θα φανεί παράξενο στα παιδιά...λίγοι θα "παίξουν" με τους δείκτες i, j... :(

Συμφωνώ Αλέξη, τα θέματα Α4 και Β2 ήταν τα πιο δύσκολα να αντιμετωπίσουν οι μαθητές. η άσκηση  είχε μια κλιμάκωση,, το θέμα 4ο ήταν εύκολο και υπήρχε αρκετό γράψιμο στις ασκήσεις. Κάποιος καλά διαβασμένος έγραφε καλά, όχι προς το άριστα όμως.

eara

  • Βετεράνος
  • ****
  • Μηνύματα: 79
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #53 στις: 29 Μάι 2013, 04:40:09 μμ »
Αδικαιολογητο επισης κατα την γνωμη μου να ζητανε απο τα παιδια να "ταξινομησουν" χωρις να χρησιμοποιησουν αυτο που μαθαμε ολη την χρονια. Εξεταζουν μονο την φαντασια τους την ωρα που βρισκονται μεσα στο αγχος κατι που δεν μου αρεσει.

Άλλο ένα αρνητικό σημείο στα θέματα το οποίο κατ' εμέ σωστά θίγεις. Δηλαδή το γεγονός ότι ζητούν στην ουσία να ταξινομήσουν τις τιμές, χωρίς τον μοναδικό αλγόριθμο ταξινόμησης που μάθαν στην τρέχουσα με βάση την εξεταστέα ύλη.

Γιάννης Αναγνωστάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 815
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #54 στις: 29 Μάι 2013, 11:20:59 μμ »
Δεν θα έπρεπε η ΠΕΚΑΠ, η ΕΠΕ (έστω μία ένωση ρε παιδιά) να βγει να κάνει μία ανακοίνωση για τα θέματα

Πουθενά δεν είμαστε ρε παιδιά...Καμία εικόνα...

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3190
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #55 στις: 29 Μάι 2013, 11:41:27 μμ »
πριν 8 περίπου ώρες (συνημμένο)

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1089
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #56 στις: 29 Μάι 2013, 11:48:44 μμ »
Από το  απόγευμα υπάρχουν αναρτημένες στο διαδίκτυο οι απόψεις και τα σχόλια της ΠΕΚΑΠ για τα θέματα:

http://www.greekinformatics.gr/ekpedeysi/334-ekpedeysi/2986-thematakailyseispliroforikis2013.html

Γιάννης Αναγνωστάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 815
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #57 στις: 30 Μάι 2013, 01:04:17 μμ »
Συνάδελφοι συγνώμη, αλλα μπαίνοντας το βράδυ στο site της ΠΕΚΑΠ δεν είδα τίποτα....

itt

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 428
  • Real stupidity beats ΑΙ any time
Απ: Πανελλαδικές εξετάσεις 2013
« Απάντηση #58 στις: 30 Μάι 2013, 01:16:59 μμ »
Μου αρέσει στο σχολιασμό το
Παράθεση
Χαρακτηρίζονται στο
µεγαλύτερο  µέρος  τους  σαφή,  ορθά  διατυπωµένα,  ενώ  κάλυπταν  ένα  σηµαντικό
φάσµα της ύλης.

που προφανώς υποδεικύνει πώς ένα μέρος ήταν ασαφές και ανορθόδοξα διατυπωμένο.Αλλά καμμια αναφορά ποια σημεία απο το διαγώνισμα συγκαταλέγονται σε αυτό το μέρος.