Αποστολέας Θέμα: ΑΣΑΦΕΙΕΣ  (Αναγνώστηκε 684 φορές)

landreou

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 124
ΑΣΑΦΕΙΕΣ
« στις: 30 Απρ 2013, 09:59:35 πμ »

Γεια σε όλους τους φίλους του Στπ

Μια σειρά ερωτήσεων για ασάφειες που διάβασα στο βιβλιο

[1] Με ποια σειρά θα εκτελεστεί το 2^3^4
[2] Στη ΓΛΩΣΣΑ πρέπει να μπαινει το ονομα προγράμματος μετά από το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
[3] Το κόμμα (,) ή η τελέια (.) χρησιμοποιούνται για το δεκαδικό
[4] Με βήμα 0 στη Για παραβιάζεται η Καθοριστικότητα ή περατότητα ή και τα δύο
[5] Με ποια σειρά θα εκτελεστεί το Αληθης ή Ψευδής και Αληθής ;

Σας ευχαριστώ όλους εκ προοιμίου

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2219
Απ: ΑΣΑΦΕΙΕΣ
« Απάντηση #1 στις: 30 Απρ 2013, 11:11:18 πμ »
Γεια σε όλους τους φίλους του Στπ

Μια σειρά ερωτήσεων για ασάφειες που διάβασα στο βιβλιο

[1] Με ποια σειρά θα εκτελεστεί το 2^3^4
[2] Στη ΓΛΩΣΣΑ πρέπει να μπαινει το ονομα προγράμματος μετά από το ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
[3] Το κόμμα (,) ή η τελέια (.) χρησιμοποιούνται για το δεκαδικό
[4] Με βήμα 0 στη Για παραβιάζεται η Καθοριστικότητα ή περατότητα ή και τα δύο
[5] Με ποια σειρά θα εκτελεστεί το Αληθης ή Ψευδής και Αληθής ;

Σας ευχαριστώ όλους εκ προοιμίου

1. Από αριστερά προς τα δεξιά, δηλαδή 8^4
2. Από ότι κατάλαβα, στην τελευταία έκδοση του βιβλίου δεν υπάρχει πουθενά όνομα μετά το τέλος. Θέλω να ελπίζω ότι οι βαθμολογητές δεν ασχολούνται καν με αυτό το θέμα.
3. Άποψη μου είναι ότι εφόσον το κόμμα έχει την χρήση του διαχωρισμού σταθερών και μεταβλητών, για υποδιαστολή θα πρέπει να χρησιμοποιούμε μόνο την τελεία.
4. Θα έλεγα η περατότητα, καθώς δεν υπάρχει αμφιβολία για το πώς θα εκτελεστεί. Εκτελείται επ'άπειρον
5. Σε αυτό δεν έχει δοθεί απάντηση και ελπίζουμε ότι θα δοθούν παρενθέσεις που να ορίζουν την σειρά. Σε διαφορετική περίπτωση, θα γίνει τόσος χαμός (όπως περίπου στο Γ του 2010) που θα υπάρξει συμβιβαστική λύση (όλα δεκτά).
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής