Αποστολέας Θέμα: αριθμομηχανη  (Αναγνώστηκε 1536 φορές)

giwrgos2000

  • Νέος
  • *
  • Μηνύματα: 2
αριθμομηχανη
« στις: 06 Οκτ 2012, 04:54:51 μμ »
ενα προγραμμα που εφτιαξα :).Εχετε καμια ιδεα για το πως μπορω να το κανω καλυτερο?  8)
να ο κωδικας:

ΠΡΟΓΡΑΜΜΑ αριθμομηχανή
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, δ, μο, σ
  ΑΚΕΡΑΙΕΣ: μ
  ΧΑΡΑΚΤΗΡΕΣ: χ
ΑΡΧΗ
  δ <- 0
  ΓΡΑΨΕ 'Πρόσθεση=1, Αφαίρεση=2, Πολλαπλασιαμός=3, Διαίρεση=4, Μέσος Όρος=5, Τετραγωνική Ρίζα=6:'
  ΔΙΑΒΑΣΕ γ
  ΑΝ γ = 1 ΤΟΤΕ
    β <- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Εισάγετε έναν αριθμό:'
      ΔΙΑΒΑΣΕ α
      β <- β + α
      ΓΡΑΨΕ 'Θέλετε να συνεχίσετε ν/ο?'
      ΔΙΑΒΑΣΕ χ
    ΜΕΧΡΙΣ_ΟΤΟΥ χ = 'ο' Η χ = 'Ο' Η χ = 'οχι' Η χ = 'ΟΧΙ' Η χ = 'o' Η χ = 'O' Η χ = '0'
    ΓΡΑΨΕ 'Το αποτέλεσμα της πρόσθεσης είναι:', β
  ΑΛΛΙΩΣ_ΑΝ γ = 2 ΤΟΤΕ
    ΓΡΑΨΕ 'Εισάγετε τον μειωτέο:'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Εισάγετε τον αφαιρετέο:'
    ΔΙΑΒΑΣΕ β
    δ <- α - β
    ΓΡΑΨΕ 'Το αποτέλεσμα της αφαίρεσης είναι:', δ
  ΑΛΛΙΩΣ_ΑΝ γ = 3 ΤΟΤΕ
    β <- 1
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Εισάγετε έναν αριθμό:'
      ΔΙΑΒΑΣΕ α
      β <- α*β
      ΓΡΑΨΕ 'Θέλετε να συνεχίσετε ν/ο?'
      ΔΙΑΒΑΣΕ χ
    ΜΕΧΡΙΣ_ΟΤΟΥ χ = 'ο' Η χ = 'Ο' Η χ = 'οχι' Η χ = 'ΟΧΙ' Η χ = 'o' Η χ = 'O' Η χ = '0'
    ΓΡΑΨΕ 'Το αποτέλεσμα του πολλαπλασιασμού είναι:', β
  ΑΛΛΙΩΣ_ΑΝ γ = 4 ΤΟΤΕ
    ΓΡΑΨΕ 'Εισάγετε τον διαιρετέο:'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Εισάγετε τον διαιρέτη:'
    ΔΙΑΒΑΣΕ β
    ΑΝ β <> 0 ΤΟΤΕ
      δ <- α/β
      ΓΡΑΨΕ 'Το αποτέλεσμα της διαίρεσης είναι:', δ
    ΑΛΛΙΩΣ_ΑΝ β = 0 ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν μπορείτε να διαιρέσετε κανέναν αριθμό με το 0'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ γ = 5 ΤΟΤΕ
    μ <- 0
    σ <- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Εισάγετε έναν αριθμό:'
      ΔΙΑΒΑΣΕ α
      μ <- μ + 1
      σ <- σ + α
      ΓΡΑΨΕ 'Θέλετε να συνεχίσετε ν/ο?'
      ΔΙΑΒΑΣΕ χ
    ΜΕΧΡΙΣ_ΟΤΟΥ χ = 'ο' Η χ = 'Ο' Η χ = 'οχι' Η χ = 'ΟΧΙ' Η χ = 'o' Η χ = 'O' Η χ = '0'
    μο <- σ/μ
    ΓΡΑΨΕ 'Ο μέσος όρος των αριθμών είναι:', μο
  ΑΛΛΙΩΣ_ΑΝ γ = 6 ΤΟΤΕ
    ΓΡΑΨΕ 'Εισάγετε έναν αριθμό:'
    ΔΙΑΒΑΣΕ α
    β <- α^(1/2)
    ΓΡΑΨΕ 'Η τετραγωνική ρίζα του αριθμού ', α, ' ειναι:', β
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Πρέπει να κάνετε πρόσθεση(1),αφαίρεση(2),πολλαπλασιασμό(3),διαίρεση(4),να υπολογίσετε τον μέσο όρο κάποιων αριθμών(5) ή να υπολογίσετε την τετραγωνική ριζα ενός αριθμού(6).'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ευχαριστώ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Stavros

  • Θαμώνας
  • ***
  • Μηνύματα: 40
    • http://csforces.gr/
Απ: αριθμομηχανη
« Απάντηση #1 στις: 07 Οκτ 2012, 12:46:18 μμ »
Ωραία προσπάθεια.
Εγώ ένα πράγμα θέλω να σημειώσω (και μία λεπτομέρεια) :

Όταν υπολογίζεις την ρίζα ήλεγξε αν ο αριθμός που δίνει ο χρήστης είναι μεγαλύτερος ίσος του 0. Αν δώσεις ρίζα του -5 βγάζει σφάλμα.

Επίσης:
ΑΝ β <> 0 ΤΟΤΕ
      δ <- α/β
      ΓΡΑΨΕ 'Το αποτέλεσμα της διαίρεσης είναι:', δ
ΑΛΛΙΩΣ_ΑΝ β = 0 ΤΟΤΕ
      ΓΡΑΨΕ 'Δεν μπορείτε να διαιρέσετε κανέναν αριθμό με το 0'
ΤΕΛΟΣ_ΑΝ

το ΑΛΛΙΩΣ_ΑΝ δεν είναι απαραίτητο, βάλε σκέτο ΑΛΛΙΩΣ. (οι καθηγητές μου είχαν ένα θέμα με το  ΑΛΛΙΩΣ_ΑΝ όπου δεν χρειάζεται)

Αν είσαι όντως στο γυμνάσιο συγχαρητήρια!!!
Stavros
3ετής φοιτητής πληροφορικής


Το νέο φοιτητικό site
www.universitas.gr
www.csforces.gr/forums
All about computers!!!
Join us!!!!

giwrgos2000

  • Νέος
  • *
  • Μηνύματα: 2
Απ: αριθμομηχανη
« Απάντηση #2 στις: 10 Οκτ 2012, 03:06:40 μμ »
ο λιγο βελτιωμενος κωδικας :)
οντως ειμαι μαθητης της 1ης γυμνασιου,δεν εχω καποιο λογο να πω ψεματα ;)
ευχαριστω παντως!

ΠΡΟΓΡΑΜΜΑ αριθμομηχανή
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: α, β, γ, δ, μο, σ
  ΑΚΕΡΑΙΕΣ: μ
  ΧΑΡΑΚΤΗΡΕΣ: χ
ΑΡΧΗ
  δ <- 0
  ΓΡΑΨΕ 'Γράψτε τον αριθμό που αντιστοιχεί στην πράξη που θέλετε να εκτελέσετε: Πρόσθεση=1, Αφαίρεση=2, Πολλαπλασιαμός=3, Διαίρεση=4, Μέσος Όρος=5, Τετραγωνική Ρίζα=6:'
  ΔΙΑΒΑΣΕ γ
  ΑΝ γ = 1 ΤΟΤΕ
    β <- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Εισάγετε έναν αριθμό:'
      ΔΙΑΒΑΣΕ α
      β <- β + α
      ΓΡΑΨΕ 'Θέλετε να συνεχίσετε ν/ο?'
      ΔΙΑΒΑΣΕ χ
    ΜΕΧΡΙΣ_ΟΤΟΥ χ = 'ο' Η χ = 'Ο' Η χ = 'οχι' Η χ = 'ΟΧΙ' Η χ = 'o' Η χ = 'O' Η χ = '0'
    ΓΡΑΨΕ 'Το αποτέλεσμα της πρόσθεσης είναι:', β
  ΑΛΛΙΩΣ_ΑΝ γ = 2 ΤΟΤΕ
    ΓΡΑΨΕ 'Εισάγετε τον μειωτέο:'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Εισάγετε τον αφαιρετέο:'
    ΔΙΑΒΑΣΕ β
    δ <- α - β
    ΓΡΑΨΕ 'Το αποτέλεσμα της αφαίρεσης είναι:', δ
  ΑΛΛΙΩΣ_ΑΝ γ = 3 ΤΟΤΕ
    β <- 1
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Εισάγετε έναν αριθμό:'
      ΔΙΑΒΑΣΕ α
      β <- α*β
      ΓΡΑΨΕ 'Θέλετε να συνεχίσετε ν/ο?'
      ΔΙΑΒΑΣΕ χ
    ΜΕΧΡΙΣ_ΟΤΟΥ χ = 'ο' Η χ = 'Ο' Η χ = 'οχι' Η χ = 'ΟΧΙ' Η χ = 'o' Η χ = 'O' Η χ = '0'
    ΓΡΑΨΕ 'Το αποτέλεσμα του πολλαπλασιασμού είναι:', β
  ΑΛΛΙΩΣ_ΑΝ γ = 4 ΤΟΤΕ
    ΓΡΑΨΕ 'Εισάγετε τον διαιρετέο:'
    ΔΙΑΒΑΣΕ α
    ΓΡΑΨΕ 'Εισάγετε τον διαιρέτη:'
    ΔΙΑΒΑΣΕ β
    ΑΝ β <> 0 ΤΟΤΕ
      δ <- α/β
      ΓΡΑΨΕ 'Το αποτέλεσμα της διαίρεσης είναι:', δ
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'Δεν μπορείτε να διαιρέσετε κανέναν αριθμό με το 0'
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ_ΑΝ γ = 5 ΤΟΤΕ
    μ <- 0
    σ <- 0
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ 'Εισάγετε έναν αριθμό:'
      ΔΙΑΒΑΣΕ α
      μ <- μ + 1
      σ <- σ + α
      ΓΡΑΨΕ 'Θέλετε να συνεχίσετε ν/ο?'
      ΔΙΑΒΑΣΕ χ
    ΜΕΧΡΙΣ_ΟΤΟΥ χ = 'ο' Η χ = 'Ο' Η χ = 'οχι' Η χ = 'ΟΧΙ' Η χ = 'o' Η χ = 'O' Η χ = '0'
    μο <- σ/μ
    ΓΡΑΨΕ 'Ο μέσος όρος των αριθμών είναι:', μο
  ΑΛΛΙΩΣ_ΑΝ γ = 6 ΤΟΤΕ
    ΓΡΑΨΕ 'Εισάγετε τον αριθμό:'
    ΔΙΑΒΑΣΕ α
    β <- α^(1/2)
    ΓΡΑΨΕ 'Η τετραγωνική ρίζα του αριθμού ', α, ' ειναι: ', β
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'Πρέπει να κάνετε πρόσθεση(1),αφαίρεση(2),πολλαπλασιασμό(3),διαίρεση(4),να υπολογίσετε τον μέσο όρο κάποιων αριθμών(5) ή να υπολογίσετε την τετραγωνική ρίζα ενός αριθμού(6).'
  ΤΕΛΟΣ_ΑΝ
  ΓΡΑΨΕ 'Ευχαριστώ.'
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ