Αποστολέας Θέμα: Επαναληπτικές Γενικών Λυκείων 2012  (Αναγνώστηκε 8298 φορές)

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3192
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Επαναληπτικές Γενικών Λυκείων 2012
« Απάντηση #15 στις: 21 Ιούν 2012, 10:47:37 πμ »
Εναλλακτική λύση για το Γ1 που έκανε μια μαθήτρια μου

Για i από 1 μέχρι 500
  Αν ΚΕΙΜ[ i ] = " " τότε pos ← i
Τέλος_επανάληψης
Αν pos = 500 τότε
  Εμφάνισε "Το μήκος του κειμένου είναι 500"
Αλλιώς
  Εμφάνισε 500 - pos
Τέλος_αν

δε μου φαίνεται σωστό, γιατί κρατάει ΤΟ ΤΕΛΕΥΤΑΙΟ ΚΕΝΟ που θα συναντήσει!! Το κείμενο σταματάει μάλλον λίγο πιο πριν
Αν δεν έχει κενό στο τέλος (χαρακτήρες=500), τότε το pos έχει λάβει τιμή το τελευταίο κενό (πριν την τελευταία λέξη)!
« Τελευταία τροποποίηση: 21 Ιούν 2012, 10:59:14 πμ από Παναγιώτης Τσιωτάκης »

Βασίλης Παπαχρήστος

  • Θαμώνας
  • ***
  • Μηνύματα: 41
Απ: Επαναληπτικές Γενικών Λυκείων 2012
« Απάντηση #16 στις: 21 Ιούν 2012, 11:13:27 πμ »
δε μου φαίνεται σωστό, γιατί κρατάει ΤΟ ΤΕΛΕΥΤΑΙΟ ΚΕΝΟ που θα συναντήσει!! Το κείμενο σταματάει μάλλον λίγο πιο πριν
Αν δεν έχει κενό στο τέλος (χαρακτήρες=500), τότε το pos έχει λάβει τιμή το τελευταίο κενό (πριν την τελευταία λέξη)!

Ναι ναι έχεις απόλυτο δίκιο, <> " " ήθελα να γράψω.
Μισό να το διορθώσω, νομίζω με <> δουλεύει.

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3192
  • I love you 3000
    • Panagiotis Tsiotakis

student_anka

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Επαναληπτικές Γενικών Λυκείων 2012
« Απάντηση #18 στις: 07 Απρ 2013, 09:42:38 μμ »
Καλησπέρα!

Έχω μια απορία που αφορά το 4ο Θέμα με τις μετρήσεις τηλεθέασης...

Συγκεκριμένα, στο ερώτημα Δ3 γιατί δημιουργούμε συνάρτηση κι όχι διαδικασία?
Αφού στην ουσία υπολογίζουμε 5 αποτελέσματα (5 ΜΟ)...

Σας ευχαριστώ για το χρόνο σας!

student_anka

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Επαναληπτικές Γενικών Λυκείων 2012
« Απάντηση #19 στις: 07 Απρ 2013, 10:05:51 μμ »
Θα ήταν λάθος δηλαδή το παρακάτω:

Διαδικασία ΜέσοςΌρος (ΘΕΑΤ, ΜΟ)
Μεταβλητές
     Ακέραιες: i, j, ΘΕΑΤ[5,7], SUM[5]
     Πραγματικές: ΜΟ[5]
Αρχή
     Για i από 1 μέχρι 5
          SUM <-- 0
               Για j από 1 μέχρι 7
                    SUM <-- SUM+ΘΕΑΤ[i, j]
               Τέλος_επανάληψης
          ΜΟ <-- SUM/7
     Τέλος_επανάληψης
Τέλος_Διαδικασίας

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 541
  • There can be only one...may it be AEPP.
Απ: Επαναληπτικές Γενικών Λυκείων 2012
« Απάντηση #20 στις: 07 Απρ 2013, 11:01:51 μμ »
Δεν θα ήταν λάθος. Με τη διόρθωση βέβαια στον κώδικά σου στο τέλος όπου
ΜΟ <-- SUM/7
να γίνει
ΜΟ[ i ] <-- SUM/7
Όμως στην εκφώνηση βλέπουμε: "Να καλεί για κάθε έναν από τους τηλεοπτικούς σταθμούς κατάλληλο υποπρόγραμμα...".
Επομένως το υποπρόγραμμα θα καλείται επαναληπτικά, κάθε φορά και για διαφορετικό σταθμό. Άρα θα επιστρέφει έναν μέσο όρο από εναν σταθμό. Οπότε ενα αποτέλεσμα=προτιμάται Συνάρτηση.
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

student_anka

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Επαναληπτικές Γενικών Λυκείων 2012
« Απάντηση #21 στις: 08 Απρ 2013, 08:56:21 πμ »
Ναι, έχετε δίκιο!
Ευχαριστώ πολύ!

stark

  • Νέος
  • *
  • Μηνύματα: 6
Απ: Επαναληπτικές Γενικών Λυκείων 2012
« Απάντηση #22 στις: 19 Απρ 2014, 01:09:42 μμ »
Καλησπέρα στην κοινότητα!Στο ερώτημα Δ3 είναι απαραίτητη η χρήση πίνακα για την εκχώρηση του μέσου πλήθους τηλεθεατών,εφόσον στη συνέχεια δεν υφίσταται κάποια επεξεργασία επί αυτού του πίνακα;Αν ναι,μπορείτε να μου αιτιολογήσετε για ποιο λόγο;Σας ευχαριστώ!

deniaa

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Επαναληπτικές Γενικών Λυκείων 2012
« Απάντηση #23 στις: 02 Μάι 2014, 03:21:04 μμ »
Έχω κι εγώ μια απορία. Γιατί γράφουμε     
 ΑΝ ΜΟ_σκ>=ΜΟ_καθ+ΜΟ_καθ*10%
 ΤΕΛΟΣ_ΑΝ

και όχι

ΑΝ ΜΟ_σκ>=ΜΟ_καθ*10%
;;;;

Thanks!!!


petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2219
Απ: Επαναληπτικές Γενικών Λυκείων 2012
« Απάντηση #24 στις: 02 Μάι 2014, 03:27:40 μμ »
Παράδειγμα
Αν ο ΜΟ_καθ είναι 10 τηλεθεατές, θέλεις να δεις αν ο ΜΟ_σκ έχει τουλάχιστον 11, δηλαδή 10% παραπάνω από τον ΜΟ_καθ
Αυτό που ελέγχεις εσύ θα βρει αν ο ΜΟ_σκ είναι πάνω από 1 τηλεθεατής, το 10% του ΜΟ_καθ
Το ποσοστό αναφέρεται σε αύξηση του μέσου όρου, όχι σε μέρος του μέσου όρου
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής