Αποστολέας Θέμα: Πολλαπλασιασμός αλά ρωσικά ??  (Αναγνώστηκε 12078 φορές)

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3136
  • Dracarys
    • Panagiotis Tsiotakis
Πολλαπλασιασμός αλά ρωσικά ??
« στις: 19 Μάι 2006, 11:28:28 πμ »

Ο ανηψούλης μου από την Τενεούπολη με ρώτησε αν ο παρακάτω αλγόριθμος (για τον πολ/σμό αλά ρωσικά) είναι σωστός (δεν τον σκέφτηκε μόνος του):

   Δεδομένα // Μ1, Μ2 //
   P ← 0
   Για Ε από Μ2 μέχρι 0 με_βήμα Κ
      Αν Ε mod 2 = 1 τότε
           P ← P + M1
      Τέλος_αν
      M1 ← M1*2
      K ← M2 div 2
   Τέλος_επανάληψης
   Αποτελέσματα // P //

Ο γιατρός μου είπε οτι ήμουν πολύ τυχερός που τη γλύτωσα και πως πρέπει να προσέχω πολύ στο εξής. Σε επόμενη παρόμοια...συγκίνηση μπορεί να μην είμαι τόσο τυχερός. Δεν είναι και πολύ συνηθισμένες τέτοιες κρίσεις στα 29...

Με εκτίμηση,


nekis

  • Βετεράνος
  • ****
  • Μηνύματα: 76
  • U R NT A #
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #1 στις: 19 Μάι 2006, 11:45:00 πμ »
:) :) :)

Vangelis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 784
  • Για ακούτε και κανένα μεγαλύτερο!!!
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #2 στις: 19 Μάι 2006, 11:58:21 μμ »
Ποιός τον έγραψε αυτόν βρε παιδιά!!!

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2442
  • I 'm not young enough to know everything
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #3 στις: 10 Ιαν 2007, 11:15:43 πμ »
Σε αντιπαράθεση των παραπάνω περιγράφω μια λύση μαθήτριας που είδα πρόσφατα
Αφού περιέγραψα στα παιδιά τη διαδικασία και κάναμε έναν πολλαπλασιασμό με το χέρι για να δούμε τα βήματα, τους είπα να υλοποιήσουν τον αλγόριθμο σε ψευδογλώσσα.
Είχα τη χαρά να δω μια μαθήτρια να συλλαμβάνει έναν από τους πιο ωραίους αλγορίθμους.

Δεδομένα //χ, ψ//
γινόμενο < - 0
Αρχή_επανάληψης
  γινόμενο < - γινόμενο + χ * (ψ mod2)   ! Τι σκέφτηκε το άτομο!!!
  χ < - 2* χ
  ψ < - ψ div 2
Μέχρις_ότου ψ = 0
Εμφάνισε γινόμενο
Γιώργος Παπαργύρης (gpapargi@hotmail.com)

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 704
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #4 στις: 10 Ιαν 2007, 11:43:40 πμ »
Είστε τυχεροί!!!
Μακάρι να είχα και εγώ τετοιες συγκινήσεις έστω και στα 31 πιστεύω να το άντεχα. :-)
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3136
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #5 στις: 10 Ιαν 2007, 03:37:52 μμ »

Πολύ ωραίο, αλλά ο στόχος του πολλαπλασιασμού αλά ρωσικά είναι να μη χρησιμοποιηθεί ο τελεστής * (του πολλαπλασιασμού)  :D

Ελένη, εσύ έχεις το Φοίβο, μη σκιάζεσαι  :o

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 797
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #6 στις: 10 Ιαν 2007, 04:00:38 μμ »
Παναγιώτη,

"παίξε" βρε συ εκείνο το ωραίο "κομμάτι" που είχες φτιάξει, να δεις πώς το λέγαν, πώς το λέγαν ... ... ... ΑΑΑ ύψωση σε δύναμη α λα ρωσσικά !!  :D

ΤΙ ωραία άσκηση !!!

Βάλε τη να τη δούνε όλοι να ... θαυμάσουν  :)
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 704
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #7 στις: 10 Ιαν 2007, 11:52:32 μμ »
Τελικά έτσι θα καταλήξω. Στην ανάγκη του Φοίβου αν καταργηθεί η ΑΕΠΠ.  ;D
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 797
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #8 στις: 14 Ιαν 2007, 12:14:22 πμ »
Επειδή ο Παναγιώτης είναι μάλλον πολύ ... μετριόφρων για να απαντήσει στην "πρόσκληση", θα μου επιτρέψει να την "ανεβάσω" εγώ την άσκηση. 

Γνωρίζοντας την "δέσμευσή" του να προσφέρει το έργο του για ελεύθερη χρήση (με τις αυτονόητες ηθικές υποχρεώσεις όσων το χρησιμοποιούν) πιστεύω δε θα με παρεξηγήσει.

Ιδού λοιπόν:

Να σχηματίσετε το διάγραμμα ροής για την παρακάτω κωδικοποίηση.
Nα σχηματίσετε τον πίνακα τιμών αν
i. x = 4, n = 2,
ii. x = 3, n = 3 
Μελετώντας τα αποτελέσματα, ποια πιστεύετε ότι είναι η λειτουργία του αλγορίθμου;

Κώδικας: Text
  1. Αλγόριθμος Ασκηση
  2.   Διάβασε x, n
  3.   m &#8592; n
  4.   z &#8592; x
  5.   αποτέλεσμα &#8592; 1
  6.   Όσο m > 0 επανάλαβε
  7.     Όσο (m mod 2 = 0) επανάλαβε
  8.     m &#8592; m div 2
  9.     z &#8592; z * z
  10.     Τέλος_επανάληψης
  11.     m &#8592; m - 1
  12.     αποτέλεσμα &#8592; αποτέλεσμα * z
  13.   Τέλος_επανάληψης
  14.   Εκτύπωσε αποτέλεσμα
  15. Τέλος Ασκηση
  16.  

Δεν είναι πολλαπλασιασμός αλα ρωσσικά, όμως νομίζω ότι "φέρνει λίγο" σε ... κάτι αλα ρωσσικά.

Ας τον εξετάσει επομένως (και ας τον "βαφτίσει") ο καθένας μόνος του  ;)
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3136
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #9 στις: 14 Ιαν 2007, 05:57:52 μμ »

Σέργιε, πρόκειται για τη ΔΣ3 στο κεφάλαιο 4 (σελίδα 42 τετραδίου μαθητή) που είναι πλέον ο μόνος αλγόριθμος στο διδακτικό πακέτο που δεν έχει χρησιμοποιηθεί ακόμα στα θέματα των εξετάσεων. Και τώρα με τη διαφήμισή του, δεν πρόκειται να μπει ποτέ  :'( . Εγώ απλά πρόσθεσα το διάγραμμα ροής. Κρίμα, και είχα πιάσει το θέμα των εξετάσεων    :o

Μπορείς με αυτόν τον αλγόριθμο να υπολογίσεις την ύψωση σε δύναμη αν στο πληκτρολόγιό σου δεν δουλεύει το ^  ;D

Με εκτίμηση, Παναγιώτης

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 797
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #10 στις: 14 Ιαν 2007, 09:03:25 μμ »
Τώρα αν πω:

...Ναι ρε συ... το θυμόμουν!!! Ήθελα να δω αν θα αφήσεις να υποθέσουμε ότι είναι δική σου η άσκηση...

θα πείσω κανένα;; :-[
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3136
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #11 στις: 15 Ιαν 2007, 05:06:39 μμ »

Εγώ σε πιστεύω γιατί είσαι καλός μου φίλος, global moderator και Λαρισαίος

sogruokyl

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #12 στις: 09 Ιαν 2008, 03:39:34 πμ »

Ο ανηψούλης μου από την Τενεούπολη με ρώτησε αν ο παρακάτω αλγόριθμος (για τον πολ/σμό αλά ρωσικά) είναι σωστός (δεν τον σκέφτηκε μόνος του):

   Δεδομένα // Μ1, Μ2 //
   P ← 0
   Για Ε από Μ2 μέχρι 0 με_βήμα Κ
      Αν Ε mod 2 = 1 τότε
           P ← P + M1
      Τέλος_αν
      M1 ← M1*2
      K ← M2 div 2
   Τέλος_επανάληψης
   Αποτελέσματα // P //

Ο γιατρός μου είπε οτι ήμουν πολύ τυχερός που τη γλύτωσα και πως πρέπει να προσέχω πολύ στο εξής. Σε επόμενη παρόμοια...συγκίνηση μπορεί να μην είμαι τόσο τυχερός. Δεν είναι και πολύ συνηθισμένες τέτοιες κρίσεις στα 29...

Με εκτίμηση,



Φίλε Παναγιώτη,
Καταλαβαίνω τη λογική του αλγόριθμου, αλλά αν δεν κάνω λάθος, δε δουλεύει...
Καταρχήν, φαντάζομαι ότι εννοούσες "με_βήμα -Κ"
Επίσης, φαντάζομαι ότι εννοούσες "K <-- E div 2" και όχι "K <-- M2 div 2"
Αλλά και πάλι αν αφαιρεί το Κ συνεχώς, στην περίπτωση που το Ε είναι περιττός δε δουλεύει...
Πρέπει να αφαιρεί το Κ+1... (και "μέχρι 1")

Έσπασα το κεφάλι μου να δω μήπως δεν έχω καταλάβει τη λογική σου και εννοείς κάτι διαφορετικό
από αυτό που κατάλαβα... Άν μπορείς εσύ ή κάποιος άλλος παρακαλώ απαντήστε μου, ευχαριστώ
εκ των προτέρων!

Αν έχω δίκιο τότε διορθωμένο πρέπει να είναι έτσι:

Δεδομένα // Μ1, Μ2 //
P ← 0
Για Ε από Μ2 μέχρι 1 με_βήμα -Κ
   Αν Ε mod 2 = 1 τότε
      P ← P + M1
      K ← Ε div 2 + 1
   Αλλιώς
      K ← Ε div 2
   Τέλος_αν
   M1 ← M1*2
Τέλος_επανάληψης
Αποτελέσματα // P //

(Το δοκίμασα στη Γλωσσομάθεια και δουλεύει, απλά πρέπει να δωθεί αρχική τιμή στο Κ)

Φαντάζομαι οτι συμφωνείς πως είναι απαράδεκτο να αλλάζει η τιμή του μετρητή (του i ή εδώ του Ε)
μέσα στην επανάληψη. ʼραγε δεν είναι άσχημο να αλλάζει τιμή το βήμα (εδώ το Κ);

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3136
  • Dracarys
    • Panagiotis Tsiotakis
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #13 στις: 09 Ιαν 2008, 01:39:03 μμ »
Φίλε Λυκούργε,

Ακριβώς όπως επισημαίνεις:

Η αρχική τιμή, η τελική, το βήμα και η τιμή του μετρητή δεν πρέπει ΠΟΤΕ να αλλάζουν τιμή εντός του βρόχου (τετράδιο μαθητή). Χιλιοειπωμένο και χιλιοσχολιασμένο.

Κι αυτό γιατί η δομή Για που είναι φτιαγμένη για να επιλύει προβλήματα με γνωστό πλήθος επαναλήψεων τα διαχειρίζεται η ίδια. Απο κει και πέρα αν θέλουμε κάτι άλλο στον αλγόριθμο μπορούμε απλά να χρησιμοποιήσουμε μια απο τις Όσο και Μέχρις_ότου.


Το έχω πει περίπου απο το 2003 που συμμετέχω σε αυτό το φορουμ: το μεγάλο πρόβλημα δεν είναι το διδακτικό πακέτο ή κάτι άλλο, αλλά η εμμονή ημών των καθηγητών να εντάσσουμε τις προγραμματιστικές μας γνώσεις (διαφορετικές ο κάθε ένας) σε αυτό το μάθημα αγνοώντας τις ειδικές συνθήκες που το διέπουν, αλλά και τους στόχους που καλείται να εκπληρώσει...
Και μερικές φορές ψάχνουμε το περίεργο, το ακραίο για εξάσκηση, για να εντυπωσιάσουμε ή για άλλους λόγους..  :'(

xazlag

  • Νέος
  • *
  • Μηνύματα: 7
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #14 στις: 13 Ιαν 2008, 10:54:50 πμ »
Καλήμερα!
Στον πολ/σμο αλα ρώσικα, για τον 2ο αριθμό που διαιρείται με το 2, οι εντολές  Μ2<--Α_Μ(Μ2/2) και
Μ2<--Μ2div 2 είναι ισοδύναμες;
Ευχαριστώ