Αποστολέας Θέμα: Διδακτική προσέγγιση του αλγόριθμου της Ταξινόμησης φυσαλίδας  (Αναγνώστηκε 2011 φορές)

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Συνάδελφοι θα θέλαμε να μοιραστούμε μαζί σας μία πρόταση-διδακτική προσέγγιση του αλγόριθμου της ταξινόμησης ευθείας ανταλλαγής ή φυσαλίδας που παρουσιάσαμε στο 6ο Πανελλήνιο Συνέδριο «Διδακτική της Πληροφορικής» που πραγματοποιήθηκε στην Φλώρινα.
Η προτεινόμενη διδακτική προσέγγιση με σκοπό την ταξινόμηση των στοιχείων ενός πίνακα στηρίζεται σε μία σκαλωσιά μάθησης με τη διαπραγμάτευση εννοιών και αξιοποίηση στοχευμένων δραστηριοτήτων και στις τρεις αλγοριθμικές συνιστώσες (ακολουθία, επιλογή και επανάληψη).
Η εισήγηση και η παρουσίαση βρίσκονται στο σύνδεσμο: http://wp.me/pykbG-c9 στο blog aepp.wordpress.com

Όπως πάντα ευπρόσδεκτα τα σχόλια και οι παρατηρήσεις.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3153
  • to Iterate is human to Recurse divine
βασικά δεν είδα τον τίτλο του θέματος πριν , από το μήνυμά σου νόμισα ότι ήταν το αρχικό θέμα για τη φυσαλίδα, για αυτό απάντησα εκεί.
Δεν έχω κάποιο άλλο σχόλιο, δεν έχω προλάβει να διαβάσω την εργασία απλά παρατήρησα ότι κατά τη γνώμη μου ένας μαθητής θα καταλάβει καλύτερα το
εύρεση μικρότερου ή 2 μικρότερων από το ταξινόμηση 1 ή 2. Δηλαδή χρησιμοποιείς σαν σκαλωσιά την εύρεση του μικρότερου που είναι μια έννοια που ήδη ξέρεις ώστε να φτάσεις σιγά σιγά στη φυσαλίδα
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 542
  • There can be only one...may it be AEPP.
Καλησπέρα.
Αν κάποιος έκανε την ταξινόμηση στοιχείων ενός πίνακα όπως παρακάτω πόσο περισσότερο επιβαρύνεται ο κώδικας;
Κώδικας: [Επιλογή]
  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 10
    ΔΙΑΒΑΣΕ Π[I]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 10
    ΜΑΧ <- Π[Κ]
    Θ <- Κ
    ΓΙΑ I ΑΠΟ Κ + 1 ΜΕΧΡΙ 10
      ΑΝ Π[I] > ΜΑΧ ΤΟΤΕ
        ΜΑΧ <- Π[I]
        Θ <- I
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    TEMP <- Π[Θ]
    Π[Θ] <- Π[Κ]
    Π[Κ] <- TEMP
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Δεν επιβαρύνεται καθόλου.
Είναι μια χαρά ταξινόμηση και διαισθητικά οι μαθητές, αν τους αφήσει κανείς να ανακαλύψουν την ταξινόμηση, σε μια τέτοια πρόταση τείνουν να καταλήγουν.
Προσωπικά δεν καταλαβαίνω για ποιο λόγο αναγκάζονται να μαθαίνουν μια πιο δυσνόητη μέθοδο, από τη στιγμή που είναι το ίδιο μη-αποδοτική ...
Φιλικά,
Γιώργος Θαλασσινός

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2450
  • I 'm not young enough to know everything
Η φυσσαλίδα υπάρχει γιατί έχει την έξυπνη έκδοση που καταλαβαίνει την πρόωρη ταξινόμηση και σταματάει. Άρα η λογική λέει: «είτε διδάσκεις και χρησιμοποιείς  την έξυπνη φυσσαλίδα γιατί είναι πιο γρήγορη από την ταξινόμηση επιλογής, είτε διδάσκεις την επιλογή  που είναι πιο απλή». Το να διδάσκεις την αργή φυσσαλίδα και να μένεις σε αυτή απλά δεν έχει νόημα. Δείχνει ότι δεν καταλαβαίνουμε γιατί διδάσκουμε το καθετί.

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 891
Έτσι ακριβώς!
Φιλικά,
Γιώργος Θαλασσινός