Αποστολέας Θέμα: Αλγοριθμικά κριτήρια  (Αναγνώστηκε 1115 φορές)

PE19

  • Θαμώνας
  • ***
  • Μηνύματα: 37
Αλγοριθμικά κριτήρια
« στις: 02 Μάι 2011, 11:31:16 μμ »
Δίνεται πίνακας Π, 10 ακεραίων και το ακόλουθο τμήμα αλγορίθμου:

Αλγόριθμος αλκριτ
Δεδομμένα // Π //
Για ι από 1 μέχρι 11
 Εμφάνισε Π[ι]
Τέλος_επανάληψης
...

α) Ποιό ή ποιά αλγοριθμικά κριτήρια δεν ικανοποιεί;
β) να αιτιολογήσετε την απάντησή σας

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: Αλγοριθμικά κριτήρια
« Απάντηση #1 στις: 02 Μάι 2011, 11:52:20 μμ »
Ήθελα να το πω και παλιότερα, σε μία αντίστοιχη συζήτηση... Δεν θυμάμαι όμως που είναι τώρα. Πολλές φορές προσπαθούμε να συσχετίσουμε τα "αλγοριθμικά κριτήρια", που όπως έχει ειπωθεί θα έπρεπε να λέγονται "χαρακτηριστικά που πρέπει να έχει κάποιος αλγόριθμος" με διάφορα είδη λαθών σε έναν αλγόριθμο (συντακτικά, λογικά ή χρόνου εκτέλεσης).
Ίσως το συγκεκριμένο θέμα είναι ένα από αυτά που θα πρέπει να αναζητήσουμε λάθη αντί την μη ικανοποίηση κάποιου ή καποιων αλγοριθμικών κριτηρίων...

Για την ιστορία θυμάμαι ότι είναι από τα παραδείγματα που έχει συμπεριληφθεί στο άρθρο των Τσιωτάκη, Στέργου, Αδαμόπουλου, Ψαλτίδου (2010), Το διδακτικό πακέτο του μαθήματος ΑΕΠΠ. Ασάφειες και επακόλουθα προβλήματα στο βιβλίο που εκδόθηκε από την ΕΠΥ μετά την ημερίδα του Ιανουαρίου 2010, http://www.scribd.com/full/37994803?access_key=key-1xz92oy35skdi37vco0h

Δίνεται πίνακας Π, 10 ακεραίων και το ακόλουθο τμήμα αλγορίθμου:

Αλγόριθμος αλκριτ
Δεδομμένα // Π //
Για ι από 1 μέχρι 11
 Εμφάνισε Π[ι]
Τέλος_επανάληψης
...

α) Ποιό ή ποιά αλγοριθμικά κριτήρια δεν ικανοποιεί;
β) να αιτιολογήσετε την απάντησή σας