Αποστολέας Θέμα: ypoprogrammata- pol/mos lala rwsika  (Αναγνώστηκε 2754 φορές)

kiro

  • Βετεράνος
  • ****
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
ypoprogrammata- pol/mos lala rwsika
« στις: 04 Απρ 2006, 04:18:43 μμ »
Καλησπέρα!

Έχουμε να υπολογίσουμε το άθροισμα δυο δισδιάστατων πινάκων με συνάρτηση

   ΣΥΝΑΡΤΗΣΗ Αθροισμα_Πινακων (Α,Β)
   ΜΕΤΑΒΛΗΤΕΣ
      ΠΡΑΓΜΑΤΙΚΕΣ: Α[100,100], Β[100,100],Γ[100,100]
      ΑΚΕΡΑΙΕΣ: i, j
   ΑΡΧΗ
      ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
         ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 100
            Γ[i,j]<- A[i,j] + B[i,j]
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      Αθροισμα_Πινακων <- Γ [i,j]
   ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Είναι σωστό να εκχωρήσουμε στο όνομα της συνάρτησης τον νέο πίνακα?

 
Θα ήθελα να ρωτήσω και κάτι ακόμα άσχετο με τα υποπρογράμματα. Σχετικά με τον πολλαπλασιασμό αλά ρωσικά δεν θα ήταν πιο σωστό να χρησιμοποιήσουμε

Αντί για Όσο α>0 επανάλαβε…… όσο α>1 ή α>=1 (αν και πάλι θα επαναλάβει αν είναι 1)

Με το όσο α >0 θα επαναλάβει και όταν το α=1 Εμείς θέλουμε να επαναλαμβάνει όσο ο αριθμός είναι μεγαλύτερος από 1 και να σταματήσει όταν είναι 1

Ευχαριστω!

filippos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 139
Απ: ypoprogrammata- pol/mos lala rwsika
« Απάντηση #1 στις: 04 Απρ 2006, 05:02:46 μμ »
1)
α. Η συνάρτηση υπολογίζει και επιστρέφει μία τιμή με το όνομά της.
β. Ο πίνακας δεν είναι μία αλλά πολλές τιμές

α. + β. => ΔΕΝ μπορούμε να εκχωρήσουμε πίνακα στο όνομα της συνάρτησης

2) ο πολ/σμός α λα ρωσσικά ΔΕΝ θα βγάλει σωστό αποτέλεσμα αν αλλαχθεί η συνθήκη συνέχειας όπως προτείνεις.  Ο πολ/σμός α λα ρωσσικά στηρίζεται στην άθροιση των τιμών του ενός τελεσταίου (του διπλασιαζόμενου) όποτε ο άλλος (ο υποδιπλασιαζόμενος) είναι μονός.  Το 1 είναι μονός αριθμός οπότε θα πρέπει να εκτελεστεί ο βρόχος για να προσθέσει τον άλλο και να προκύψει σωστό αποτέλεσμα.  Δοκίμασέ το.

kiro

  • Βετεράνος
  • ****
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: ypoprogrammata- pol/mos lala rwsika
« Απάντηση #2 στις: 04 Απρ 2006, 07:12:34 μμ »

Δηλ δεν μπορω να υπολογισω το άθροισμα δυο διασιαστατων πινακων με συναρτηση?θα πρεπει να χρησιμοποιησω διαδικασια?


kiro

  • Βετεράνος
  • ****
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: ypoprogrammata- pol/mos lala rwsika
« Απάντηση #4 στις: 05 Απρ 2006, 06:27:40 μμ »
 ok...sas eyxaristw!

xaidi

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 111
  • who is WHO!!!!!!
Απ: ypoprogrammata- pol/mos lala rwsika
« Απάντηση #5 στις: 06 Απρ 2006, 10:58:57 πμ »
Αν η επεξεργασία που ζητείται στον πίνακα δίνει ως αποτέλεσμα παραπάνω από μια τιμή ή όλο τον πίνακα ή κάποια μετατροπή του πρώτου κλπ χρησιμοποιείς διαδικασία. Αν το αποτέλεσμα είναι μια τιμή πχ ελάχιστο στοιχείων ή άθροισμα στοιχείων μπορείς να επιλέξεις να φτιάξεις και συνάρτηση.
Ευχαριστώ,