Αποστολέας Θέμα: Τελικό Επαναληπτικό Διαγώνισμα 2009-2010 απο το Στέκι  (Αναγνώστηκε 30748 φορές)

TorusKnot

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2009-2010 απο το Στέκι
« Απάντηση #105 στις: 15 Μάι 2010, 02:43:24 μμ »
Συγχαρητήρια σε όλη την ομάδα

Οι δικές μου λύσεις για τα ερωτήματα ε και στ.

      ! ε ερώτημα
      ΓΙΑ έτος ΑΠΟ 1 ΜΕΧΡΙ 15
            κ ← 0
            ΓΙΑ χώρα ΑΠΟ 1 ΜΕΧΡΙ 76            
                  ΑΝ  Θέση[χώρα, έτος] = 1  Ή Θέση[χώρα, έτος] = 2 ΤΟΤΕ
                        κ ← κ + 1
                        Ζ[έτος, κ] ← χώρα
                  ΤΕΛΟΣ_ΑΝ   
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

      ! στ ερώτημα
      max ← 0
      ΓΙΑ έτος ΑΠΟ 1 ΜΕΧΡΙ 15
            πλήθος[έτος] ← 0
            ΓΙΑ χρονιά ΑΠΟ 1 ΜΕΧΡΙ 15
                  ΑΝ Ζ[έτος, 1] = Ζ[χρονιά, 1] ΚΑΙ Ζ[έτος, 2] = Ζ[χρονιά, 2] ΤΟΤΕ
                        πλήθος[έτος] ← πλήθος[έτος] + 1
                  ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΑΝ πλήθος[έτος] > max TOTE
                  max ← πλήθος[έτος]
                  θέση ← έτος
            ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΕΜΦΑΝΙΣΕ Ομάδα[Ζ[θέση, 1]], Ομάδα[Ζ[θέση, 2]]

Σχόλια:
1.   Στο ερώτημα (ε) εξασφαλίζεται κατά τη δημιουργία του πίνακα Ζ (με τα ζευγάρια των τελικών) ότι η πρώτη ομάδα κάθε ζευγαριού (γραμμής) είναι αυτή με τη μικρότερη θέση στον πίνακα Ομάδες. Επομένως δεν χρειάζεται η αντιμετάθεση.
2.   Στο ερώτημα (στ), έχουμε δημιουργία του πίνακα πλήθος, παράλληλο στον πίνακα Ζ που δημιουργήθηκε στο ερώτημα (ε), ο οποίος για κάθε γραμμή (ζευγάρι τελικού) του πίνακα Ζ, περιέχει το πλήθος των εμφανίσεων του στον πίνακα Ζ. Έπειτα εύρεση μέγιστου στον πίνακα πλήθος και εμφάνιση του αντίστοιχου ζευγαριού.

Ευχαριστώ για την πρόκληση..

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2009-2010 απο το Στέκι
« Απάντηση #106 στις: 15 Μάι 2010, 03:07:31 μμ »
Πολύ καλή λύση

1.   Στο ερώτημα (ε) εξασφαλίζεται κατά τη δημιουργία του πίνακα Ζ (με τα ζευγάρια των τελικών) ότι η πρώτη ομάδα κάθε ζευγαριού (γραμμής) είναι αυτή με τη μικρότερη θέση στον πίνακα Ομάδες. Επομένως δεν χρειάζεται η αντιμετάθεση.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

pgrontas

  • Ομάδα διαγωνισμάτων 2016
  • *
  • Μηνύματα: 1315
  • There are always possibilities...
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2009-2010 απο το Στέκι
« Απάντηση #107 στις: 15 Μάι 2010, 04:35:39 μμ »
Νομίζω ότι στο στ της παραπάνω λύσης δεν χρειάζεται ο πίνακας πλήθος.
A man provided with paper, pencil, and rubber, and subject to strict discipline is in effect a universal machine - Alan Turing

TorusKnot

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2009-2010 απο το Στέκι
« Απάντηση #108 στις: 15 Μάι 2010, 05:24:27 μμ »
Έχεις δίκιο... Εφόσον η σύγκριση γίνεται εντός της εξωτερικής επανάληψης μία μεταβλητή αρκεί...  ;) Παρασύρθηκα από το γενικό κλίμα των πινάκων και έγινα... large. Ευχαριστώ για την επισήμανση

miltiathis

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2009-2010 απο το Στέκι
« Απάντηση #109 στις: 20 Μάι 2010, 05:34:11 μμ »
Συγχαρητήρια!

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2009-2010 απο το Στέκι
« Απάντηση #110 στις: 20 Μάι 2010, 07:25:11 μμ »
Πολύ καλή λύση

Συγχαρητήρια σε όλη την ομάδα

Οι δικές μου λύσεις για τα ερωτήματα ε και στ.

      ! ε ερώτημα
      ΓΙΑ έτος ΑΠΟ 1 ΜΕΧΡΙ 15
            κ ← 0
            ΓΙΑ χώρα ΑΠΟ 1 ΜΕΧΡΙ 76            
                  ΑΝ  Θέση[χώρα, έτος] = 1  Ή Θέση[χώρα, έτος] = 2 ΤΟΤΕ
                        κ ← κ + 1
                        Ζ[έτος, κ] ← χώρα
                  ΤΕΛΟΣ_ΑΝ   
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

      ! στ ερώτημα
      max ← 0
      ΓΙΑ έτος ΑΠΟ 1 ΜΕΧΡΙ 15
            πλήθος[έτος] ← 0
            ΓΙΑ χρονιά ΑΠΟ 1 ΜΕΧΡΙ 15
                  ΑΝ Ζ[έτος, 1] = Ζ[χρονιά, 1] ΚΑΙ Ζ[έτος, 2] = Ζ[χρονιά, 2] ΤΟΤΕ
                        πλήθος[έτος] ← πλήθος[έτος] + 1
                  ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΑΝ πλήθος[έτος] > max TOTE
                  max ← πλήθος[έτος]
                  θέση ← έτος
            ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΕΜΦΑΝΙΣΕ Ομάδα[Ζ[θέση, 1]], Ομάδα[Ζ[θέση, 2]]

Σχόλια:
1.   Στο ερώτημα (ε) εξασφαλίζεται κατά τη δημιουργία του πίνακα Ζ (με τα ζευγάρια των τελικών) ότι η πρώτη ομάδα κάθε ζευγαριού (γραμμής) είναι αυτή με τη μικρότερη θέση στον πίνακα Ομάδες. Επομένως δεν χρειάζεται η αντιμετάθεση.
2.   Στο ερώτημα (στ), έχουμε δημιουργία του πίνακα πλήθος, παράλληλο στον πίνακα Ζ που δημιουργήθηκε στο ερώτημα (ε), ο οποίος για κάθε γραμμή (ζευγάρι τελικού) του πίνακα Ζ, περιέχει το πλήθος των εμφανίσεων του στον πίνακα Ζ. Έπειτα εύρεση μέγιστου στον πίνακα πλήθος και εμφάνιση του αντίστοιχου ζευγαριού.

Ευχαριστώ για την πρόκληση..

Νομίζω ότι χρειάζεται να συμπληρωθεί η συνθήκη 
ΑΝ (Ζ[έτος, 1] = Ζ[χρονιά, 1] ΚΑΙ Ζ[έτος, 2] = Ζ[χρονιά, 2]) Η (Ζ[έτος, 1] = Ζ[χρονιά, 2] ΚΑΙ Ζ[έτος, 2] = Ζ[χρονιά, 1]) ΤΟΤΕ

        πλήθος <- πλήθος + 1

      ΤΕΛΟΣ_ΑΝ
VR in Computing

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2009-2010 απο το Στέκι
« Απάντηση #111 στις: 20 Μάι 2010, 07:52:23 μμ »
Όχι δεν χρειάζεται  γιατί

Παράθεση
Στο ερώτημα (ε) εξασφαλίζεται κατά τη δημιουργία του πίνακα Ζ (με τα ζευγάρια των τελικών) ότι η πρώτη ομάδα κάθε ζευγαριού (γραμμής) είναι αυτή με τη μικρότερη θέση στον πίνακα Ομάδες. Επομένως δεν χρειάζεται η αντιμετάθεση.


Νομίζω ότι χρειάζεται να συμπληρωθεί η συνθήκη 
ΑΝ (Ζ[έτος, 1] = Ζ[χρονιά, 1] ΚΑΙ Ζ[έτος, 2] = Ζ[χρονιά, 2]) Η (Ζ[έτος, 1] = Ζ[χρονιά, 2] ΚΑΙ Ζ[έτος, 2] = Ζ[χρονιά, 1]) ΤΟΤΕ

        πλήθος <- πλήθος + 1

      ΤΕΛΟΣ_ΑΝ
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 175
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2009-2010 απο το Στέκι
« Απάντηση #112 στις: 20 Μάι 2010, 09:10:09 μμ »
Όχι δεν χρειάζεται  γιατί



Σωστά δίκιο έχεις.
VR in Computing

ILAMPRIADIS

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2009-2010 απο το Στέκι
« Απάντηση #113 στις: 25 Νοέ 2010, 04:29:32 μμ »
Τελικό Επαναληπτικό Διαγώνισμα 2009-2010 εφ'όλης της ύλης απο την ομάδα διαγωνισμάτων του στεκιού.

Έγινε μια μικρή τροποποίηση στο Θέμα 1Ε β του τελικού διαγωνίσματος Τρίτη 13/4 10:35 μ.μ.

Όσοι επθυμούν ας ξανακατεβάσουν τη διορθωμένη έκδοση


Στις 11/5 προστέθηκαν και οι λύσεις.
Στο πρώτο αρχείο δίνονται οι προτεινόμενες λύσεις και στο δεύτερο αρχείο έχουμε εναλλακτικές λύσεις για κάποια από τα ερωτήματα.