Αποστολέας Θέμα: ΑΠΟΡΙΑ ΣΕ ΑΣΚΗΣΗ  (Αναγνώστηκε 1648 φορές)

petros93

  • Νέος
  • *
  • Μηνύματα: 9
ΑΠΟΡΙΑ ΣΕ ΑΣΚΗΣΗ
« στις: 26 Νοέ 2010, 10:48:12 πμ »
Γεια σας.
Η καθηγήτριά μας, μας έβαλε σε διαγώνισμα την εξής άσκηση:

Να διαβάζετε το πολύ 10 αριθμούς και να υπολογίζετε-εμφανίζετε το πλήθος, το άθροισμα και το μέσο όρο τους. Επίσης η επανάληψη τερματίζεται όταν θα διαβαστεί ο αριθμός 0 (μηδέν).

Θα ήθελα την γνώμη σας αν την έκανα σωστά ή όχι (αν όχι τι λάθος έκανα?). Ακολουθεί η λύση την οποία έδωσα:

σ<- 0
ι<- 0
διάβασε χ
όσο (ι<10) και (χ<>0) επανάλαβε
   σ<- σ+χ
   ι<- ι+1
   διάβασε χ
τέλος_επανάληψης
μο<- σ/ι
εμφάνισε ι, σ, μο



 
Ευχαριστώ...

papet

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 48
    • Σεληνιακό Πάρκο - Σκέψεις και Ημέρες
Απ: ΑΠΟΡΙΑ ΣΕ ΑΣΚΗΣΗ
« Απάντηση #1 στις: 26 Νοέ 2010, 11:08:22 πμ »
Προτού προχωρήσεις σε διαίρεση με το πλήθος των αριθμών, θα μπορούσες να σιγουρευτείς ότι δεν δόθηκε ως πρώτος αριθμός το 0.
May the Force b with u...
papet

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: ΑΠΟΡΙΑ ΣΕ ΑΣΚΗΣΗ
« Απάντηση #2 στις: 26 Νοέ 2010, 01:49:49 μμ »
Υπάρχει ένα μικρό προβληματάκι στο ότι όταν φτάσει το ι στο 10, θα διαβάσει και ενδέκατο βαθμό και μετά θα σταματήσει
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

petros93

  • Νέος
  • *
  • Μηνύματα: 9
Απ: ΑΠΟΡΙΑ ΣΕ ΑΣΚΗΣΗ
« Απάντηση #3 στις: 26 Νοέ 2010, 02:52:57 μμ »
Δηλαδή papet έπρεπε να γίνει κάπως έτσι ?

σ<- 0
ι<- 0
διάβασε χ
όσο (ι<10) και (χ<>0) επανάλαβε
   σ<- σ+χ
   ι<- ι+1
   διάβασε χ
τέλος_επανάληψης
Αν ι<>0 τότε
μο<- σ/ι
εμφάνισε ι, σ, μο
τέλος_αν

petros13 το προβληματάκι που ανάφερεις πως λύνεται ??

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: ΑΠΟΡΙΑ ΣΕ ΑΣΚΗΣΗ
« Απάντηση #4 στις: 26 Νοέ 2010, 03:29:27 μμ »
Βάλε ένα "Αν" μέσα στην επανάληψη
Αν ι <10 τότε
Διάβασε χ
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

petros93

  • Νέος
  • *
  • Μηνύματα: 9
Απ: ΑΠΟΡΙΑ ΣΕ ΑΣΚΗΣΗ
« Απάντηση #5 στις: 26 Νοέ 2010, 03:32:02 μμ »
Ευχαριστώ πολύ