Αποστολέας Θέμα: ΕΡΩΤΗΣΗ ΣΕ ΑΣΚΗΣΗ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ  (Αναγνώστηκε 1435 φορές)

MARIA THEOHARI

  • Οπαδός
  • **
  • Μηνύματα: 12
ΕΡΩΤΗΣΗ ΣΕ ΑΣΚΗΣΗ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ
« στις: 02 Νοέ 2010, 09:23:26 πμ »
Δίνεται η παρακάτω εκφώνηση:
Ένα πάρκινγκ χρεώνει τα οχήματα ως εξής:
1,2 € για όλες τις ώρες και αν υπάρχουν ώρες πάνω από 5, κάθε μια από αυτές χρεώνεται επιπλέον 0,5 €.

Ποιά λύση από τις 2 είναι σωστή;
αν ω<=5 τοτε
    ΧΡ<-- 1,2
Αλλιώς
    χρ<--1,2 + (ω-5)*0,5
τέλος_αν

ή

αν ω<=5 τοτε
    ΧΡ<-- 1,2*ω
Αλλιώς
    χρ<--1,2*ω + (ω-5)*0,5
τέλος_αν



Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: ΕΡΩΤΗΣΗ ΣΕ ΑΣΚΗΣΗ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ
« Απάντηση #1 στις: 02 Νοέ 2010, 10:09:33 πμ »
Βάσει της εκφώνησης η λύση 1 είναι ok...

Η λύση 2 ερμηνεύει διαφορετικά την διατύπωση του προβλήματος... (κάθε μία από τις πέντε ώρες χρεώνεται με 1.2 ευρώ)...

Δίνεται η παρακάτω εκφώνηση:
Ένα πάρκινγκ χρεώνει τα οχήματα ως εξής:
1,2 € για όλες τις ώρες και αν υπάρχουν ώρες πάνω από 5, κάθε μια από αυτές χρεώνεται επιπλέον 0,5 €.

Ποιά λύση από τις 2 είναι σωστή;
αν ω<=5 τοτε
    ΧΡ<-- 1,2
Αλλιώς
    χρ<--1,2 + (ω-5)*0,5
τέλος_αν

ή

αν ω<=5 τοτε
    ΧΡ<-- 1,2*ω
Αλλιώς
    χρ<--1,2*ω + (ω-5)*0,5
τέλος_αν




Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1088
Απ: ΕΡΩΤΗΣΗ ΣΕ ΑΣΚΗΣΗ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ
« Απάντηση #2 στις: 02 Νοέ 2010, 11:28:26 πμ »
Η 2η λύση παραπέμπτει σε κλιμακωτό υπολογισμό.

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1465
  • Δεν αντέχω την (συμ)-πίεσηηη .......
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: ΕΡΩΤΗΣΗ ΣΕ ΑΣΚΗΣΗ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ
« Απάντηση #3 στις: 02 Νοέ 2010, 04:04:08 μμ »
Υπάρχει μια ασάφεια στη διατύπωση της άσκησης (τι σημαίνει όλες τις ώρες ;) για το αν για τις 5 ώρες χρεώνονται 1,2 € συνολικά ή ανά ώρα, οπότε η 1η λύση απαντά σωστά την 1η εκφώνηση και η 2η την άλλη.
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

Vangelis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 786
  • Για ακούτε και κανένα μεγαλύτερο!!!
Απ: ΕΡΩΤΗΣΗ ΣΕ ΑΣΚΗΣΗ ΣΤΗ ΔΟΜΗ ΕΠΙΛΟΓΗΣ
« Απάντηση #4 στις: 02 Νοέ 2010, 10:34:26 μμ »
"Η κατανόηση ενός προβλήματος εξαρτάται σε μεγάλο βαθμό απο την διατύπωσή του"   σελ 6

Εδω είναι σαφές ότι δεν υπάρχει σαφήνεια διατύπωσης.