Αποστολέας Θέμα: Υλοποίηση Αλγορίθμου Εισαγωγής  (Αναγνώστηκε 1114 φορές)

Θεοπίστη

  • Νέος
  • *
  • Μηνύματα: 3
Υλοποίηση Αλγορίθμου Εισαγωγής
« στις: 13 Μάρ 2010, 12:43:22 πμ »
Καταρχάς συγχαρητήρια σε όλους για αυτό το forum! Θα ήθελα να ρωτήσω αν γίνεται να υλοποιηθεί ο αλγόριθμος Ευθείας Εισαγωγής ως εξής:
Κώδικας: [Επιλογή]
Για κ από 2 μέχρι Ν+1
   λ <-- κ -1
   Όσο (λ<>0) επανάλαβε
      Αν Α[λ+1] < Α[λ] τότε
         temp <-- Α[λ]
         Α[λ] <-- Α[λ+1]
         Α[λ+1] <-- temp
         λ <-- λ -1
      Αλλιώς
         λ <-- 0
      Τέλος_αν
   Τέλος_επανάληψης
Τέλος_επανάληψης


bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 511
Απ: Υλοποίηση Αλγορίθμου Εισαγωγής
« Απάντηση #1 στις: 13 Μάρ 2010, 01:31:13 πμ »
Νομίζω ότι έχει ένα πρόβλημα το Για,

θα έπρεπε να είναι από 2 μέχρι Ν και όχι μέχρι Ν + 1...

κατά τα άλλα εκ πρώτης όψεως μου φαίνεται σωστός αλγόριθμος ταξινόμησης...