Αποστολέας Θέμα: ΑΠΟΡΙΑ ΣΤΗΝ ΑΝ  (Αναγνώστηκε 1201 φορές)

petros93

  • Νέος
  • *
  • Μηνύματα: 9
ΑΠΟΡΙΑ ΣΤΗΝ ΑΝ
« στις: 21 Οκτ 2010, 10:28:02 πμ »
ΓΕΙΑ ΣΑΣ.
ΕΙΜΑΙ ΜΑΘΗΤΗΣ ΤΗΣ Γ' ΤΑΞΗΣ ΚΑΙ ΕΧΩ ΜΙΑ ΑΠΟΡΙΑ ΣΤΗΝ ΕΝΤΟΛΗ ΑΝ.
ΘΑ ΗΘΕΛΑ ΝΑ ΡΩΤΗΣΩ ΑΝ ΙΣΧΥΟΥΝ ΤΑ ΠΑΡΑΚΑΤΩ ΓΙΑΤΙ ΕΧΩ ΜΠΕΡΔΕΥΤΕΙ ΑΠΟ ΤΟ ΒΙΒΛΙΟ:

1) ΠΕΡΙΟΡΙΣΜΕΝΗ ΕΠΙΛΟΓΗ

    ΑΝ συνθήκη ΤΟΤΕ εντολή

2) ΑΠΛΗ ΕΠΙΛΟΓΗ

    ΑΝ συνθήκη ΤΟΤΕ
         εντολές
   ΤΕΛΟΣ_ΑΝ

3) ΣΥΝΘΕΤΗ ΕΠΙΛΟΓΗ

    ΑΝ συνθήκη ΤΟΤΕ
         εντολές
   ΑΛΛΙΩΣ
         εντολές
   ΤΕΛΟΣ_ΑΝ


andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 999
Απ: ΑΠΟΡΙΑ ΣΤΗΝ ΑΝ
« Απάντηση #1 στις: 21 Οκτ 2010, 11:58:34 πμ »
Τα 1) και 2) είναι το ένα και το αυτό !!!!   Απλή επιλογή.

Η διαφοροποίηση είναι :
1) Μία εντολή  (*)
2) Πολλές εντολές

(*)  Μπορεί όμως να παρουσιαστεί και ως :

  Αν συνθήκη τότε
       εντολή
  Τέλος_αν

petros93

  • Νέος
  • *
  • Μηνύματα: 9
Απ: ΑΠΟΡΙΑ ΣΤΗΝ ΑΝ
« Απάντηση #2 στις: 21 Οκτ 2010, 12:25:46 μμ »
ΔΗΛΑΔΗ ΑΝ ΜΑΣ ΖΗΤΗΣΟΥΝ ΠΟΙΑ ΕΙΝΑΙ Η ΑΠΛΗ ΕΠΙΛΟΓΗ ΘΑ ΑΝΑΦΕΡΟΥΜΕ ΚΑΙ ΤΑ ΔΥΟ ?

Ρήγος Γιώργος

  • Οπαδός
  • **
  • Μηνύματα: 14
Απ: ΑΠΟΡΙΑ ΣΤΗΝ ΑΝ
« Απάντηση #3 στις: 21 Οκτ 2010, 01:44:38 μμ »
Αν σου ζητήσουν την απλή δομή επιλογής θα πεις οτι ειναι η

Αν συνθήκη τότε
     Εντολές
Τέλος_Αν

manpap

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 121
  • Είμαι χαζομπαμπάς...
Απ: ΑΠΟΡΙΑ ΣΤΗΝ ΑΝ
« Απάντηση #4 στις: 27 Οκτ 2010, 12:08:37 πμ »
Θα ήθελα να συμπληρώσω και την
 γ) ΠΟΛΛΑΠΛΗ ΕΠΙΛΟΓΗ

    ΑΝ συνθήκη1 ΤΟΤΕ
         εντολές1
    ΑΛΛΙΩΣ_ΑΝ συνθήκη2 ΤΟΤΕ
         εντολές2
    ...
   ΑΛΛΙΩΣ
         εντολέςΝ
   ΤΕΛΟΣ_ΑΝ

ενώ για να έχεις μία συνολική εικόνα για την Αν, προσδιορίζεις και την
ΕΜΦΩΛΕΥΜΕΝΗ ΕΠΙΛΟΓΗ, όχι ως μία 4η μορφή αλλά ως χαρακτηρισμό για μία οποιαδήποτε από τις 3 επιλογές (απλή, σύνθετη, πολλαπλή) όταν κάποια από αυτές συναντάται "μέσα" σε μία άλλη.

Σου εύχομαι καλή και τυχερή χρονιά να έχεις φέτος και να πετύχεις τους στόχους σου  :)
Συντηρώ το μυαλό μου ακοίμητο, λαγαρό, ανήλεο. Το αμολώ να παλεύει ακατάλυτα. Άλλο αργαστήρι να κάνω το σκοτάδι φως δεν έχω.
Ν. Καζαντζάκης