Αποστολέας Θέμα: Πολλαπλασιασμός αλά ρωσικά ??  (Αναγνώστηκε 13025 φορές)

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3218
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #15 στις: 13 Ιαν 2008, 01:35:28 μμ »
Ναι, είναι το ίδιο

όπως και αυτό που χρησιμοποιεί το σχολικό

Μ2 <-- [Μ2/2], που εξηγεί οτι οι αγκύλες εκφράζουν το ακέραιο μέρος

Απλά στο σχολικό βιβλίο, οι τελεστές div, mod παρουσιάζονται στο κεφάλαιο 7 και όχι στο 2!
Θεωρεί βέβαια το βιβλίο καθηγητή (όχι βάσιμα πάντα), πως η ύλη διδάσκεται σπειροειδώς...

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 543
  • There can be only one...may it be AEPP.
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #16 στις: 14 Οκτ 2015, 01:34:43 μμ »
Ο ανηψούλης μου από την Τενεούπολη με ρώτησε αν ο παρακάτω αλγόριθμος (για τον πολ/σμό αλά ρωσικά) είναι σωστός (δεν τον σκέφτηκε μόνος του):

   Δεδομένα // Μ1, Μ2 //
   P ← 0
   Για Ε από Μ2 μέχρι 0 με_βήμα Κ
      Αν Ε mod 2 = 1 τότε
           P ← P + M1
      Τέλος_αν
      M1 ← M1*2
      K ← M2 div 2
   Τέλος_επανάληψης
   Αποτελέσματα // P //

Ο γιατρός μου είπε οτι ήμουν πολύ τυχερός που τη γλύτωσα και πως πρέπει να προσέχω πολύ στο εξής. Σε επόμενη παρόμοια...συγκίνηση μπορεί να μην είμαι τόσο τυχερός. Δεν είναι και πολύ συνηθισμένες τέτοιες κρίσεις στα 29...

Με εκτίμηση,
Το Ε είναι δεσμευμένο :P :P :P
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 201
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #17 στις: 04 Μάι 2017, 09:20:41 πμ »
Καλήμερα!
Στον πολ/σμο αλα ρώσικα, για τον 2ο αριθμό που διαιρείται με το 2, οι εντολές  Μ2<--Α_Μ(Μ2/2) και
Μ2<--Μ2div 2 είναι ισοδύναμες;
Ευχαριστώ

αν ενας αριθμος ειναι ακεραιος εστω χ αυτος ο αριθμος τοτε ισχυει x div2=Α_Μ(χ/2).αν δεν ειναι ακεραιος τοτε
η ισοτητα δεν ισχυει καθως το div χρησιμοποιειται μονο για ακεραιους.πχ 5/2=2.5 αρα A_Μ(2.5)=2 και 5div2=2

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1094
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #18 στις: 04 Μάι 2017, 10:40:45 πμ »
Να μη ξεχνάμε ότι αναφερόμαστε σε αλγόριθμο που το τρόπος γραφής δεν είναι τόσο αυστηρός. Προφανώς αν υλοποιηθεί σε ΓΛΩΣΣΑ θα υπάρχουν κάποιοι περιορισμοί ως προς τον τύπο των μεταβλητών που θα εφαρμόζεται ο πολλαπλασιασμός αλα ρωσικά ή ορισμένες δυσκολίες θα αντιμετωπιστούν με άλλον τρόπο (όπως αναφέρθηκε με το ΑΜ).

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2223
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #19 στις: 04 Μάι 2017, 10:51:56 πμ »
Μα ο πολλαπλασιασμός αλά ρωσικά αναφέρεται μόνο σε ακεραίους, άρα είναι δεκτό και το Α_Μ σαν υλοποίηση σε ΓΛΩΣΣΑ
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

sakisnemkav

  • Βετεράνος
  • ****
  • Μηνύματα: 72
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #20 στις: 26 Σεπ 2019, 10:32:51 πμ »

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 201
Απ: Πολλαπλασιασμός αλά ρωσικά ??
« Απάντηση #21 στις: 06 Οκτ 2019, 03:33:05 πμ »

προγραμμα σε Γλωσσα πολλαπλασιασμου αλλα ρωσικα χωρις συντελεστη * και χωρις Αν


ΠΡΟΓΡΑΜΜΑ πολσμος_αλα_ρωσικα
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β
  ΠΡΑΓΜΑΤΙΚΕΣ: αθρ
ΑΡΧΗ

  αθρ <- 0
  ΔΙΑΒΑΣΕ α, β
  ΟΣΟ α >= 1 και β<>0 ΕΠΑΝΑΛΑΒΕ  !0^0 δεν οριζεται και υπαρχει πιθανοτητα αν δεν βαλω τη δευτερη συνθηκη να προκυψει αυτο μεσα στην επαναληψη

    αθρ <- αθρ + β^(α mod 2) - (1 - α mod 2)
    α <- α div 2
    β <- β + β
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ Α_Μ(αθρ)         !για να φαινεται χωρις τα μηδενικα δεκαδικα,ως ακεραιος


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


2η ΕΚΔΟΧΗ  που λαμβανει υποψιν και αρνητικους αριθμους με τους ιδιους περιορισμους που εχω παραπανω(χωρις *,ΑΝ):


ΠΡΟΓΡΑΜΜΑ πολσμος_αλα_ρωσικα
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β
  ΠΡΑΓΜΑΤΙΚΕΣ: αθρ, χ
ΑΡΧΗ

  αθρ <- 0
  ΔΙΑΒΑΣΕ α, β
  χ <- Α_Τ(α) + Α_Τ(β)
  χ <- Α_Τ(α + β) - χ + 1
             !αν α*β>=0 το χ ειναι 1 αλλιως ειναι αρνητικο(αποδεικνυεται ευκολα)
  α <- Α_Τ(α)
  β <- Α_Τ(β)
  ΟΣΟ α >= 1 ΚΑΙ β <> 0 ΕΠΑΝΑΛΑΒΕ!0^0 δεν οριζεται και υπαρχει πιθανοτητα αν δεν βαλω τη δευτερη συνθηκη να προκυψει αυτο μεσα στην επαναληψη

    αθρ <- αθρ + β^(α mod 2) - (1 - α mod 2)
    α <- α div 2
    β <- β + β
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       !το div χρησιμοποειται με ακεραιους για αυτο χρησιμοποιω τη συναρτηση Α_Μ
  ΓΡΑΨΕ (Α_Μ(αθρ)) div (Α_Μ(χ) div Α_Μ(Α_Τ(χ)))


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
« Τελευταία τροποποίηση: 06 Οκτ 2019, 05:11:59 πμ από Κωστας τζιαννης »