Αποστολέας Θέμα: Θέμα 4  (Αναγνώστηκε 3870 φορές)

mathitis2

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Θέμα 4
« Απάντηση #15 στις: 04 Ιούν 2010, 09:03:51 μμ »
Ευχαριστω. Ελυσα και το Γ και το Δ χωρις πινακες, αφου δεν ελεγε για χρηση πινακα.

mour

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 179
Απ: Θέμα 4
« Απάντηση #16 στις: 04 Ιούν 2010, 09:24:03 μμ »
εχω λυσει το θεμα 4 χωρίς πίνακες. Πειτε μου σας παρακαλω αν είναι σωστο

Αλγόριθμος θεμα_4
tc11← 1000^1000
tc12← 1000^1000
tc13← 1000^1000
tc21← 1000^1000
tc22← 1000^1000
tc23← 1000^1000
tc31← 1000^1000
tc32← 1000^1000
tc33← 1000^1000
max1← 1000^1000
max2← 1000^1000
max3← 1000^1000
onc11← " "
onc12← " "
onc13← " "
onc21← " "
onc22← " "
onc23← " "
onc31← " "
onc32← " "
onc33← " "
on1← " "
on2← " "
on3← " "
c1← 0
c2← 0
c3← 0
Για i από 1 μέχρι 35
    Διάβασε on
    Αρχή_επανάληψης
        Διάβασε kat
    Μέχρις_ότου kat="c1" ή kat="c2"ή kat="c3"
    Διάβασε prxr,gph
    sx← prxr/(70*gph)
    Αν kat="c1" τότε
        c1← c1+1
    αλλιώς_αν kat="c2" τότε
        c2← c2+1
    αλλιώς
        c3← c3+1
    Τέλος_αν
    Αν kat="c1" τότε
        Αν sx < tc11 τότε
            tc13← tc12
            onc13← onc12
            tc12← tc11
            onc12← onc11
            tc11← sx
            onc11← on
        αλλιώς_αν sx < tc12 τότε
            tc13← tc12
            onc13← onc12
            tc12← sx
            onc12← on
        αλλιώς_αν sx < tc13 τότε
            tc13← sx
            onc13← on
        Τέλος_αν
    αλλιώς_αν kat="c2" τότε
        Αν sx < tc21 τότε
            tc23← tc22
            onc23← onc22
            tc22← tc21
            onc22← onc21
            tc21← sx
            onc21← on
        αλλιώς_αν sx < tc22 τότε
            tc23← tc22
            onc23← onc22
            tc22← sx
            onc22← on
        αλλιώς_αν sx < tc23 τότε
            tc23← sx
            onc23← on
        Τέλος_αν
    αλλιώς
        Αν sx < tc31 τότε
            tc33← tc32
            onc33← onc32
            tc32← tc31
            onc32← onc31
            tc31← sx
            onc31← on
        αλλιώς_αν sx < tc32 τότε
            tc33← tc32
            onc33← on32
            tc32← sx
            onc32← on
        αλλιώς_αν sx < tc33 τότε
            tc33← sx
            onc33← on
        Τέλος_αν
    Τέλος_αν
    Αν sx < max1 τότε
        max3← max2
        on3← on2
        max2← max1
        on2← on1
        max1← sx
        on1← on
    αλλιώς_αν sx < max2 τότε
        max3← max2
        on3← on2
        max2← sx
        on2← on
    αλλιώς_αν sx < max3 τότε
        max3← sx
        on3← on
    Τέλος_αν
Τέλος_επανάληψης
maxk← c1
onmax← "c1"
Αν c2 > maxk τότε
    maxk← c2
    onmax← "c2"
Τέλος_αν
Αν c3 > maxk τότε
    maxk← c3
    onmax← "c3"
Τέλος_αν
Εμφάνισε onmax
Εμφάνισε "Για την κατηγορια c1:",onc11,onc12,onc13
Εμφάνισε "Για την κατηγορια c2:",onc21,onc22,onc23
Εμφάνισε "Για την κατηγορια c3:",onc31,onc32,onc33
Εμφάνισε "Για τη γενικη καταταξη:",on1,on2,on3
Τέλος θεμα_4

Κατά τη γνώμη μου είναι μία από τις χειρότερες προσεγγίσεις που θα μπορούσε να γίνει.
ΔΥΣΤΥΧΩΣ (για εμένα...) θα έπαιρνε όλα τα μόρια ΑΝ ήταν ΤΕΛΕΙΩΣ σωστό. Επειδή είναι ΠΟΛΥ εύκολο να γίνει λάθος με τόσες επαναλαμβανόμενες εντολές και τόσες μεταβλητές, πιθανότατα κάτι θα είχε ξεφύγει και θα έχανε μονάδες
PS οι εντολές "tc11← 1000^1000"  θα "έσκαγαν" σχεδόν σε οποιαδήποτε από τις πραγματικές γλώσσες προγραμματισμού (πιθανόν να υπάρχει και καμία ιδιαίτερη γλώσσα που να μη σκαει...)  και στη ΓΛΩΣΣΑ δε θα δούλευε

mathitis2

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Θέμα 4
« Απάντηση #17 στις: 04 Ιούν 2010, 10:08:37 μμ »
Σας ευχαριστω κυριε καθηγητα για την προσωπικη σας αποψη. Ελπιζω να τον ελεγξετε κιολας να μου πειτε αν εχει λαθη, γιατι ανησυχω μηπως τον παρουν λαθος.

merlin

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 320
Απ: Θέμα 4
« Απάντηση #18 στις: 04 Ιούν 2010, 10:13:34 μμ »
Πότε πρόλαβες ρε θηρίο και τα έγραψες όλα αυτά?
Μη μου πεις ότι το είχες κάνει και στο πρόχειρο και το αντέγραψες στο καθαρό?
Εντάξει, είπαμε να μην χρησιμοποιούμε πίνακες όποτε να ' ναι, αλλά εσύ το παράκανες!  :)  :)

Πιστεύω ότι θα πήγες καλά και στα υπόλοιπα θέματα γιατί δείχνει ότι έχεις καταλάβει αρκετά πράγματα (αν και η "αποστροφή" σου για τους πίνακες φτάνει στα όρια του μαζοχισμού! )   :)
Παρασκευάς Πανάγου
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής ΠΕ20

mathitis2

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Θέμα 4
« Απάντηση #19 στις: 04 Ιούν 2010, 10:28:02 μμ »
Τελειωσα στις 2 ωρες. Δεν εφυγα ομως.

Ενταξει τα θεματα ηταν καλα. Στο σχολειο μου ολοι εκαναν πινακες και στο Γ και στο Δ.

Θα εκανα πινακες αν ελεγε πινακες. Αφου δεν ελεγε σημαινε για μενα ψαξε να δεις αν απαιτουνται. Στο προχειρο βγηκαν και οι δυο χωρις πινακες και αρα αφου δεν χρειαζονταν ειπα ότι δεν θα χρησιμοποιησω πινακες.

Ελπιζω να μπω στο πολυτεχνειο!

Αληθεια το ελεγξατε αν ειναι σωστο;

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: Θέμα 4
« Απάντηση #20 στις: 04 Ιούν 2010, 11:04:31 μμ »
Η λύση σου είναι σωστή έτσι όπως είναι διατυπωμένη σε αλγόριθμο.

Το αν θα είχε πρόβλημα σε μια μεταφορά της σε πρόγραμμα θεωρώ ότι ξεφεύγει από τα ζητούμενα της άσκησης.
Και ως εκ τούτου δε πρέπει να μας απασχολήσει.
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"

elf

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 291
Απ: Θέμα 4
« Απάντηση #21 στις: 04 Ιούν 2010, 11:27:38 μμ »
@mathitis2
Ρε μπας και είσαι συνάδελφος και μας δουλεύεις;    ;)
Η λύση σου είναι πρωτότυπη και χρειάζεται λιγότερο χώρο για τα δεδομένα.
Είναι σωστή γιατί από την εκφώνηση θέτονται οι περιορισμοί:
1. σχετικοί χρόνοι διαφορετικοί μεταξύ τους
2. τρία τουλάχιστον σκάφη ανά κατηγορία
οπότε γνωρίζεις σίγουρα ότι θα έχεις 3 (ούτε λιγότερα ούτε περισσότερα) πρώτα σκάφη ανά κατηγορία και συνολικά και ότι δεν θα έχεις ισοβαθμίες. ΔΕΝ έβγαινε αν δεν σου δίνονταν αυτοί οι περιορισμοί στην άσκηση, αλλά έτσι είσαι εντάξει.
Τώρα για την αυθαίρετη τιμή 1000^1000, θα μπορούσες να αρχικοποιήσεις τους χρόνους σε -1 και να πεις πχ
Αν sx < tc11 Η tc11 = -1  τότε
κοκ
δηλαδή αν ο χρόνος είναι μικρότερος από του προηγούμενου σκάφους ή δεν έχω βάλει ακόμα τιμή.
Τυπικά η αρχικοποίηση δεν είναι σωστή, όχι γιατί η τιμή είναι υπερβολικά μεγάλη, αλλά γιατί δεν σου δίνεται ρητά από την εκφώνηση τέτοιος περιορισμός. Αλλά ούτε και εγώ που το γράφω θα το θεωρούσα λάθος.  Δεν λέω, ξενίζει στην αρχή η λύση, δεν είναι και εύκολη στην ανάγνωση (ελπίζω να μην έχεις ξεχάσει κάνα τέλος_αν γιατί τότε όντως δεν θα διαβάζεται). Μια φορά σίγουρα δεν πρόκειται να κοπεί .. λόγω διαφορετικότητας :)

mour

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 179
Απ: Θέμα 4
« Απάντηση #22 στις: 04 Ιούν 2010, 11:52:59 μμ »
Σας ευχαριστω κυριε καθηγητα για την προσωπικη σας αποψη. Ελπιζω να τον ελεγξετε κιολας να μου πειτε αν εχει λαθη, γιατι ανησυχω μηπως τον παρουν λαθος.
Από μια ματιά που έριξα φαίνεται σωστός. ΑΝ είναι το ιδιο σωστός στο γραπτό θεωρώ ότι είναι 20/20.
Η "διαφωνία" μου στην προσέγγιση είναι ότι είναι τελείως "μονολιθική" και εντελώς επίφοβη στη δημιουργία της.
Πχ αν έλεγε ότι θέλει τους 10 πρώτους πόσες μεταβλητές θα χρειαζόσουν? Ελπίζω να γίνομαι κατανοητός.
Καλά αποτελέσματα!!!

Obelix

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 119
Απ: Θέμα 4
« Απάντηση #23 στις: 05 Ιούν 2010, 12:17:21 μμ »
Ερώτηση προς βαθμολογητές:
Η λύση με τις τέσσερις ταξινομήσεις, στην οποία κατέφυγαν πιστεύω αρκετοί μαθητές, λαμβάνει όλες τις μονάδες;
 

noname

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 190
Απ: Θέμα 4
« Απάντηση #24 στις: 05 Ιούν 2010, 03:04:02 μμ »
Ερώτηση προς βαθμολογητές:
Η λύση με τις τέσσερις ταξινομήσεις, στην οποία κατέφυγαν πιστεύω αρκετοί μαθητές, λαμβάνει όλες τις μονάδες;

Αν είναι σωστή, γιατί όχι;
(αν και δεν είμαι βαθμολογητής  :))

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1094
Απ: Θέμα 4
« Απάντηση #25 στις: 06 Ιούν 2010, 12:42:02 πμ »
Ερώτηση προς βαθμολογητές:
Η λύση με τις τέσσερις ταξινομήσεις, στην οποία κατέφυγαν πιστεύω αρκετοί μαθητές, λαμβάνει όλες τις μονάδες;
 
Αν είναι σωστή, ναι λαμβάνει όλες τις μονάδες.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3164
  • to Iterate is human to Recurse divine
Απ: Θέμα 4
« Απάντηση #26 στις: 06 Ιούν 2010, 03:25:23 πμ »
Ακριβώς, ότι είναι σωστό πιάνει όλες τις μονάδες άσχετα πως το έχει κάνει ο μαθητής, στο θέμα 4 κάποιοι δεν έχουν χρησιμοποιήσει πίνακα αλλά είναι σωστοί.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr