Αποστολέας Θέμα: Θέμα 4  (Αναγνώστηκε 3860 φορές)

Γιάννης Αναγνωστάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 817
Θέμα 4
« στις: 29 Μάι 2010, 11:58:40 πμ »
Καλημέρα

Υπάρχουν μαθητές, που για διάφορους λόγους, έχουν λύσει το θέμα 4 χωρίς πίνακες, και προφανώς δεν έχουν κάνει το τελευταίο υποερώτημα. Με την προυπόθεση ότι οι λύσεις των τριών πρώτων ερωτημάτων, είναι σωστές με δομή επανάληψης, δεν δικαιούνται τα 15 μοριά?

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 512
Απ: Θέμα 4
« Απάντηση #1 στις: 29 Μάι 2010, 12:02:25 μμ »
κατά τη γνώμη μου ναι...

μάλιστα λύνεται και ολόκληρο χωρίς πίνακα!!!

Κρατάς τρία μέγιστα και κάθε φορά που βρίσκεις ένα μέγιστο "ολισθαίνεις" τις τιμές των προηγούμενων...

Το έκανε μαθήτρια μου και με έστειλε αδιάβαστο!!!

Γιάννης Αναγνωστάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 817
Απ: Θέμα 4
« Απάντηση #2 στις: 29 Μάι 2010, 12:05:53 μμ »
κατά τη γνώμη μου ναι...

μάλιστα λύνεται και ολόκληρο χωρίς πίνακα!!!

Κρατάς τρία μέγιστα και κάθε φορά που βρίσκεις ένα μέγιστο "ολισθαίνεις" τις τιμές των προηγούμενων...

Το έκανε μαθήτρια μου και με έστειλε αδιάβαστο!!!

Τέτοιοι μαθητές είναι που σε κάνουν και αγαπάς το μάθημα ακόμα παραπάνω..
Πρέπει να δυσκολεύτηκε αρκετα για να εξασφαλίσει ότι ο αλγόριθμος που έγραψε δουλεύει σωστά..Μαγκιά της!

periklis

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Θέμα 4
« Απάντηση #3 στις: 29 Μάι 2010, 12:29:42 μμ »
Καλημέρα

Υπάρχουν μαθητές, που για διάφορους λόγους, έχουν λύσει το θέμα 4 χωρίς πίνακες, και προφανώς δεν έχουν κάνει το τελευταίο υποερώτημα. Με την προυπόθεση ότι οι λύσεις των τριών πρώτων ερωτημάτων, είναι σωστές με δομή επανάληψης, δεν δικαιούνται τα 15 μοριά?

den kserw ti les
swsta to kana

Γιάννης Αναγνωστάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 817
Απ: Θέμα 4
« Απάντηση #4 στις: 29 Μάι 2010, 12:34:43 μμ »
den kserw ti les
swsta to kana
Δεν καταλαβες τι ρώτησα μάλλον..Δεν είπα ότι δεν λύνεται, ρώτησα πως βαθμολογούνται τα παιδιά αυτά

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2784
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Θέμα 4
« Απάντηση #5 στις: 29 Μάι 2010, 11:56:24 μμ »
Κρατάς τρία μέγιστα και κάθε φορά που βρίσκεις ένα μέγιστο "ολισθαίνεις" τις τιμές των προηγούμενων...

Το έκανε μαθήτρια μου και με έστειλε αδιάβαστο!!!

Στο Γ τι έκανε;

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 512
Απ: Θέμα 4
« Απάντηση #6 στις: 30 Μάι 2010, 12:19:26 πμ »
το έλυσε... χωρίς πίνακα

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1094
Απ: Θέμα 4
« Απάντηση #7 στις: 31 Μάι 2010, 12:42:49 πμ »
Καλημέρα

Υπάρχουν μαθητές, που για διάφορους λόγους, έχουν λύσει το θέμα 4 χωρίς πίνακες, και προφανώς δεν έχουν κάνει το τελευταίο υποερώτημα. Με την προυπόθεση ότι οι λύσεις των τριών πρώτων ερωτημάτων, είναι σωστές με δομή επανάληψης, δεν δικαιούνται τα 15 μοριά?

Αν όλα είναι σωστά τότε θα λάβει τα 15 μόρια

Crazy_Waters

  • Βετεράνος
  • ****
  • Μηνύματα: 87
Απ: Θέμα 4
« Απάντηση #8 στις: 31 Μάι 2010, 08:19:15 μμ »
Είναι ακριβώς το ίδιο (στην ανάποδη εκδοχή του) με αυτό που συζητάμε για το Γ τόσες μέρες. Εννοείται ότι πρέπει να πάρει όλες τις μονάδες.

twisted

  • Θαμώνας
  • ***
  • Μηνύματα: 42
Απ: Θέμα 4
« Απάντηση #9 στις: 01 Ιούν 2010, 01:18:41 πμ »
Καλησπέρα  :)

Μαθήτρια μου επειδή δεν την έφτανε ο χρόνος (πως κατάφερε να μην της φτάσει;;;  ???) το Δ4 το έλυσε λίγο γρήγορα όπως μου είπε και μετά την ταξινόμηση και την εμφάνιση των 3 πρώτων τις γενικής για την κάθε κατηγορία έκανε τα εξής:
Κώδικας: [Επιλογή]
για σκαφ από 1 μέχρι 3
   αν ΚΑΤ[σκαφ] = 'C1' τότε
      εμφάνισε ΟΝ[σκαφ]
   τέλος_αν
τέλος_επανάληψης

Και έκανε το ίδιο και για τις άλλες 2 κατηγορίες. Πόσα από τα 5 θα χάσει.

George

  • Θαμώνας
  • ***
  • Μηνύματα: 41
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα 4
« Απάντηση #10 στις: 01 Ιούν 2010, 01:42:13 πμ »
και μια ακόμη απάντηση  στο ερώτημα δ4 όπως δόθηκε από ένα μαθητή:

Μετα την ταξινόμηση και την εμφάνιση των 3 πρώτων

Π[1] ← ''C1''
Π[2] ← ''C2''
Π[3] ← ''C3''
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 3
   ΓΡΑΨΕ ''Οι τρεις καλύτεροι της  κατηγορίας '', Π[J], ''είναι:''
   Μ ←0
    Ι ←1
    ΟΣΟ Ι <= 35 ΚΑΙ Μ<3 ΕΠΑΝΑΛΑΒΕ
       ΑΝ Κατηγορία [ I ] = Π[J] ΤΟΤΕ
          ΓΡΑΨΕ ΟΝ[Ι]
          Μ ← Μ+1
       ΤΕΛΟΣ_ΑΝ
       Ι ← Ι + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
« Τελευταία τροποποίηση: 01 Ιούν 2010, 02:19:57 πμ από George »

noname

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 190
Απ: Θέμα 4
« Απάντηση #11 στις: 01 Ιούν 2010, 02:03:31 πμ »
και μια ακόμη απάντηση  στο ερώτημα δ4 όπως δόθηκε από ένα μαθητή:

Μετα την ταξινόμηση και την εμφάνιση των 3 πρώτων

Π[1] ← ''C1''
Π[2] ← ''C2''
Π[3] ← ''C3''
ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 3
   ΓΡΑΨΕ ''Οι τρεις καλύτεροι της  κατηγορίας '', Π[J], ''είναι:''
   Μ ←0
    Ι ←1
    ΟΣΟ Ι <= 100 35 ΚΑΙ Μ<3 ΕΠΑΝΑΛΑΒΕ
       ΑΝ Κατηγορία[Ι] = Π[J] ΤΟΤΕ
          ΓΡΑΨΕ ΟΝ[Ι]
          Μ ← Μ+1
       ΤΕΛΟΣ_ΑΝ
       Ι ← Ι + 1
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Πολύ ωραίο!

George

  • Θαμώνας
  • ***
  • Μηνύματα: 41
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα 4
« Απάντηση #12 στις: 01 Ιούν 2010, 02:17:38 πμ »
Σωστα
Λαθος δικό μου κατα την αντιγραφη. Το διορθωσα

mathitis2

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Θέμα 4
« Απάντηση #13 στις: 04 Ιούν 2010, 07:35:09 μμ »
εχω λυσει το θεμα 4 χωρίς πίνακες. Πειτε μου σας παρακαλω αν είναι σωστο

Αλγόριθμος θεμα_4
tc11← 1000^1000
tc12← 1000^1000
tc13← 1000^1000
tc21← 1000^1000
tc22← 1000^1000
tc23← 1000^1000
tc31← 1000^1000
tc32← 1000^1000
tc33← 1000^1000
max1← 1000^1000
max2← 1000^1000
max3← 1000^1000
onc11← " "
onc12← " "
onc13← " "
onc21← " "
onc22← " "
onc23← " "
onc31← " "
onc32← " "
onc33← " "
on1← " "
on2← " "
on3← " "
c1← 0
c2← 0
c3← 0
Για i από 1 μέχρι 35
    Διάβασε on
    Αρχή_επανάληψης
        Διάβασε kat
    Μέχρις_ότου kat="c1" ή kat="c2"ή kat="c3"
    Διάβασε prxr,gph
    sx← prxr/(70*gph)
    Αν kat="c1" τότε
        c1← c1+1
    αλλιώς_αν kat="c2" τότε
        c2← c2+1
    αλλιώς
        c3← c3+1
    Τέλος_αν
    Αν kat="c1" τότε
        Αν sx < tc11 τότε
            tc13← tc12
            onc13← onc12
            tc12← tc11
            onc12← onc11
            tc11← sx
            onc11← on
        αλλιώς_αν sx < tc12 τότε
            tc13← tc12
            onc13← onc12
            tc12← sx
            onc12← on
        αλλιώς_αν sx < tc13 τότε
            tc13← sx
            onc13← on
        Τέλος_αν
    αλλιώς_αν kat="c2" τότε
        Αν sx < tc21 τότε
            tc23← tc22
            onc23← onc22
            tc22← tc21
            onc22← onc21
            tc21← sx
            onc21← on
        αλλιώς_αν sx < tc22 τότε
            tc23← tc22
            onc23← onc22
            tc22← sx
            onc22← on
        αλλιώς_αν sx < tc23 τότε
            tc23← sx
            onc23← on
        Τέλος_αν
    αλλιώς
        Αν sx < tc31 τότε
            tc33← tc32
            onc33← onc32
            tc32← tc31
            onc32← onc31
            tc31← sx
            onc31← on
        αλλιώς_αν sx < tc32 τότε
            tc33← tc32
            onc33← on32
            tc32← sx
            onc32← on
        αλλιώς_αν sx < tc33 τότε
            tc33← sx
            onc33← on
        Τέλος_αν
    Τέλος_αν
    Αν sx < max1 τότε
        max3← max2
        on3← on2
        max2← max1
        on2← on1
        max1← sx
        on1← on
    αλλιώς_αν sx < max2 τότε
        max3← max2
        on3← on2
        max2← sx
        on2← on
    αλλιώς_αν sx < max3 τότε
        max3← sx
        on3← on
    Τέλος_αν
Τέλος_επανάληψης
maxk← c1
onmax← "c1"
Αν c2 > maxk τότε
    maxk← c2
    onmax← "c2"
Τέλος_αν
Αν c3 > maxk τότε
    maxk← c3
    onmax← "c3"
Τέλος_αν
Εμφάνισε onmax
Εμφάνισε "Για την κατηγορια c1:",onc11,onc12,onc13
Εμφάνισε "Για την κατηγορια c2:",onc21,onc22,onc23
Εμφάνισε "Για την κατηγορια c3:",onc31,onc32,onc33
Εμφάνισε "Για τη γενικη καταταξη:",on1,on2,on3
Τέλος θεμα_4

freedomst

  • Βετεράνος
  • ****
  • Μηνύματα: 82
Απ: Θέμα 4
« Απάντηση #14 στις: 04 Ιούν 2010, 08:03:09 μμ »
@ mathitis2

Πιστεύω ότι η λύση που έδωσες απαντά πλήρως στα ερωτήματα του Θέμα Δ.
Και μάλιστα με πολύ έξυπνο τρόπο, μπράβο.
Καλά αποτελέσματα.
Σταματοπούλου Ελευθερία
ΠΕ19 - ΓΕΛ Κρύας Βρύσης

"Ουδέν κακόν αμιγές καλού"