Ψηφοφορία

Πιστεύετε ότι η λύση με πίνακες στο Θέμα Γ  :

Είναι λάθος - να κοπούν 3-5 μονάδες
28 (8.2%)
Είναι λάθος - να κοπούν 1-2 μονάδες
23 (6.7%)
Είναι σωστή αλλά όχι ιδανική - να κοπούν 1-2 μονάδες
29 (8.5%)
Είναι σωστή αλλά όχι ιδανική - να μην κοπούν μονάδες
108 (31.7%)
Είναι σωστή - να μην κοπούν μονάδες
153 (44.9%)

Σύνολο ψηφοφόρων: 339

Αποστολέας Θέμα: Ημερήσια 2010  (Αναγνώστηκε 170666 φορές)

Σούλας Βασίλης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 305
    • Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Απ: Ημερήσια 2010
« Απάντηση #75 στις: 28 Μάι 2010, 01:07:25 μμ »
...δες κι αυτό:
ΑΛΛΙΩΣ_ΑΝ ΒΑΘΜΟΣ <= ΜΟ-2 ΤΟΤΕ

Πολύ βιασύνη πολλά λάθη!!!!  :)
Σούλας Βασίλης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Δ.Π.Θ.
Καθηγητής Πληροφορικής ΠΕ19
http://users.sch.gr/vasisoulas
http://eclass.sch.gr/modules/auth/opencourses.php?fc=%D4-52

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Ημερήσια 2010
« Απάντηση #76 στις: 28 Μάι 2010, 01:09:21 μμ »
Λύσεις.

Για ι ΑΠΟ 2 ΜΕΧΡΙ 35
  ΓΙΑ λ ΑΠΟ 35 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
  ΑΝ Σχ[λ]<Σχ[λ-λ] ΤΟΤΕ

jsari

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 67
Απ: Ημερήσια 2010
« Απάντηση #77 στις: 28 Μάι 2010, 01:11:06 μμ »
Η άποψη μου για το θέμα Γ είναι η εξής:

Όταν η άσκηση δεν μας λέει να διαβάσουμε το πλήθος των στοιχείων τότε το πλήθος θεωρείται δεδομένο και άρα αποτελεί και δεδομένο για τον αλγόριθμο και συνεπώς μπορεί να χρησιμοποιηθεί πίνακας.

Όταν όμως υπάρχει εντολή που διαβάζει το μέγεθος του πίνακα αυτό σημαίνει ότι το πλήθος αυτό είναι άγνωστο όταν ξεκινάει ο αλγόριθμος και συνεπώς δεν μπορεί να χρησιμοποιηθεί πίνακας.

Από τα παραπάνω προκύπτει ότι είναι λάθος η χρήση του πίνακα.

Όσο αναφορά την βαθμολογία η άποψη μου είναι να κοπούν 2 μονάδες αν κάποιος κάνει χρήση πινάκων και επιπλέον να κοπούν οι μονάδες που η λύση τους ευνοείται από την χρήση πινκάνων. Αυτό συμβαίνει με το Γ5.
Άρα προτείνω να κόβονται 2 + 4 = 6 μονάδες για κάποιον που έχει κάνει χρήση πινάκων.
Με εκτίμηση,
Σαρημπαλίδης Ιωάννης

Σούλας Βασίλης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 305
    • Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Απ: Ημερήσια 2010
« Απάντηση #78 στις: 28 Μάι 2010, 01:13:41 μμ »
Για ι ΑΠΟ 2 ΜΕΧΡΙ 35
  ΓΙΑ λ ΑΠΟ 35 ΜΕΧΡΙ ι ΜΕ_ΒΗΜΑ -1
  ΑΝ Σχ[λ]<Σχ[λ-λ] ΤΟΤΕ

Είναι άλλος.
Σούλας Βασίλης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Δ.Π.Θ.
Καθηγητής Πληροφορικής ΠΕ19
http://users.sch.gr/vasisoulas
http://eclass.sch.gr/modules/auth/opencourses.php?fc=%D4-52

builder

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Ημερήσια 2010
« Απάντηση #79 στις: 28 Μάι 2010, 01:14:22 μμ »
Σχετικά με το πολυ-συζητημένο 3ο θέμα:
Η γνώμη μου είναι ότι πρέπει να αντιμετωπίζουμε σωστά τα πράγματα (όχι σχετικά σωστά) και όχι
όπως μας βολεύει.
Δεδομένα:
α. πρόκειται για μια καλή άσκηση που στόχο είχε να δημιουργήσει αυτές τις συζητήσεις.
β. δεν πάνε όλες οι ασκήσεις με πίνακα όταν ζητείται αλγόριθμος και όχι πρόγραμμα. Αν
   κάποιος ισχυρίζεται αυτό, κατά τη γνώμη μου είναι λάθος ή να δοθεί από του χρόνου
   ξεκάθαρη διευκρίνηση
Στο δια ταύτα:
Καλώς ή κακώς πολλοί μαθητές πήγαν με πίνακες. Αυτοί που πήγαν πρέπει να χάσουν λίγες
μονάδες εντελώς συμβολικά και για να "αποκατασταθούν" οι ελάχιστοι που τους έκοψε
ότι "σε μία στατική δομή δεδομένων το μέγεθος είναι γνωστό κατά τη μεταγλώττιση"
(ας είναι και ένα μόριο-δεν είμαι απέναντι στα παιδιά ούτε σε κανένα - μην παρεξηγήσετε
τα λεγόμενά μου)

Ευχαριστώ,
καλά αποτελέσματα,
Γιώργος

nekis

  • Βετεράνος
  • ****
  • Μηνύματα: 76
  • U R NT A #
Απ: Ημερήσια 2010
« Απάντηση #80 στις: 28 Μάι 2010, 01:16:39 μμ »
Φίλοι και συνάδελφοι
Μετά από πολύ καιρό αφωνίας νομίζω ότι έχω να πω κάτι
Δείτε το παρακάτω (νομίζω ότι είναι βέλτιστο από 3 μεχρι 9 ο εξωτερικός βρόχος) :


  ΓΙΑ χ ΑΠΟ 3 ΜΕΧΡΙ 9 ΜΕ_ΒΗΜΑ 2
    ΓΙΑ ψ ΑΠΟ 19 ΜΕΧΡΙ χ ΜΕ_ΒΗΜΑ -2
      ΑΝ Π[ψ] < Π[ψ - 2] ΤΟΤΕ
        ΠΡΟΣ <- Π[ψ - 2]
        Π[ψ - 2] <- Π[ψ]
        Π[ψ] <- ΠΡΟΣ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Δεν νομίζω επίσης ότι θα έχει καμία επίπτωση σε μονάδες επίσης...
Καλά αποτελέσματα στα παιδιά μας.
Νεκτάριος Κυριάκου

dream

  • Θαμώνας
  • ***
  • Μηνύματα: 36
Απ: Ημερήσια 2010
« Απάντηση #81 στις: 28 Μάι 2010, 01:20:22 μμ »
Σας αποστελλω τα θέματα μαζί με τις λύσεις τους .
« Τελευταία τροποποίηση: 28 Μάι 2010, 06:41:14 μμ από dream »

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Ημερήσια 2010
« Απάντηση #82 στις: 28 Μάι 2010, 01:21:15 μμ »

Eri

  • Καθηγήτρια Πληροφορικής
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 139
Απ: Ημερήσια 2010
« Απάντηση #83 στις: 28 Μάι 2010, 01:23:22 μμ »
Σχετικά με το πολυ-συζητημένο 3ο θέμα:
Η γνώμη μου είναι ότι πρέπει να αντιμετωπίζουμε σωστά τα πράγματα (όχι σχετικά σωστά) και όχι
όπως μας βολεύει.
Δεδομένα:
α. πρόκειται για μια καλή άσκηση που στόχο είχε να δημιουργήσει αυτές τις συζητήσεις.
β. δεν πάνε όλες οι ασκήσεις με πίνακα όταν ζητείται αλγόριθμος και όχι πρόγραμμα. Αν
   κάποιος ισχυρίζεται αυτό, κατά τη γνώμη μου είναι λάθος ή να δοθεί από του χρόνου
   ξεκάθαρη διευκρίνηση
Στο δια ταύτα:
Καλώς ή κακώς πολλοί μαθητές πήγαν με πίνακες. Αυτοί που πήγαν πρέπει να χάσουν λίγες
μονάδες εντελώς συμβολικά και για να "αποκατασταθούν" οι ελάχιστοι που τους έκοψε
ότι "σε μία στατική δομή δεδομένων το μέγεθος είναι γνωστό κατά τη μεταγλώττιση"
(ας είναι και ένα μόριο-δεν είμαι απέναντι στα παιδιά ούτε σε κανένα - μην παρεξηγήσετε
τα λεγόμενά μου)

Ευχαριστώ,
καλά αποτελέσματα,
Γιώργος

Η έννοια της μεταγλώτησης αναφέρεται απο το 6ο κεφάλαιο και μετα! Τυχαιο είναι αυτο;; Οχι προφανως ειναι εννοια που συνδεέται με το πρόγραμμα και κατ' επακταση με τον προγραμματισμο. Γιατι δηλαδη πρέπει να αφορα την αλγοριθμικη σκέψη η μεταγλώτισση;;;;

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3147
  • to Iterate is human to Recurse divine
Απ: Ημερήσια 2010
« Απάντηση #84 στις: 28 Μάι 2010, 01:28:59 μμ »
Έχω την εντύπωση ότι βρίσκεις τον πρώτο κάθε κατηγορίας και όχι τους τρεις πρώτους κατηγορίας ή κάνω λάθος?

[/quote]
Σας ασποστελλω τα θέματα μαζί με τις λύσεις τους ..
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Γιάννης Σ.

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 146
    • -
Απ: Ημερήσια 2010
« Απάντηση #85 στις: 28 Μάι 2010, 01:29:41 μμ »
..!Στη συνέχεια ταξινομούμε τον πίνακα Σχετικός_Χρόνος κατά φθίνουσα σειρά

Γιατί φθίνουσα;

SotirisD

  • Βετεράνος
  • ****
  • Μηνύματα: 90
Απ: Ημερήσια 2010
« Απάντηση #86 στις: 28 Μάι 2010, 01:31:17 μμ »
Καλησπέρα και από εμένα, είμαι υποψήφιος και εγώ. Ευχαριστώ επίσης για τις λύσεις, να πω πως εγώ χρησιμοποίησα πίνακα επειδή μας ζήταγε αλγόριθμο ;). Ήθελα να ρωτήσω σχετικά με κάποιες λύσεις που έκανα εγώ, και κατά πόσο είναι σωστές και αν θα μου κόψουν μόρια.

Καταρχήν στο θέμα Α1 πειράζει που έβαλα ΑΛΛΙΩΣ_ΑΝ ΜΟ-ΒΑΘΜΟΣ <= 2 ΤΟΤΕ;

Επίσης στο θέμα γ το έλυσα με πίνακα αλλά στο τελευταίο ερώτημα έκανα τα εξείς:
Παράθεση
κ<-1
   Για i από 2 μέχρι ΑΡ
       Για j από ΑΡ μέχρι i με_βήμα -1
            Αν Ε[j-1]<E[j] τότε
                Αντιμετάθεσε Ε[j], Ε[j-1]
                Αν j-1=κ τότε
                     κ<-κ+1
                Τέλος_αν
            Τέλος_αν
       Τέλος_επανάληψης
   Τέλος_επανάληψης
   Εμφάνισε ''η θέση του περσινού πρωταθλητή είναι'', κ
Αυτό το έκανα με την έννοια ότι αφού ο αθλητής είναι στην πρώτη θέση, η θέση του στην αντιμετάθεση θα αλλάζει όταν αντιμεταθέτεται η επίδοση(j-1=κ) και θα γίνεται +1(κ<-κ+1).

Επίσης αντί για flag στο Γ4 είπα
Παράθεση
Αν π<>0 τότε
    Εμφάνισε π
Τέλος_αν


και τέλος για το θέμα δ, στο τελευταίο ερώτημα έκανα άλλους τρις πίνακες οι οποίου έχουν αντίστοιχα τις επιδώσεις και τα ονόματα των τριών κατηγοριών και τους ταξινόμησα όπως και το γενικό πίνακα.
Και στο ερώτημα για το μεγαλύτερο πλήθος σκαφών στις κατηγορίες αντί για
   
Παράθεση
Αν κ1>κ2 και κ1>κ3 τότε
      Εμφάνισε “C1”
   αλλιώς_αν κ2>κ1 και κ2>κ3 τότε
      Εμφάνισε “C2”
   αλλιώς
      Εμφάνισε “C3”
   Τέλος_αν

έκανα max στα τρία πλήθη.
   
Παράθεση
k1<-max
   o_max<-ON[1]
   Αν k2>max  τότε
      max<-k2
      o_max<-ON[2]
   Τέλος_αν
     Αν k3>max  τότε
      max<-k3
      o_max<-ON[3]
   Τέλος_αν

Ευχαριστώ!

amilikas

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 38
Απ: Ημερήσια 2010
« Απάντηση #87 στις: 28 Μάι 2010, 01:32:22 μμ »
Φυσικά και δεν πρεπει να χρησιμοποιηθεί πίνακς. Στατικη δομή ειναι, το μέγεθος πρεπει να ειναι γνωστο (ή καποιο συγκεκριμένο και γνωστο οριο) κατα τον προγραμματισμο τους και όχι κατα την εκτέλεση. Το λεει ξεκαθαρα το σχολικο κεφ 3. Αλγόριθμος (εστω και σε ψευδογλωσσα) δεν ειναι κατι ασχετο ούτε αυθερετο απο ενα προγραμμα δοσμενο στη ΓΛΩΣΣΑ.
Πρεπει να κοπουν μονάδες (ποσες θα μαθουμε αυριο) αλλα γνωμη μου ειναι οχι πολλες.
Αν βεβαια το εκανε σε Pascal ή C/C++ και ειναι σωστο τοτε καμια μονάδα, αφου εκει μπορούμε να εχουμε arrays με μεγεθος που καθοριζεται κατα την διαρκεια της εκτελεσης (new/malloc) :)

builder

  • Νέος
  • *
  • Μηνύματα: 9
Απ: Ημερήσια 2010
« Απάντηση #88 στις: 28 Μάι 2010, 01:33:29 μμ »
Eri:
α. Το μυαλό δεν σκέφτεται ξεχωριστά ανά κεφάλαιο.
   Όταν λύνεις μια άσκηση σκέφτεσαι αν είναι για γνωστό ή άγνωστο πλήθος επαναλήψεων
   και αποφασίζεις πως θα λύσεις την άσκηση, συμφωνείς;
   Η μεταγλώττιση δεν έχει σχέση με το τι απόφαση θα πάρεις στο προηγούμενο.
β. Δηλαδή μου λες ότι επειδή είμαι πριν το 6, μιας και μιλάμε για αλγορίθμους, οποιαδήποτε
   άσκηση "πάει" με πίνακες βάζοντας αυθαίρετα ένα μεγάλο αριθμό για μήκος;

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3147
  • to Iterate is human to Recurse divine
Απ: Ημερήσια 2010
« Απάντηση #89 στις: 28 Μάι 2010, 01:33:42 μμ »
Λοιπόν από ότι φαίνεται από τις πρώτες εντυπώσεις το θέμα που θα συζητηθεί είναι το Γ.
Σίγουρα λύση με πίνακα όπως αυτές που έχουν δώσει αρκετά φροντιστήρια είναι λάθος. Το επιχείρημα για αυτό είναι ότι οι πίνακες δεν δημιουργούνται σε χρόνο εκτέλεσης. Το λέει ξεκάθαρα στο κεφάλαιο 3, όπου περιγράφει τους πίνακες σε ψευδογλώσσα και τους χαρακτηρίζει στατικές δομές. Άρα τέτοιο θέμα δεν υπάρχει.
   Το πρόβλημα είναι πως επειδή η εκφώνηση έλεγε να διαβάζουν το πλήθος αρκετοί πήραν πίνακες (για να μην πω η τεράστια πλειοψηφία).  Λόγω της δυσκολίας του θέματος υποθέτω ότι θα κοπούν πολύ λίγες μονάδες.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr