Αποστολέας Θέμα: ΠΡΟΒΛΗΜΑ  (Αναγνώστηκε 1398 φορές)

Stop GOTO

  • Οπαδός
  • **
  • Μηνύματα: 16
ΠΡΟΒΛΗΜΑ
« στις: 04 Νοέ 2012, 01:16:36 μμ »
Μπορείτε να μου πείτε το λάθος που έχω κάνει εδώ;

ΠΡΟΓΡΑΜΜΑ ασκηση
ΑΡΧΗ
 ΣΥΝΑΡΤΗΣΗ πρόσθεση(α, β, γ):ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
 ΑΡΧΗ
    πρόσθεση <- α + β + γ
 ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 ΔΙΑΔΙΚΑΣΙΑ εκτύπωση( α, β, γ)
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
  ΑΡΧΗ
     ΓΡΑΨΕ 'Το άθροισμα των α, β, και γ είναι ' , πρόσθεση( α, β, γ)
  ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΑΡΧΗ
  ΚΑΛΕΣΕ εκτύπωση(2, 3, 4)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
« Τελευταία τροποποίηση: 04 Νοέ 2012, 01:28:19 μμ από Stop GOTO »

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3174
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΠΡΟΒΛΗΜΑ
« Απάντηση #1 στις: 04 Νοέ 2012, 01:44:34 μμ »
πιο σωστό φαντάζει το:

ΠΡΟΓΡΑΜΜΑ ασκηση
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
ΑΡΧΗ
  α <- 2
  β <- 3
  γ <- 4
  ΚΑΛΕΣΕ εκτύπωση(α, β, γ)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 ΔΙΑΔΙΚΑΣΙΑ εκτύπωση( α, β, γ)
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
  ΑΡΧΗ
     ΓΡΑΨΕ 'Το άθροισμα των α, β, και γ είναι ' , πρόσθεση( α, β, γ)
  ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

 ΣΥΝΑΡΤΗΣΗ πρόσθεση(α, β, γ):ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
 ΑΡΧΗ
    πρόσθεση <- α + β + γ
 ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Stop GOTO

  • Οπαδός
  • **
  • Μηνύματα: 16
Απ: ΠΡΟΒΛΗΜΑ
« Απάντηση #2 στις: 04 Νοέ 2012, 07:55:35 μμ »
πιο σωστό φαντάζει το:

ΠΡΟΓΡΑΜΜΑ ασκηση
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
ΑΡΧΗ
  α <- 2
  β <- 3
  γ <- 4
  ΚΑΛΕΣΕ εκτύπωση(α, β, γ)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 ΔΙΑΔΙΚΑΣΙΑ εκτύπωση( α, β, γ)
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
  ΑΡΧΗ
     ΓΡΑΨΕ 'Το άθροισμα των α, β, και γ είναι ' , πρόσθεση( α, β, γ)
  ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

 ΣΥΝΑΡΤΗΣΗ πρόσθεση(α, β, γ):ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
 ΑΡΧΗ
    πρόσθεση <- α + β + γ
 ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Ναι, συμφωνω αλλα επειδή έχω δει αυτή τη λύση σε ένα tutorial και μόλις την περασα στο Διερμηνευτη τα εβγαζε λαθος... τελος παντων. Ευχαριστω πολύ

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3174
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: ΠΡΟΒΛΗΜΑ
« Απάντηση #3 στις: 05 Νοέ 2012, 09:11:46 πμ »
tutorial σχετικού με ΑΕΠΠ?
στη ΓΛΩΣΣΑ δεν τοποθετούνται τα υποπρογράμματα στο τμήμα δηλώσεων του προγράμματος, άρα εκ προοιμίου δεν κολλάει!!

Stop GOTO

  • Οπαδός
  • **
  • Μηνύματα: 16
Απ: ΠΡΟΒΛΗΜΑ
« Απάντηση #4 στις: 05 Νοέ 2012, 12:01:25 μμ »
σχετικό με Pascal... γι'αυτο το εχω λαθος μαλλον ε;

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2211
Απ: ΠΡΟΒΛΗΜΑ
« Απάντηση #5 στις: 05 Νοέ 2012, 12:36:57 μμ »
Σε Pascal θέλεις να το υλοποιήσεις ή σε ΓΛΩΣΣΑ;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Stop GOTO

  • Οπαδός
  • **
  • Μηνύματα: 16
Απ: ΠΡΟΒΛΗΜΑ
« Απάντηση #6 στις: 05 Νοέ 2012, 09:16:52 μμ »
Σε Pascal θέλεις να το υλοποιήσεις ή σε ΓΛΩΣΣΑ;
σε ΓΛΩΣΣΑ