Αποστολέας Θέμα: Υπολογισμός Μέσου Όρου άγνωστου πλήθους αριθμών  (Αναγνώστηκε 5532 φορές)

Blahadoni Despoina

  • Επισκέπτης
Ασκηση
Να γραφει Αλγοριθμος που θα διαβαζει Θερμοκρασιες που δινονται απο πληκτρολογιο και θα δινει τον Μεσο ορο (Στο τελος της ακολουθειας των αριθμων θα δινεται μεταβλητη της επιλογης σας .

Μπορειται να με βοηθησετε σας παρακαλω να καταλαβω πως θα αναπτυξω αυτον τον Αλγοριθμο.
Σας ευχαριστω πολυ. :)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Re: Υπολογισμός Μέσου Όρου άγνωστου πλήθους αριθμώ
« Απάντηση #1 στις: 27 Νοέ 2005, 10:36:11 μμ »
Δέσποινα, διέγραψα το μήνυμά σου από το θέμα που το έβαλες και άνοιξα καινούργιο θέμα με τον κατάλληλο τίτλο.

Η ερώτησή σου δεν έχει σχέση με το θέμα που την καταχώρησες, αφού εκείνο αφορά σε προβληματισμούς σχετικά με την εντολή επίλεξε ενώ η δική σου ερώτηση στην υλοποίηση του μηχανισμού για υπολογισμό του μέσου όρου άγνωστου πλήθους αριθμών.
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Άρης Βερνάρδος

  • Θαμώνας
  • ***
  • Μηνύματα: 25
    • Εκπαίδευση και Πληροφορική
Re: Υπολογισμός Μέσου Όρου άγνωστου πλήθους αριθμώ
« Απάντηση #2 στις: 28 Νοέ 2005, 01:34:44 πμ »
Θα το θέσω με λίγο καλύτερη διατύπωση:
Να γραφεί αλγόριθμος που να διαβάζει άγνωστο πλήθος θερμοκρασιών και να υπολογίζει και να εμφανίζει το μέσο όρο τους. Η εισαγωγή των στοιχείων να σταματάει μόλις δοθεί μία συγκεκριμένη τιμή (την οποία καλείστε να επιλέξετε).
Σε τέτοιες περιπτώσεις επιλέγουμε μία τιμή η οποία να μην είναι σωστή για το πρόβλημα. Π.χ. εδώ που έχουμε να κάνουμε με θερμοκρασίες θα μπορούσαμε να επιλέξουμε την τιμή -999. Σ' αυτά τα προβλήματα, η τιμή αυτή ονομάζεται συχνά και "τιμή φρουρός" (σχ. βιβλίο, σελ. 175). Ακολουθεί η λύση:

Αλγόριθμος Θερμοκρασίες
Sum <-- 0
Π <-- 0
Διάβασε Θ
Όσο Θ <> -999 επανάλαβε
        Π <-- Π + 1
        Sum <-- Sum + Θ
        Διάβασε Θ
Τέλος_επανάληψης
!Εξασφάλιση καθοριστικότητας αλγορίθμου
Αν Π > 0 τότε
        ΜΟ <-- Sum / Π
        εμφάνισε ΜΟ
αλλιώς
        εμφάνισε "Δεν δώσατε θερμοκρασίες!"
Τέλος_αν
Τέλος Θερμοκρασίες

Εύχομαι να σε βοήθησα.
« Τελευταία τροποποίηση: 28 Νοέ 2005, 01:41:42 πμ από comp-edu »
Α. Βερνάρδος
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Ε.Μ.Π.
Καθηγητής Πληροφορικής ΠΕ19

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3190
  • I love you 3000
    • Panagiotis Tsiotakis
Re: Υπολογισμός Μέσου Όρου άγνωστου πλήθους αριθμώ
« Απάντηση #3 στις: 28 Νοέ 2005, 05:25:48 μμ »
Σε όσα έγραψε ο φίλος μου Άρης, θα παραθέσω την επίλυση και με τη χρήση της δομής επανάληψης Μέχρις_ότου:

Αλγόριθμος Θερμοκρασίες_αλλιώς
Sum <-- 0
Π <-- 0
Αρχή_επανάληψης
 Διάβασε Θ
 Αν Θ <> -999 τότε
   Π <-- Π + 1
   Sum <-- Sum + Θ
 Τέλος_αν
Μέχρις_ότου Θ = -999
Αν Π <> 0 τότε  ! καθοριστικότητα
 ΜΟ <-- Sum / Π
 Εμφάνισε ΜΟ
Αλλιώς
 Εμφάνισε "Δεν δώσατε θερμοκρασίες!"
Τέλος_αν
Τέλος Θερμοκρασίες_αλλιώς

Όπου η δομή επιλογής εντός του βρόχου χρειάζεται γιατί δεν επιθυμούμε να επεξεργαστούμε την τιμή "φρουρό". Όμως, παρατηρούμε οτι αυτή η δομή επιλογής περιλαμβάνεται στην πρώτη υλοποίηση στην δομή Όσο!!

Άρα, το συμπέρασμα είναι πως η δομή Όσο είναι ισχυρότερη δομή επανάληψης.

Με εκτίμηση,