Αποστολέας Θέμα: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι  (Αναγνώστηκε 20270 φορές)

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 511
Καλή επιτυχία...
« Τελευταία τροποποίηση: 26 Μάρ 2008, 12:16:11 πμ από EleniK »

djohn

  • Νέος
  • *
  • Μηνύματα: 4
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #1 στις: 07 Αύγ 2008, 02:55:22 μμ »
Χαίρεται.... Μήπως υπάρχουν κάπου και οι λύσεις? Αν όχι υπάρχει περίπτωση κάποιος να ρίξει μια ματιά στην λύση του 4ου θέματος?

(έδωσα πανελλήνιες το 2007 και τώρα πήρα απόφαση να ξαναδώσω, το θέμα το έλυσα μετά από 6 ώρες επανάληψης και ενώ είχα 1 χρόνο + να κάνω αεππ, γι αυτό παρακαλώ να είστε επιεικείς)

σελ 1


σελ 2


σελ 3



MichaelP

  • Θαμώνας
  • ***
  • Μηνύματα: 34
  • ...Εγώ τους τα μαθαίνω χωρίς Απο...Έως ....
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #2 στις: 24 Ιαν 2009, 01:01:47 μμ »

Κατέβασα πρόσφατα το εν'λόγω θέμα και θα ήθελα να αναφέρω τα εξής:

1. Θεωρώ εκτός πραγματικότητας το 3ο και 4ο θέμα από πλευράς δυσκολίας
2. Δεν νομίζω ότι ο σκοπός είναι να δώσουμε στα παιδιά θέματα τόσο υψηλού επιπέδου και βαθμού δυσκολίας
3. Υπάρχει ένα ζήτημα στη διατύπωση της 3ης άσκησης στην αρχή όπου θεωρούμε ότι ο ανελκυστήρας, αρχικά βρίσκεται στο ισόγειο.
4. Πώς αντιμετωπίζετε το 4ο θέμα, στο σημείο που απαιτείται η επαναταξινόμηση των ομάδων με βάση τη διαφορά τερμάτων (μόνο αυτών που ισοβαθμούν?) Έχω την μικρή υποψία ότι οι λύσεις, αν υπάρχουν θα έχουν λάθος. Παρακαλώ διορθώστε με.

Ευχαριστώ

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #3 στις: 24 Ιαν 2009, 01:26:43 μμ »
Κατέβασα πρόσφατα το εν'λόγω θέμα και θα ήθελα να αναφέρω τα εξής:
Μπορείς να πεις πιο συγκεκριμένα τα σημεία που θεωρείς ότι είναι δύσκολα να τα απαντήσει ένας μαθητής κατά τη γνώμη σου?
Παράθεση
1. Θεωρώ εκτός πραγματικότητας το 3ο και 4ο θέμα από πλευράς δυσκολίας
4. Πώς αντιμετωπίζετε το 4ο θέμα, στο σημείο που απαιτείται η επαναταξινόμηση των ομάδων με βάση τη διαφορά τερμάτων (μόνο αυτών που ισοβαθμούν?) Έχω την μικρή υποψία ότι οι λύσεις, αν υπάρχουν θα έχουν λάθος. Παρακαλώ διορθώστε με.
Υποθέτω ότι από το θέμα 4 το ερώτημα που θεωρείς ότι είναι δύσκολο και εκτός πραγματικότητας είναι το 4ο έτσι? γιατί τα προηγούμενα είναι βατά. Αν κάποιος μαθητής δεν μπορεί να κάνει το 3ο ας πούμε δεν έχει καταλάβει τι είναι ο πίνακας και τι αποθηκεύουμε εκεί.
Το 4ο ερώτημα λοιπόν που θεωρείς εκτός πραγματικότητας έχει πέσει στις πανελλήνιες του 2004 στο 4ο θέμα με την ολυμπιάδα πληροφορικής. Εκεί τα παιδιά έπρεπε να ταξινομήσουν έναν πίνακα με βαθμούς και για όσους είναι ισόβαθμοι να τους εμφανίζουν σε αλφαβητική σειρά. Δηλαδή το ερώτημα αυτό του 2004 είναι πιο δύσκολο από το 4ο του διαγωνίσματος γιατί εκεί ζήταγαν και σύγκριση ονομάτων για την οποία πρέπει να ξέρεις τι είναι η λεξικογραφική διάταξη, η οποία μάλιστα εξηγείται σε εδάφιο του βιβλίου το οποίο είναι εκτός ύλης!!!!!
Άρα το συγκεκριμένο θέμα μάλλον παρα-είναι εντός πραγματικότητας.
   Μάλιστα όσον αφορά το λάθος που λες όχι μόνο λύνεται αλλά υπάρχουν και 2 εντελώς διαφορετικοί τρόποι για να το κάνεις. Στον ένα από τους 2 που έδωσε και η επιτροπή υπάρχουν μάλιστα και 2-3 παραλλαγές.

Για το ασανσέρ τώρα δεν καταλαβαίνω γιατί το βρισκείς εκτός πραγματικότητας. Το θέμα αυτό πραγματικα εξετάζει το επίπεδο κατανόησης κάποιου στους πίνακες και δεν είναι τυποποιημένη άσκηση που μπορεί να λυθεί από κάποιον μηχανικά, χωρίς να καταλαβαίνει τι κάνει.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3174
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #4 στις: 24 Ιαν 2009, 02:50:42 μμ »
η αλφαβητική ταξινόμηαη και η σύγκριση αλφαριθμητικών περιγράφεται πολύ αναλυτικά στην αρχή του κεφαλαίου 8, που είναι εντός ύλης.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #5 στις: 24 Ιαν 2009, 03:03:40 μμ »
Ναι σωστά, απλά δεν εννοούσα ότι η σύγκριση αλφαριθμητικών είναι εκτός ύλης. Δεν το διατύπωσα καλά.
Είχα στο μυαλό μου το παράδειγμα που έχει στις σελίδες 86-87, όπου αφιερώνει 2 σελίδες για να εξηγήσει την δυαδική αναζήτηση ενός ονόματος σε έναν πίνακα ονομάτων ο οποίος είναι σε αλφαβητική σειρά και μιλάει για λεξικογραφική διάταξη. Το παράδειγμα είναι καλό για να δει ο μαθητής πως αποθηκεύονται τα ονόματα σε έναν πίνακα και πως κάνουμε αναζήτηση όταν είναι σε αλφαβητική σειρά. Έτσι συνδέει την έννοια του μικρότερου με αυτό που προηγείται αλφαβητικά.
  Απλά η δυαδική αναζήτηση είναι εκτός ύλης  :(

η αλφαβητική ταξινόμηαη και η σύγκριση αλφαριθμητικών περιγράφεται πολύ αναλυτικά στην αρχή του κεφαλαίου 8, που είναι εντός ύλης.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3174
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #6 στις: 24 Ιαν 2009, 03:07:11 μμ »
Η δυαδική αναζήτηση μπορεί να υλοποιηθεί με Για?
 :D  >:D  :D  :D  :o  8)  :laugh:  :P

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #7 στις: 24 Ιαν 2009, 03:25:25 μμ »
Ναι απλά δεν θα σταματάει όταν το βρει π.χ. για Ν στοιχεία κάπως έτσι
Κώδικας: Text
  1. log2 <- ΛΟΓ(Ν) / ΛΟΓ(2)
  2. ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ log2
  3. Εντολές
  4.  


Η δυαδική αναζήτηση μπορεί να υλοποιηθεί με Για?
 :D  >:D  :D  :D  :o  8)  :laugh:  :P
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1014
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #8 στις: 24 Ιαν 2009, 03:31:33 μμ »
Θα συμφωνήσω με τον/ την MichaelP .

ΝΑΙ είναι εκτός πραγματικότητας.  Γιατί ; 

Γιατί μας έχει επιβληθεί μια άλλη "ποιοτική" πραγματικότητα (ειδικά με τα θέματα του 2008).

Είναι η   :   ο βλάκας (= αναγνώστης συνταγών) να γράφει 17 και ο παπαγάλος 19.   

MichaelP

  • Θαμώνας
  • ***
  • Μηνύματα: 34
  • ...Εγώ τους τα μαθαίνω χωρίς Απο...Έως ....
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #9 στις: 24 Ιαν 2009, 04:02:42 μμ »
Παιδιά, σιγά λίγο...
Λέγοντας εκτός πραγματικότητας εννοώ συνολικά δηλαδή, δεν μπορούν να συνυπάρξουν 3ο και 4ο θέμα ταυτόχρονα μαζί με την θεωρία σε ένα διαγώνισμα, στις πανελλήνιες. Αυτό εννοώ.
Τώρα συγκεκριμένα θα ήθελα να μου διατυπώσει κάποιος μια απο τις πολλές λύσεις για το τελευταίο υποερώτημα του 4ου παρακαλώ. Είναι εύκολο;

Ευχαριστώ

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1014
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #10 στις: 24 Ιαν 2009, 04:38:06 μμ »
Το τελευταίο υποερώτημα του 4ου θέματος.  Έχει ... τυποποίηση !   Φωνάζει   "2004 καλημέρα. Θυμίσου με !"

! Φυσαλίδα φθίνουσα  στον  Β[4]  !  όπου 4 θέσε 8   
! και σε περίπτωση ισοβαθμίας φθίνουσα στον Δ[4]   ! η διαφορά   
  ΓΙΑ I ΑΠΟ 2 ΜΕΧΡΙ 4
    ΓΙΑ J ΑΠΟ 4 ΜΕΧΡΙ I ΜΕ_ΒΗΜΑ -1
      ΑΝ Β[J] > Β[J - 1] ΤΟΤΕ
        temp1 <- Β[J]
        Β[J] <- Β[J - 1]
        Β[J - 1] <- temp1
        temp2 <- Ο[J]
        Ο[J] <- Ο[J - 1]
        Ο[J - 1] <- temp2
        temp1 <- Δ[J]
        Δ[J] <- Δ[J - 1]
        Δ[J - 1] <- temp1
      ΑΛΛΙΩΣ_ΑΝ Β[J] = Β[J - 1] ΚΑΙ Δ[J] > Δ[J - 1] ΤΟΤΕ
        temp2 <- Ο[J]
        Ο[J] <- Ο[J - 1]
        Ο[J - 1] <- temp2
        temp1 <- Δ[J]
        Δ[J] <- Δ[J - 1]
        Δ[J - 1] <- temp1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                                                ! τα εμφανίζω   
  ΓΡΑΨΕ 'ΤΕΛΙΚΗ ΚΑΤΑΤΑΞΗ'
  ΓΡΑΨΕ 'ΟΜΑΔΑ     ΒΑΘΜΟΛΟΓΙΑ  ΔΙΑΦΟΡΑ ΤΕΡΜΑΤΩΝ'
  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΡΑΨΕ Ο, '     ', Β, '          ', Δ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ 

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1014
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #11 στις: 24 Ιαν 2009, 04:41:43 μμ »
Διόρθωση! τα εμφανίζω   
  ΓΡΑΨΕ 'ΤΕΛΙΚΗ ΚΑΤΑΤΑΞΗ'
  ΓΡΑΨΕ 'ΟΜΑΔΑ     ΒΑΘΜΟΛΟΓΙΑ  ΔΙΑΦΟΡΑ ΤΕΡΜΑΤΩΝ'
  ΓΙΑ I ΑΠΟ 1 ΜΕΧΡΙ 4
    ΓΡΑΨΕ Ο[Ι], '     ', Β[Ι], '          ', Δ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

MichaelP

  • Θαμώνας
  • ***
  • Μηνύματα: 34
  • ...Εγώ τους τα μαθαίνω χωρίς Απο...Έως ....
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #12 στις: 24 Ιαν 2009, 05:11:39 μμ »
οκ, δεκτό. Επιμένω, χωρίς να θέλω να σας προσβάλω, ότι τα θέματα είναι δύσκολα, όλα μαζί σε ένα διαγωνισμό πανελληνίων.
Σε κάθε περίπτωση πάντως συμφωνώ ότι χρειάζονται κάτι (πολύ) περισσότερο από παπαγαλία του μαθήματος. Χρειάζονται το πνεύμα του προγραμματιστή, για το οποίο χαίρομαι. Αυτό βέβαια θα το έλεγα περισσότερο για το 3ο θέμα του ανελκυστήρα και λιγότερο για το 4ο, το οποίο, αν κάποιος δεν έχει δει την συγκεκριμένη ανάπτυξη αλγορίθμου ξανά, την συγκεκριμένη λογική δηλαδή (αναφέρομαι στο τελευταίο υποερώτημα αποκλειστικά) θεωρώ ότι είναι δύσκολο να μην πάει το μυαλό του αλλού, δηλαδή σε άλλες αλχημείες για να ταξινομήσει ορθά τον τελικό πίνακα. Ομολογώ ότι προσωπικά δεν το είχα ξαναδεί και παρόλο που το δικό μου μυαλό πήγε σε αυτή τη λύση (στην αρχή) δεν την συνέχισα, και προσπάθησα να χαρίσω ένα bunus σε καθεμία απο τις ομάδες που ισοβαθμούν (απο 0-0.9) ώστε σε μια νέα ταξινόμηση να κάτσουν στη σωστή θέση και μετά να χρησιμοποιήσω Α_Μ για να γυρίσω στη σωστή βαθμολογία...Αλχημείες. Δεν ξέρω...το δικό μου μυαλό έτσι λειτούργησε. Φοβάμαι όμως ότι το μυαλό των παιδιών (των περισσοτέρων) δεν θα δουλέψει τόσο καλά όσο το δικό μου στην περίπτωση που δεν το είχαν ξαναδεί. Αν από την άλλη το είχαν ξαναδεί, τότε θα πήγαινε κατ'ευθείαν σ'αυτό (παπαγαλία δηλαδή). Τώρα εσείς θα μου πείτε ααα φίλε μου ας πρόσεχε το παιδί, να διάβαζε και να είχε δεί το κολπάκι. Ε αυτό λέω και εγώ πρόκειται για κολπάκι δηλαδή πρόκειται για μια μορφή παπαγαλίας δευτέρου επιπέδου, αν μου επιτρέπετε.
Και μή μου πείτε ότι η μεταβολή του δεδομένου αλγορίθμου ταξινόμισης είναι κάτι που κάνουμε καθημερινά για να λύσουμε ασκήσεις...άρα δεν εμπεριέχεται κανένα κόλπο στο θέμα, γιατί θα σας απαντήσω ότι στο 95% των περιπτώσεων δεν απαιτείται η τροποποίηση του εν'λόγω αλγορίθμου, πέραν ίσως της τροποποίησης για την ταυτόχρονη αντίστοιχη ταξινόμηση ενός δεύτερου πίνακα, με βάση έναν πρωτεύον που ταξινομούμε.

Αυτά. Ευχαριστώ για την λύση.

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1465
  • Δεν αντέχω την (συμ)-πίεσηηη .......
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #13 στις: 24 Ιαν 2009, 06:47:41 μμ »
Φίλε MichaelP,
η ομάδα που έβγαλε και βγάζει τα διαγωνίσματα θέλει προφανώς να "δώσει" αυτό που λείπει απο το μάθημα στο σχολείο ή το φορντηστήριο. Πίστεψέ με δεν είναι σκοπός (δικός μου τουλάχιστον) να "βάλω " θέματα Πανελληνιών. Σκοπός είναι να βάλουμε στην μπάντα τους τυφλοσούρτες και την παπαγαλία, που μέχρι στιγμής χαρακτηρίζει τις Πανελλήνιες σ'αυτό το μάθημα, οπότε δικαιολογημένα φαίνονται δύσκολες οι ασκήσεις.
Αν τις βρίσκανε εύκολες οι μαθητές θα ανησυχούσα γιατί δε θα υπήρχε λόγος ύπαρξης της ομάδας διαγωνισμάτων :)
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

vasiko

  • Βετεράνος
  • ****
  • Μηνύματα: 82
  • !!!!...!!!
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #14 στις: 24 Ιαν 2009, 08:20:46 μμ »
Μόλις κοίταξα τα θέματα και πραγματικά πρόκειται για εξαιρετική δουλειά.
Μϊα ερώτηση μόνο θα ήθελα να κάνω. Στο τρίτο θέμα δεν μπορώ να καταλάβω τι ακριβώς θέλετε να απαντήση ο μαθητής στο υποερώτημα β"δ) Να περιγραφούν όλες οι δομές δεδομένων που χρησιμοποιήθηκαν". Τι ακριβώς πρέπει να περιγράψει;
Και ποιος ο σκοπός του ερωτήματος αυτού.
Ευχαριστώ.

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1465
  • Δεν αντέχω την (συμ)-πίεσηηη .......
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #15 στις: 24 Ιαν 2009, 10:37:27 μμ »
Δομές δεδομένων στο συγκεκριμένο θέμα αποτελούν οι πίνακες που χρησιμοποιούνται.
Το ερώτημα είναι θεωρητικό και σκοπό έχει να ελέγξει ως προς αυτή την κατεύθυνση τον μαθητή. Περίεργο, αλλά δεν είναι λίγοι οι μαθητές που λύνουν ασκήσεις σε πίνακες και δεν αναγνωρίζουν τι είναι οι δομές δεδομένων αν και κάνουν χρήση αυτών.
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

MichaelP

  • Θαμώνας
  • ***
  • Μηνύματα: 34
  • ...Εγώ τους τα μαθαίνω χωρίς Απο...Έως ....
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #16 στις: 25 Ιαν 2009, 01:58:57 πμ »
Αγαπητοί,

Όλοι συμφωνούμε για το ότι απαιτείται υψηλότερο επίπεδο στη γ' λυκείου.
Καλό θα ήταν όμως το υψηλότερο επίπεδο να μη τα ανακαλύπτουν ξαφνικά τα παιδιά στο 3ωρο των εξετάσεών τους. Θα ήταν χρήσιμο για τα νεύρα τους, νομίζω και τα δικά μας, να προϋπάρχει η ανάλογη υποδομή στην οποία θα στηριχθεί αυτό το επίπεδο, ήδη από την 1η λυκείου.
Δεν είναι δυνατόν να τους πετάμε ένα ξεροκόκαλο (βιβλίο) και να τους λέμε φτιάξε επίπεδο.
Άρα αυτό που πρώτα πρέπει να ανέβει είναι το δικό μας επίπεδο, προκειμένου να αντιληφθούμε την πραγματικότητα και να προσπαθήσουμε να την αλλάξουμε.
Και επιτρέψτε μου να πολιτικολογήσω λίγο (αν και δεν είναι ο κατάλληλος τόπος, το αντιλαμβάνομαι) αλλά πως είναι δυνατόν να συζητάμε για επίπεδο και αλλαγές σ'αυτή τη χώρα και όταν έρθει η ώρα της κάλπης, να το ρίχνουμε διαρκώς στα μπλέ και πράσινα ανθρωπάκια, είναι κάτι που ποτέ δεν κατάλαβα.

Συγχωρέστε την ατασθαλία μου αυτή.

Καλή συνέχεια.

vasiko

  • Βετεράνος
  • ****
  • Μηνύματα: 82
  • !!!!...!!!
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #17 στις: 25 Ιαν 2009, 01:13:30 μμ »
Δομές δεδομένων στο συγκεκριμένο θέμα αποτελούν οι πίνακες που χρησιμοποιούνται.
Το ερώτημα είναι θεωρητικό και σκοπό έχει να ελέγξει ως προς αυτή την κατεύθυνση τον μαθητή. Περίεργο, αλλά δεν είναι λίγοι οι μαθητές που λύνουν ασκήσεις σε πίνακες και δεν αναγνωρίζουν τι είναι οι δομές δεδομένων αν και κάνουν χρήση αυτών.

Εξακολουθώ να μην καταλάβαίνω ποια απάντηση περιμένετε από το μαθητή.
Να σας πει "Χρησιμοποίησα ένα μονοδιάστατο πίνακα 10 θέσεων" για να ελέγξετε αν έχει κατανοήση ότι ο πίνακας είναι δομή δεδομένων;
Κατάλαβα καλά;

MichaelP

  • Θαμώνας
  • ***
  • Μηνύματα: 34
  • ...Εγώ τους τα μαθαίνω χωρίς Απο...Έως ....
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #18 στις: 25 Ιαν 2009, 03:43:11 μμ »
Όχι, να πει ότι χρησιμοποίησα στατικές δομές δεδομένων, να τις περιγράψει: διαστάσεις, αριθμό στοιχείων και να διατυπώσει τι δουλειά κάνουν δηλαδή πώς χρησιμοποιούνται, για ποιο λόγο και τι τύπο δεδομένων διατηρούν.

vasiko

  • Βετεράνος
  • ****
  • Μηνύματα: 82
  • !!!!...!!!
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #19 στις: 25 Ιαν 2009, 04:59:13 μμ »
Όχι, να πει ότι χρησιμοποίησα στατικές δομές δεδομένων, να τις περιγράψει: διαστάσεις, αριθμό στοιχείων και να διατυπώσει τι δουλειά κάνουν δηλαδή πώς χρησιμοποιούνται, για ποιο λόγο και τι τύπο δεδομένων διατηρούν.
OK Ευχαριστώ για τη διευκρίνηση.
Νομίζω ότι η εκφώνηση είναι πολύ συμπυκνωμένη και θα πάρουμε πολλές λάθος απαντήσεις από μαθητές που έχουν διαβάσει.

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #20 στις: 26 Ιαν 2009, 08:36:25 πμ »
Το θέμα 4 είναι εμπνευσμένο από το διδακτικό πακέτο. Τετράδιο μαθητή, κεφάλαιο 9, ΔΣ6. Εκεί υπάρχει και η τριγωνική σάρωση και η ταξινόμηση με δευτερεύον κριτήριο.

Αυτό που θέλουμε να δείξουμε είναι ότι το ίδιο το διδακτικό πακέτο έχει θαυμάσια θέματα και εμείς είμαστε υποχρεωμένοι να τα διδάξουμε γιατί είναι εντός ύλης. Κάποιος που έχει διδαχθεί το διδακτικό πακέτο (δηλαδή την εξεταστέα ύλη και όχι μόνο τα ΣΟΣ) θα πρέπει να λύσει το θέμα 4.

Έχουμε φτάσει στο σημείο (λόγω των θεμάτων που πέφτουν στις εξετάσεις) να θεωρούμε λάθος τη στήριξη του διδακτικού πακέτου και σωστό το να πέφτουν τα κονσερβοποιημένα θέματα που πέφτουν στις εξετάσεις που λύνονται με κώδικες που τους μαθαίνουν απέξω. Εκεί έχουμε φτάσει


evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #21 στις: 26 Ιαν 2009, 12:12:17 μμ »

Μια στιγμή, δηλαδή εσύ τι προτείνεις? να ζητάμε από τους μαθητές να εφαρμόσουν απλά τους αλγορίθμους? Πως θα ξεχωρίσεις έτσι αυτόν που έχει κατανοήσει πως δουλεύει ο αλγόριθμος και αυτόν που απλά τον έχει μάθει απέξω. Ειδικά για την ταξίνομηση της φυσαλίδας η τεράστια πλειοψηφία των μαθητών δεν κάθεται να τον καταλάβει απλά τον μαθαίνει απέξω. Όταν βλέπουν ότι για τα θέματα που πέφτουν τους αρκεί αυτό θα κάνουν μόνο αυτό και οι καθηγητές θα διδάξουν μόνο αυτό. Θα πουν στον μαθητή άστο αμα δεν το καταλαβαίνεις μάθε το απέξω και είσαι οκ.
  Ε το θέμα αυτό τους έκανε να καθήσουν και να σκεφτούν πως δουλεύει ο αλγόριθμος και τι αλλαγή πρέπει να κάνουν εκεί πάνω. Και φυσικά θα πάει το μυαλό λίγων μαθητών εκεί διότι πρέπει να ξεχωρίσουν οι καλύτεροι και όχι να γράφουν όλοι 100 και να έχουν την εντύπωση ότι ΑΟΔΕ και ΑΕΠΠ έχουν το 100άρι σίγουρο.
   Αν έχεις πρόβλημα με τη συνολική δυσκολία του διαγωνίσματος, ότι δηλαδή ίσως να μην υπάρξει καλή κατανομή της βαθμολογίας το συζητάμε.
   Αλλά όσον αφορά την τροποποίηση του αλγορίθμου προσωπικά είμαι κάθετος. Μόνο έτσι ο μαθητής θα δείξει αν έχει κατανόησει πλήρως πως δουλεύει.
   Σκέψου για παράδειγμα τα μαθηματικά της κατεύθυνσης. Όλοι οι μαθητές έχουν μάθει τους βασικούς κανόνες παραγώγισης μηχανικά. Οι περισσότεροι όμως δεν ξέρουν διαισθητικά τι είναι η παράγωγος. Αν χρειαστεί να εφαρμόσουν τον ορισμό αρκετοί θα σηκώσουν τα χέρια ψηλά.

Ο σκοπός των θεμάτων είναι να ελέγξουν το επίπεδο κατανόησης της θεωρίας. Η απλή εφαρμογή κάποιων τεχνικών ή αλγορίθμων και η αποστήθιση της θεωρίας δεν συνεπάγονται απαραίτητα και την κατανόησή της.

Και μή μου πείτε ότι η μεταβολή του δεδομένου αλγορίθμου ταξινόμισης είναι κάτι που κάνουμε καθημερινά για να λύσουμε ασκήσεις...άρα δεν εμπεριέχεται κανένα κόλπο στο θέμα, γιατί θα σας απαντήσω ότι στο 95% των περιπτώσεων δεν απαιτείται η τροποποίηση του εν'λόγω αλγορίθμου, πέραν ίσως της τροποποίησης για την ταυτόχρονη αντίστοιχη ταξινόμηση ενός δεύτερου πίνακα, με βάση έναν πρωτεύον που ταξινομούμε.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

MichaelP

  • Θαμώνας
  • ***
  • Μηνύματα: 34
  • ...Εγώ τους τα μαθαίνω χωρίς Απο...Έως ....
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #22 στις: 26 Ιαν 2009, 07:58:21 μμ »
gpapargi, γράφεις: Το θέμα 4 είναι εμπνευσμένο από το διδακτικό πακέτο. Τετράδιο μαθητή, κεφάλαιο 9, ΔΣ6. Εκεί υπάρχει και η τριγωνική σάρωση και η ταξινόμηση με δευτερεύον κριτήριο.

Αυτό που θέλουμε να δείξουμε είναι ότι το ίδιο το διδακτικό πακέτο έχει θαυμάσια θέματα και εμείς είμαστε υποχρεωμένοι να τα διδάξουμε γιατί είναι εντός ύλης. Κάποιος που έχει διδαχθεί το διδακτικό πακέτο (δηλαδή την εξεταστέα ύλη και όχι μόνο τα ΣΟΣ) θα πρέπει να λύσει το θέμα 4.

Δεν κατάλαβα, γιατί το τετράδιο μαθητή είναι εντός ύλης; όχι ότι με χαλάει απλά ρωτάω. Δηλαδή για να καταλάβω βρε παιδιά, τι είναι εντός ύλης και τι εκτός; Νομίζω ότι η εξεταστέα ύλη είναι συγκεκριμένη, και δεν περιλαμβάνει το τετράδιο του μαθητή.

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1465
  • Δεν αντέχω την (συμ)-πίεσηηη .......
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #23 στις: 26 Ιαν 2009, 09:10:18 μμ »

Δεν κατάλαβα, γιατί το τετράδιο μαθητή είναι εντός ύλης; όχι ότι με χαλάει απλά ρωτάω. Δηλαδή για να καταλάβω βρε παιδιά, τι είναι εντός ύλης και τι εκτός; Νομίζω ότι η εξεταστέα ύλη είναι συγκεκριμένη, και δεν περιλαμβάνει το τετράδιο του μαθητή.


 ???
Τώρα καταλαβαίνω γιατί δε μπορούμε να συνενοηθούμε, ενώ μιλάμε μαζί ...
Απο που συμπέρανες φίλε MichaelP ότι το Τετράδιο του μαθητή είναι εκτός ύλης; Το είδες γραμμένο καπου ; Σου το είπε κάποιος ; Το συμπέρανες αυθαίρετα ;
Γιατί εδώ και 10 χρόνια που διδάσκω το μάθημα το Τετράδιο αποτελεί όχι μόνο μέρος της ύλης αλλά αρκετά θέματα των Πανελλαδικών έχουν επιλεγεί απο εκεί .......

Όταν το Υπουργείο δίνει π.χ στην ύλη το Κεφ.2 απο το βιβλίο του μαθητή , αυτομάτως εντάσσεται και το αντίστοιχο κεφάλαιο του τετραδίου. Δεν είναι προφανές ; Απο που πηγάζουν οι ασκήσεις οι οποίες εμπεδώνουν τη θεωρία ; Απο το διάστημα ; Απο τη προσωπική συλλογή του καθενός καθηγητή; ......Η απάντηση είναι εύκολη.. απο το Τετράδιο Μαθητή ......
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

MichaelP

  • Θαμώνας
  • ***
  • Μηνύματα: 34
  • ...Εγώ τους τα μαθαίνω χωρίς Απο...Έως ....
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #24 στις: 27 Ιαν 2009, 09:21:32 πμ »
περίμενε, αυτό συνεπάγεται ότι ορισμένες extra έννοιες οι οποίες βρίσκονται μόνο στο τετράδιο του μαθητή είναι εντός ύλης, θεωρούνται γνωστές. Όπως επίσης ορισμένοι άλλοι αλγόριθμοι. Έχω πραγματικά την εντύπωση ότι αυτό που λές δεν ισχύει. Παρόλα αυτά, επειδή έχεις πολύ περισσότερη εμπειρία απο μένα, το σέβομαι και το δέχομαι ώς σωστό.
Σε ευχαριστώ πολύ.

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1465
  • Δεν αντέχω την (συμ)-πίεσηηη .......
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #25 στις: 27 Ιαν 2009, 10:15:08 πμ »
Φίλε Μιχάλη,

δεν είναι θέμα εμπειρίας αλλά λογικής. Το βιβλίο περιγράφει κυρίως τη θεωρητική προσέγγιση κάθε δομής εντολών ή δεδομένων, με αρκετά μικρό πλήθος ασκήσεων. Δηλαδή μόνο αυτές που λύνει το βιβλίο θεωρούνται εντός ύλης ; Απο τη στιγμή που μια άσκηση λύνεται βάσει της εντός ύλης θεωρίας, τότε αυτομάτως είναι στην ύλη.
Για παράδειγμα η συγχώνευση στους πίνακες αναφέρεται στο βιβλίο μόνο θεωρητικά ενώ ο αλγόριθμος δίνεται στο τετράδιο μαθητή κεφ.9 σελ. 91 στο παράδειγμα 3.
Εσύ θεωρείς ότι είναι εκτός ύλης επειδή δεν αναγράφεται στο βιβλίο ;
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

Σούλας Βασίλης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 305
    • Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #26 στις: 27 Ιαν 2009, 10:35:11 πμ »
Τα αντίστοιχα κεφάλαια του βιβλίου μαθητή που βρίσκονται στο τετράδιο μαθητή είναι εντός ύλης και πράγματι πολλά θέματα των Πανελληνίων είναι από εκεί.
Σούλας Βασίλης
Ηλεκτρολόγος Μηχανικός & Μηχανικός Η/Υ Δ.Π.Θ.
Καθηγητής Πληροφορικής ΠΕ19
http://users.sch.gr/vasisoulas
http://eclass.sch.gr/modules/auth/opencourses.php?fc=%D4-52

MichaelP

  • Θαμώνας
  • ***
  • Μηνύματα: 34
  • ...Εγώ τους τα μαθαίνω χωρίς Απο...Έως ....
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #27 στις: 27 Ιαν 2009, 11:20:30 πμ »
ok, δεν αντιτίθεμαι στις απόψεις σας αγαπητοί φίλοι. Τις δέχομαι απόλυτα. Απλά θέλω περισσότερες διευκρινήσεις για να καταλάβω μερικά πράγματα:
Έννοιες (όχι δύσκολες) αλλά που παρόλα αυτά περιγράφονται στο τετράδιο, όπως για παράδειγμα ο αραιός πίνακας, μπορούν να αναφερθούν σε θέμα πανελληνίων χωρίς εξήγηση ; Πχ δίνεται ένας 80% αραιός πίνακας....ή να βρεθεί αν ο πίνακας που προκύπτει τουλάχιστον είναι 80% αραιός, χωρίς να εξηγήσει τι σημαίνει αραιός πίνακας;

Ευχαριστώ.

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1014
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #28 στις: 27 Ιαν 2009, 12:02:25 μμ »
Καλημέρα σας.   

Είναι αυτονόητο ότι το τετράδιο είναι εντός ύλης.  Τότε γιατί το δίνουν ;Γνωρίζω συναδέλφους σε σχολεία που λένε ευθέως στους μαθητές :  "Το τετράδιο ξεχάστε το."  !!!!

MichaelP

  • Θαμώνας
  • ***
  • Μηνύματα: 34
  • ...Εγώ τους τα μαθαίνω χωρίς Απο...Έως ....
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #29 στις: 27 Ιαν 2009, 12:06:52 μμ »
Τότε όταν βγαίνει η ύλη, γιατί δεν λένε : κεφ Χ,Υ,Ζ απο το σχολικό και τα κεφάλαια Ω,Τ, απο - εώς στο τετράδιο του μαθητή; Αυτό δεν μπορώ να καταλάβω.

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1014
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #30 στις: 27 Ιαν 2009, 12:10:45 μμ »
Και κάτι άλλο για την τυποποίηση   :   

Λίγο πριν μπούμε στους πίνακες  : 

ΝΓΑ που να διαβάζει 30 θερμοκρασίες  και να υπολογίζει τη μέση θερμοκρασία αυτών.

Για ι από 1 μέχρι 30
   Διάβασε θερμοκρασία ! μεταβλητή
Τέλος_επανάληψης

Σ <- 0
Για ι από 1 μέχρι 30
   Διάβασε θερμοκρασία
   Σ <- Σ + θερμοκρασία
Τέλος_επανάληψης
μο <- Σ/30

Η παραπάνω μαθήτρια , άραγε καταλαβαίνει τι κάνει ;

Απλά της είπα :   Δώσε τον κωδικό της συνταγής !!!

Δεν θέλουμε απλησίαστα θέματα.  Απλά θέματα ,  αλλά να σκέφτεται ο  μαθητής και να καταλαβαίνει τι κάνει.


MichaelP

  • Θαμώνας
  • ***
  • Μηνύματα: 34
  • ...Εγώ τους τα μαθαίνω χωρίς Απο...Έως ....
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #31 στις: 27 Ιαν 2009, 12:14:10 μμ »
Η ύλη όπως προκύπτει απο το υπουργείο ορίζει:
"Από το βιβλίο "Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον" των Α. Βακάλη, Η. Γιαννόπουλου, Ν. Ιωαννίδη, Χ. Κοίλια, Κ. Μάλαμα, Ι. Μανωλόπουλου, Π. Πολίτη, έκδοση Ο.Ε.Δ.Β. 2008, η ύλη για το σχολικό έτος 2008 - 2009 είναι:"

Δεν αναφέρει τίποτα για το τετράδιο του μαθητή. Αυτό έρχεται να συμπληρώσει το σχολικό βιβλίο (στο οποίο θα εξεταστούν οι μαθητές) προκειμένου να γίνουν κάποιες έννοιες πιό κατανοητές. Άσχετα αν χρειάζεται να ασχοληθούμε και με το τετράδιο του μαθητή, το συγκεκριμένο τετράδιο είναι εκτός εξεταζόμενης ύλης. Ναι, απαιτείται τα παιδιά να προετοιμαστούν με γνώμονα και αυτό το βιβλίο, δεν διαφωνούμε, αλλά είναι άλλο αυτό και άλλο να λέμε ότι είναι εντός ύλης.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #32 στις: 27 Ιαν 2009, 12:55:12 μμ »
  Νομίζω έχουμε παρεξηγήσει την έννοια της ύλης και η κουβέντα πάει σε λάθος κατεύθυνση. Οι γιώργηδες δεν εννοούν ότι το τετράδιο του μαθητή μπορεί να εξεταστεί σαν θεωρία. Αυτό το συμπέρανες εσύ Μιχάλη επειδή θεωρήσαμε το τετράδιο του μαθητή εντός ύλης. Το τετράδιο του μαθητή δεν είναι στην ύλη με το σκεπτικό ότι πρέπει ο μαθητής να ξέρει τι είναι διαγώνιος πίνακας ή άνω τριγωνικός ή δεν ξέρω τι άλλο. Ούτε είναι υποχρεωμένος να ξέρει για τον πολλαπλασιασμό πινάκων.
  Επειδή το τετράδιο του μαθητή είναι εξαιρετικά προχειρογραμμένο και αυτό φαίνεται σε πολλά σημεία πολλές φορές θεωρεί γνωστές έννοιες που δεν ξέρουν τα παιδιά και δεν είναι μέρος της θεωρίας. Υπό αυτή την έννοια έχεις δίκιο όταν λες ότι το τετράδιο είναι εκτός ύλης.
    Τα παιδιά όμως δεν εννοούν αυτό όταν λένε ότι είναι εντός ύλης. Εννοούν ότι πολλές ασκήσεις που έχουν πέσει θέματα στις εξετάσεις έχουν παρθεί ακόμα και αυτούσιες πολλές φορές (βλέπε θέμα 2 πέρυσι) ακόμα και από τμήμα του τετραδίου που αναφέρεται σε κεφάλαιο εκτός ύλης. Άρα πρέπει να δίνουμε σημασία στο τετράδιο του μαθητή αφού αποτελεί ουσιαστικά τράπεζα θεμάτων για την επιτροπή (τους λόγους ας μην τους αναλύσω εδώ, καταλαβαίνουν όλοι γιατί) και όσο μπορούμε να ακολουθούμε τη φιλοσοφία των ασκήσεων.
  Για παράδειγμα μπορεί να μπει θέμα που να ζητάει τη σάρωση της κυρίας διαγωνίου ενός πίνακα από τους μαθητές. Δεν μπορεί όμως να χρησιμοποιηθεί η λέξη "κύρια διαγώνιος" γιατί δεν είναι μια έννοια που έχουν διδαχθεί τα παιδιά. Θα πρέπει η εκφώνηση να τους οδηγεί εκεί με άλλο τρόπο ή να χρησιμοποιεί την ωρολογία αυτή αφού την ορίσει πρώτα και τους δείξει και ένα σχήμα για να καταλάβουν και διαισθητικά.
 Πιστεύω ότι συμφωνείς και εσύ με το παραπάνω σκεπτικό
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

MichaelP

  • Θαμώνας
  • ***
  • Μηνύματα: 34
  • ...Εγώ τους τα μαθαίνω χωρίς Απο...Έως ....
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #33 στις: 27 Ιαν 2009, 02:15:45 μμ »
 :D Ακριβώς evry, αυτό εννοούσα από την αρχή, άλλο το εντός εξεταστέας ύλης όπως αυτή καθορίζεται κάθε χρόνο από το υπουργείο, και άλλο αν το συγκεκριμένο βοήθημα του μαθητή είναι must γιατί μπαίνουν θέματα από εκεί, γιατί αναλύει κάποια θέματα σε μεγαλύτερο βάθος γιατί, γιατί...
οκ νομίζω ότι λύθηκε η όποια παρεξήγηση.

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #34 στις: 30 Ιαν 2009, 12:54:14 μμ »
Το τετράδιο είναι εντός ύλης γιατί περιέχει τις ασκήσεις του μαθήματος. Το βιβλίο έχει μόνο τη θεωρία.
Πχ στα μαθηματικά το ίδιο σύγγραμμα περιέχει και τη θεωρία και τις ασκήσεις. Σε εμάς αυτά τα 2 είναι σε χωριστά συγγράμματα.

Διαφορετικά το μάθημά μας θα ήταν μόνο θεωρία.

Πχ την πρώτη φορά που διδάχθηκε το μάθημα τι ασκήσεις θα έπρεπε να κάνει ο καθηγητής; Προφανώς το τετράδιο. Αυτό που είναι μέσα είναι αυτά που αντιστοιχούν στις εντός ύλης παραγράφους του βιβλίου.

τασα

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #35 στις: 20 Φεβ 2009, 11:50:00 πμ »
Mipos tha itan eukolo na ixa tis apadiseis tou 3ou thematos giati exw  psilokolisi ? thanks.

mirsini20

  • Επισκέπτης
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #36 στις: 08 Φεβ 2010, 04:10:51 μμ »
μηπως θα μπορουσα να βρω καπου τις λυσεις ωστε να εχςω ενα προτυπο διορθωσησ??
σας ευχαριστω

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 511
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #37 στις: 10 Μάρ 2010, 12:42:08 πμ »
Παραθέτω τη λύση όλου του διαγωνίσματος μετά από τα αιτήματά σας...

Αν υπάρχει διαφωνία με το ανέβασμα των λύσεων το συζητάμε και την κατεβάζουμε...
Απλά είδα αρκετά αιτήματα...

Επίσης καλό είναι να ρίξει κάποιος και ένα δεύτερο μάτι μήπως τυχόν μου ξέφυγε κάτι...
Καλό είναι να διορθώνουμε και τους καθηγητές καμμιά φορά...  :D

« Τελευταία τροποποίηση: 11 Μάρ 2010, 11:16:20 μμ από bagelis »

Θεοπίστη

  • Νέος
  • *
  • Μηνύματα: 3
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #38 στις: 18 Μάρ 2010, 02:26:36 πμ »
Νομίζω ότι στο 3ο Θέμα στις απαντήσεις δεν έκανες αυτό που λέει στο β)1) .....και εμφανίζει μήνυμα που δείχνει αν το ασανσέρ κατεβαίνει ή ανεβαίνει.

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 511
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #39 στις: 18 Μάρ 2010, 02:57:09 μμ »
Έχεις απόλυτο δίκιο...

Το ανεβάζω πάλι....

programmer

  • Θαμώνας
  • ***
  • Μηνύματα: 44
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #40 στις: 08 Φεβ 2015, 04:47:06 πμ »
ΤΟ  4 8ΕΜΑ ΣΕ ΓΛΩΣΣΑ ΜΠΟΡΕΙΤΕ ΝΑ ΤΟ ΔΟΚΙΜΑΣΕΤΕ
« Τελευταία τροποποίηση: 08 Φεβ 2015, 05:02:57 πμ από programmer »

programmer

  • Θαμώνας
  • ***
  • Μηνύματα: 44
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #41 στις: 08 Φεβ 2015, 05:13:06 πμ »
Έχεις απόλυτο δίκιο...

Το ανεβάζω πάλι....
ΝΟΜΙΖΩ ΟΤΙ ΣΤΟ 3 ΘΕΜΑ ΔΕΝ ΕΧΕΙΣ ΕΛΕΓΞΕΙ ΓΙΑ ΤΟ ΑΝ Η ΚΛΗΣΗ ΒΡΙΣΚΕΤΑΙ ΣΤΗΝ ΤΡΕΧΩΝ ΘΕΣΗ.ΠΧ ΑΝ ΒΡΙΣΚΕΤΑΙ ΣΤΟΝ ΤΡΙΤΟ ΟΡΟΦΟ ΚΑΙ ΤΟ ΚΑΛΕΣΩ ΘΑ ΔΕΙΞΕΙ ΜΗΝΥΜΑ "ΤΟ ΑΣΑΝΣΕΡ ΚΑΤΕΒΑΙΝΕΙ".ΞΕΧΑΣΕΣ ΕΝΑΝ ΕΛΕΓΧΟ ΝΟΜΙΖΩ ΓΙΑ ΤΟ = ΚΑΙ ΝΑ ΞΑΝΑΔΙΝΕΙ ΟΡΟΦΟ ΠΟΥ ΤΟ ΚΑΛΕΙ Ο ΧΡΗΣΤΗΣ ΟΤΑΝ ΙΣΧΥΕΙ Η ΙΣΟΤΗΤΑ Η ΝΑ ΤΟΥ ΕΜΦΑΝΙΖΕΙ ΚΑΤΑΛΛΗΛΟ ΜΥΝΗΜΑ.

DmitrijPyc

  • Νέος
  • *
  • Μηνύματα: 8
    • Barracuda
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #42 στις: 21 Μάι 2017, 04:53:33 μμ »
 ΤΟ 3ο ΘΕΜΑ.
ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_3
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α[10],Ι,ΤΕΜΠΤ,ΚΛΗΣΗ,ΠΡΟ,Σ[10],Θ
  ΧΑΡΑΚΤΗΡΕΣ: ΑΠ
ΑΡΧΗ
  Α[1] <-- 1
  Σ[1] <-- 0
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 10
    Α[Ι] <-- 0   
    Σ[Ι] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  θ <-- 1
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΔΩΣΕ ΟΡΟΦΟ ΚΛΗΣΗΣ'
    ΔΙΑΒΑΣΕ ΚΛΗΣΗ
    Σ[ΚΛΗΣΗ] <-- Σ[ΚΛΗΣΗ]+1
    ΑΝ Θ>ΚΛΗΣΗ ΤΟΤΕ
      ΓΙΑ Ι ΑΠΟ Θ ΜΕΧΡΙ ΚΛΗΣΗ-1 ΜΕ ΒΗΜΑ -1
        ΤΕΜΠΤ <-- Α[Ι]
        Α[Ι] <-- Α[Ι-1]
        Α[Ι-1] <-- ΤΕΜΠΤ
        ΓΡΑΨΕ 'ΤΟ ΑΣΑΝΣΕΡ ΚΑΤΕΒΑΙΝΕΙ'
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

    ΑΛΛΙΩΣ
      ΓΙΑ Ι ΑΠΟ Θ ΜΕΧΡΙ ΚΛΗΣΗ-1
        ΤΕΜΠΤ <-- Α[Ι]
        Α[Ι] <-- Α[Ι+1]
        Α[Ι+1] <-- ΤΕΜΠΤ
        ΓΡΑΨΕ 'ΤΟ ΑΣΑΝΣΕΡ ΑΝΕΒΑΙΝΕΙ'
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'ΔΩΣΕ ΤΟΝ ΟΡΟΦΟ ΠΡΟΟΡΙΣΜΟΥ'

    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ ΠΡΟ
      ΑΝ ΟΧΙ(ΠΡΟ<>ΚΛΗΣΗ) ΤΟΤΕ
        ΓΡΑΨΕ 'ΑΔΥΝΑΤΟ'
      ΤΕΛΟΣ_ΑΝ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΠΡΟ<>ΚΛΗΣΗ
    ΑΝ ΚΛΗΣΗ>ΠΡΟ ΤΟΤΕ
      ΓΙΑ Ι ΑΠΟ ΚΛΗΣΗ ΜΕΧΡΙ ΠΡΟ+1 ΜΕ ΒΗΜΑ -1
        ΤΕΜΠΤ <-- Α[Ι]
        Α[Ι] <-- Α[Ι-1]
        Α[Ι-1] <-- ΤΕΜΠΤ
        ΓΡΑΨΕ 'ΟΡΟΦΟΣ=',Ι
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΑΛΛΙΩΣ
      ΓΙΑ Ι ΑΠΟ ΚΛΗΣΗ ΜΕΧΡΙ ΠΡΟ-1
        ΤΕΜΠΤ <-- Α[Ι]
        ΓΡΑΨΕ 'ΟΡΟΦΟΣ=',Ι

        Α[Ι] <-- Α[Ι+1]
        Α[Ι+1] <-- ΤΕΜΠΤ
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΑΝ
    ΓΡΑΨΕ 'ΕΠΙΘΥΜΕΙΤΑΙ ΤΗΝ ΕΠΑΝΑΛΗΨΗ ΝΑΙ ή ΟΧΙ?'
    ΔΙΑΒΑΣΕ ΑΠ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΑΠ='ΟΧΙ'
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ 'Ο',Ι,'-ΟΣ ΟΡΟΦΟΣ ΚΛΗΘΗΚΕ',Σ[Ι],'ΦΟΡΕΣ'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ   

DmitrijPyc

  • Νέος
  • *
  • Μηνύματα: 8
    • Barracuda
Απ: Τρίωρο Διαγώνισμα στους Πίνακες από το Στέκι
« Απάντηση #43 στις: 25 Μάι 2017, 01:10:13 μμ »
Θεμα 4ο

ΠΡΟΓΡΑΜΜΑ  ΘΜΕΑ_40
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[8],ΤΕΜΠΤ1
  ΑΚΕΡΑΙΕΣ: ΣΚΟΡ[8,8],Ι,Κ,ΒΑΘΜΟΛΟΓΙΑ[8],ΣΥΜ1,ΣΥΜ2,Ξ,ΤΕΜΠΤ
  ΛΟΓΙΚΕΣ: ΦΛΑΓ
ΑΡΧΗ
  !Α ΕΡΩΗΤΗΜΑ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 8
    ΓΡΑΨΕ 'ΔΩΣΕ ΤΟ ΟΝΟΜΑ ΤΗΣ',Ι,'-ΗΣ ΟΜΑΔΑΣ'
    ΔΙΑΒΑΣΕ ΟΝ[Ι]
    ΒΑΘΜΟΛΟΓΙΑ[Ι] <-- 0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  !Β ΕΡΩΤΗΜΑ

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 8

    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 8

      ΑΝ Ι<>Κ ΤΟΤΕ
        ΓΡΑΨΕ 'ΔΩΣΕ ΤΑ ΓΚΟΛ ΠΟΥ ΕΒΑΛΕ Η',Ι,'-Η ΟΜΑΔΑ ΟΤΑΝ ΕΠΕΞΑΙ ΕΝΑΝΤΙΑ ΤΗΣ',Κ,'-ΗΣ ΟΜΑΔΑΣ'
        ΔΙΑΒΑΣΕ ΣΚΟΡ[Ι,Κ]
      ΑΛΛΙΩΣ
        ΣΚΟΡ[Ι,Κ] <-- 0
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  !Γ ΕΡΩΤΗΜΑ

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 8
    ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 8
      ΑΝ Ι<>Κ ΤΟΤΕ
        ΑΝ ΣΚΟΡ[Ι,Κ]>ΣΚΟΡ[Κ,Ι] ΤΟΤΕ
          ΒΑΘΜΟΛΟΓΙΑ[Ι] <-- ΒΑΘΜΟΛΟΓΙΑ[Ι]+3
        ΑΛΛΙΩΣ_ΑΝ ΣΚΟΡ[Ι,Κ]=ΣΚΟΡ[Κ,Ι] ΤΟΤΕ
          ΒΑΘΜΟΛΟΓΙΑ[Ι] <-- ΒΑΘΜΟΛΟΓΙΑ[Ι]+1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  !Δ ΕΡΩΤΗΜΑ

  ΦΛΑΓ <-- ΨΕΥΔΗΣ
  Ι <-- 2
  ΟΣΟ Ι<=8 ΚΑΙ ΦΛΑΓ=ΨΕΥΔΗΣ ΕΠΑΝΑΛΑΒΕ
    ΦΛΑΓ <-- ΑΛΗΘΗΣ

    ΓΙΑ Κ ΑΠΟ 8 ΜΕΧΡΙ Ι ΜΕ ΒΗΜΑ -1
      ΑΝ ΒΑΘΜΟΛΟΓΙΑ[Κ]>ΒΑΘΜΟΛΟΓΙΑ[Κ-1] ΤΟΤΕ
        ΦΛΑΓ <-- ΨΕΥΔΗΣ
        ΤΕΜΠΤ <-- ΒΑΘΜΟΛΟΓΙΑ[Κ]
        ΒΑΘΜΟΛΟΓΙΑ[Κ] <-- ΒΑΘΜΟΛΟΓΙΑ[Κ-1]
        ΒΑΘΜΟΛΟΓΙΑ[Κ-1] <-- ΤΕΜΠΤ

        ΤΕΜΠΤ1 <-- ΟΝ[Κ]
        ΟΝ[Κ] <-- ΟΝ[Κ-1]
        ΟΝ[Κ-1] <-- ΤΕΜΠΤ1
      ΤΕΛΟΣ_ΑΝ
      ΑΝ ΒΑΘΜΟΛΟΓΙΑ[Κ]=ΒΑΘΜΟΛΟΓΙΑ[Κ-1] ΤΟΤΕ
        ΣΥΜ1 <-- 0
        ΣΥΜ2 <-- 0
        ΓΙΑ Ξ ΑΠΟ 1 ΜΕΧΡΙ 8
          ΑΝ Κ<>Ξ ΤΟΤΕ
            ΣΥΜ1 <-- ΣΥΜ1+ΣΚΟΡ[Κ,Ξ]-ΣΚΟΡ[Ξ,Κ]
          ΤΕΛΟΣ_ΑΝ
          ΑΝ Κ-1<>Ξ ΤΟΤΕ
            ΣΥΜ2 <-- ΣΥΜ2+ΣΚΟΡ[Κ-1,Ξ]-ΣΚΟΡ[Ξ,Κ-1]
          ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΝ ΣΥΜ1>ΣΥΜ2 ΤΟΤΕ
          ΦΛΑΓ <-- ΨΕΥΔΗΣ
          ΤΕΜΠΤ1 <-- ΟΝ[Κ]
          ΟΝ[Κ] <-- ΟΝ[Κ-1]
          ΟΝ[Κ-1] <-- ΤΕΜΠΤ1
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    Ι <-- Ι+1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 8
    ΓΡΑΨΕ Ι,'-Η ΟΜΑΔΑ ΕΙΝΑΙ=',ΟΝ[Ι],'ΜΕ ΒΑΘΜΟΛΟΓΙΑ=',ΒΑΘΜΟΛΟΓΙΑ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ