Αποστολέας Θέμα: Θέμα 1 γ  (Αναγνώστηκε 9588 φορές)

panosz

  • Θαμώνας
  • ***
  • Μηνύματα: 30
  • Γράψτε το προσωπικό σας σλόγκαν!
Θέμα 1 γ
« στις: 31 Μάι 2007, 04:52:36 μμ »
Καλησπέρα,
Μαθητής μου αντί για δομή πολλαπλής επιλογής, δημιουργησε εμφωλευμένη δομή επιλογή.
Σωστό ή λάθος ??

Ευχαριστώ για το χρόνο σας
Panos

greecechris

  • Βετεράνος
  • ****
  • Μηνύματα: 85
Απ: Θέμα 1 γ
« Απάντηση #1 στις: 31 Μάι 2007, 04:55:42 μμ »
rikse kwdika

fragile

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 66
  • ΑΔΡΑΞΤΕ ΤΗΝ ΗΜΕΡΑ
Απ: Θέμα 1 γ
« Απάντηση #2 στις: 31 Μάι 2007, 04:56:52 μμ »
Πιστεύω ότι είναι λάθος

Π.Χ.

Αν (Α>0).
   Αν (Α=0).
 
   Τέλος-Αν
Τέλος_Αν

Αν έκανε αυτό τότε είναι σίγουρα ΛΑΘΟΣ.....

Στείλε την δομή αν δεν είναι αυτή ώστε να το συζητήσουμε
fragile..........

greecechris

  • Βετεράνος
  • ****
  • Μηνύματα: 85
Απ: Θέμα 1 γ
« Απάντηση #3 στις: 31 Μάι 2007, 04:58:55 μμ »
Αν α>0 τότε
 αν α<0

lol lathos einai tyflwthika xaxaxa
afou an einai a>0 den tha mpei na elegksei to a<0..

nai an einai etsi einai lathos..

dwse kwdika

apapag

  • Θαμώνας
  • ***
  • Μηνύματα: 29
Απ: Θέμα 1 γ
« Απάντηση #4 στις: 31 Μάι 2007, 05:07:12 μμ »
@panag_z

Θεωρώ ότι μπορεί να γραφτεί ισοδύναμα και με εμφωλευμένα ΑΝ αρκεί αυτά να ακολουθούν την ίδια λογική αλληλουχία των ελέγχων της τιμής του Α με αυτή που δίνεται.
Δηλαδή:
ΑΝ Α>0 ΤΟΤΕ
Νάσια Παπαγιάννη
Ηλ/γος Μηχ/κος και Μηχ/κος Υπολογιστών

apapag

  • Θαμώνας
  • ***
  • Μηνύματα: 29
Απ: Θέμα 1 γ
« Απάντηση #5 στις: 31 Μάι 2007, 05:09:30 μμ »
Προφανώς το προηγούμενο post έφυγε πριν την ώρα του...
Οπότε το παρακάτω είναι σωστό, αλλά όχι και το πιο κομψό.  ;)
   ΑΝ Α>0 ΤΟΤΕ
      ΕΚΤΥΠΩΣΕ "Θετικός"
   ΑΛΛΙΩΣ
        ΑΝ Α=0 ΤΟΤΕ
           ΕΚΤΥΠΩΣΕ "Μηδέν"
        ΑΛΛΙΩΣ
           ΕΚΤΥΠΩΣΕ "Αρνητικός"
        ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΑΝ
Νάσια Παπαγιάννη
Ηλ/γος Μηχ/κος και Μηχ/κος Υπολογιστών

fragile

  • Ομάδα διαγωνισμάτων 2008
  • *
  • Μηνύματα: 66
  • ΑΔΡΑΞΤΕ ΤΗΝ ΗΜΕΡΑ
Απ: Θέμα 1 γ
« Απάντηση #6 στις: 31 Μάι 2007, 05:13:02 μμ »
Νάσια (πιστεύω να μην σε ενοχλεί που σε αποκαλώ με το μικρό σου)

Και εγώ θεωρώ ότι μπορεί να γραφτεί με Εμφωλευμένα Αν, αλλά το θέμα είναι τι έγραψε ο μαθητής γι' αυτό του ζήτησα τον κώδικα. Πάντως το αποτέλεσμα με εμφωλευμένα αν είναι κατά ομολογία πιο δύσχρηστο με την λύση με πολλαπλό αν. Κοίτα και την περίπτωση της επίλεξε. Και με αυτή γίνεται.

Αυτή είναι η ομοργιά της ΑΕΠΠ άσχετα αν μερικοί την υποβαθμίζουν συνεχώς.

Fragile

fragile..........

greecechris

  • Βετεράνος
  • ****
  • Μηνύματα: 85
Απ: Θέμα 1 γ
« Απάντηση #7 στις: 31 Μάι 2007, 05:13:33 μμ »
an a > 0 tote emfanise "thetikos"
an a= tote emfanise "mhden"
an a < 0 tote emfanise "arnitikos"

ALLA ME

an a>0 tote
 Emfanise "thetikos"
 An a = 0 tote
 Emfanise "mhden"
  an a<0 tote
   Emfanise "arnitikos"
  telos_an
 telos_an
telos_an
AUTO EINAI SAFOS LATHOS AFOU THA ELEGKSEI OLA TA AN META TO PRWTO AN ISXUEI TO PRWTO..
KSEKINAME ME TO 2 AN 2>0 TOTE EMFANIZEI THETIKOS KAI ELEGXEI TA ALLA POU ANAGKASTIKA EINAI PSEUDI..
DINOUME 0...AN A>0 DEN MPAINEI KAN STO PRWTO AN KAI FEUGEI STO TELOS ARA DEN ELEGXEI TA MESA AN..TO IDIO THA GINEI AN THA DWSEIS TIMI -2 KAI GENIKA ARNITIKI

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3177
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα 1 γ
« Απάντηση #8 στις: 31 Μάι 2007, 05:18:28 μμ »

Νάσια, είναι σωστό αφού στην ουσία έχουν το ίδιο διάγραμμα ροής με την πολλαπλή επιλογή

Παναγιώτης

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Απ: Θέμα 1 γ
« Απάντηση #9 στις: 31 Μάι 2007, 05:25:37 μμ »
Νάσια νομίζω επίσης οτι ειναι σωστό
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19

apapag

  • Θαμώνας
  • ***
  • Μηνύματα: 29
Απ: Θέμα 1 γ
« Απάντηση #10 στις: 31 Μάι 2007, 05:49:24 μμ »
Αυτό που ήθελα να τονίσω και εγώ απαντώντας σε αυτό το thread είναι ότι είναι σωστό και με τα εμφωλευμένα...
Απλά, όπως λέει και ο fragile (και το βιβλίο), η χρήση εμφωλευμένων ΑΝ μπορεί να οδηγήσει σε πιο πολύπλοκους και δυσνόητους αλγορίθμους... (μπορεί να έγινα εγώ δυσνόητη, όμως...  ;))
Νάσια Παπαγιάννη
Ηλ/γος Μηχ/κος και Μηχ/κος Υπολογιστών

panosz

  • Θαμώνας
  • ***
  • Μηνύματα: 30
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα 1 γ
« Απάντηση #11 στις: 31 Μάι 2007, 05:57:51 μμ »
Ο μαθητής μου έκανε αυτό:
ΑΝ Α>0 ΤΟΤΕ
      ΕΚΤΥΠΩΣΕ "Θετικός"
   ΑΛΛΙΩΣ
        ΑΝ Α=0 ΤΟΤΕ
           ΕΚΤΥΠΩΣΕ "Μηδέν"
        ΑΛΛΙΩΣ
           ΕΚΤΥΠΩΣΕ "Αρνητικός"
        ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ
ΕΚΤΥΠΩΣΕ "....."

Ευχαριστώ για το χρόνο σας
Panos

apapag

  • Θαμώνας
  • ***
  • Μηνύματα: 29
Απ: Θέμα 1 γ
« Απάντηση #12 στις: 31 Μάι 2007, 06:20:09 μμ »
Έγραψες ένα ΤΕΛΟΣ_ΑΝ παραπάνω (φαντάζομαι κατά λάθος...)
Κατά τα άλλα είναι σωστό.
Νάσια Παπαγιάννη
Ηλ/γος Μηχ/κος και Μηχ/κος Υπολογιστών

greecechris

  • Βετεράνος
  • ****
  • Μηνύματα: 85
Απ: Θέμα 1 γ
« Απάντηση #13 στις: 31 Μάι 2007, 06:20:29 μμ »
σωστο..

greecechris

  • Βετεράνος
  • ****
  • Μηνύματα: 85
Απ: Θέμα 1 γ
« Απάντηση #14 στις: 31 Μάι 2007, 06:22:35 μμ »
nasia sou eklepsan to nick https://savannah.cern.ch/users/apapag   :P :P :P :P :P

panosz

  • Θαμώνας
  • ***
  • Μηνύματα: 30
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: Θέμα 1 γ
« Απάντηση #15 στις: 01 Ιούν 2007, 01:13:20 πμ »
@ apapag ναι το τελευταιο Τελος_αν μπήκε κατά λάθος (copy - paste ....)

Panos

michalis

  • Οπαδός
  • **
  • Μηνύματα: 15
Απ: Θέμα 1 γ
« Απάντηση #16 στις: 01 Ιούν 2007, 11:00:13 πμ »
Ο μαθητής μου έκανε αυτό:
ΑΝ Α>0 ΤΟΤΕ
      ΕΚΤΥΠΩΣΕ "Θετικός"
      ΕΚΤΥΠΩΣΕ "Tέλος"
   ΑΛΛΙΩΣ_ΑΝ Α=0 ΤΟΤΕ
           ΕΚΤΥΠΩΣΕ "Μηδέν"
           ΕΚΤΥΠΩΣΕ "Tέλος"
        ΑΛΛΙΩΣ
           ΕΚΤΥΠΩΣΕ "Αρνητικός"
           ΕΚΤΥΠΩΣΕ "Tέλος"
ΤΕΛΟΣ_ΑΝ
  Πως το βλέπετε να βαθμολογείτε?

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2213
Απ: Θέμα 1 γ
« Απάντηση #17 στις: 01 Ιούν 2007, 11:32:05 πμ »
Εφόσον παράγει αλγοριθμικά το σωστό αποτέλεσμα, για μένα είναι σωστό
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

raniasgr

  • Οπαδός
  • **
  • Μηνύματα: 10
Απ: Θέμα 1 γ
« Απάντηση #18 στις: 01 Ιούν 2007, 11:53:21 πμ »
Ένας μαθητής μου απάντησε το θέμα με απλή δομή επιλογής ως εξής :
ΑΝ Α>0 ΤΟΤΕ
      ΕΚΤΥΠΩΣΕ "Θετικός"
      ΕΚΤΥΠΩΣΕ "Tέλος"
ΤΕΛΟΣ_ΑΝ
ΑΝ Α=0 ΤΟΤΕ
           ΕΚΤΥΠΩΣΕ "Μηδέν"
           ΕΚΤΥΠΩΣΕ "Tέλος"
ΤΕΛΟΣ_ΑΝ
ΑΝ Α<0 ΤΟΤΕ
           ΕΚΤΥΠΩΣΕ "Αρνητικός"
           ΕΚΤΥΠΩΣΕ "Tέλος"
ΤΕΛΟΣ_ΑΝ

Πώς λέτε να βαθμολογηθεί?
Καθηγήτρια Πληροφορικής - ΠΕ19

Kalli

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 41
Απ: Θέμα 1 γ
« Απάντηση #19 στις: 01 Ιούν 2007, 12:07:58 μμ »
Ερώτηση για γραπτό μαθητή μου:
Αν το διάγραμμα είναι σωστό και έχει ξεχάσει τα ΝΑΙ, ΟΧΙ πόσο θα κόψουν;

Obelix

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 119
Απ: Θέμα 1 γ
« Απάντηση #20 στις: 01 Ιούν 2007, 12:38:06 μμ »
Ερώτηση: Το ερώτημα (2) πώς πιστεύετε ότι θα βαθμολογηθεί? Θα πρέπει ο αλγόριθμος να είναι ο σωστός ή να είναι αυτός που αντιστοιχεί στο διάγραμμα ροής που σχεδίασε ο μαθητής, ακόμα και αν αυτό περιέχει λάθη?

Προκαταβολικά για την περίπτωση που η κουβέντα πάει στο πώς πρέπει να βαθμολογηθεί, η δική μου άποψη είναι η δεύτερη περίπτωση, καθώς δεν εξετάζεται σε κανένα άλλο σημείο των θεμάτων η ικανότητα μετατροπής διαγράμματος ροής σε αλγόριθμο ή το αντίστροφο.

Πάντως, πολλοί μαθητές επέλεξαν να κατασκευάσουν πρώτα τον αλγόριθμο και μετά το διάγραμμα...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα 1 γ
« Απάντηση #21 στις: 01 Ιούν 2007, 12:47:41 μμ »

  Σε όσους εξέτασα χθες έκανα ένα μικρό γκάλοπ, τους ρώτησα αν τους βοήθησε η μετατροπή σε διάγραμμα ροής ώστε να κάνουν τον τελικό αλγόριθμο, και όλοι συμφώνησαν ότι το διάγραμμα ροής πιο πολύ τους μπέρδεψε παρά τους βοήθησε. Μάλιστα αρκετοί αντί να γράψουν Τύπωσε "Τέλος" μέσα σε παραλληλόγραμμο έγραψαν Τέλος μέσα σε έλλειψη.
       Η γνώμη μου είναι ότι δεν πρέπει το διάγραμμα ροής και ο ψευδοκώδικας να είναι ακριβώς τα ίδια. Θα πρέπει όμως και τα δυο να είναι ισοδύναμα με το αρχικό με τα ΠΗΓΑΙΝΕ. Δηλαδή να βγάζουν όλα τις ίδιες ακριβώς εξόδους για αντίστοιχες εισόδους.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Muldy

  • Οπαδός
  • **
  • Μηνύματα: 16
Απ: Θέμα 1 γ
« Απάντηση #22 στις: 02 Ιούν 2007, 12:23:33 πμ »
μία ερώτηση για το θέμα 1ο, στο περι γλώσσα κατά βήματα. Εγώ δεν έβαλα καθόλου το "εκτυπωσε τελος", αρχικά νόμιζα ότι ήταν το τελος του αλγοριθμου και μετά νόμιζα τελος επαναληψης οπότε το άφησα κενό, έκανα το αν κ.τλ. αλλά το εκτύπωσε ή τελος τπτ. το ίδιο και στον αλγόριθμο. ήθελα να ρωτήσω αν κοπούν μόρια και από τα δύο υποερωτήματα ή το δεύτερο θεωρηθεί προέκταση του πρώτου, και αν ναι πόσα από το καθένα; αυτά..  :-\

ΥΓ. στο βιβλίο από όσο θυμάμαι έλεγε αποφεύγουμε ή δεν είναι επιτρεπτες, δεν θυμάμαι κατα λέξη, να βάζουμε όνομα τελος, αλγοριθμος,αν,αλλιως και γενικότερα λέξεις που έχουν νόημα σε διαδικασίες . τώρα βέβαια από την άλλη δεν είναι μεταβλητή/σταθερά αλλά εκτύπωση κειμένου.. δεν ξέρω αλλά την ώρα των εξετάσεων εγώ μπερδεύτηκα και την ώρα μου την χρησιμοποίησα κυρίως σε αυτό, τα άλλα πάνω κάτω ήξερα ότι ήταν όπως τα είχα.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα 1 γ
« Απάντηση #23 στις: 02 Ιούν 2007, 02:16:13 πμ »

   Λογικά μια μονάδα και για τα δυο θα πρέπει να σου κοπεί το πολύ.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέμα 1 γ
« Απάντηση #24 στις: 02 Ιούν 2007, 12:32:13 μμ »
Κάθε λάθος "χρεώνεται" μόνο μία φορά.

Αυτό που αναφέρεις είναι λάθος. Ερμήνευσες την εντολή εξόδου ως δήλωση για το τέλος του αλγόριθμου.

1 μονάδα
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέμα 1 γ
« Απάντηση #25 στις: 02 Ιούν 2007, 12:42:16 μμ »
  Σε όσους εξέτασα χθες έκανα ένα μικρό γκάλοπ, τους ρώτησα αν τους βοήθησε η μετατροπή σε διάγραμμα ροής ώστε να κάνουν τον τελικό αλγόριθμο, και όλοι συμφώνησαν ότι το διάγραμμα ροής πιο πολύ τους μπέρδεψε παρά τους βοήθησε.

Δεν ξέρω Ευρυπίδη αν θα είχαν την ίδια γνώμη σε περίπτωση που το θέμα έδινε κάποιο πιό σύνθετο αλγόριθμο (όπως αυτόν της σελίδας 48).  Το πήγαινε, πιό εύκολα ερμηνεύεται ως βέλος ροής εκτέλεσης οπότε το ΔΡ προκύπτει, νομίζω, ευκολότερα.  Δεν έχω βρει μέχρι στιγμής μαθητή που βρίσκει εύκολα την κωδικοποίηση του συγκεκριμένου αλγόριθμου (σελ.48) χωρίς να "περάσει" από ΔΡ.
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Obelix

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 119
Απ: Θέμα 1 γ
« Απάντηση #26 στις: 02 Ιούν 2007, 04:43:43 μμ »

Παράθεση
Ερώτηση: Το ερώτημα (2) πώς πιστεύετε ότι θα βαθμολογηθεί? Θα πρέπει ο αλγόριθμος να είναι ο σωστός ή να είναι αυτός που αντιστοιχεί στο διάγραμμα ροής που σχεδίασε ο μαθητής, ακόμα και αν αυτό περιέχει λάθη?

Παράθεση
Κάθε λάθος "χρεώνεται" μόνο μία φορά.

Να θεωρήσω ότι αυτό απαντάει και στο ερώτημά μου??

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέμα 1 γ
« Απάντηση #27 στις: 02 Ιούν 2007, 04:50:11 μμ »
Τόσο το ερώτημα 1 (ισοδύναμο διάγραμμα ροής) όσο και το 2 (ισοδύναμη δομημένο κωδικοποίηση) αναφέρονται στο αρχικό τμήμα αλγορίθμου και εξετάζονται ξεχωριστά.

Θα πρέπει το διάγραμμα ροής να είναι ισοδύναμο της φυσικής γλώσσας σε βήματα.

Θα πρέπει η δομημένη κωδικοποίηση να είναι ισοδύναμη της φυσικής γλώσσας σε βήματα.

Σε ελεύθερη μετάφραση, για κάθε είσοδο να παράγουν την ίδια έξοδο.
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα 1 γ
« Απάντηση #28 στις: 02 Ιούν 2007, 10:39:46 μμ »
  Βασικά ο σύνθετος αλγόριθμος, δηλαδή το να έχεις πεπλεγμένες δομές επιλογής και επανάληψης μέσα στην άλλη δε βγαίνει με διάγραμμα ροής, θέλει άλλα κόλπα, τέτοια είναι η μια από τις δυο ασκήσεις στο τετράδιο του μαθητή. Πάντως μέχρι στιγμής πολλοί μαθητές αντί να βάλουν την εντολή  Τύπωσε "Τέλος" μέσα σε Παραλληλόγραμμο προτιμούν το Τέλος σε έλλειψη. Αυτοί χάνουν (μονάδες) :-) Αν δεν υπήρχε το διάγραμμα ροής δε νομίζω ότι θα το έκαναν αυτό.

Δεν ξέρω Ευρυπίδη αν θα είχαν την ίδια γνώμη σε περίπτωση που το θέμα έδινε κάποιο πιό σύνθετο αλγόριθμο (όπως αυτόν της σελίδας 48).  Το πήγαινε, πιό εύκολα ερμηνεύεται ως βέλος ροής εκτέλεσης οπότε το ΔΡ προκύπτει, νομίζω, ευκολότερα.  Δεν έχω βρει μέχρι στιγμής μαθητή που βρίσκει εύκολα την κωδικοποίηση του συγκεκριμένου αλγόριθμου (σελ.48) χωρίς να "περάσει" από ΔΡ.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Obelix

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 119
Απ: Θέμα 1 γ
« Απάντηση #29 στις: 03 Ιούν 2007, 03:30:56 μμ »
Η παρακάτω λύση, ας πούμε:

ΑΝ Α>0 ΤΟΤΕ
      ΕΚΤΥΠΩΣΕ "Θετικός"
ΤΕΛΟΣ_ΑΝ

ΑΝ Α=0 ΤΟΤΕ
      ΕΚΤΥΠΩΣΕ "Μηδέν"
ΑΛΛΙΩΣ
      ΕΚΤΥΠΩΣΕ "Αρνητικός"
ΤΕΛΟΣ_ΑΝ

ΕΚΤΥΠΩΣΕ "Tέλος"

και το διάγραμμα ροής που αντιστοιχεί σε αυτή τη λύση, πόσες μονάδες από τις 11 πιστεύετε ότι μπορεί να πάρει?

« Τελευταία τροποποίηση: 03 Ιούν 2007, 03:43:12 μμ από Obelix »

Παναγιώτης Τσιωτάκης

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3177
  • I love you 3000
    • Panagiotis Tsiotakis
Απ: Θέμα 1 γ
« Απάντηση #30 στις: 03 Ιούν 2007, 03:35:13 μμ »

Μα πως γίνεται να θεωρεί ο μαθητής πιο εύκολη τη μετάβαση από το αρχικό στη δομημένη ψευδογλώσσα;

Και σε τελική ανάλυση για να δοθεί αυτή η σειρά των ερωτημάτων δεν έπρεπε να σκεφτεί ο μαθητής οτι για κάποιο λόγο του έχει δοθεί έτσι;;

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 801
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέμα 1 γ
« Απάντηση #31 στις: 03 Ιούν 2007, 04:10:58 μμ »
Η παρακάτω λύση, ας πούμε:

ΑΝ Α>0 ΤΟΤΕ
      ΕΚΤΥΠΩΣΕ "Θετικός"
ΤΕΛΟΣ_ΑΝ

ΑΝ Α=0 ΤΟΤΕ
      ΕΚΤΥΠΩΣΕ "Μηδέν"
ΑΛΛΙΩΣ
      ΕΚΤΥΠΩΣΕ "Αρνητικός"
ΤΕΛΟΣ_ΑΝ

ΕΚΤΥΠΩΣΕ "Tέλος"

και το διάγραμμα ροής που αντιστοιχεί σε αυτή τη λύση, πόσες μονάδες από τις 11 πιστεύετε ότι μπορεί να πάρει?



7 στις 11.

Δίνει λάθος αποτέλεσμα στι μία από τις 3 περιπτώσεις (α>0)
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Απ: Θέμα 1 γ
« Απάντηση #32 στις: 04 Ιούν 2007, 04:19:37 μμ »
Παναγιώτη και εμένα αρκετοί μαθητές μου θεωρούν πιο ευκολο να "φτιάξουν" πρώτα τον αλγόριθμο και μετά το διαγραμμα ροής. Βασικα αυτό που κάνουν είναι να εκτελέσουν τα βήματα (όπως συνήθως κάνουν με τα 2α θέματα του στυλ τι εμφανίζει ..) και μετά απο τα αποτελέσματα να συμπεράνουν ποια δομή θα επιλέξουν.
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19

filippos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 139
Απ: Θέμα 1 γ
« Απάντηση #33 στις: 10 Ιούν 2007, 02:34:11 πμ »
Η μετατροπή φυσικής γλώσσας με βήματα σε διάγραμμα ροής είναι υπόθεση ρουτίνας.  Κάθε πήγαινε είναι βέλος ροής.  Στη συνέχεια θα πρέπει να ανγνωριστούν αλγοριθμικές δομές (με ή χωρίς μετατροπές του διαγράμματος) ώστε να οδηγηθεί ο μαθητής στην ψευδογλώσσα.  Βρείτε μου ένα μαθητή που θα πάει ευκολότερα στην ψευδογλώσσα απευθείας από τη φυσική στο παράδειγμα της σελίδας 48.  Το διάγραμμα βαίνει σχεδόν δίχως σκέψη (κάθε πήγαινε : ένα βέλος ροής) και στη συνέχεια αποκαλύπτονται οι δομές από μόνες τους

EleniK

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 708
Απ: Θέμα 1 γ
« Απάντηση #34 στις: 13 Ιούν 2007, 11:45:43 μμ »
Και όμως Φίλιππε υπάρχουν τετοιοι μαθητες που θεωρούν το να φτιάξουν πρώτα τον αλγόριθμο πιο ευκολο. Εγω έχω τουλάχιστον 10 παραδείγματα αν όχι παραπάνω
Ελένη Κοκκίνου
Καθηγήτρια Πληροφορικής, ΠΕ19