Αποστολέας Θέμα: Διαγώνισμα προσομείωσης πανελλαδικών εξετάσεων στην ΑΕΠΠ  (Αναγνώστηκε 1845 φορές)

Κανένας

  • Βετεράνος
  • ****
  • Μηνύματα: 52
Προσομοιωμένο Διαγώνισμα του σχολικού έτους 2018-2019 στο μάθημα Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον (ΑΕΠΠ) μαζί με ενδεικτικές λύσεις.

Το διαγώνισμα συνέταξε και επιμελήθηκε ομάδα εκπαιδευτικών πληροφορικής:  Μαρία Αναστοπούλου, Νικηφόρος  Μανδηλαράς,  Μανώλης  Αργυρός για τα σχολεία των Κυκλάδων και της Δωδεκανήσου.

Συντονισμός: Κωνσταντίνος Ζέρβας, Συντονιστής Εκπαιδευτικού Έργου Πληροφορικής ΠΕ86  για Κυκλάδες και Δωδεκάνησα, 1ο ΠΕ.Κ.Ε.Σ/ Περιφερειακή Διεύθυνση Εκπαίδευσης Νοτίου Αιγαίου.
« Τελευταία τροποποίηση: 18 Μάι 2019, 11:58:36 πμ από Κανένας »
ΝΙΚΗΦΟΡΟΣ ΜΑΝΔΗΛΑΡΑΣ
ΓΕΛ ΝΑΞΟΥ

wmaster

  • Θαμώνας
  • ***
  • Μηνύματα: 20
Καλημέρα,
πολύ ωραία και επιμελημένα θέματα, Ευχαριστούμε.

Καραμαούνας Πολύκαρπος

  • Θαμώνας
  • ***
  • Μηνύματα: 29
  • Καθηγητής Πληροφορικής
Ωραίο διαγώνισμα. Συνημμένα μερικές επισημάνσεις.
« Τελευταία τροποποίηση: 17 Μάι 2019, 01:36:54 μμ από Καραμαούνας Πολύκαρπος »

wmaster

  • Θαμώνας
  • ***
  • Μηνύματα: 20
Οι ενδεικτικές λύσεις είναι σωστές στο ερώτημα Γ4.
Μ=(100+1) DIV 2, ΔΗΛ, 75
M= (76+100) DIV 2 ΔΗΛ 88
Μ=(89+100) DIV 2 ΔΗΛ 94

Στο ερώτημα Δ6 ξέφυγε ένα ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ στο αρχικό διάβασμα, όπως απαντηθεί και στο Δ3 :
   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
          ! Διάβασμα στοιχείων
               ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 21
                 ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 20
                    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                                ΔΙΑΒΑΣΕ Θ[κ, λ]
                       ΜΕΧΡΙΣ_ΟΤΟΥ Θ[κ, λ]  >= 1 ΚΑΙ Θ[κ,λ] <= 20
                     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
               ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
.......

Καραμαούνας Πολύκαρπος

  • Θαμώνας
  • ***
  • Μηνύματα: 29
  • Καθηγητής Πληροφορικής
Συμφωνώ ως προς το Γ4
Διαφωνώ ως προς το Δ6: "Σε περίπτωση λανθασμένης εισαγωγής να εμφανίζεται
μήνυμα και να επανεισάγονται όλες οι θέσεις τερματισμού του
συγκεκριμένου αγώνα
"

Έτσι που έχει απαντηθεί, επανεισάγονται όλες οι θέσεις τερματισμού όλων των αγώνων.

Κανένας

  • Βετεράνος
  • ****
  • Μηνύματα: 52
Εναλλακτική λύση του Δ
« Απάντηση #5 στις: 17 Μάι 2019, 08:10:07 μμ »
Επισυνάπτεται αρχείο με εναλλακτική λύση του θέματος Δ
ΝΙΚΗΦΟΡΟΣ ΜΑΝΔΗΛΑΡΑΣ
ΓΕΛ ΝΑΞΟΥ

annastasios

  • Θαμώνας
  • ***
  • Μηνύματα: 22
πολύ ωραία θέματα, Μπράβο και ευχαριστούμε για το μοίρασμα!
στο θέμα Α3 θεωρείς το Κ ακέραιο?

tanius76

  • Βετεράνος
  • ****
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Η σειριακή Αναζήτηση μπορεί να χρησιμοποιηθεί σε ταξινομημένους πίνακες. Σ/Λ ;

Με βάση την λογική είναι Σωστό
Όμως στο βιβλίο σελίδα 166 γράφει : " Χρησιμοποιείται όμως υποχρεωτικά για πίνακες που δεν είναι ταξινομημένοι"
Τι λέτε;

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2212
Να μην τεθεί ως θέμα..
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

tanius76

  • Βετεράνος
  • ****
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Να μην τεθεί ως θέμα..
αν τεθεί ; κάντε το σταυρό σας!

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4922
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Νομίζω ότι ο ποιητής εννοεί "αν δεν είναι ταξινομημένοι, τότε θα πρέπει να χρησιμοποιήσουμε υποχρεωτικά την σειριακή αναζήτηση, αφού η δυαδική δεν δουλεύει",
και δεν εννοεί "τη σειριακή τη χρησιμοποιούμε μόνο σε μη ταξινομημένους πίνακες και απαγορεύεται να τη χρησιμοποιήσουμε σε ταξινομημένους".

Επομένως δεν αντιτίθεται στο Σ/Λ που έθεσες.

Κανένας

  • Βετεράνος
  • ****
  • Μηνύματα: 52
πολύ ωραία θέματα, Μπράβο και ευχαριστούμε για το μοίρασμα!
στο θέμα Α3 θεωρείς το Κ ακέραιο?
Σωστά, πρέπει η τιμή του Κ να είναι φυσικός αριθμός
ΝΙΚΗΦΟΡΟΣ ΜΑΝΔΗΛΑΡΑΣ
ΓΕΛ ΝΑΞΟΥ

junior

  • Οπαδός
  • **
  • Μηνύματα: 11
Σωστά, πρέπει η τιμή του Κ να είναι φυσικός αριθμός

Γιατί πρέπει η τιμή του Κ να είναι φυσικός αριθμός;
Δύναται να είναι και πραγματικός αριθμός.

Σ <- 0
ΔΙΑΒΑΣΕ Κ
ΓΙΑ i ΑΠΟ  Κ  ΜΕΧΡΙ  0  ΜΕ_ΒΗΜΑ -2
   ΑΝ i <> 0 ΤΟΤΕ
         Σ <- Σ + i ^ 2
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

junior

  • Οπαδός
  • **
  • Μηνύματα: 11
Η σειριακή Αναζήτηση μπορεί να χρησιμοποιηθεί σε ταξινομημένους πίνακες. Σ/Λ ;

Με βάση την λογική είναι Σωστό
Όμως στο βιβλίο σελίδα 166 γράφει : " Χρησιμοποιείται όμως υποχρεωτικά για πίνακες που δεν είναι ταξινομημένοι"
Τι λέτε;

Η απάντηση είναι απλή. Με βάση την ΛΟΓΙΚΗ, κάτι που υποχρεωτικά χρησιμοποιείται σε μία περίπτωση, δεν σημαίνει αυτόματα ότι απαγορεύεται να χρησιμοποιηθεί (υποχρεωτικά ή προαιρετικά) σε άλλη περίπτωση. Η απάντηση είναι ξεκάθαρα Σ.

Απλά στην προκειμένη περίπτωση, αν ο πίνακας είναι ταξινομημένος, τότε χρησιμοποιούμε πιο αποδοτικό αλγόριθμο, χωρίς αυτό να σημαίνει ότι δεν μπορεί να χρησιμοποιηθεί η σειριακή, διότι δεν θα δουλέψει ή θα δώσει λάθος αποτελέσματα.

Αν η ερώτηση ήταν:
Η σειριακή Αναζήτηση ενδείκνυται/συνιστάται να χρησιμοποιηθεί σε ταξινομημένους πίνακες. Σ/Λ ;
Τι θα απαντούσαμε; Καλό είναι να μην μπει τέτοια ερώτηση επειδή η αποδοτικότητα αλγορίθμων είναι εκτός ύλης;

junior

  • Οπαδός
  • **
  • Μηνύματα: 11
Οι ενδεικτικές λύσεις είναι σωστές στο ερώτημα Γ4.
Μ=(100+1) DIV 2, ΔΗΛ, 75
M= (76+100) DIV 2 ΔΗΛ 88
Μ=(89+100) DIV 2 ΔΗΛ 94

Είναι:
Μ=(1+100) DIV 2, ΔΗΛ, 50
Μ=(51+100) DIV 2, ΔΗΛ, 75
Μ=(76+100) DIV 2, ΔΗΛ, 88
Μ=(89+100) DIV 2, ΔΗΛ, 94