Αποστολέας Θέμα: ΟΕΦΕ 2011 ΔΙΑΦΟΡΕΤΙΚΗ ΛΥΣΗ ΣΤΟ ΘΕΜΑ Δ(Γ)  (Αναγνώστηκε 702 φορές)

kyriakos208

  • Θαμώνας
  • ***
  • Μηνύματα: 21
ΟΕΦΕ 2011 ΔΙΑΦΟΡΕΤΙΚΗ ΛΥΣΗ ΣΤΟ ΘΕΜΑ Δ(Γ)
« στις: 07 Νοέ 2018, 08:25:22 μμ »
Μια διαφορετική λύση(ΧΩΡΙΣ ΤΑΞΙΝΟΜΗΣΗ ΔΙΣΔΙΑΣΤΑΤΟΥ ΠΙΝΑΚΑ) για το Θέμα Δ-(γ )
Εκφώνηση:'Να αποθηκεύει στον πίνακα Σ[14] και να εμφανίζει τη συνολική βαθμολογία του κάθε διαγωνιζομένου,η οποία υπολογίζεται από την συνολική βαθμολογία των κριτών προστιθέμενης και της βαθμολογίας του κοινού ως εξής:ο πρώτος σε ψήφους από το κοινό λαμβάνει 42 βαθμούς,ο δεύτερος 39,ο τρίτος 36 κ.ο.κ μέχρι τον τελευταίο που θα λάβει 3 βαθμούς(δεν υπάρχει καμία ισοβαθμία στις ψήφους του κοινού)

ΜΑΧ<--ΒΚ[1]
Θ_1<--1
ΜΙΝ<--ΒΚ[1]
Θ<--1
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 14
  ΑΝ ΒΚ[Ι]>ΜΑΧ ΤΟΤΕ
     ΜΑΧ<--ΒΚ[Ι]
     Θ_1<--Ι
  ΑΛΛΙΩΣ
             ΑΝ ΒΚ[Ι]<ΜΙΝ ΤΌΤΕ
                   ΜΙΝ<--ΒΚ[Ι]
                   Θ<--Ι
            ΤΈΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΒΚ[Θ_1]<--42
ΒΚ[Θ]<--3
Z<--39
ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 12
   ΔΙΑΦ<--ΜΑΧ-ΜΙΝ
   ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 14
         ΑΝ ΔΙΑΦ>ΜΑΧ-ΒΚ[Ι] ΚΑΙ ΒΚ[Ι]<>ΜΑΧ ΚΑΙ ΜΑΧ-ΒΚ[Ι]>0 ΤΌΤΕ
               ΔΙΑΦ<--ΜΑΧ-ΔΙΑΦ
         ΤΈΛΟΣ_ΑΝ
  ΤΈΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΑΧ<--ΜΑΧ-ΔΙΑΦ
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 14
   ΑΝ ΒΚ[Ι]=ΜΑΧ ΤΟΤΕ
         Σ[Ι]<--Ζ
          Ζ<--Ζ-3
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
« Τελευταία τροποποίηση: 01 Φεβ 2019, 10:55:42 πμ από kyriakos208 »

kyriakos208

  • Θαμώνας
  • ***
  • Μηνύματα: 21
Απ: ΟΕΦΕ 2011 ΔΙΑΦΟΡΕΤΙΚΗ ΛΥΣΗ ΣΤΟ ΘΕΜΑ Δ(Γ)
« Απάντηση #1 στις: 01 Φεβ 2019, 10:56:09 πμ »
Αν υπάρχει κάποιο λάθος πείτε μου

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 105
Απ: ΟΕΦΕ 2011 ΔΙΑΦΟΡΕΤΙΚΗ ΛΥΣΗ ΣΤΟ ΘΕΜΑ Δ(Γ)
« Απάντηση #2 στις: 01 Φεβ 2019, 11:22:34 μμ »
Η βασική μου ένσταση, είναι απλώς ένα
ΓΙΑΤΙ;
Γιατί να αντικαταστήσεις κάτι κατανοητό Ο(n2) με κάτι δυσνόητο Ο(n2);
Πέραν αυτού:

Μια διαφορετική λύση(ΧΩΡΙΣ ΤΑΞΙΝΟΜΗΣΗ ΔΙΣΔΙΑΣΤΑΤΟΥ ΠΙΝΑΚΑ) για το Θέμα Δ-(γ )

έτσι κι αλλιώς δε θα κάναμε ταξινομηση σε κανένα δισδιάστατο νομίζω, αλλά σε έναν μονοδιάστατο με τις συνολικές βαθμολογίες των κριτών
 

ΒΚ[Θ_1]<--42
ΒΚ[Θ]<--3

εδώ μάλλον ήθελες:
Σ[Θ_1]<--42
Σ[Θ]<--3

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 14
   ΑΝ ΒΚ[Ι]=ΜΑΧ ΤΟΤΕ
         Σ[Ι]<--Ζ
          Ζ<--Ζ-3
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
χωρίς να έχω καταλάβει απόλυτα τη σκέψη σου, λες ότι στο ΒΚ δεν υπάρχουν ισοβαθμίες, άρα γιατί να κάνεις αυτό το έξτρα ψάξιμο, αφού το ΜΑΧ περιμένεις ότι θα το βρεις σε μία μόνο θέση;

kyriakos208

  • Θαμώνας
  • ***
  • Μηνύματα: 21
Απ: ΟΕΦΕ 2011 ΔΙΑΦΟΡΕΤΙΚΗ ΛΥΣΗ ΣΤΟ ΘΕΜΑ Δ(Γ)
« Απάντηση #3 στις: 02 Φεβ 2019, 10:20:00 πμ »
Η βασική μου ένσταση, είναι απλώς ένα
ΓΙΑΤΙ;
Γιατί να αντικαταστήσεις κάτι κατανοητό Ο(n2) με κάτι δυσνόητο Ο(n2);
Πέραν αυτού:

έτσι κι αλλιώς δε θα κάναμε ταξινομηση σε κανένα δισδιάστατο νομίζω, αλλά σε έναν μονοδιάστατο με τις συνολικές βαθμολογίες των κριτών
 

εδώ μάλλον ήθελες:
Σ[Θ_1]<--42
Σ[Θ]<--3
χωρίς να έχω καταλάβει απόλυτα τη σκέψη σου, λες ότι στο ΒΚ δεν υπάρχουν ισοβαθμίες, άρα γιατί να κάνεις αυτό το έξτρα ψάξιμο, αφού το ΜΑΧ περιμένεις ότι θα το βρεις σε μία μόνο θέση;
Θέλει ταξινόμηση δισδιάστατου για τα επόμενα ερωτήματα,θέλει δηλαδή ένα Για μέσα στη ταξινόμηση,οι πίνακες είναι παράλληλοι

kyriakos208

  • Θαμώνας
  • ***
  • Μηνύματα: 21
Απ: ΟΕΦΕ 2011 ΔΙΑΦΟΡΕΤΙΚΗ ΛΥΣΗ ΣΤΟ ΘΕΜΑ Δ(Γ)
« Απάντηση #4 στις: 02 Φεβ 2019, 10:22:45 πμ »
Η βασική μου ένσταση, είναι απλώς ένα
ΓΙΑΤΙ;
Γιατί να αντικαταστήσεις κάτι κατανοητό Ο(n2) με κάτι δυσνόητο Ο(n2);
Πέραν αυτού:

έτσι κι αλλιώς δε θα κάναμε ταξινομηση σε κανένα δισδιάστατο νομίζω, αλλά σε έναν μονοδιάστατο με τις συνολικές βαθμολογίες των κριτών
 

εδώ μάλλον ήθελες:
Σ[Θ_1]<--42
Σ[Θ]<--3
χωρίς να έχω καταλάβει απόλυτα τη σκέψη σου, λες ότι στο ΒΚ δεν υπάρχουν ισοβαθμίες, άρα γιατί να κάνεις αυτό το έξτρα ψάξιμο, αφού το ΜΑΧ περιμένεις ότι θα το βρεις σε μία μόνο θέση;

Η σκέψη μου είναι από το Μαξ το δεύτερο μεγαλύτερο Μαξ απέχει όσο το Μαξ - τη μικρότερη απόσταση ανάμεσα στο Μαξ και σε έναν αριθμό .

Πχ το 50 από το 40 απέχει όσο το 50- την μικρότερη απόσταση που θα βγει το 10 άρα το επόμενο Μαξ είναι το 40

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 105
Απ: ΟΕΦΕ 2011 ΔΙΑΦΟΡΕΤΙΚΗ ΛΥΣΗ ΣΤΟ ΘΕΜΑ Δ(Γ)
« Απάντηση #5 στις: 03 Φεβ 2019, 11:36:20 πμ »
εγώ θα αντιπροτείνω την ακόλουθη λύση:


για υπ από 1 μέχρι 14
  Σ[υπ] <-- 0       !συνολική βαθμολογία υποψηφίου
  χαμηλ[υπ] <-- 11 !χαμηλότερη βαθμολογία υποψηφίου από κάποιο κριτή
  για κρ από 1 μέχρι 4
    Σ[υπ] <-- Σ[υπ] + Β[υπ,κρ]
    αν Β[υπ,κρ] < χαμηλ[υπ] τότε
      χαμηλ[υπ] <-- Β[υπ,κρ]
    τέλος_αν
  τέλος_επανάληψης
τέλος_επανάληψης

για χ από 2 μέχρι 14      !ταξινόμηση μονοδιάστατων πινάκων ως προς τη βαθμολογια κοινού κατά φθίνουσα σειρά
  για υπ από 14 μέχρι χ με βήμα -1
    αν ΒΚ[υπ] > ΒΚ[υπ-1] τότε
      αντιμετάθεσε ΒΚ[υπ], ΒΚ[υπ-1]
      αντιμετάθεσε Σ[υπ], Σ[υπ-1]
      αντιμετάθεσε χαμηλ[υπ], χαμηλ[υπ-1]
      αντιμετάθεσε ΟΝ[υπ], ΟΝ[υπ-1]
    τέλος_αν
  τέλος_επανάληψης
τέλος_επανάληψης

για υπ από 1 μέχρι 14       !προσαύξηση συνολικής βαθμολογίας κατά 42, 39, 36, ...
  Σ[υπ] <-- Σ[υπ] + 45-υπ*3
τέλος_επανάληψης

θ <-- 1      !σε ποιά θέση είναι αυτός που θα αποχωρήσει
για υπ από 2 μέχρι 14
  αν (Σ[υπ] < Σ[θ]) ή (Σ[υπ] = Σ[θ] και χαμηλ[υπ] < χαμηλ[θ]) τότε
    θ <-- υπ
  τέλος_αν
τέλος_επανάληψης

γράψε 'bye bye', ΟΝ[θ]