Αποστολέας Θέμα: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη  (Αναγνώστηκε 14669 φορές)

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4879
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #105 στις: 22 Φεβ 2019, 04:18:08 μμ »
Ναι την 18.04.1 θα βάζουμε μέχρι να βγει η 20.04.1.

stam12

  • Βετεράνος
  • ****
  • Μηνύματα: 87
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #106 στις: 03 Ιούν 2019, 02:47:12 μμ »
Ερώτηση: μπορεί να παρεμβληθεί κάποιο "switch" (hab) ανάμεσα στο "server" και το "gigabit switch";

Επίσης, πως καθορίζονται οι Σταθμοί Εργασίας αν είναι "thin" ή "fat"; Υπάρχει κάπου σχετική επιλογή;

Συγνώμη αν έχουν απαντηθεί ήδη οι ερωτήσεις μου, δεν το έχω ψάξει αναλυτικά.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4879
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #107 στις: 03 Ιούν 2019, 03:16:53 μμ »
Οι παρακάτω περιπτώσεις είναι όλες καλές:
  • Ο server είναι στο ίδιο switch με τους clients.
  • Παρεμβάλλεται κι άλλο switch ανάμεσα, αλλά και ο server και όλα τα switch και οι clients είναι gigabit.
  • Παρεμβάλλεται κι άλλο switch ανάμεσα, και κάποιοι clients είναι 100 MBps, αλλά το κεντρικό switch είναι managed gigabit με απενεργοποιημένο το flow control, π.χ. το TP-LINK SG1024DE.
Αν όμως υπάρχει έστω και ένας 100 MBps client ΚΑΙ το κεντρικό switch δεν είναι managed gigabit, τότε υπάρχει πρόβλημα·  είναι σαν το δίκτυό μας να είναι όλο 100 MBps κι ας έχει κάποια κομμάτια gigabit.

Οι clients γίνονται thin αν έχουν λιγότερα από 400 MB RAM (FAT_RAM_THRESHOLD στο lts.conf), ή αν έχει μπει η οδηγία LTSP_FATCLIENT=False στο lts.conf (ερώτηση #2 στο http://ts.sch.gr/wiki/Linux/LTSP/FAQ).

stam12

  • Βετεράνος
  • ****
  • Μηνύματα: 87
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #108 στις: 04 Ιούν 2019, 10:13:41 πμ »
Ευχαριστώ για την ανταπόκριση.

Μόλις προσπάθησα να εγκαταστήσω το "sch-scripts" από ένα Server που πήραμε πρόσφατα, ο οποίος είχε προ εγκατεστημένο  το ubuntu MATE. Το μήνυμα που μου έβγαλε είναι το εξής:

E: Αδυναμία εντοπισμού του πακέτου mate-hud

... και δεν προχώρησε η εγκατάσταση. Ελπίζω να μη χρειάζεται να εγκαταστήσω ξανά το "ubuntu"!

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4879
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #109 στις: 04 Ιούν 2019, 11:11:33 πμ »
Φαίνεται να έχεις το Ubuntu 16.04. Για να σιγουρευτούμε, γράψε:
grep VERSION= /etc/os-release

Το Ubuntu 16.04 δεν υποστηρίζεται για νέες εγκαταστάσεις LTSP, οπότε θα πρέπει να εγκαταστήσεις το Ubuntu 18.04 εξαρχής.
http://ts.sch.gr/wiki/Linux/Εγκατάσταση_Ubuntu

stam12

  • Βετεράνος
  • ****
  • Μηνύματα: 87
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #110 στις: 04 Ιούν 2019, 12:50:37 μμ »
Ναι, όντως αυτή είναι, η 16.04 :(
Οπότε μάλλον θα πρέπει να προχωρήσω σε νέα εγκατάσταση;

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4879
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #111 στις: 04 Ιούν 2019, 01:05:44 μμ »
Ναι, κάνε φρέσκια εγκατάσταση 18.04 διαγράφοντας τελείως την υπάρχουσα 16.04.

stam12

  • Βετεράνος
  • ****
  • Μηνύματα: 87
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #112 στις: 04 Ιούν 2019, 04:30:55 μμ »
Οκ, αυτό θα κάνω, ευχαριστώ.

Άλλη ερώτηση τώρα... στο wiki της Τεχνικής στήριξης λέει: "Εάν όλοι οι σταθμοί σας είναι 64bit με τουλάχιστον 2 GB RAM, κατεβάστε την 64bit έκδοσή του, ενώ αν έστω και ένας είναι παλιός 32bit, κατεβάστε την 32bit έκδοση".

Ο "server" που έχω είναι καινούριος υπολογιστής και σηκώνει σίγουρα την 64bit έκδοση. Οι σταθμοί εργασίας όμως είναι πιο παλιοί 32bit υπολογιστές. Οπότε να μη βάλω τελικά στο "server" την 64bit έκδοση του ΛΣ;

Δημήτρης Γκίνης

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 418
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #113 στις: 04 Ιούν 2019, 05:36:30 μμ »
Αν ανάμεσα στα μηχανήματα που προορίζεις για clients υπάρχει έστω και ένα με 32bit cpu (p4 και παλιότερος) τότε βάλε τη 32bit έκδοση.
Διαφορετικά 64 bit.

stam12

  • Βετεράνος
  • ****
  • Μηνύματα: 87
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #114 στις: 04 Ιούν 2019, 06:07:04 μμ »
Ok, 32bit δηλαδή ΛΣ, άσχετα αν ο Server σηκώνει άνετα το 64-άρι. Απλά δε πολυκαταλαβαίνω το λόγο, αφού το ΛΣ είναι υπόθεση του μηχανήματος που το φοράει.

Δημήτρης Γκίνης

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 418
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #115 στις: 04 Ιούν 2019, 07:14:10 μμ »
Στην αρχιτεκτονικήτου ltsp όλο το software (ΛΣ, εφαρμογές, drivers κλπ) που τρέχει ο server, φορτώνεται μέσω δικτύου και στους client. Έτσι αν στον server σου τρέχεις 64bit ΛΣ και έχεις client 32μπιτο, αυτός δεν θα μπορεί να το τρέξει.
Για τον ίδιο λόγο αν πχ κάποιος client έχει κάρτα γραφικών που δεν υποστηρίζει επιτάχυνση 3d (ενώ στον server παίζει κανονικά) θα έχει πρόβλημα στις εφαρμογές που έχουν τέτοιες απαιτήσεις. Αυτό βέβαια διορθώνεται.

stam12

  • Βετεράνος
  • ****
  • Μηνύματα: 87
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #116 στις: 05 Ιούν 2019, 01:49:23 μμ »
Εντάξει παιδιά, ευχαριστώ πολύ, εφαρμόστηκε σήμερα η λύση LTSP και λειτούργησαν όλα μια χαρά, όπως προβλεπόταν. Έφτιαξα εργαστήριοοο!  Γιούπιιι :D Να 'στε καλά και πάλι.

Μόνο ένα θεματάκι...
όταν έκλεισα το server για να φύγω, είχα ξεχάσει ένα client ανοιχτό κι όταν πήγα να τον κλείσω δεν αποκρινόταν, είχε κολλήσει. Συμβαίνει πάντα αυτό;

ilias_s

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 213
Απ: ΣΕΠΕΗΥ με Ubuntu 18.04/LTSP/sch-scripts/Επόπτη
« Απάντηση #117 στις: 05 Ιούν 2019, 02:21:38 μμ »
...

Μόνο ένα θεματάκι...
όταν έκλεισα το server για να φύγω, είχα ξεχάσει ένα client ανοιχτό κι όταν πήγα να τον κλείσω δεν αποκρινόταν, είχε κολλήσει. Συμβαίνει πάντα αυτό;

Ναι, αυτό συμβαίνει όταν κλείσεις τον server ή αν διακοπεί για κάποιο λόγο η σύνδεση client-server.