Αποστολέας Θέμα: Δήλωση πίνακα στον αλγόριθμο Φυσαλίδα  (Αναγνώστηκε 299 φορές)

_dim

  • Οπαδός
  • **
  • Μηνύματα: 13
Δήλωση πίνακα στον αλγόριθμο Φυσαλίδα
« στις: 03 Οκτ 2017, 01:43:46 πμ »
Καλησπέρα,
Προσπαθώ να τρέξω στο διερμηνευτή της γλώσσας αυτον τον αλγόριθμο για τον πίνακα table[52,12,71,56,5,10,19,90,45]. Πως πρέπει να δηλώσω τον πίνακα με τα 9 αυτά στοιχεία του στη δεύτερη γραμμή εκει που λέει "Δεδομένα" // // και πως θα προβάλω τον ταξινομημένο πίνακα εκει που λέει "Αποτελέσματα";
Δεν έχω καταλάβει πως δηλώνεις ένα πίνακα με συγκεκριμένα στοιχεία στο πεδίο 'ΔΕΔΟΜΕΝΑ // //"

Αλγόριθμος φυσαλιδα
Δεδομένα //table,n //
Για i από 2 μέχρι n
  Για j από n μέχρι i με βήμα -1
    Αν table[j- 1] > table[j] τότε
      Αντιμετάθεσε table[j - 1], table[j]
    Τέλος_αν
  Τέλος_επανάληψης
Τέλος_επανάληψης
Αποτελέσματα // //
Τέλος

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4801
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Δήλωση πίνακα στον αλγόριθμο Φυσαλίδα
« Απάντηση #1 στις: 03 Οκτ 2017, 07:17:41 πμ »
Διόρθωσε τη γραμμή 10 όπως φαίνεται στη συνημμένη εικόνα, δηλαδή:
Αποτελέσματα // table //
Μετά πήγαινε στο μενού "Εκτέλεση → Εκτέλεση με καταγραφή εισόδου, Alt+F6".
Στη συνέχεια δώσε την είσοδο όπως φαίνεται στην "Οθόνη εκτέλεσης" στην εικόνα.

Τα δεδομένα που έδωσες θα καταγραφούν στο "Αρχείο εισόδου" και θα αποθηκευτούν μαζί με το πρόγραμμα στην επόμενη αποθήκευση.
Έτσι αν στη συνέχεια το ξανατρέξεις, θα χρησιμοποιηθούν τα δεδομένα από το "Αρχείο εισόδου" και δεν θα σου ζητηθούν από το πληκτρολόγιο.

_dim

  • Οπαδός
  • **
  • Μηνύματα: 13
Απ: Δήλωση πίνακα στον αλγόριθμο Φυσαλίδα
« Απάντηση #2 στις: 04 Οκτ 2017, 01:02:37 πμ »
Ευχαριστώ πολύ.