Αποστολέας Θέμα: Ασκήσεις στους πίνακες  (Αναγνώστηκε 14403 φορές)

mxeg

  • Νέος
  • *
  • Μηνύματα: 8
Re: ΑΠΑΝΤΗΣΗ ΣΤΗΝ ΠΑΡΑΠΑΝΩ ΑΣΚΗΣΗ ΤΟΥ  Κων/νου Μαν
« Απάντηση #15 στις: 07 Απρ 2004, 11:20:08 μμ »
 ΑΠΑΝΤΗΣΗ ΣΤΗΝ ΠΑΡΑΠΑΝΩ ΑΣΚΗΣΗ ΤΟΥ  Κων/νου Μανολοπουλου
Nα γράψτε προγραμμα σε Γλώσσα το οποίο
θα διαβαζει μια προταση 20 χαρκτήρων και θα  
τυπωνει τη συχνότητα εμφάνισης καθε γράμματος

!υποθέτουμε ότι η χαρακτήρες βρίσκονται σ ένα πίνακα (Α) μονοδιάστατο
!βρίσκουμε τα διαφορετικά στοιχεία και τα καταχωρούμε σ ένα  πίνακα (Β)

ΠΡΟΓΡΑΜΜΑ ΣΥΧΝΟΤΗΤΑ
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ:ΠΛΗΘΟΣ[20],Ι,Κ,ΘΕΣΗ
 ΧΑΡΑΚΤΗΡΕΣ:Α[20],Β[20],
 ΛΟΓΙΚΗ:ΒΡΕΘΗΚΕ
ΑΡΧΗ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
   ΓΡΑΨΕ ' ΔΩΣΕ ΤΟΝ',Ι,'ΧΑΡΑΚΤΗΡΑ '
   ΔΙΑΒΑΣΕ Α[Ι]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 Β[1] <-- Α[1]
 ΘΕΣΗ <-- 1
 ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 20
   Κ <-- 1
   ΒΡΕΘΗΚΕ <-- ΨΕΥΔΗΣ
   ΟΣΟ (Κ<=ΘΕΣΗ) ΚΑΙ (ΒΡΕΘΗΚΕ=ΨΕΥΔΗΣ) ΕΠΑΝΑΛΑΒΕ
     ΑΝ Α[Ι]=Β[Κ] ΤΟΤΕ
       ΒΡΕΘΗΚΕ <-- ΑΛΗΘΗΣ
     ΑΛΛΙΩΣ
       Κ <-- Κ+1
     ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΑΝ ΒΡΕΘΗΚΕ=ΨΕΥΔΗΣ ΤΟΤΕ
     ΘΕΣΗ <-- ΘΕΣΗ+1
     Β[ΘΕΣΗ] <-- Α[Ι]
   ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Ο ΠΙΝΑΚΑΣ (Β) ΠΕΡΙΕΧΕΙ ΤΟΥΣ ΜΟΝΑΔΙΚΟΥΣ ΧΑΡΑΚΤΗΡΕΣ
!ΥΠΟΛΟΓΙΖΩ ΤΩΡΑ ΤΗΝ ΣΥΧΝΟΤΗΤΑ ΤΩΝ ΓΡΑΜΜΑΤΩΝ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΘΕΣΗ
   ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20
     ΑΝ Α[Κ]=Β[Ι] ΤΟΤΕ
       ΠΛΗΘΟΣ[Ι] <-- ΠΛΗΘΟΣ[Ι]+1
     ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΘΕΣΗ
   ΓΡΑΨΕ Β[Ι],' ',ΠΛΗΘΟΣ[Ι]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ    



Μαρουλάκης Χαράλαμπος

  • Επισκέπτης
Re: Ασκήσεις στους πίνακες ΑΠΑΝΤΗΣΗ ΣΤΗΝ ΠΑΡΑΠΑΝΩ
« Απάντηση #16 στις: 07 Απρ 2004, 11:28:48 μμ »
 ΑΠΑΝΤΗΣΗ ΣΤΗΝ ΠΑΡΑΠΑΝΩ ΑΣΚΗΣΗ ΤΟΥ  Κων/νου Μανολοπουλου
Nα γράψτε προγραμμα σε Γλώσσα το οποίο
θα διαβαζει μια προταση 20 χαρκτήρων και θα  
τυπωνει τη συχνότητα εμφάνισης καθε γράμματος

!υποθέτουμε ότι η χαρακτήρες βρίσκονται σ ένα πίνακα (Α) μονοδιάστατο
!βρίσκουμε τα διαφορετικά στοιχεία και τα καταχωρούμε σ ένα  πίνακα (Β)

ΠΡΟΓΡΑΜΜΑ ΣΥΧΝΟΤΗΤΑ
ΜΕΤΑΒΛΗΤΕΣ
 ΑΚΕΡΑΙΕΣ:ΠΛΗΘΟΣ[20],Ι,Κ,ΘΕΣΗ
 ΧΑΡΑΚΤΗΡΕΣ:Α[20],Β[20],
 ΛΟΓΙΚΗ:ΒΡΕΘΗΚΕ
ΑΡΧΗ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
   ΓΡΑΨΕ ' ΔΩΣΕ ΤΟΝ',Ι,'ΧΑΡΑΚΤΗΡΑ '
   ΔΙΑΒΑΣΕ Α[Ι]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 Β[1] <-- Α[1]
 ΘΕΣΗ <-- 1
 ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 20
   Κ <-- 1
   ΒΡΕΘΗΚΕ <-- ΨΕΥΔΗΣ
   ΟΣΟ (Κ<=ΘΕΣΗ) ΚΑΙ (ΒΡΕΘΗΚΕ=ΨΕΥΔΗΣ) ΕΠΑΝΑΛΑΒΕ
     ΑΝ Α[Ι]=Β[Κ] ΤΟΤΕ
       ΒΡΕΘΗΚΕ <-- ΑΛΗΘΗΣ
     ΑΛΛΙΩΣ
       Κ <-- Κ+1
     ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΑΝ ΒΡΕΘΗΚΕ=ΨΕΥΔΗΣ ΤΟΤΕ
     ΘΕΣΗ <-- ΘΕΣΗ+1
     Β[ΘΕΣΗ] <-- Α[Ι]
   ΤΕΛΟΣ_ΑΝ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
!Ο ΠΙΝΑΚΑΣ (Β) ΠΕΡΙΕΧΕΙ ΤΟΥΣ ΜΟΝΑΔΙΚΟΥΣ ΧΑΡΑΚΤΗΡΕΣ
!ΥΠΟΛΟΓΙΖΩ ΤΩΡΑ ΤΗΝ ΣΥΧΝΟΤΗΤΑ ΤΩΝ ΓΡΑΜΜΑΤΩΝ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΘΕΣΗ
   ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 20
     ΑΝ Α[Κ]=Β[Ι] ΤΟΤΕ
       ΠΛΗΘΟΣ[Ι] <-- ΠΛΗΘΟΣ[Ι]+1
     ΤΕΛΟΣ_ΑΝ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ ΘΕΣΗ
   ΓΡΑΨΕ Β[Ι],' ',ΠΛΗΘΟΣ[Ι]
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ    

nekis

  • Βετεράνος
  • ****
  • Μηνύματα: 76
  • U R NT A #
Re: Ασκήσεις στους πίνακες
« Απάντηση #17 στις: 20 Δεκ 2004, 11:26:58 πμ »
 :-/ Αγαπητοί συναγωνιστές, έχω να προτείνω μια άσκηση για συζήτηση.

Σε μια σκακιέρα (δισδιάστατος α[8,8] )τοποθετούμε αρχικά έναν λευκό ίππο και δεχόμαστε είσοδο για τη θέση ενός μαύρου ίππου. Η έξοδος του αλγόριθμου είναι αν τα δυο κομμάτια "τρώγονται".

Θεωρώ ότι η άσκηση μπορεί να επεκταθεί σε πολλές άλλες εκδοχές  και με άλλα κομμάτια.