Αποστολέας Θέμα: helpp  (Αναγνώστηκε 1346 φορές)

Eleftheria_k

  • Νέος
  • *
  • Μηνύματα: 9
helpp
« στις: 21 Ιαν 2017, 09:00:55 μμ »
Πως θα ελεξω το περιεχόμενο ενος πινακα
αν ειναι ταξινομημενος κατά αύξουσα σειρα η κατα φθίνουσα η δεν ειναι καθολου ταξινομημενος..σεολες τις παραπανω ενεργειες να εμφανίζει κατάλληλο μηνυμα..

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3059
  • to Iterate is human to Recurse divine
Απ: helpp
« Απάντηση #1 στις: 21 Ιαν 2017, 09:28:26 μμ »
Θα ψάξεις να βρεις αν υπάρχουν δυο διαδοχικά στοιχεία τα οποία δεν είναι στη σειρά που θέλεις. Αν βρεις τέτοιο αντιπαράδειγμα θα θέσεις μια λογική μεταβλητή ΑΥΞΟΥΣΑ με τιμή ψευδής. Στην αρχή η λογική αυτή μεταβλητή θα είναι αληθής. Αν δεν βρει στοιχεία τα οποία να μην είναι σε αύξουσα σειρά θα παραμείνει αληθής αλλιώς αν βρει έστω και ένα θα γίνει ψευδής.

Αυτή είναι η βασική ιδέα.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Eleftheria_k

  • Νέος
  • *
  • Μηνύματα: 9
Απ: helpp
« Απάντηση #2 στις: 22 Ιαν 2017, 10:16:43 μμ »
Ναι και στο τελος θα πω:
Αν ΑΥΞΟΥΣΑ= ΑΛΗΘΗΣ τοτε γραψε"αυξουσα διαταξη"
Αλλιως γραψε "φθινουσα διαταξη"
Εγω ομως θελω τρεις περιπτώσεις..αν δεν ειναι ταξινομημενος πως θα το εμφανιζω.αυτο δεν εχω καταλαβει

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3059
  • to Iterate is human to Recurse divine
Απ: helpp
« Απάντηση #3 στις: 22 Ιαν 2017, 10:27:55 μμ »
Αν δεν είναι αύξουσα δεν σημαίνει ότι είναι φθίνουσα, μπορεί να μην είναι τίποτα.

Κώδικας: Pascal
  1. ΑΥΞΟΥΣΑ <- ΑΛΗΘΗΣ
  2. ΦΘΙΝΟΥΣΑ <- ΑΛΗΘΗΣ
  3. i <- 2
  4. ΟΣΟ (ΑΥΞΟΥΣΑ Ή ΦΘΙΝΟΥΣΑ) ΚΑΙ i<=N ΕΠΑΝΑΛΑΒΕ
  5.     ΑΝ A[i-1] < A[i] Τότε
  6.         ΦΘΙΝΟΥΣΑ <- ΨΕΥΔΗΣ
  7.     ΤΕΛΟΣ_ΑΝ
  8.     ΑΝ A[i-1] > A[i] Τότε
  9.         ΑΥΞΟΥΣΑ <- ΨΕΥΔΗΣ
  10.     ΤΕΛΟΣ_ΑΝ
  11.     i <- i + 1
  12. ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  13.  

Σκέψου τι θα πρέπει να γράψεις έξω από την επανάληψη ώστε να εμφανιστούν τα σωστά μηνύματα
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Eleftheria_k

  • Νέος
  • *
  • Μηνύματα: 9
Απ: helpp
« Απάντηση #4 στις: 22 Ιαν 2017, 10:39:11 μμ »
Ενταξει θα το προσπαθήσω!!ευχαριστω :D

Κωστας τζιαννης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 184
Απ: helpp
« Απάντηση #5 στις: 03 Μάι 2017, 03:37:10 πμ »
Πως θα ελεξω το περιεχόμενο ενος πινακα
αν ειναι ταξινομημενος κατά αύξουσα σειρα η κατα φθίνουσα η δεν ειναι καθολου ταξινομημενος..σεολες τις παραπανω ενεργειες να εμφανίζει κατάλληλο μηνυμα..

αν θες μια ευκολη λυση  ειναι η εξης.εστω οτι ο πινακας που θελουμε να ελεγξουμε ειναι ο Α.φτιαξε εναν πινακα Β και εναν Γ.περνα σε καθε εναν απο αυτους τα στοιχεια του Α.ταξινομησε τον β σε αυξουσα και τον γ σε φθινουσα σειρα.συγκρινε τον α με τον β στοιχειο προς στοιχειο.κανε το ιδιο και με τον γ.αν ο α ειναι ιδιος με τον β τοτε ειναι σε αυξουσα σειρα.αν ειναι ιδιος με τον γ ειναι σε φθινουσα.αν δεν ειναι ιδιος με κανεναν τοτε ειναι αταξινομητος.μπορεις να χρησιμοποιησεις και εναν πινακα πχ μονο τον β ταξινομοντας τον πρωτα σε αυξουσα σειρα τον συγκρινεις με τον α.επειτα τον ταξινομεις σε φθινουσα και κανεις το ιδιο.η λυση αυτη δεν ειναι η εξυπνοτερη λυνει ομως το προβλημα