Αποστολέας Θέμα: Ο παλιός είναι αλλιώς......  (Αναγνώστηκε 926 φορές)

SPY

  • Βετεράνος
  • ****
  • Μηνύματα: 61
  • Γράψτε το προσωπικό σας σλόγκαν!
Ο παλιός είναι αλλιώς......
« στις: 27 Μάι 2016, 01:34:51 μμ »
Συνάδελφοι γεια σας,

Ρίξτε μια ματιά και στα θέματα του παλαιού συστήματος.

http://minedu.gov.gr/publications/docs2016/EXETASEIS-2016/them_plir_kat_c_hmer_os_160527.pdf

Νομίζω ότι είναι πολύ δυσκολότερα από εκείνα του νέου.

Επισημαίνω τα εξής
1) το ανόητο θέμα παπαγαλίας Α2 (5 πλεονεκτήματα του Δομημένου Προγραμματισμού)
2) τα πονηρά Α3, Α4 και Α5 που θέλανε λίγη σκέψη τέλος πάντων.
3) Το Β1 που είναι η αδίδακτη δυαδική αναζήτηση.
4) Το Β2 μερική συγχώνευση 2 αντίθετα ταξινομημένων πινάκων.
5) Το Γ3 που ζητάει 2 ελαχιστες τιμές χωρίς πίνακα.
6) Το Δ2 που απαιτεί κατευθυνόμενη λύση με συνάρτηση.

Αναρωτιέμαι αν έπεφταν αυτά τα θέματα στο νέο σύστημα τι κλιμάκωση βαθμολογίας θα είχαμε;
Τι να πεί κανείς. Μετά πώς να μη πιστεύεις ότι δεν περνάει γραμμή;





Λαμπράκης Μανώλης

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 638
Απ: Ο παλιός είναι αλλιώς......
« Απάντηση #1 στις: 27 Μάι 2016, 01:57:18 μμ »
Συνάδελφε τα είδα και εγώ...τα θεωρώ αρκετά δύσκολα, καμία σχέση με του νέου συστήματις..κάπου στη μέση θα έπρεπε ίσως να είναι όλα τα θέματα...

georgekpl

  • Νέος
  • *
  • Μηνύματα: 1
Απ: Ο παλιός είναι αλλιώς......
« Απάντηση #2 στις: 27 Μάι 2016, 10:10:15 μμ »
Θα ήθελα να ρωτήσω κάτι! Αν στο Θέμα Γ λύθηκε με χρήση πίνακα και βγάζει σαν έξοδο τα ζητούμενα, χάνονται όλοι οι βαθμοί του θέματος.

epsilonXi

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 115
Απ: Ο παλιός είναι αλλιώς......
« Απάντηση #3 στις: 27 Μάι 2016, 11:01:07 μμ »
το 3ο θέμα μ'αρέσει έτσι:

όνομα[1] <-- 'ακυρο όνομα'
όνομα[2] <-- 'ακυρο όνομα'
μέγεθος[1] <-- 1001
μέγεθος[2] <-- 1001
χωρητικότητα <-- 1000
αρχεία <-- 0
οβερ10 <-- 0
διαβασε μέγεθος[3], όνομα[3]
όσο χωρητικότητα >= μέγεθος[3] επανάλαβε
  γράψε 'επιτρεπτή αποθήκευση'
  χωρητικότητα <-- χωρητικότητα - μέγεθος[3]
  αρχεία <-- αρχεία+1
  αν μέγεθος[3] > 10 τότε
    οβερ10 <-- οβερ10 + 1
  τέλος_αν
  για χ από 3 μέχρι 2 με βήμα -1
    αν μέγεθος[χ] < μέγεθος[χ-1] τότε
      αντιμετάθεσε μέγεθος[χ], μέγεθος[χ-1]
      αντιμετάθεσε όνομα[χ], όνομα[χ-1]
    τέλος_αν
  τέλος_επανάληψης
  διάβασε μέγεθος[3], όνομα[3]
τέλος_επανάληψης
γράψε οβερ10/αρχεία*100, '% των αποθηκευμένων αρχείων έχουν μέγεθος > 10GB'
γράψε 'τα 2 μικρότερα αρχεία ήταν το ', όνομα[1], ' και το ', όνομα[2]

SPY

  • Βετεράνος
  • ****
  • Μηνύματα: 61
  • Γράψτε το προσωπικό σας σλόγκαν!
Ο παλιός είναι αλλιώς......
« Απάντηση #4 στις: 28 Μάι 2016, 12:52:07 μμ »
Θα ήθελα να ρωτήσω κάτι! Αν στο Θέμα Γ λύθηκε με χρήση πίνακα και βγάζει σαν έξοδο τα ζητούμενα, χάνονται όλοι οι βαθμοί του θέματος.
Προφανώς και δεν χάνονται 20 μονάδες. Θα ήταν παράλογο. Πόσες θα αφαιρεθούν είναι θέμα των συντονιστών. Αν υπάρχει, ή προκύψει από τις συναντήσεις, κάτι συγκεκριμένο που το γνωρίζει κάποιος συνάδελφος ας το αναφέρει.