Αποστολέας Θέμα: Ακέραιος δείκτης πίνακα στα "Βασικά στατιστικά μεγέθη"  (Αναγνώστηκε 931 φορές)

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2780
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Αν θεωρούμε ότι:
α) ο τελεστής  / δίνει εξ ορισμού πραγματικού τύπου αποτέλεσμα
β) οι δείκτες στους πίνακες πρέπει να είναι ακέραιοι
τότε στο παράδειγμα του σχολικού βιβλίου με τα βασικά στατιστικά μεγέθη (σελ. 188 της παλιάς έκδοσης, βλ: http://alkisg.mysch.gr/steki/index.php?topic=1436.0) υπάρχει προβληματάκι!
 
!Υπολογισμός διαμέσου
ΑΝ Ν MOD 2 =0 TOTE
    Διάμεσος <- (X[N/2]+X[N/2+1])/2
ΑΛΛΙΩΣ
    Διάμεσος <- X[(N+1)/2]
ΤΕΛΟΣ_ΑΝ

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1015
!Υπολογισμός διαμέσου
ΑΝ Ν MOD 2 =0 TOTE
    Διάμεσος <- (X[N div 2]+X[N div 2+1])/2
ΑΛΛΙΩΣ
    Διάμεσος <- X[(N+1) div 2]
ΤΕΛΟΣ_ΑΝ