Αποστολέας Θέμα: 1 client δεν ξεκιναει  (Αναγνώστηκε 797 φορές)

vinternoll

  • Νέος
  • *
  • Μηνύματα: 6
1 client δεν ξεκιναει
« στις: 08 Σεπ 2014, 11:57:48 πμ »
Πριν παραθεσω το προβλημα που συναντησα θα ηθελα να δωσω συγχαρητηρια σε ολη την ομαδα που δουλεψε ωστε μπορεσουμε ευκολα να εγκαταστησουμε το Ubuntu στα εργαστηρια.

Το καλοκαιρι εγκατεστησα το λειτουργικο και δουλεψαν ολοι οι clients εκτος απο εναν.
Να σημειωσω οτι εχω επανω περασμενα Windows XP o loader ρυθμιστηκε να φορτωνει By default το PXE εκτος κι αν επιλεξουμε με το βελακι τα  XP.
Το προβλημα που συνανταω ειναι το εξης:

Αν το αφησω να φορτωσει το Ubuntu κολλαει για 2-3 δευτερολεπτα και αμεσως μετα πεταει μηνυμα οτι δεν βρισκει το αρχειο hal.dll (λογικα περναει στη δευτερη επιλογη και μετα το κολλημα παει να φορτωσει τα XP).
Αν εξαρχης επιλεξω τα XP τοτε αυτα φορτωνουν κανονικα.

Με format των ΧΡ θα διορθωθει το προβλημα ή αδικος κοπος;
Εκανα αλλη μια δημοσιευση εικονικου δισκου μπας και γινει κατι αλλα τιποτα.

apapakL

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 365
    • ΕΛ/ΛΑΚ και εκπαίδευση
Απ: 1 client δεν ξεκιναει
« Απάντηση #1 στις: 08 Σεπ 2014, 01:42:19 μμ »
Δοκίμασες να ξαναεγκαταστήσεις τον loader;

vinternoll

  • Νέος
  • *
  • Μηνύματα: 6
Απ: 1 client δεν ξεκιναει
« Απάντηση #2 στις: 08 Σεπ 2014, 01:50:49 μμ »
Πολλες φορες αλλα δεν εγινε κατι διαφορετικο

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4879
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: 1 client δεν ξεκιναει
« Απάντηση #3 στις: 08 Σεπ 2014, 07:18:04 μμ »
Αν η κάρτα δικτύου είναι ενσωματωμένη στη μητρική (onboard), είναι πιθανό το iPXE να μην την υποστηρίζει, οπότε και πρέπει να χρησιμοποιήσεις την πρώτη επιλογή, "Υποστήριξη από το BIOS":
http://ts.sch.gr/wiki/Linux/LTSP/Εκκίνηση_από_το_δίκτυο

vinternoll

  • Νέος
  • *
  • Μηνύματα: 6
Απ: 1 client δεν ξεκιναει
« Απάντηση #4 στις: 09 Σεπ 2014, 07:04:52 μμ »
Αν η κάρτα δικτύου είναι ενσωματωμένη στη μητρική (onboard), είναι πιθανό το iPXE να μην την υποστηρίζει, οπότε και πρέπει να χρησιμοποιήσεις την πρώτη επιλογή, "Υποστήριξη από το BIOS":
http://ts.sch.gr/wiki/Linux/LTSP/Εκκίνηση_από_το_δίκτυο
Επειδη ελειπα σημερα εκτος σχολειου για σεμιναριο θα τσεκαρω αυριο.
Αν δεν κανω λαθος η καρτα δικτυου δεν ειναι ενσωματωμενη (οπως και στα υπολοιπα μηχανηματα) αλλα θα το δω αυριο και θα ενημερωσω.

vinternoll

  • Νέος
  • *
  • Μηνύματα: 6
Απ: 1 client δεν ξεκιναει
« Απάντηση #5 στις: 11 Σεπ 2014, 09:00:36 μμ »
Τελικα η καρτα δεν ηταν ενσωματωμενη.
Δεν ξερω τι μπορει να φταιει αλλα καταφερα να ξεκινησω τον client με το ipxe.iso το οποιο εγραψα σε CD.
Το boot ομως γινεται μονο αν εχω αποσυνδεδεμενο τον σκληρο.
Αν εχω disabled ολες τις επιλογες εκτος απο το CD απο το BIOS δεν ξεκιναει.

Τελος παντων αρκει που βρεθηκε τροπος.
Για την Α Ταξη που θελω Windows θα συνδεω το δισκο ή πιθανον να μη χρειαστει να καθεται καποιος σε αυτον τον client.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4879
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: 1 client δεν ξεκιναει
« Απάντηση #6 στις: 11 Σεπ 2014, 10:32:24 μμ »
Πόσταρε λίγο το C:\Boot.ini, μπορεί να έχει λάθος γράμμα drive για το ipxe αν τα Windows είναι στο δεύτερο ή σε extended partition.

Είναι κρυφό, ένας τρόπος να το ανοίξεις είναι μέσα από τα Windows, Έναρξη → Εκτέλεση, notepad C:\Boot.ini, και μετά copy/paste τα περιεχόμενά του εδώ.