Αποστολέας Θέμα: ubuntu δεν φορτώνουν όταν είναι συνδεδεμένο με video splitter για προτζεκτορα  (Αναγνώστηκε 2236 φορές)

khatziar

  • Οπαδός
  • **
  • Μηνύματα: 19
Γεια σας,
Στο μηχάνημα που έχουμε συνδεδεμένο τον προτζέκτορα με video splitter KONIG δεν εκκινούν τα ubuntu. Κολλάνε αμέσως μετά το μενού grub στις τελίτσες που "γεμίζουν".
Όταν τα καλώδια της οθόνης είναι απευθείας στον υπολογιστή ξεκινούν. Όταν αργότερα τα ubuntu είναι σε λειτουργία και συνδέσω τον προτζέκτορα όλα δουλεύουν καλά.
Υποθέτω ότι στην εκκίνηση δεν υποστηρίζει κάποια χαμηλή ανάλυση που επιβάλει αυτή η σύνδεση αλλά δεν ξέρω πως να το αλλάξω.
Αν έχετε καμμιά ιδέα θα βοηθούσε γιατί είναι κουραστικό να αλλάζω καλώδια σε κάθε εκκίνηση.
Ευχαριστώ πολύ
Κώστας Χατζηαράπης
3ο-6ο Δημ. Σχολείο Συκεών

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4801
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
  • Είναι LTSP server;
  • Είναι LTSP client;
  • Χρησιμοποίησες το Live CD της Τεχνικής Στήριξης για την εγκατάσταση;
  • Τι κάρτα γραφικών έχει και τι drivers χρησιμοποιεί; Πόσταρε το αποτέλεσμα της εντολής: lspci -nn -k | grep -A 2 VGA
  • Δοκίμασε να πατήσεις Esc με το που εμφανίζονται οι τελίτσες με το Ubuntu, ώστε να φανούν πιθανά μηνύματα λαθών.
  • Όταν "κολλάει", εμφανίζεται μαύρη οθόνη, ή φαίνονται ακόμα οι τελίτσες;
  • Τέλος, κάνε μια ανεπιτυχή εκκίνηση (με το splitter), και ακριβώς μετά μια επιτυχή (χωρίς το splitter), και τότε ανέβασε το αρχείο /var/log/Xorg.0.log.old εδώ.

khatziar

  • Οπαδός
  • **
  • Μηνύματα: 19
Είναι standalone ubuntu με εγκατάσταση από το  Live CD της Τεχνικής Στήριξης .
Σκέφτομαι πάντως να τον κάνω ltsp server και μαζεύω κάποιες ερωτήσεις πριν αρχίσω τη διαδικασία.
Τις ερωτήσεις 4-7 θα στις απαντήσω αύριο από το εργαστήριο του σχολείου.

Ευχαριστώ για την γρήγορη απάντηση

khatziar

  • Οπαδός
  • **
  • Μηνύματα: 19
1-3)
όπως έγραψα παραπάνω είναι standalone εγκατεστημένο με το Live CD της Τεχνικής Στήριξης. (γιατί είχα στο νου μου να το κάνουμε ltsp)

4)
dss@pc06:~$ lspci -nn -k | grep -A 2 VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2] (rev 10)
   Subsystem: ASUSTeK Computer Inc. P5KPL-VM Motherboard [1043:82b0]
   Kernel driver in use: i915

5-6)
Έκανα λάθος, τελίτσες δεν φαίνονται  (αυτό γινόνταν όταν εκκινούσα με usb όταν έκανα εγκατάσταση μέχρι να ψιλιαστώ το θέμα με video splitter)

Μετά το grub η οθόνη (CRT Proview) βγάζει μήνυμα "Power save enable monitor shut down after few seonds" και μετά μαυρίζει.
Όμως παρατήρησα ότι τα ubuntu φορτώνουν από κάτω γιατί ακούγεται ο ήχος της οθόνης σύνδεσης,

7) Επισυνάπτω το αρχείο

Ευχαριστώ και πάλι

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4801
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Υποθέτω ότι λόγω splitter δεν μπορεί να ανιχνεύσει το monitor και έτσι του βάζει πολύ ψηλή ανάλυση που δεν μπορεί να τη σηκώσει, και μαυρίζει.
Δοκίμασε το εξής:
Εκκίνηση χωρίς το splitter,
κλικ στο όνομα π.χ. "Υπεύθυνος ΣΕΠΕΗΥ" στο πάνω δεξιά μέρος της οθόνης, και "Λογαριασμοί χρηστών" από το μενού που θα εμφανιστεί,
και για τον λογαριασμό χρήστη σου, ενεργοποίησε την "Αυτόματη σύνδεση", ώστε τελικά να μπαίνει κατευθείαν στο λογαριασμό σου χωρίς κωδικό πρόσβασης.

Στη συνέχεια, σύνδεσε το splitter χωρίς reboot,
κλικ στο εικονίδιο με το γρανάζι τέρμα πάνω δεξιά, και επιλογή του μενού "Οθόνες",
και βάλε μια χαμηλότερη ανάλυση, π.χ. 1024x768 σε clone mode ή ό,τι άλλο θες - το σημαντικό είναι να πατηθεί το κουμπί "Εφαρμογή" ώστε να έχεις καθορισμένη συγκεκριμένη ανάλυση.

Μετά reboot με το splitter και δες αν κράτησε την ανάλυση που έβαλες...


Αν δεν παίξουν τα παραπάνω, πες τι επιθυμητή ανάλυση θες ώστε να σου πω συγκεκριμένα τι να γράψεις στο xorg.conf.

khatziar

  • Οπαδός
  • **
  • Μηνύματα: 19
Λοιπόν, έκανα αυτά που είπες και δεν αλλάζει κάτι.
Και με αυτόματη σύνδεση και με μικρότερη ανάλυση η οθόνη είναι μαύρη και τα ubuntu από κάτω λειτουργούν.
Η ανάλυση που θέλω είναι 1024x768
Αν είναι χρονοβόρο δεν χρειάζεται να ασχοληθείς παραπάνω.
Σ'ευχαριστώ πολύ, όπως και να έχει.
Σημαντικό τώρα είναι να κάνω κάποιες αλλαγές για να τρέξω το ltsp σε fat clients και 100άρι δίκτυο. Θα ποστάρω μερικές ερωτήσεις σε άλλο θέμα...


alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4801
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Να σημειώσω δύο λύσεις για την περίπτωση του splitter στον server, αλλά δεν έχουν ακόμα δοκιμαστεί εκτενώς, οπότε αν κάποιος έχει πρόβλημα με splitter ας έρθει από το IRC να τις δούμε μαζί.

1) Αν η κάρτα γραφικών έχει KMS driver (πλέον έχουν σχεδόν όλες), τότε τρέχουμε sudo dpkg-reconfigure grub-pc και στην ερώτηση "Γραμμή εντολής Linux" βάζουμε μία από τις παρακάτω παραμέτρους, ανάλογα με την οθόνη μας:
drm_kms_helper.edid_firmware=edid/1024x768.bin
drm_kms_helper.edid_firmware=edid/1280x1024.bin
drm_kms_helper.edid_firmware=edid/1600x1200.bin
drm_kms_helper.edid_firmware=edid/1680x1050.bin
drm_kms_helper.edid_firmware=edid/1920x1080.bin

Αν είναι για client τότε αντί να τρέξουμε dpkg-reconfigure, βάζουμε την παράμετρο στο pxelinux.cfg.

2) Αν δεν έχει KMS driver, τότε βάζουμε vga=ask για να δούμε ένα μενού με όλες τις αναλύσεις πατώντας enter όταν ο server μπουτάρει, και μετά διαλέγουμε ανάλυση, και βάζουμε π.χ. vga=0x344 για 1024x768x32.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4801
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Μια ακόμα λύση είναι να χρησιμοποιηθεί ο vesa driver, χάνοντας όμως και όλη την επιτάχυνση γραφικών αλλά και όλες τις μη-τυπικές αναλύσεις.
Δίνουμε sudo gedit /etc/X11/xorg.conf και βάζουμε τα παρακάτω:

Κώδικας: [Επιλογή]
Section "Device"
    Identifier  "Configured Video Device"
    Driver      "vesa"
EndSection

Section "Monitor"
    Identifier  "Configured Monitor"
EndSection

Section "Screen"
    Identifier  "Default Screen"
    Monitor     "Configured Monitor"
    Device      "Configured Video Device"
EndSection

charalampidis

  • Οπαδός
  • **
  • Μηνύματα: 10
Έχω το ίδιο πρόβλημα σε client.
Πώς όμως τροποποιώ το pxelinux.cfg για τον συγκεκριμένο client και ποια εντολή-παράμετρο εισάγω;

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4801
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Το παρόν θέμα αφορά την ρύθμιση του server. Η ρύθμιση των clients είναι πολύ πιο απλή και γίνεται από τις παρακάτω εντολές του lts.conf:
Κώδικας: Bash
  1. # Οι παρακάτω οδηγίες χρησιμεύουν όταν το πρόγραμμα οδήγησης δεν ανιχνεύει
  2. # σωστά την (πιθανώς παλιά CRT) οθόνη και δείχνει μόνο χαμηλές αναλύσεις.
  3. # Δείτε το εγχειρίδιο της οθόνης για τις σωστές τιμές, αυτές είναι για 1024x768.
  4. X_HORZSYNC=30.0-88.0
  5. X_VERTREFRESH=50.0-88.0

Εάν δυσκολευτείς στο να βρεις τις σωστές τιμές χρονισμού της οθόνης του client, έλα από το IRC.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4801
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Σε μια άλλη περίπτωση, 16.04 με VGA και προτζέκτορα χωρίς splitter, χρειάστηκε το παρακάτω xorg.conf ώστε να γίνει clone:
Κώδικας: Bash
  1. # To set the DP-1 monitor as primary
  2. Section "Monitor"
  3.     Identifier  "DP-1"
  4.     Option      "Primary" "true"
  5. EndSection
  6.  
  7. Section "Monitor"
  8.     Identifier  "HDMI-1"
  9.     Option      "PreferredMode" "1280x1024"
  10. EndSection

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4801
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Τώρα με το KMS είναι προτιμότερος ο modesetting driver αντί του vesa:
Κώδικας: [Επιλογή]
Section "Device"
    Identifier  "Configured Video Device"
    Driver      "modesetting"
EndSection

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4801
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Και μια άλλη επιλογή που δούλεψε με splitter, ήταν:
sudo dpkg-reconfigure grub-pc
και video=VGA-1:1366x768@60