Αποστολέας Θέμα: Point releases του Ubuntu (12.04.x)  (Αναγνώστηκε 5152 φορές)

yiannis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 217
Point releases του Ubuntu (12.04.x)
« στις: 24 Φεβ 2013, 08:58:20 μμ »
Είδα ότι στο επίσημο site του ubuntu υπάρχει πλέον η 12.04.2 LTS έκδοση. Υπάρχει σκέψη να γίνουν και τα live CDs της Τεχνικής Στήριξης σε αυτήν την έκδοση; Αν κάποιος θέλει να κάνει τώρα ένα clean install είναι καλύτερα να πάρει κατευθείαν την 12.04.2 ή να μείνει σε εκείνη της ΤΣ; Άλλωστε θα γίνει και έτσι η αναβάθμιση, λογικά...

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4931
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #1 στις: 24 Φεβ 2013, 09:13:23 μμ »
Είδα ότι στο επίσημο site του ubuntu υπάρχει πλέον η 12.04.2 LTS έκδοση. Υπάρχει σκέψη να γίνουν και τα live CDs της Τεχνικής Στήριξης σε αυτήν την έκδοση; Αν κάποιος θέλει να κάνει τώρα ένα clean install είναι καλύτερα να πάρει κατευθείαν την 12.04.2 ή να μείνει σε εκείνη της ΤΣ; Άλλωστε θα γίνει και έτσι η αναβάθμιση, λογικά...

Αυτό είναι σημαντικό: ΜΗΝ το κάνετε!!! Συνεχίστε με τα CDs της Τεχνικής Στήριξης.

Η διαφορά είναι ότι μια καθαρή εγκατάσταση της 12.04.2 έρχεται με linux-generic-lts-quantal και xserver-xorg-lts-quantal,
ενώ η 12.04.1 με αναβάθμιση διατηρεί τα linux-generic-pae και xserver-xorg.

Για την ώρα τα πρώτα έχουν κάποια σοβαρά προβλήματα τα οποία τα κάνουν ακατάλληλα για μη προχωρημένους χρήστες.
1) Δεν παίζει το virtualbox λόγω του νέου kernel: https://bugs.launchpad.net/ubuntu/+source/virtualbox/+bug/1081307
2) Δεν παίζει η samba (file sharing) λόγω του νέου kernel: https://bugs.launchpad.net/ubuntu/+source/samba/+bug/1016895
3) Η "αφαίρεση παλιών πυρήνων" των sch-scripts αλλά και το ίδιο το LTSP θα έχουν ένα θέμα με τον νέο kernel. Γενικά, παίζουν οι εξής kernels:
linux-image-generic-pae: Με αυτόν έρχεται η 12.04.1. Επειδή είναι "pae", μερικά παλιά μηχανήματα δεν τον υποστηρίζουν.
linux-image-generic-lts-quantal: Με αυτόν έρχεται η 12.04.2. Είναι κι αυτός "pae" αλλά δυστυχώς δεν το γράφει στο όνομα πακέτου.
linux-image-generic: Αυτόν τον βάζουμε όταν έχουμε μηχανήματα που δεν υποστηρίζουν "pae".

Το πρόβλημα είναι ότι αφού ο linux-image-generic-lts-quantal δεν γράφει "pae" στο όνομά του, τα sch-scripts και το LTSP θεωρούν ότι δεν είναι pae.
Άρα, το linux-image-generic θεωρείται παλιότερη έκδοσή του, και προτείνουν την αφαίρεσή του και γενικά δεν τον χρησιμοποιούν αυτόματα για τα παλιά μηχανήματα. Δηλαδή με την 12.04.2 θα είναι πολύ πιο δύσκολο να δουλέψουν μηχανήματα που δεν υποστηρίζουν pae.

Δεν έχω σκεφτεί ακόμα καλή λύση για το (3), αλλά πάντως δεν θα βγουν νέα live CD από την Τεχνική Στήριξη μέχρι να λυθεί τουλάχιστον το (1) και το (2). (Είχα σκοπό να βγάλω εδώ και 1 βδομάδα αλλά επίτηδες το αναβάλλω για να μην μπλέξουν τα σχολεία με αυτά τα προβλήματα).

Στη γενική περίπτωση πάντως, ναι, σε κάθε point release του Ubuntu (12.04.x), θα βγαίνουν και αντίστοιχα live CDs από την ΤΣ.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4931
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #2 στις: 28 Φεβ 2013, 12:54:50 μμ »
4) Το xserver-xorg-video-s3virge-lts-quantal δεν υπάρχει στο xserver-xorg-lts-quantal, και επομένως όσοι έχουν τέτοιες παλιές κάρτες καλά θα κάνουν να μείνουν με την 12.04.1 + αναβαθμίσεις.

Επειδή τα σχολεία δεν πολυέχουν ...υπολογιστές τελευταίου εξαμήνου, ας μείνουμε στην αναβαθμισμένη 12.04.1 για μερικούς μήνες, και αν λυθούν κάμποσα από τα παραπάνω προβλήματα του "-lts-quantal hardware enablement stack", το ξανασκεφτόμαστε...


Οπότε σύντομα θα βγει νέα έκδοση των Live CDs, με 12.04.1 αναβαθμισμένη, που θα ισοδυναμεί με 12.04.2 με τον παλιό πυρήνα και το παλιό xorg.
Και αν κάποιος θέλει βάζει τον καινούργιο πυρήνα και το καινούργιο xorg χειρωνακτικά...

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4931
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #3 στις: 07 Σεπ 2013, 02:53:47 μμ »
Στη σελίδα http://ts.sch.gr/wiki/Linux/LiveCD ανεβάσαμε νέες εκδόσεις των Live CDs/DVDs για την εγκατάσταση σχολικών εργαστηρίων, οι οποίες αντιστοιχούν στην 12.04.4 έκδοση του Ubuntu. Εννοείται ότι τα σχολεία που έχουν ήδη 12.04 δεν τα χρειάζονται καθόλου.

Μια "λεπτομέρεια" για τους πιο προχωρημένους: τα CD αυτά επίτηδες δεν φτιάχτηκαν με βάση την 12.04.4 αλλά με αναβαθμισμένη 12.04.1. Αυτό έγινε ώστε να έχουν τον κανονικό πυρήνα της 12.04 και όχι τον αναβαθμισμένο πυρήνα και Xorg των 12.10/13.04, όπως περιγράφεται στο https://wiki.ubuntu.com/Kernel/LTSEnablementStack. Έτσι όλα τα σχολεία θα έχουν τον ίδιο πυρήνα ανεξάρτητα από το ποιο CD χρησιμοποίησαν για την εγκατάσταση, ενώ επίσης ο παλιός πυρήνας υποστηρίζεται καλύτερα από το LTSP (παράλληλη χρήση pae/μη pae πυρήνων για παλιά τερματικά).

Αν όμως κάποιο σχολείο έχει εξαιρετικά σύγχρονους υπολογιστές (π.χ. φετεινούς), και εμφανιστούν προβλήματα υποστήριξης γραφικών, μπορεί (τότε και μόνο τότε) να μεταβεί στον καινούργιο πυρήνα δίνοντας:
Κώδικας: Bash
  1. sudo apt-get install --purge linux-hwe-generic xserver-xorg xorg

Στη συνέχεια επανεκκίνηση, Αφαίρεση παλιών πυρήνων από τα sch-scripts και Δημοσίευση εικονικού δίσκου.

Αν τα προβλήματα με τους καινούργιους clients συνεχιστούν, τότε και μόνο τότε μπορεί να αναβαθμίσει και το Xorg, δίνοντας:
Κώδικας: Bash
  1. sudo apt-get install --purge linux-hwe-generic xserver-xorg-lts-trusty xorg

yiannis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 217
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #4 στις: 20 Σεπ 2013, 11:12:46 πμ »
Πολύ καλό και για όσους κάνουν νέα εγκατάσταση από την αρχή. Δεν θα χρειάζονται τόσες πολλές ενημερώσεις μετά.
Ευχαριστούμε και πάλι ;)

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4931
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #5 στις: 30 Ιαν 2014, 01:55:00 μμ »
Βγήκαν νέες εκδόσεις, linux-generic-lts-saucy και xserver-xorg-lts-saucy,
αντί για τις παλιότερες linux-generic-lts-raring και xserver-xorg-lts-raring.

Όποιος έχει ήδη βάλει τις -raring μπορεί αν θέλει να κάνει αναβάθμιση στις νεότερες.
Όποιος δεν τις έχει βάλει να μην ασχοληθεί καθόλου. :)

yiannis

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 217
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #6 στις: 30 Ιαν 2014, 04:10:03 μμ »
Πώς βρίσκουμε ποιο από τα δύο έχουμε;

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4931
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #7 στις: 30 Ιαν 2014, 04:20:16 μμ »
dpkg -l 'linux-image*-lts-*' 'xserver-xorg-lts-*' | grep ^ii

elf

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 287
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #8 στις: 01 Σεπ 2014, 12:31:20 πμ »
Στο σύστημά μου (φετεινό λαπτοπ με Ubuntu 12.04 LTSP server, 3.11.0-26-generic precise) βγαίνει το μήνυμα:
" Your current Hardware Enablement Stack (HWE) is going out of support
on 2014-08-07.  After this date security updates for critical parts (kernel
and graphics stack) of your system will no longer be available.
For more information, please see:
http://wiki.ubuntu.com/1204_HWE_EOL"
Από το wiki φαίνεται ότι έχω 3 επιλογές:
1.Install 12.04.5 HWE (Trusty kernel/graphics)
2.Upgrade to 14.04 LTS
3.Fresh install of 14.04 LTS
Είναι καλύτερο να προτιμήσω την πρώτη επιλογή, έτσι δεν είναι;

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4931
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #9 στις: 01 Σεπ 2014, 10:03:31 πμ »
Για την 12.04, υπάρχουν οι εξής πυρήνες διαθέσιμοι:
ΌνομαΈκδοσηΚατάσταση
linux-image-generic3.2ΟΚ
linux-image-generic-lts-quantal3.5Ξεπερασμένος
linux-image-generic-lts-raring3.8Ξεπερασμένος
linux-image-generic-lts-saucy3.11Ξεπερασμένος
linux-image-generic-lts-trusty3.13Προτεινόμενος για υποστήριξη νέων επεξεργαστών

Και τα εξής xorg:
ΌνομαΑντίστοιχη έκδοση xorg-coreΚατάσταση
xserver-xorg1.11Προτεινόμενο για υποστήριξη παλιών καρτών γραφικών
xserver-xorg-lts-quantal1.13Ξεπερασμένο
xserver-xorg-lts-raring1.13Ξεπερασμένο
xserver-xorg-lts-saucy1.14Ξεπερασμένο
xserver-xorg-lts-trusty1.15ΟΚ

Τα εργαστήρια με την default εγκατάσταση από το live CD μας, έχουν εγκατεστημένα τα πρώτα από τον κάθε πίνακα.
Όσοι ακολούθησαν κάποτε τις οδηγίες του παρόντος θέματος, μπορεί να έχουν κάποια ξεπερασμένη έκδοση. Μόνο σε αυτούς εμφανίζεται το μήνυμα που ανάφερες.

Προτείνεται:
1) Όσοι έχουν την αρχική εγκατάσταση και τους δουλεύουν όλα, να μην κάνουν τίποτα.

2) Τα "συνηθισμένα/προτεινόμενα" πια είναι αυτά που είναι σημειωμένα με bold στους πίνακες.
Αυτό γίνεται με την εξής εντολή:
Κώδικας: Bash
  1. sudo apt-get install --purge linux-hwe-generic xserver-xorg xorg
(το hwe εγκαθιστά το τελευταίο, το -trusty)
...και reboot, αφαίρεση παλιών πυρήνων, δημοσίευση εικονικού δίσκου κλπ.
Για νέες εγκαταστάσεις, σε κάποια στιγμή θα βγάλουμε ένα ακόμα live CD της 12.04.5 που θα περιέχει αυτές τις προτεινόμενες εκδόσεις.

3) Αν κάποιος έχει πολύ καινούργιους clients και κάνει το προτεινόμενο (2) παραπάνω, και παρόλα αυτά έχει θέματα με τις κάρτες γραφικών, τότε προτείνεται να το αναφέρει στον παρόν θέμα, και να δοκιμάσει το εξής:
Κώδικας: Bash
  1. sudo apt-get install --purge linux-hwe-generic xserver-xorg-lts-trusty xorg

elf

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 287
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #10 στις: 01 Σεπ 2014, 11:36:52 μμ »
Κατατοπιστικότατο!
Είχα xorg 1.13 και το άλλαξα σε 1.11 , αλλά πολλά προγράμματα σταμάτησαν να παίζουν λόγω opengl, πχ έβγαινε το μήνυμα στο celestia GdkGLExt-WARNING **: Window system doesn't support OpenGL. Έτσι άλλαξα σε 1.15 και τώρα είναι εντάξει.
Tο θέμα όμως είναι ότι έχω παλιές κάρτες γραφικών σε κάποιους client (sis650, P4, fat) και αναγκάστηκα να βάλω xserver=vesa για να παίξουν.
Υπάρχει περίπτωση να έχω διαφορετική έκδοση xorg στο server από αυτή στον εικονικό;
Γενικά να δοκιμάσω κάτι άλλο;
Για πολλοστή φορά ευχαριστώ!

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4931
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #11 στις: 02 Σεπ 2014, 08:48:47 πμ »
elf, σου έτυχαν οι πιο περίεργες περιπτώσεις, οπότε αν μπορείς κάποια στιγμή έλα από το IRC να το δούμε live, για να βεβαιωθώ ότι δεν υπάρχει κάποια άλλη λύση, και να σημειώσω τα σχετικά pci-ids.

Για να έχεις διαφορετική έκδοση xorg στον server από αυτήν στον εικονικό, μια απλή μέθοδος είναι να βάζεις την παλιά, να κάνεις δημοσίευση εικονικού, και μετά να ξαναβάζεις την καινούργια. Πριν από κάθε δημοσίευση η ίδια διαδικασία, σπαστικό... τουλάχιστον μπορεί να γίνει και χωρίς reboot του server.

Αν θες να δοκιμάσεις μια άλλη πιο αυτοματοποιημένη μέθοδο, δώσε:
Κώδικας: Bash
  1. sudo gedit /usr/share/ltsp/cleanup.d/51-xserver-xorg

και στο αρχείο αυτό βάλε:
Κώδικας: Text
  1. apt-get install --yes --purge xserver-xorg xorg

Θεωρητικά έτσι κάθε φορά που κάνεις δημοσίευση εικονικού, θα εγκαθίσταται αυτόματα μέσα στον εικονικό το παλιό xorg, χωρίς να επηρεάζει την έκδοση του server.

elf

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 287
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #12 στις: 02 Σεπ 2014, 09:14:28 πμ »
επειδή υπάρχει περίπτωση να τοποθετηθώ σε άλλο σχολείο, θα το αφήσω προς το παρόν.
Σήμερα που τα είδα στο εργαστήριο, γίνεται αναλυτικά το εξής:
server: xorg 1.13 και 1.15 ok, αλλά με 1.11 δεν παίζει opengl
παλιοί fat (sis650, P4): xorg 1.13 δεν έφτανε ούτε login page, έπρεπε xserver=vesa, ενώ τώρα με 1.15 έβγαλα το xserver=vesa και μπαίνει στη login αλλά δεν παίζει opengl

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 4931
    • alkisg@im.sch.gr
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #13 στις: 02 Σεπ 2014, 11:03:40 πμ »
Έπαιζε ποτέ (π.χ. xorg 1.11) opengl στην sis;

Άρα τελικά, με τη δεύτερη λύση, "linux-hwe-generic xserver-xorg-lts-trusty", νομίζω είσαι όσο καλύτερα πάει, δεν χρειάζεται κάτι άλλο...

elf

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 287
Απ: Point releases του Ubuntu (12.04.x)
« Απάντηση #14 στις: 04 Σεπ 2014, 09:05:39 πμ »
Έπαιζε ποτέ (π.χ. xorg 1.11) opengl στην sis;

Ναι έπαιζε, αλλά είχα βάλει xserver=vesa και ήταν τόσο αργό που μόνο στη θεωρία έτρεχε. Με 1.15 το opengl δεν παίζει ούτε με xserver=vesa.  Μάλλον είμαι οκ τώρα (έτσι κ αλλιώς 2 Pentium4 έχουν μείνει μόνο), εκτός αν μπορώ να ψάξω κάπως για καλύτερους drivers?