Αποστολέας Θέμα: Μετρατροπή δομή επιλογής (ειδική περίπτωση)  (Αναγνώστηκε 1114 φορές)

Γιάννης Σ.

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 146
    • -
Γεια σας. ::)

Μπορεί κάποιος να μου πει πως θα μετατραπεί σε δύο απλές δομές επιλογής ή σε μια εμφωλευμένη η παρακάτω:
Αν Χ>0 ή Υ>0 Τότε
     Γράψε 'Θετικός'
Τέλος_Αν

Ποια δηλ. θα ήταν η αντιστοιχία της παρακάτω δομής με Ή:
 Αν Χ>0 και Υ>0           Αν Χ>0 Τότε                         
    Γράψε 'Θετικός'          Αν Υ>0 Τότε                             
 Τ_Αν                 ---->           Γράψε 'Θετικός'     
                                       Τ_Αν
                                   Τ_Αν
 :)
Γίνεται;

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2211
Απ: Μετρατροπή δομή επιλογής (ειδική περίπτωση)
« Απάντηση #1 στις: 02 Νοέ 2012, 12:42:46 πμ »
Απαντήθηκε σε άλλο θέμα
Αν Χ > 0 τότε
    Εμφάνισε 'Θετικός'
Αλλιώς
    Αν Υ > 0 τότε
           Εμφάνισε 'Θετικός'
    Τέλος_Αν
Τέλος_Αν
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

Γιάννης Σ.

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 146
    • -
Απ: Μετρατροπή δομή επιλογής (ειδική περίπτωση)
« Απάντηση #2 στις: 02 Νοέ 2012, 01:12:18 πμ »
Ευχαριστω πολύ, δεν το σκέφτηκα. :)

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 887
Απ: Μετρατροπή δομή επιλογής (ειδική περίπτωση)
« Απάντηση #3 στις: 04 Νοέ 2012, 02:50:23 μμ »
Η ερώτηση που κάνεις είναι παρόμοια με αυτή που γίνεται εδώ:
http://alkisg.mysch.gr/steki/index.php?topic=4851.msg51582;topicseen#msg51582

αλλά υπάρχει διαφορά: εκεί ζητούσε να γίνει με απλές συνθήκες, οπότε η καλύτερη απάντηση είναι του Ευριπίδη.

Στη δικιά σου ερώτηση, αν σου κάνει η εμφωλευμένη, η απάντηση του Πέτρου σε καλύπτει.

Αν όμως θέλεις μόνο απλή επιλογή (ούτε σύνθετη, ούτε εμφωλευμένη, ούτε πολλαπλή) τότε η κατάλληλη απάντηση είναι αυτή που δίνει ο vaggelism στο παραπάνω thread:
Κώδικας: [Επιλογή]
ΑΝ Σ1 ΤΟΤΕ
   ΕΝΤΟΛΕΣ
ΤΕΛΟΣ_ΑΝ
ΑΝ Σ2 ΚΑΙ ΟΧΙ Σ1 ΤΟΤΕ
  ΕΝΤΟΛΕΣ
ΤΕΛΟΣ_ΑΝ
Φιλικά,
Γιώργος Θαλασσινός