Αποστολέας Θέμα: Θέμα Β  (Αναγνώστηκε 3909 φορές)

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2449
  • I 'm not young enough to know everything
Θέμα Β
« στις: 01 Ιούν 2012, 10:03:38 πμ »
Εδώ μιλάμε για θέμα Β

karagige

  • Νέος
  • *
  • Μηνύματα: 3
Απ: Θέμα Β
« Απάντηση #1 στις: 01 Ιούν 2012, 03:01:00 μμ »
Ερώτηση για διορθωτές: Αν στο διάγραμμα ροής (Β2) αντί για αρχή_επανάληψης...μέχρις_ότου γραφτεί με αντίστοιχη για...από...μέχρι ή όσο...επανάλαβε, πώς θα βαθμολογηθεί; Ευχαριστώ πολύ...

geoAlex

  • Ομάδα διαγωνισμάτων 2012
  • *
  • Μηνύματα: 23
Απ: Θέμα Β
« Απάντηση #2 στις: 01 Ιούν 2012, 03:43:13 μμ »
Θέμα Β1
Αν τρέξουμε τον αλγόριθμο θα πέρναμε τις παρακάτω τιμές ( μπλέ οι τιμές που θα εμφανιστούν)

Κ Χ   ι
1 -1 0
      1
-1       

-1 -1     

     
     
-1       

-1 1     

     
     
-2       

-2 2     

  4    
     
-8       

-8 4     

     
     
-40       

-40 5     

     
Τερματισμός βρόγχου Όσο


Θέμα Β2

ν ← 0
s ← 0
Αρχή_επανάληψης
  Αν ν mod 2 = 1 τότε
    χ ← -1
  αλλιώς
    χ ← 1
  Τέλος_αν
  s ← s + χ/(2*ν + 1)
  ν ← ν + 1
Μέχρις_ότου ν = 99
π ← 4*s
Εκτύπωσε π

« Τελευταία τροποποίηση: 01 Ιούν 2012, 03:59:29 μμ από geoAlex »
Γιώργος Αλεξίου

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2779
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Θέμα Β
« Απάντηση #3 στις: 01 Ιούν 2012, 03:45:42 μμ »
Ερώτηση για διορθωτές: Αν στο διάγραμμα ροής (Β2) αντί για αρχή_επανάληψης...μέχρις_ότου γραφτεί με αντίστοιχη για...από...μέχρι ή όσο...επανάλαβε, πώς θα βαθμολογηθεί; Ευχαριστώ πολύ...

Εξαρτάται από τη λύση...! Καλύτερα να δώσεις συγκεκριμένη λύση για να τη σχολιάσουμε...

karagige

  • Νέος
  • *
  • Μηνύματα: 3
Απ: Θέμα Β
« Απάντηση #4 στις: 01 Ιούν 2012, 06:07:11 μμ »
s ← 0
για ν από 0 μέχρι 98
  Αν ν mod 2 = 1 τότε
    χ ← -1
  αλλιώς
    χ ← 1
  Τέλος_αν
  s ← s + χ/(2*ν + 1)
τέλος_επανάληψης
π ← 4*s
Εκτύπωσε π

ή

ν ← 0
s ← 0
όσο ν<>99 επανάλαβε
  Αν ν mod 2 = 1 τότε
    χ ← -1
  αλλιώς
    χ ← 1
  Τέλος_αν
  s ← s + χ/(2*ν + 1)
  ν ← ν + 1
τέλος_επανάληψης
π ← 4*s
Εκτύπωσε π

noname

  • Ομάδα διαγωνισμάτων 2013
  • *
  • Μηνύματα: 190
Απ: Θέμα Β
« Απάντηση #5 στις: 01 Ιούν 2012, 06:19:45 μμ »
Μαθητές που έκαναν κανονικά πίνακα τιμών στον οποίο φαίνεται η σειρά με την οποία εμφανίζονται οι τιμές, αλλά δεν έκαναν στο τέλος σύνοψη αυτών, χάνουν μονάδες;

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2212
Απ: Θέμα Β
« Απάντηση #6 στις: 01 Ιούν 2012, 06:21:33 μμ »
Όχι
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #7 στις: 01 Ιούν 2012, 06:58:38 μμ »
Είσαι σίγουρος?
Όχι

Για να πάρει όλες τις μονάδες θα πρέπει να απαντήσει στην ερώτηση. Απαντάει ακριβώς σε αυτό που τον ρωτάνε?
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2212
Απ: Θέμα Β
« Απάντηση #8 στις: 01 Ιούν 2012, 07:04:05 μμ »
Αν έχει μια στήλη εξόδου στον πίνακα, δεν απαντάει;
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #9 στις: 01 Ιούν 2012, 07:39:10 μμ »
αν έχει μια στήλη εξόδου τότε ναι. αν π.χ την έχει ονομάσει έξοδο ή οθόνη, αλλά
αν δίνει μόνο έναν πίνακα τιμών των μεταβλητών χωρίς να φαίνεται τι εμφανίζεται δε νομίζω ότι πρέπει να πάρει όλες τις μονάδες

Αν έχει μια στήλη εξόδου στον πίνακα, δεν απαντάει;
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Σπύρος Δουκάκης

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 831
  • Έτερος εξ ετέρου σοφός, το τε πάλαι το τε νυν
    • http://sdoukakis.wordpress.com/
Απ: Θέμα Β
« Απάντηση #10 στις: 01 Ιούν 2012, 07:44:28 μμ »
Κατά την γνώμη μου, η επιστροφή σε θέματα εικονικής εκτέλεσης χωρίς αριθμημένα βήματα (όπως και πέρσι) αποτελεί οπισθοδρόμηση...

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2779
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Θέμα Β
« Απάντηση #11 στις: 01 Ιούν 2012, 11:00:30 μμ »
s ← 0
για ν από 0 μέχρι 98
  Αν ν mod 2 = 1 τότε
    χ ← -1
  αλλιώς
    χ ← 1
  Τέλος_αν
  s ← s + χ/(2*ν + 1)
τέλος_επανάληψης
π ← 4*s
Εκτύπωσε π

ή

ν ← 0
s ← 0
όσο ν<>99 επανάλαβε
  Αν ν mod 2 = 1 τότε
    χ ← -1
  αλλιώς
    χ ← 1
  Τέλος_αν
  s ← s + χ/(2*ν + 1)
  ν ← ν + 1
τέλος_επανάληψης
π ← 4*s
Εκτύπωσε π

Είναι σωστά.

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1087
Απ: Θέμα Β
« Απάντηση #12 στις: 01 Ιούν 2012, 11:20:23 μμ »
αν έχει μια στήλη εξόδου τότε ναι. αν π.χ την έχει ονομάσει έξοδο ή οθόνη, αλλά
αν δίνει μόνο έναν πίνακα τιμών των μεταβλητών χωρίς να φαίνεται τι εμφανίζεται δε νομίζω ότι πρέπει να πάρει όλες τις μονάδες


Συμφωνώ

karagige

  • Νέος
  • *
  • Μηνύματα: 3
Απ: Θέμα Β
« Απάντηση #13 στις: 02 Ιούν 2012, 12:55:08 πμ »
Είναι σωστά.
Οπότε πρέπει να βαθμολογηθεί κανονικά... Ευχαριστώ.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #14 στις: 03 Ιούν 2012, 12:11:24 πμ »
Σχετικά με το θέμα Β.

Καταρχήν για το Β1. Αρκετοί μαθητές θα έχουν κάνει λάθος την πρώτη πράξη 1 mod 2 = 0
οπότε μετά θα τους βγαίνουν όλο μηδενικά.
Στο βαθμολογικό δώσαμε στους βαθμολογητές και αυτή την απάντηση γιατί θεωρήσαμε ότι θα είναι από τα πιο συνηθισμένα λάθη
Το δίνω και εδώ για όσους βαθμολογητές διαβάζουν το φόρουμ να το έχουν υπόψη τους.

1 -1
0  0
0  1
0  3
0  4
0  6

Προφανώς το παραπάνω είναι σωστό με μόνο λάθος το πρώτο 0. Άρα πρέπει να πάρει τουλάχιστον 8/10 αφού κάθε λάθος μετράει μόνο μια φορά.

Επίσης με το Διάγραμμα ροής τα πράγματα δεν είναι τόσο απλά. Θα διαφωνήσω με τον Νίκο ότι αν κάποιος δώσει ΔΡ με Για ή Όσο θα πάρει ίδιες μονάδες.
Πιστεύω ότι θα πρέπει να κοπούν έστω 1 στις 10 αφού αυτό που δίνει ο μαθητής έχει διαφορετικό διάγραμμα ροής από αυτό που του έδωσαν. Οι ελέγχοι και οι εντολές δεν γίνονται με την ίδια σειρά.
Η εκφώνηση λέει ισοδύναμο και όχι να εμφανίζει τα ίδια,
τώρα τι σημαίνει ισοδύναμο, αυτή την κουβέντα νομίζω την έχουμε ξανακάνει....
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1087
Απ: Θέμα Β
« Απάντηση #15 στις: 03 Ιούν 2012, 12:25:17 πμ »
Και εγώ θα διαφωνήσω με τη χρήση της ΌΣΟ ή της ΓΙΑ για την υλοποιηση του διαγράμματος σε κωδικοποίηση.

Στην ενημέρωση των βαθμολογητών, σημφωνήσαμε να κόβουμε 2 μονάδες για αυτήν την χρήση των δύο παραπάνω εντολών επανάληψης.

Αθανάσιος Πέρδος

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 288
Απ: Θέμα Β
« Απάντηση #16 στις: 03 Ιούν 2012, 10:25:55 πμ »
Τα ίδια ακριβώς προβλήματα είχαν προκύψει και σε παλιότερες εξετάσεις (2006) όπου ζητούνταν μετατροπή από Για σε διάγραμμα ροής. Υπήρχαν μαθητές που έβαζαν τη συνθήκη στο τέλος της δομής και συζητούσαμε αν θα το δεχτούμε σωστό ή λάθος στο βαθμολογικό. Υπήρχε το επιχείρημα (δεν εξετάζω την ορθότητα του) ότι εκτελούνται ακριβώς οι ίδιες εντολές άρα έπρεπε να το δεχτούμε σωστό.

Σε ότι αφορά τη χρήση της Όσο, αν ο μαθητής γράψει όλες τις εντολές μία φορά πάνω από τη συνθήκη συνέχειας και μία φορά μέσα στο σώμα εντολών τότε είναι ολόσωστο. Αλλάζοντας βέβαια και τη συνθήκη σε (όχι συνθήκη)

Δεν θέλω να κατηγορήσω την επιτροπή αλλά το συγκεκριμένο έχει ξανασυμβεί. Θα μπορούσαν τα μέλη της να είναι πιο ενημερωμένα ώστε να αποφύγουμε όλο αυτό το μπέρδεμα. Όταν βάζουμε ένα θέμα θα πρέπει πάντοτε να σκεφτόμαστε και τις πιθανές λύσεις. 

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2779
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Θέμα Β
« Απάντηση #17 στις: 03 Ιούν 2012, 01:29:11 μμ »
Θα διαφωνήσω με τον Νίκο ότι αν κάποιος δώσει ΔΡ με Για ή Όσο θα πάρει ίδιες μονάδες.
...
Οι ελέγχοι και οι εντολές δεν γίνονται με την ίδια σειρά.
Η εκφώνηση λέει ισοδύναμο και όχι να εμφανίζει τα ίδια,
τώρα τι σημαίνει ισοδύναμο, αυτή την κουβέντα νομίζω την έχουμε ξανακάνει....

Ακριβώς επειδή είναι μεγάλη η κουβέντα για το τι σημαίνει ισοδύναμο, για αυτό δεν θα καταβάλω καμία προσπάθεια ώστε να συμφωνήσουμε!  ;)

Συμφωνώ όμως με τον aperdos ότι θα έπρεπε η επιτροπή να αποφεύγει τέτοια μπερδέματα...

Κατά τη γνώμη μου οι θεματοδότες πρέπει:

β) Να έχουν υπόψη τους και να αποφύγουν τα γκρίζα - αμφισβητούμενα σημεία του μαθήματος.

… να έχει μεγάλη εμπειρία στη διδασκαλία του μαθήματος και να παρακολουθεί από κοντά την εξέλιξή του. Αλλιώς, θεωρώ, ότι αυτό θα έδειχνε έλλειψη υπευθυνότητας από την πλευρά του που δεν βοηθά ούτε το μάθημα ούτε τους μαθητές.



evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3145
  • to Iterate is human to Recurse divine
Απ: Θέμα Β
« Απάντηση #18 στις: 03 Ιούν 2012, 02:07:45 μμ »
Ακριβώς επειδή είναι μεγάλη η κουβέντα για το τι σημαίνει ισοδύναμο, για αυτό δεν θα καταβάλω καμία προσπάθεια ώστε να συμφωνήσουμε!  ;)
Μα δεν θα συμφωνήσουμε Νίκο γιατί η έννοια της ισοδυναμίας αλγορίθμων δεν ορίζεται πουθενά στην βιβλιογραφία (τουλάχιστον από όσο έχω ψάξει εγώ)

Κατά τη γνώμη μου όταν ζητάμε μετατροπές μεταξύ δομών επανάληψης ή διαφορετικών αναπαραστάσεων αλγόριθμων θα πρέπει να δίνουμε μια από τις παρακάτω εκφράσεις, ανάλογα με το τι θέλουμε από τους μαθητές

1. έτσι ώστε να εμφανίζει τα ίδια αποτελέσματα
2. έτσι ώστε να εκτελεί τα ίδια ακριβώς βήματα με την ίδια ακριβώς σειρά

What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr