Αποστολέας Θέμα: Τελικό Επαναληπτικό Διαγώνισμα 2011-2012 από το Στέκι  (Αναγνώστηκε 29381 φορές)

NIKOS_KALYVAS

  • Νέος
  • *
  • Μηνύματα: 8
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2011-2012 από το Στέκι
« Απάντηση #90 στις: 29 Μάι 2012, 03:47:01 μμ »
ΚΑΛΗΣΠΕΡΑ ΣΕ ΟΛΟΥΣ.
ΜΗΠΩΣ Η ΑΠΑΝΤΗΣΗ ΣΤΟ ΘΕΜΑ Β2. ΥΠΟΕΡΩΤΗΜΑ 2. ΕΙΝΑΙ (2 ΚΑΙ ΟΧΙ 100;

manosteach

  • Βετεράνος
  • ****
  • Μηνύματα: 89
    • manosteach.com
    • ΔΩΡΕΑΝ ONLINE ΜΑΘΗΜΑΤΑ ΑΕΠΠ & ECDL
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2011-2012 από το Στέκι
« Απάντηση #91 στις: 29 Μάι 2012, 04:17:32 μμ »
Στο παρακάτω αναφέρεσαι;
Πάντως αν αναφέρεσαι στο παρακάτω, το σωστό είναι 100. Αφού ο αλγόριθμος υπολογίζει τον ΜΟ 100 μαθητών.
Σε μπερδεύει μάλλον το γεγονός οτι στο Β1 ζητάει να βγάλεις τον πίνακα τιμών για 2 μόνο μαθητές.
Στο Β2 όμως σου λέει να το συμπληρώσεις ώστε να επιτελεί την ίδια λειτουργία με το αρχικό
Αλγόριθμος Βαθμολογία
   (1)   
Για i από 1 μέχρι    (2)   
   (3)   
Για j από 1 μέχρι    (4)   
Διάβασε Χ
Α <-- Α + Χ
Τέλος_επανάληψης
   (5)   
Εμφάνισε "Ο ",    (6)    , "ος μαθητής έχει μέσο όρο ", Υ
Τέλος_επανάληψης
Τέλος Βαθμολογία
« Τελευταία τροποποίηση: 29 Μάι 2012, 04:36:58 μμ από manosteach »
Δωρεάν online μαθήματα μέσω internet.
http://www.manosteach.com

NIKOS_KALYVAS

  • Νέος
  • *
  • Μηνύματα: 8
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2011-2012 από το Στέκι
« Απάντηση #92 στις: 29 Μάι 2012, 07:49:08 μμ »
ΣΩΣΤΟΣ manosteach
thanks

nikolasmer

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 534
  • There can be only one...may it be AEPP.
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2011-2012 από το Στέκι
« Απάντηση #93 στις: 10 Μάι 2014, 11:08:03 μμ »
Επίσης μια παρατήρηση για το θέμα Δ
Έχει ενδιαφέρον αφού το λύσει κάποιος με τον πρώτο τρόπο που θα του έρθει στο μυαλό, να προσπαθήσει να τα κάνει όλα χρησιμοποιώντας μια μόνο επανάληψη.
Δηλαδή να παραμετροποιήσει με κάποιον τρόπο την κατεύθυνση.
Απλοποίησα στην αίθουσα το πρόβλημα της μετακίνησης σε ένα πίνακα, οριζόντια ή κατακόρυφα, αριστερά ή δεξιά, πάνω ή κάτω.
Παρουσίασα τον παρακάτω κώδικα
Κώδικας: [Επιλογή]
Διάβασε α, β
Αν α < β τότε
  Για ι από α μέχρι β
    Εμφάνισε ι
  Τέλος_επανάληψης
αλλιώς_αν α > β τότε
  Για ι από α μέχρι β με_βήμα -1
    Εμφάνισε ι
  Τέλος_επανάληψης
Τέλος_αν
και ρωτάω μήπως θα μπορούσαμε να παραμετροποιήσουμε μια επανάληψη και αντί για δυο να χρησιμοποιήσουμε μόνο μια.
"Μα είναι εύκολο..." μου απάντησε μια μαθήτρια μέσα σε 10 δευτερόλεπτα. "...Να... θα παραμετροποιήσουμε το βήμα."
Ορίστε ο κώδικάς της...
Κώδικας: [Επιλογή]
Διάβασε α, β
Για ι από α μέχρι β με_βήμα Α_Μ(Α_Τ(α - β)/(β - α))
  Εμφάνισε ι
Τέλος_επανάληψης
:D :D :D
ΝΑΙ... με αυτά τα μυαλά θα βαράω ενέσεις οι οποίες θα με κρατάν ζωντανό για ενα χρόνο ακόμα...
αλλά και ντρέπομαι....ντρέπομαι για τα 10 δευτερόλεπτα, γιατί όταν αναρωτήθηκα εγώ ο ίδιος για την παραπάνω παραμετροποίηση χρειάστηκα πολύ περισσότερα.
Καλή επιτυχία σε όλα τα παιδιά μιάς και ζυγώνει περίοδος εξετάσεων.
Απ' τα τσακάλια δεν γλυτώνεις μ'ευχές ή παρακάλια
(Κ. Βάρναλης)

Μερεντίτης Νικόλαος
Καθηγητής Πληροφορικής - Φροντιστής

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2167
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2011-2012 από το Στέκι
« Απάντηση #94 στις: 10 Μάι 2014, 11:58:00 μμ »
Κι εγώ φέτος έχω πάθει πλάκα με το τι θεωρούν κάποια παιδιά "προφανή λύση" σε ένα ερώτημα
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής