Αποστολέας Θέμα: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι  (Αναγνώστηκε 35692 φορές)

Katsadouros_Dhm

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 370
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #45 στις: 02 Μάι 2011, 11:06:06 μμ »
Δες πάλι τι ζητάει το Δ5 ερώτημα...!
Έχεις δίκιο. Έλυσα παραλλαγή του υποερωτήματος... Βρήκα για κάθε στοά το μεγαλύτερο πληθος συνεχόμενων καμένων λαμπτήρων :D

Katsadouros_Dhm

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 370
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #46 στις: 02 Μάι 2011, 11:11:32 μμ »
Το πρόγραμμα δεν τερματίζει πρόωρα σε κάποιες περιπτώσεις (όταν μετά από εύστοχο πέναλτι της πρώτης ομάδας δεν χρειάζεται να ρίξει η δεύτερη).
π.χ. όταν το σκορ είναι 3-1 και εκτελεί η πρώτη και το βάζει.
Έχεις δίκιο. Είπαμε θέλουν και οι δύο λύσεις βελτίωση-διόρθωση. Στο ένα τρώμε γκολ και στο άλλο μας καίγονται οι λάμπες :'(

ggfiogos

  • ΚΕΠΛΗΝΕΤ
  • *
  • Μηνύματα: 184
    • 2o Γενικό Λύκειο Ναυπλίου
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #47 στις: 02 Μάι 2011, 11:21:50 μμ »
Δεν ξέρω σε ποιους αναφέρεστε ως κακοπροαίρετους και δεν θα ήθελα να απαντήσω σε αυτό. Άλλωστε στη δική μου απάντηση ευχαρίστησα.
Η ερώτηση που κάνω προς όλους τους συναδέλφους που τυχαίνει να διδάσκουν το μάθημα φέτος είναι: Μπορεί ένας μαθητής στα πλαίσια και μόνο του σχολικού δίωρου να ανταπεξέλθει σε ένα τέτοιο διαγώνισμα;  Πόσες ασκήσεις εντός σχολικού ωραρίου πάνω στους πίνακες μπορέσατε να λύσετε εκτός από τις τυποποιημένες;

Όταν δημοσιεύετε ένα προϊόν εργασίας να είστε έτοιμοι να δεχθείτε και τις όποιες κριτικές. Άλλωστε, για αυτό δεν υπάρχει το φόρουμ;
Λέων Προκόπης
2ο ΓΕΛ Ναυπλίου

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2774
  • Πύργος Ηλείας
    • ΚΕΠΛΗΝΕΤ Ηλείας
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #48 στις: 02 Μάι 2011, 11:38:40 μμ »
ΟΚ συνάδελφοι...! Πιθανώς να ήταν μια ατυχής στιγμή... Ας μην το συνεχίζουμε άλλο... και ας εστιάσουμε στη ουσία...
Όλες οι κριτικές είναι καλοδεχούμενες...

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1464
  • Δεν αντέχω την (συμ)-πίεσηηη .......
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #49 στις: 03 Μάι 2011, 12:06:08 πμ »
Όλες οι κριτικές είναι καλοδεχούμενες αρκεί να μην περιέχουν χαρκτηρισμούς και πικρόχολα σχόλια. Μου αρκεί ένα δε μ'αρέσει ή το βρίσκω υπερβολικα μεγάλο ή ότιδήποτε άλλο , αλλά δε μπορώ να δεχτώ οτι είμαι επιδειξιομανής, αντιπαιδαγωγικός και εκτός πραγματικότητας. Είναι προσβλητικό για μένα.

Ευχαριστώ
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

kwtakis

  • Νέος
  • *
  • Μηνύματα: 5
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #50 στις: 03 Μάι 2011, 10:20:54 πμ »
Παράθεση
ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 50
    ΑΝ ποσ_καμ[ι] = μεγ_ποσ_καμ ΤΟΤΕ
      ΓΡΑΨΕ 'Στην ', ι, 'η στοά έχουμε μέγιστο ποσοστό καμένων λαμπτήρων'
      ΓΡΑΨΕ μεγ_ποσ_καμ
    ΤΕΛΟΣ_ΑΝ
    ΑΝ ποσ_καμ[ι] = 100 ΤΟΤΕ
      ΓΡΑΨΕ 'Η ', ι, 'η στοά δεν έχει καθόλου φωτισμό'
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Στο Δ4 πρέπει να προσθέσουμε και μια λογική μεταβλητή στον έλεγχο... μετά να ελέγξουμε την τιμή της ώστε να εμφανίσουμε μήνυμα αν δεν υπάρχουν στοές με καθόλου φωτισμό...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3059
  • to Iterate is human to Recurse divine
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #51 στις: 03 Μάι 2011, 12:10:18 μμ »
Αυτό που λες το κάνει παρακάτω.
Δες τη μεταβλητή Υπάρχουν_στοές_χωρίς_φως
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

JR

  • Οπαδός
  • **
  • Μηνύματα: 10
    • Film And Fap
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #52 στις: 03 Μάι 2011, 01:30:46 μμ »
ΣΥΝΑΡΤΗΣΗ συν_καμ(κατ_1, ι1, πλθ): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: κατ_1[50, 50], ι1, πλθ, ξ, κ, μεγ
ΑΡΧΗ
  μεγ <- 0
  κ <- 0
  ΓΙΑ ξ ΑΠΟ 1 ΜΕΧΡΙ πλθ
    ΑΝ κατ_1[ι1, ξ] = 0 ΤΟΤΕ
      κ <- κ + 1
      ΑΝ κ > μεγ ΤΟΤΕ
        μεγ <- κ
      ΤΕΛΟΣ_ΑΝ
    ΑΛΛΙΩΣ
      κ <- 0
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  συν_καμ <- μεγ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Άσκοπος έλενχος για το μέγιστο κάθε φορά.

ΑΝ κατ_1[ι1, ξ] = 0 ΤΟΤΕ
      κ <- κ + 1
ΑΛΛΙΩΣ
      ΑΝ κ > μεγ ΤΟΤΕ
        μεγ <- κ
      ΤΕΛΟΣ_ΑΝ
       κ <- 0
ΤΕΛΟΣ_ΑΝ

έτσι θα γίνεται έλενχος μόνο όταν παύει το 'σερί'. φιλικά

Όσο για το διαγώνισμα το πρώτο θέμα ήταν απίστευτο!, παραγματικά πολύ όμορφο. όλα τα λεφτά!
Τα υπόλοιπα ήταν κλασσικά.

Χωρίς παρεξήση θα ήθελα να ρωτήσω 'Γιατί τέτοιο όνομα στην συνάρτηση στο τέταρτο θέμα?' χαχα  :angel:



sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #53 στις: 03 Μάι 2011, 01:37:33 μμ »
Άσκοπος έλενχος για το μέγιστο κάθε φορά.

ΑΝ κατ_1[ι1, ξ] = 0 ΤΟΤΕ
      κ <- κ + 1
ΑΛΛΙΩΣ
      ΑΝ κ > μεγ ΤΟΤΕ
        μεγ <- κ
      ΤΕΛΟΣ_ΑΝ
       κ <- 0
ΤΕΛΟΣ_ΑΝ


Τώρα γίνεται άσκοπος έλεγχος σε κάθε σερί με άσσους και όχι μηδενικά. Ακόμη όταν το μέγιστο συνεχόμενων μηδενικών είναι στο τέλος της στοάς τότε δεν το συγκρίνουμε με το ήδη υπολογισμένο μέγιστο οπότε χρειάζεται να μπει άλλη μία αν στο τέλος που να το κάνει αυτό.
« Τελευταία τροποποίηση: 03 Μάι 2011, 01:52:10 μμ από sstergou »
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3059
  • to Iterate is human to Recurse divine
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #54 στις: 03 Μάι 2011, 01:44:20 μμ »
Πολύ καλή παρατήρηση αλλά τι θα γίνει όταν το σερί δεν παύει? ;)
Σε αυτή την περίπτωση αν το τελευταίο σερί είναι και το μεγαλύτερο θα υπάρξει πρόβλημα
Σε αυτό που προτείνεις μου φαίνεται ότι χρειάζεται ένας ακόμα ελέγχος έξω από την επανάληψη μήπως το τελευταίο σερί είναι το μεγαλύτερο

Άσκοπος έλενχος για το μέγιστο κάθε φορά.

ΑΝ κατ_1[ι1, ξ] = 0 ΤΟΤΕ
      κ <- κ + 1
ΑΛΛΙΩΣ
      ΑΝ κ > μεγ ΤΟΤΕ
        μεγ <- κ
      ΤΕΛΟΣ_ΑΝ
       κ <- 0
ΤΕΛΟΣ_ΑΝ

έτσι θα γίνεται έλενχος μόνο όταν παύει το 'σερί'. φιλικά

Όσο για το διαγώνισμα το πρώτο θέμα ήταν απίστευτο!, παραγματικά πολύ όμορφο. όλα τα λεφτά!
Τα υπόλοιπα ήταν κλασσικά.

Χωρίς παρεξήση θα ήθελα να ρωτήσω 'Γιατί τέτοιο όνομα στην συνάρτηση στο τέταρτο θέμα?' χαχα  :angel:

edit: Στάθη με πρόλαβες
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1009
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #55 στις: 03 Μάι 2011, 01:53:09 μμ »
Η  ΣΥΝΑΡΤΗΣΗ ΣΤΟ   Δ6.

! Δ6 μον 5
ΣΥΝΑΡΤΗΣΗ Συνεχόμενοι(ΚΑ, στοά, λα): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΚΑ[5, 5], στοά, λα, j, π, αλ, μεγ
ΑΡΧΗ
  αλ <- 0                                              ! αλλαγές
  ΑΝ ΚΑ[στοά, 1] = 1 ΤΟΤΕ
    π <- 0
  ΑΛΛΙΩΣ
    π <- 1         !  η 1η λάμπα καμένη                         
  ΤΕΛΟΣ_ΑΝ
 
  ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ λα - 1
! 1η περίπτωση  00000 μετράω ...
    ΑΝ ΚΑ[στοά, j] = ΚΑ[στοά, j + 1] ΚΑΙ ΚΑ[στοά, j] = 0 ΤΟΤΕ
      π <- π + 1
! 2η 10 ή 01  συγκρίνω και π <- 1
    ΑΛΛΙΩΣ_ΑΝ ΟΧΙ(ΚΑ[στοά, j] = 1 ΚΑΙ ΚΑ[στοά, j + 1] = 1) ΤΟΤΕ
      αλ <- αλ + 1
      ΑΝ αλ = 1 ΤΟΤΕ
        μεγ <- π
      ΑΛΛΙΩΣ
        ΑΝ π > μεγ ΤΟΤΕ
          μεγ <- π
        ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΑΝ
      π <- 1
! 3η 111111  τίποτα ...
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ π <> 0 ΤΟΤΕ
    ΑΝ π > μεγ ΤΟΤΕ
      μεγ <- π
    ΤΕΛΟΣ_ΑΝ
  ΑΛΛΙΩΣ
    μεγ <- 0
  ΤΕΛΟΣ_ΑΝ
  Συνεχόμενοι <- μεγ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΑΠ

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3059
  • to Iterate is human to Recurse divine
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #56 στις: 03 Μάι 2011, 02:03:06 μμ »
Εξαιρετική παρατήρηση στάθη, στην αρχή δεν το κατάλαβα, αλλά ενώ εκ πρώτης όψεως ο τρόπος που προτείνει ο JR φαίνεται πιο αποδοτικός, ουσιαστικά έχει ακριβώς την ίδια πολυπλοκότητα και στη χειρότερη περίπτωση αλλά ακόμα και στη μέση!!!
Εκτός φυσικά αν θεωρήσουμε ότι οι καμμένοι λαμπτήρες είναι η μειοψηφία

Τώρα γίνεται άσκοπος έλεγχος κάθε σε σερί με άσσους και όχι μηδενικά.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 983
  • Program or be Programmed
    • pseudoglossa.gr
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #57 στις: 03 Μάι 2011, 02:16:38 μμ »
Ναι, αρχικά κι εγώ είχα λύσει το θέμα χρησιμοποιώντας τον τρόπο του JR αλλά μόλις είδα την λύση με την σύγκριση σε κάθε μηδενικό κατάλαβα ότι δεν κερδίζουμε και τίποτε παραπάνω... Άσε που γλιτώνεις και την Αν στο τέλος
Στάθης Στέργου - sstergouATgmailDOTcom - http://www.pseudoglossa.gr

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2444
  • I 'm not young enough to know everything
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #58 στις: 03 Μάι 2011, 02:34:12 μμ »
Μπορείς και να μαρκάρεις την αρχή [1,0] και το τέλος [0,1] της ακολουθίας μηδενικών και να κάνεις την πράξη.

JR

  • Οπαδός
  • **
  • Μηνύματα: 10
    • Film And Fap
Απ: Τελικό Επαναληπτικό Διαγώνισμα 2010-2011 απο το Στέκι
« Απάντηση #59 στις: 03 Μάι 2011, 02:51:15 μμ »
Πολύ καλή παρατήρηση αλλά τι θα γίνει όταν το σερί δεν παύει? ;)
Σε αυτή την περίπτωση αν το τελευταίο σερί είναι και το μεγαλύτερο θα υπάρξει πρόβλημα
Σε αυτό που προτείνεις μου φαίνεται ότι χρειάζεται ένας ακόμα ελέγχος έξω από την επανάληψη μήπως το τελευταίο σερί είναι το μεγαλύτερο

ουπς το ξέχασα
ναι με έναν έλενχο στο τέλος έξω από την επανάληψη διορθώνεται  :)